Porblem editing makefile

Discussion in 'C++' started by Raffounz, Sep 14, 2006.

  1. Raffounz

    Raffounz Guest

    Hi everyvone, I'm workin on a projet for integrating comunication
    between iaxclient and libjingle. I must made visible the inludes of the
    two libraries each other. I edited the makefile adding a INCLUDE_PATH
    line, modified LD_FLAGS to include libraries and added the CFLAG of one
    library in the other, without results for libjingle. I have these
    errors everytime:

    In file included from
    /home/raffounz/Tesi/iaxclient_mod/trunk/iaxclient/lib/audio_encode.h:17,
    from linphonemediaengine.cc:36:
    /home/raffounz/Tesi/iaxclient_mod/trunk/iaxclient/lib/iaxclient_lib.h:106:24:
    error: iax-client.h: No such file or directory
    In file included from linphonemediaengine.cc:36:
    /home/raffounz/Tesi/iaxclient_mod/trunk/iaxclient/lib/audio_encode.h:19:17:
    error: gsm.h: No such file or directory

    How can I make these file visible in the recurrent include? I remember
    that on command line I must add a -I/librarypath line to the gcc
    options...
     
    Raffounz, Sep 14, 2006
    #1
    1. Advertising

  2. Raffounz wrote:
    > Hi everyvone, I'm workin on a projet for integrating comunication
    > between iaxclient and libjingle. I must made visible the inludes of
    > the two libraries each other. I edited the makefile adding a
    > INCLUDE_PATH line, modified LD_FLAGS to include libraries and added
    > the CFLAG of one library in the other, without results for libjingle.
    > I have these errors everytime:
    >
    > In file included from
    > /home/raffounz/Tesi/iaxclient_mod/trunk/iaxclient/lib/audio_encode.h:17,
    > from linphonemediaengine.cc:36:
    > /home/raffounz/Tesi/iaxclient_mod/trunk/iaxclient/lib/iaxclient_lib.h:106:24:
    > error: iax-client.h: No such file or directory
    > In file included from linphonemediaengine.cc:36:
    > /home/raffounz/Tesi/iaxclient_mod/trunk/iaxclient/lib/audio_encode.h:19:17:
    > error: gsm.h: No such file or directory
    >
    > How can I make these file visible in the recurrent include? I remember
    > that on command line I must add a -I/librarypath line to the gcc
    > options...


    This is not a _language_ problem. Please ask in the newsgroup dedicated
    to your compiler (or the OS). They can help you learn how to use it.

    V
    --
    Please remove capital 'A's when replying by e-mail
    I do not respond to top-posted replies, please don't ask
     
    Victor Bazarov, Sep 14, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Gandu
    Replies:
    0
    Views:
    1,092
    Gandu
    Jan 8, 2004
  2. Ray
    Replies:
    2
    Views:
    724
  3. Replies:
    1
    Views:
    315
    Michael Nemtsev [MVP]
    Jan 24, 2009
  4. pp
    Replies:
    7
    Views:
    2,814
    John Machin
    Jan 10, 2010
  5. Nilendu
    Replies:
    1
    Views:
    104
    Bob Walton
    Nov 28, 2003
Loading...

Share This Page