Problem connecting to my database

Discussion in 'ASP .Net' started by =?Utf-8?B?UGF0cmljayBG?=, Oct 2, 2006.

  1. Hi, i have SQL Server 2005 and a database set that is called, myCompany
    the problem is that i cant connect from my page to it,
    here is from the web.config: ( i have got this connectionstring from my
    sqldataobject on my page)
    <add name="ConStr" connectionString="Data Source=localhost;Initial
    Catalog=myCompany;Integrated Security=True"
    providerName="System.Data.SqlClient" />

    the strange part is that its trying to connect to a SQL express database,
    but i have it on in my SQL Server 2005. I dont have SQL Express installed
    since i was intending to work oly with SQL Server 2005 and i have all
    memberships and rols inside my SQL Server aswell.
    keep getting this error message:
    An error has occurred while establishing a connection to the server. When
    connecting to SQL Server 2005, this failure may be caused by the fact that
    under the default settings SQL Server does not allow remote connections.
    (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance
    Specified)
    Description: An unhandled exception occurred during the execution of the
    current web request. Please review the stack trace for more information about
    the error and where it originated in the code.

    SQLExpress database file auto-creation error:


    The connection string specifies a local Sql Server Express instance using a
    database location within the applications App_Data directory. The provider
    attempted to automatically create the application services database because
    the provider determined that the database does not exist. The following
    configuration requirements are necessary to successfully check for existence
    of the application services database and automatically create the application
    services database:


    If the applications App_Data directory does not already exist, the web
    server account must have read and write access to the applications directory.
    This is necessary because the web server account will automatically create
    the App_Data directory if it does not already exist.
    If the applications App_Data directory already exists, the web server
    account only requires read and write access to the applications App_Data
    directory. This is necessary because the web server account will attempt to
    verify that the Sql Server Express database already exists within the
    applications App_Data directory. Revoking read access on the App_Data
    directory from the web server account will prevent the provider from
    correctly determining if the Sql Server Express database already exists. This
    will cause an error when the provider attempts to create a duplicate of an
    already existing database. Write access is required because the web server
    accounts credentials are used when creating the new database.
    Sql Server Express must be installed on the machine.
    The process identity for the web server account must have a local user
    profile. See the readme document for details on how to create a local user
    profile for both machine and domain accounts.
     
    =?Utf-8?B?UGF0cmljayBG?=, Oct 2, 2006
    #1
    1. Advertising

  2. Morten Wennevik, Oct 2, 2006
    #2
    1. Advertising

  3. According to the exception message, you have a connection string (which could
    be the default in the master web.config) that is attempting to use a
    SQLExpress connection string that uses the Auto-attach feature, which is not
    supported by SQL Server 2005.
    You may need to use the <remove name="LocalSqlServer" ...>
    element to get rid of this, before adding in your own connection string.
    Also, you need to Attach the database in SQL Managment Studio, it cannot be
    loaded dynamically as in SQLEXPRESS.
    Peter

    --
    Co-founder, Eggheadcafe.com developer portal:
    http://www.eggheadcafe.com
    UnBlog:
    http://petesbloggerama.blogspot.com




    "Patrick F" wrote:

    > Hi, i have SQL Server 2005 and a database set that is called, myCompany
    > the problem is that i cant connect from my page to it,
    > here is from the web.config: ( i have got this connectionstring from my
    > sqldataobject on my page)
    > <add name="ConStr" connectionString="Data Source=localhost;Initial
    > Catalog=myCompany;Integrated Security=True"
    > providerName="System.Data.SqlClient" />
    >
    > the strange part is that its trying to connect to a SQL express database,
    > but i have it on in my SQL Server 2005. I dont have SQL Express installed
    > since i was intending to work oly with SQL Server 2005 and i have all
    > memberships and rols inside my SQL Server aswell.
    > keep getting this error message:
    > An error has occurred while establishing a connection to the server. When
    > connecting to SQL Server 2005, this failure may be caused by the fact that
    > under the default settings SQL Server does not allow remote connections.
    > (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance
    > Specified)
    > Description: An unhandled exception occurred during the execution of the
    > current web request. Please review the stack trace for more information about
    > the error and where it originated in the code.
    >
    > SQLExpress database file auto-creation error:
    >
    >
    > The connection string specifies a local Sql Server Express instance using a
    > database location within the applications App_Data directory. The provider
    > attempted to automatically create the application services database because
    > the provider determined that the database does not exist. The following
    > configuration requirements are necessary to successfully check for existence
    > of the application services database and automatically create the application
    > services database:
    >
    >
    > If the applications App_Data directory does not already exist, the web
    > server account must have read and write access to the applications directory.
    > This is necessary because the web server account will automatically create
    > the App_Data directory if it does not already exist.
    > If the applications App_Data directory already exists, the web server
    > account only requires read and write access to the applications App_Data
    > directory. This is necessary because the web server account will attempt to
    > verify that the Sql Server Express database already exists within the
    > applications App_Data directory. Revoking read access on the App_Data
    > directory from the web server account will prevent the provider from
    > correctly determining if the Sql Server Express database already exists. This
    > will cause an error when the provider attempts to create a duplicate of an
    > already existing database. Write access is required because the web server
    > accounts credentials are used when creating the new database.
    > Sql Server Express must be installed on the machine.
    > The process identity for the web server account must have a local user
    > profile. See the readme document for details on how to create a local user
    > profile for both machine and domain accounts.
     
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=, Oct 2, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tom Wild
    Replies:
    0
    Views:
    6,750
    Tom Wild
    Aug 14, 2003
  2. Tom Wild
    Replies:
    1
    Views:
    10,993
    Kevin Swarts
    Aug 25, 2003
  3. Nathan Sokalski
    Replies:
    9
    Views:
    485
    Steve Long
    Jun 8, 2005
  4. Greg W via DotNetMonster.com

    problem connecting to my database behind a firewall

    Greg W via DotNetMonster.com, Jul 16, 2005, in forum: ASP .Net
    Replies:
    7
    Views:
    565
    Alan Samet
    Jul 19, 2005
  5. =?Utf-8?B?UGF0cmljayBG?=

    Problem connecting to my database

    =?Utf-8?B?UGF0cmljayBG?=, Jul 21, 2006, in forum: ASP .Net
    Replies:
    2
    Views:
    417
    Kevin Spencer
    Jul 21, 2006
Loading...

Share This Page