Problem getting gems/listing gems. EINVAL

Discussion in 'Ruby' started by Thaddeus L Olczyk, Aug 15, 2006.

  1. Environment:
    rubygems 0.9.0
    ruby 1.8.4
    OS NT 4 sp6

    Problem:
    Upon trying to install a gem or list from either rubyforge or why's
    site I recieve this error message
    Exception `Errno::EINVAL' at
    I:/PROGRAMS/Scripting/ruby/lib/ruby/1.8/net/protocol.rb:176 - Invalid
    argument
    ERROR: While executing gem ... (Errno::EINVAL)

    Some Diagnostics:
    Examing code and a few well placed print statements I discover this
    exception is generated when the application first trys to write to the
    Socket. Connecting by hand and sending the same string returns in
    a 200 ie using "telnet code.whytheluckystiff.net 80" then typing in
    the header returns a 200.

    Thanks in advance.


    --------------------------------------------------
    Thaddeus L. Olczyk, PhD
    Think twice, code once.
    Thaddeus L Olczyk, Aug 15, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tomás

    Gems -- #include <gems.hpp>

    Tomás, Mar 4, 2006, in forum: C++
    Replies:
    7
    Views:
    421
    Tomás
    Mar 5, 2006
  2. Yura Kloubakov
    Replies:
    1
    Views:
    228
    GOTOU Yuuzou
    May 13, 2005
  3. Replies:
    4
    Views:
    150
    Daniel Berger
    Jan 8, 2009
  4. Shilo Ayalon

    Listing installed gems

    Shilo Ayalon, Jan 25, 2009, in forum: Ruby
    Replies:
    7
    Views:
    137
    Rob Biedenharn
    Jan 26, 2009
  5. Bhay Zone
    Replies:
    1
    Views:
    311
    Luis Lavena
    Sep 8, 2010
Loading...

Share This Page