Problem installing ASPX pages on my local IIS

Discussion in 'ASP .Net' started by Lars, Feb 18, 2008.

  1. Lars

    Lars Guest

    Hi

    I have an IIS server installed on my local PC and I want to publish my
    ASP.NET site to my local webserver. I know the webserver is working since I
    can add an index.html file and view in a browser through my no-ip.org domain
    name. But when I publish my local Visual Studio 2008 (VS2008) project to my
    IIS I can't reach the site at all. I can run the site from within the VS2008
    IDE.

    Is there any thing I need to add to my IIS. The project in VS2008 includes
    thre user groups and two users. Administrators, Accessors and a Public
    group. Does this setting require some thing more?

    Yours
    Lars
     
    Lars, Feb 18, 2008
    #1
    1. Advertising

  2. Lars

    Lars Guest

    Hi

    I manage to get the page viewable

    But I still can't use the login form.

    I get the following error and I don't know what it means

    An attempt to attach an auto-named database for file C:\Documents and
    Settings\Rosoft\Mina dokument\Visual Studio
    2008\WebSites\Lesson05\Lesson05\App_Data\dbMusicFiles.mdf failed. A database
    with the same name exists, or specified file cannot be opened, or it is
    located on UNC share.


    I only have one copy of the file dbMusicFiles.mdf

    What is UNC Share?


    Again: It works when I run the page from within the browser.

    Lars


    "Lars" <> skrev i meddelandet
    news:eek:Yduj.3901$...
    > Hi
    >
    > I have an IIS server installed on my local PC and I want to publish my
    > ASP.NET site to my local webserver. I know the webserver is working since
    > I can add an index.html file and view in a browser through my no-ip.org
    > domain name. But when I publish my local Visual Studio 2008 (VS2008)
    > project to my IIS I can't reach the site at all. I can run the site from
    > within the VS2008 IDE.
    >
    > Is there any thing I need to add to my IIS. The project in VS2008 includes
    > thre user groups and two users. Administrators, Accessors and a Public
    > group. Does this setting require some thing more?
    >
    > Yours
    > Lars
    >
     
    Lars, Feb 18, 2008
    #2
    1. Advertising

  3. Lars

    gnewsgroup Guest

    On Feb 18, 7:30 am, "Lars" <> wrote:
    > Hi
    >
    > I manage to get the page viewable
    >
    > But I still can't use the login form.
    >
    > I get the following error and I don't know what it means
    >
    > An attempt to attach an auto-named database for file C:\Documents and
    > Settings\Rosoft\Mina dokument\Visual Studio
    > 2008\WebSites\Lesson05\Lesson05\App_Data\dbMusicFiles.mdf failed. A database
    > with the same name exists, or specified file cannot be opened, or it is
    > located on UNC share.
    >
    > I only have one copy of the file dbMusicFiles.mdf
    >
    > What is UNC Share?
    >
    > Again: It works when I run the page from within the browser.
    >
    > Lars
    >
    > "Lars" <> skrev i meddelandetnews:eek:Yduj.3901$...
    >
    > > Hi

    >
    > > I have an IIS server installed on my local PC and I want to publish my
    > > ASP.NET site to my local webserver. I know the webserver is working since
    > > I can add an index.html file and view in a browser through my no-ip.org
    > > domain name. But when I publish my local Visual Studio 2008 (VS2008)
    > > project to my IIS I can't reach the site at all. I can run the site from
    > > within the VS2008 IDE.

    >
    > > Is there any thing I need to add to my IIS. The project in VS2008 includes
    > > thre user groups and two users. Administrators, Accessors and a Public
    > > group. Does this setting require some thing more?

    >
    > > Yours
    > > Lars


    To answer only 1 of your questions, a UNC share refers to a shared
    folder on a LAN server, which you can get to by

    \\the_server_name\the_folder\the_subfolder\
     
    gnewsgroup, Feb 18, 2008
    #3
  4. It could very well be a permissions error. ASP.Net will need
    read/write/delete permissions to the database to successfully update it.
    Chances are, it is only getting read permissions. Use the security tab of
    the file's properties panel to ensure the asp.net user has these
    permissions.

    Hope this helps,
    Mark Fitzpatrick
    Microsoft MVP - Expression

    "Lars" <> wrote in message
    news:rTeuj.3903$...
    > Hi
    >
    > I manage to get the page viewable
    >
    > But I still can't use the login form.
    >
    > I get the following error and I don't know what it means
    >
    > An attempt to attach an auto-named database for file C:\Documents and
    > Settings\Rosoft\Mina dokument\Visual Studio
    > 2008\WebSites\Lesson05\Lesson05\App_Data\dbMusicFiles.mdf failed. A
    > database with the same name exists, or specified file cannot be opened, or
    > it is located on UNC share.
    >
    >
    > I only have one copy of the file dbMusicFiles.mdf
    >
    > What is UNC Share?
    >
    >
    > Again: It works when I run the page from within the browser.
    >
    > Lars
    >
    >
    > "Lars" <> skrev i meddelandet
    > news:eek:Yduj.3901$...
    >> Hi
    >>
    >> I have an IIS server installed on my local PC and I want to publish my
    >> ASP.NET site to my local webserver. I know the webserver is working since
    >> I can add an index.html file and view in a browser through my no-ip.org
    >> domain name. But when I publish my local Visual Studio 2008 (VS2008)
    >> project to my IIS I can't reach the site at all. I can run the site from
    >> within the VS2008 IDE.
    >>
    >> Is there any thing I need to add to my IIS. The project in VS2008
    >> includes thre user groups and two users. Administrators, Accessors and a
    >> Public group. Does this setting require some thing more?
    >>
    >> Yours
    >> Lars
    >>

    >
    >
     
    Mark Fitzpatrick, Feb 18, 2008
    #4
  5. Running the site from within VS doesn't really mean anything. VS, by
    default, will use a built-in web server that (formerly known as Cassini)
    that runs independently of IIS so that users without IIS can still test and
    debug apps.

    Hope this helps,
    Mark Fitzpatrick
    Microsoft MVP - Expression

    "Lars" <> wrote in message
    news:eek:Yduj.3901$...
    > Hi
    >
    > I have an IIS server installed on my local PC and I want to publish my
    > ASP.NET site to my local webserver. I know the webserver is working since
    > I can add an index.html file and view in a browser through my no-ip.org
    > domain name. But when I publish my local Visual Studio 2008 (VS2008)
    > project to my IIS I can't reach the site at all. I can run the site from
    > within the VS2008 IDE.
    >
    > Is there any thing I need to add to my IIS. The project in VS2008 includes
    > thre user groups and two users. Administrators, Accessors and a Public
    > group. Does this setting require some thing more?
    >
    > Yours
    > Lars
    >
     
    Mark Fitzpatrick, Feb 18, 2008
    #5
  6. Lars

    Rbrt Guest

    Yu might to look at the event log on your local machine to see what is in
    there as well.

    "Mark Fitzpatrick" wrote:

    > Running the site from within VS doesn't really mean anything. VS, by
    > default, will use a built-in web server that (formerly known as Cassini)
    > that runs independently of IIS so that users without IIS can still test and
    > debug apps.
    >
    > Hope this helps,
    > Mark Fitzpatrick
    > Microsoft MVP - Expression
    >
    > "Lars" <> wrote in message
    > news:eek:Yduj.3901$...
    > > Hi
    > >
    > > I have an IIS server installed on my local PC and I want to publish my
    > > ASP.NET site to my local webserver. I know the webserver is working since
    > > I can add an index.html file and view in a browser through my no-ip.org
    > > domain name. But when I publish my local Visual Studio 2008 (VS2008)
    > > project to my IIS I can't reach the site at all. I can run the site from
    > > within the VS2008 IDE.
    > >
    > > Is there any thing I need to add to my IIS. The project in VS2008 includes
    > > thre user groups and two users. Administrators, Accessors and a Public
    > > group. Does this setting require some thing more?
    > >
    > > Yours
    > > Lars
    > >

    >
     
    Rbrt, Feb 18, 2008
    #6
  7. Lars

    Lars Guest

    HI Mark

    Yes changing the rights on the site helped but I can't storw the site on the
    server root for some howe. The only problem I have now is that I don't get
    the database to work on IIS. I have tried to use a different storage
    location than the development folder for the site as well as linking IIS to
    the actual development storage. I have read threads on the Internet where
    some say that it's a bug and there are different solutions but none of the
    recomendations help me. I get the error as shown below. I have tried
    shutting down Norton Firewall as well as tried to use DMZ in my firewall.
    Still the same problem. WHen I try to add a user in SQL Server I fail. I
    can't edit the grids that are shown for managing aliases in SQL server. UPon
    that the other databases I have installed on my machines doesn't seam to
    work from ASP.NET. For example InnoDB, Interbase even though I have ODBC for
    them installed. I would like to use a free database like MySQL but no one
    seams to know how to set up MySQL to work with ASP.NET.

    Here's the error message I get.


    Server Error in '/private' Application.
    --------------------------------------------------------------------------------

    An attempt to attach an auto-named database for file C:\Documents and
    Settings\Rosoft\Mina dokument\Visual Studio
    2008\WebSites\Lesson05\Lesson05\App_Data\MP3.mdf failed. A database with the
    same name exists, or specified file cannot be opened, or it is located on
    UNC share.

    Lars


    "Mark Fitzpatrick" <> skrev i meddelandet
    news:...
    > It could very well be a permissions error. ASP.Net will need
    > read/write/delete permissions to the database to successfully update it.
    > Chances are, it is only getting read permissions. Use the security tab of
    > the file's properties panel to ensure the asp.net user has these
    > permissions.
    >
    > Hope this helps,
    > Mark Fitzpatrick
    > Microsoft MVP - Expression
    >
    > "Lars" <> wrote in message
    > news:rTeuj.3903$...
    >> Hi
    >>
    >> I manage to get the page viewable
    >>
    >> But I still can't use the login form.
    >>
    >> I get the following error and I don't know what it means
    >>
    >> An attempt to attach an auto-named database for file C:\Documents and
    >> Settings\Rosoft\Mina dokument\Visual Studio
    >> 2008\WebSites\Lesson05\Lesson05\App_Data\dbMusicFiles.mdf failed. A
    >> database with the same name exists, or specified file cannot be opened,
    >> or it is located on UNC share.
    >>
    >>
    >> I only have one copy of the file dbMusicFiles.mdf
    >>
    >> What is UNC Share?
    >>
    >>
    >> Again: It works when I run the page from within the browser.
    >>
    >> Lars
    >>
    >>
    >> "Lars" <> skrev i meddelandet
    >> news:eek:Yduj.3901$...
    >>> Hi
    >>>
    >>> I have an IIS server installed on my local PC and I want to publish my
    >>> ASP.NET site to my local webserver. I know the webserver is working
    >>> since I can add an index.html file and view in a browser through my
    >>> no-ip.org domain name. But when I publish my local Visual Studio 2008
    >>> (VS2008) project to my IIS I can't reach the site at all. I can run the
    >>> site from within the VS2008 IDE.
    >>>
    >>> Is there any thing I need to add to my IIS. The project in VS2008
    >>> includes thre user groups and two users. Administrators, Accessors and a
    >>> Public group. Does this setting require some thing more?
    >>>
    >>> Yours
    >>> Lars
    >>>

    >>
    >>

    >
     
    Lars, Feb 18, 2008
    #7
  8. Lars

    Lars Guest

    Hi

    After talking to an old friend of mine that I wirked with back in 1995 who
    happens to be sort of an expert in ASP.NET. I got some advice. When you get
    this type of problem

    *)
    Make sure you have the user rights proprly set for each user and also the
    right security for the folders and files on the homepage.

    *)
    I also found one thing out my self. The reason I couldn't login on my
    homepage location was rather obvious when found out why. Visual Studio 2008
    (VS2008) was connected to the local Microsoft SQL Server. At the same time
    the homepage tried to access the very same database and that coused the
    problem. Once I exit VS2008 I'm able to login and use the database as I
    want. Wheater this is a "bug" or a "feature" in Microsoft SQL Server is for
    Microsoft to tell.

    Hope this can help some one else with the same problem.

    Yours
    Lars


    "Lars" <> skrev i meddelandet
    news:rTeuj.3903$...
    > Hi
    >
    > I manage to get the page viewable
    >
    > But I still can't use the login form.
    >
    > I get the following error and I don't know what it means
    >
    > An attempt to attach an auto-named database for file C:\Documents and
    > Settings\Rosoft\Mina dokument\Visual Studio
    > 2008\WebSites\Lesson05\Lesson05\App_Data\dbMusicFiles.mdf failed. A
    > database with the same name exists, or specified file cannot be opened, or
    > it is located on UNC share.
    >
    >
    > I only have one copy of the file dbMusicFiles.mdf
    >
    > What is UNC Share?
    >
    >
    > Again: It works when I run the page from within the browser.
    >
    > Lars
    >
    >
    > "Lars" <> skrev i meddelandet
    > news:eek:Yduj.3901$...
    >> Hi
    >>
    >> I have an IIS server installed on my local PC and I want to publish my
    >> ASP.NET site to my local webserver. I know the webserver is working since
    >> I can add an index.html file and view in a browser through my no-ip.org
    >> domain name. But when I publish my local Visual Studio 2008 (VS2008)
    >> project to my IIS I can't reach the site at all. I can run the site from
    >> within the VS2008 IDE.
    >>
    >> Is there any thing I need to add to my IIS. The project in VS2008
    >> includes thre user groups and two users. Administrators, Accessors and a
    >> Public group. Does this setting require some thing more?
    >>
    >> Yours
    >> Lars
    >>

    >
    >
     
    Lars, Feb 19, 2008
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Norman Yuan
    Replies:
    0
    Views:
    518
    Norman Yuan
    Jun 20, 2008
  2. Juan T. Llibre
    Replies:
    0
    Views:
    1,216
    Juan T. Llibre
    Jun 20, 2008
  3. RadioSignal

    passing variables from .aspx.cs code pages to .aspx pages

    RadioSignal, Sep 12, 2005, in forum: ASP .Net Web Controls
    Replies:
    7
    Views:
    2,307
    Mirronelli
    Oct 22, 2005
  4. Billy
    Replies:
    7
    Views:
    167
    Jeff Cochran
    Dec 17, 2003
  5. David
    Replies:
    1
    Views:
    477
    Jeff Cochran
    Apr 6, 2004
Loading...

Share This Page