Problem redirecting to pages when SmartNavigation is active. Why?

Discussion in 'ASP .Net' started by Peter Rilling, Apr 23, 2004.

  1. Past threads on Google do not offer much help or explanation, so maybe
    someone can offer a fresh perspective.

    I have a website that is installed on both a test and production
    environments. This site uses SmartNavigation on some of the pages. The
    test environment works as expected. When you click the submit button, you
    are redirected to the correct page. However, when you click the submit
    button when using the production environment, you get the following HTML
    content and no redirection happens.

    <BODY><ASP_SMARTNAV_RDIR url="/default.aspx"></ASP_SMARTNAV_RDIR></BODY>
    I am sure that turning off SmartNavigation would solve the problem, I don't
    want to inconvenience the user.

    Here are some points to keep in mind.

    1) Two servers contain identical code for the site. One server works, the
    other does not.
    2) This is consistent, meaning that more than one client is having the
    problem when accessing the production.
    3) If a browser instance accesses the production environment, the above
    HTML is displayed. If the same browser uses the test environment, redirect
    occurs as expected. This rules out a problem with the client.


    Any thoughts. From what I can see of other posts, lots of people have a
    similar problem, but no one has yet to provide an explanation and solution.
     
    Peter Rilling, Apr 23, 2004
    #1
    1. Advertising

  2. Peter Rilling

    Rick Spiewak Guest

    Not an explanation, but perhaps using server.transfer would work around
    this.

    "Peter Rilling" <> wrote in message
    news:%...
    > Past threads on Google do not offer much help or explanation, so maybe
    > someone can offer a fresh perspective.
    >
    > I have a website that is installed on both a test and production
    > environments. This site uses SmartNavigation on some of the pages. The
    > test environment works as expected. When you click the submit button, you
    > are redirected to the correct page. However, when you click the submit
    > button when using the production environment, you get the following HTML
    > content and no redirection happens.
    >
    > <BODY><ASP_SMARTNAV_RDIR url="/default.aspx"></ASP_SMARTNAV_RDIR></BODY>
    > I am sure that turning off SmartNavigation would solve the problem, I

    don't
    > want to inconvenience the user.
    >
    > Here are some points to keep in mind.
    >
    > 1) Two servers contain identical code for the site. One server works,

    the
    > other does not.
    > 2) This is consistent, meaning that more than one client is having the
    > problem when accessing the production.
    > 3) If a browser instance accesses the production environment, the above
    > HTML is displayed. If the same browser uses the test environment,

    redirect
    > occurs as expected. This rules out a problem with the client.
    >
    >
    > Any thoughts. From what I can see of other posts, lots of people have a
    > similar problem, but no one has yet to provide an explanation and

    solution.
    >
    >
     
    Rick Spiewak, Apr 25, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?bV9sYWNp?=
    Replies:
    2
    Views:
    514
    =?Utf-8?B?bV9sYWNp?=
    Oct 15, 2004
  2. Mr. SweatyFinger

    why why why why why

    Mr. SweatyFinger, Nov 28, 2006, in forum: ASP .Net
    Replies:
    4
    Views:
    917
    Mark Rae
    Dec 21, 2006
  3. Mr. SweatyFinger
    Replies:
    2
    Views:
    2,035
    Smokey Grindel
    Dec 2, 2006
  4. Martin

    Problem Redirecting Mobile ASP pages

    Martin, Mar 22, 2005, in forum: ASP .Net Mobile
    Replies:
    2
    Views:
    136
    Martin
    Mar 28, 2005
  5. carlos seramos
    Replies:
    2
    Views:
    493
    carlos seramos
    Aug 1, 2003
Loading...

Share This Page