Problem using ASP Wizard Control in User Control

Discussion in 'ASP .Net Web Controls' started by Lasse, May 31, 2006.

  1. Lasse

    Lasse Guest

    Hi all,

    I have an asp wizard control that retrieves items from a collection and
    contingent on the number of items in the collection, it dynamically adds the
    correspondent number of wizardsteps to the wizard. This is done by code in
    the Page PreInit handler or Page Init handler.



    It all works well when used on a Web Form (.aspx), but when I place the
    wizard on a Web User Control (.ascx); wizardsteps do not retain user input
    when navigating to another wizardstep, ie when i navigate back to the page
    it displays null or default values. It displays the same behavior even if I
    add the wizardsteps in design mode.



    Any ideas?



    //Lasse
    Lasse, May 31, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John
    Replies:
    3
    Views:
    2,866
    Joshua Flanagan
    Dec 11, 2005
  2. Replies:
    0
    Views:
    577
  3. Runsrealfast
    Replies:
    2
    Views:
    397
    Chris Fulstow
    Oct 2, 2006
  4. Andy B
    Replies:
    0
    Views:
    423
    Andy B
    Apr 19, 2008
  5. dotnet_nut

    asp.net 2.0 Wizard Control and User Control (.ascx)

    dotnet_nut, Oct 24, 2006, in forum: ASP .Net Web Controls
    Replies:
    0
    Views:
    256
    dotnet_nut
    Oct 24, 2006
Loading...

Share This Page