Problem using com object in IIS 4

Discussion in 'ASP General' started by d, Sep 13, 2003.

  1. d

    d Guest

    Hey all,

    I've been having a weird problem using com objects in IIS 4.
    I've built a middleware system that can be called with XML
    requests over HTTP. The request is sent to an ASP page which
    creates a com object that handles the request. This com object
    usually calls other asp pages that handle sub functions.
    This has worked fine, but now I have a new component that is
    giving me a lot of problems. It's a component that contains
    a few calls to a SQL db using ADO.

    It works fine for a while, but then I start getting an error
    in the backend component. I have very good error handling, so
    I get an XML response back with the error number and location.
    I have been able to pin point the line of code that gives the
    error (5, illegal function call). But it's almost impossible
    that an error would happen there... The line of code contains
    an add to a collection. I add a simple variable to a collection.
    This runs fine for a long time and then I get the error.
    On my local machine the code works fine. As soon as I plug it into
    IIS it goes wrong. The error always occurs in the same spot.

    After this error has occurred, I can no longer use any component
    that uses my database component. If I leave the machine alone
    for a while it will pick up again...

    I'm confused...

    Thanks,
    Dirk.
     
    d, Sep 13, 2003
    #1
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Grind Boy

    .NET IIS to IIS credentials problem...

    Grind Boy, Aug 13, 2003, in forum: ASP .Net
    Replies:
    4
    Views:
    2,651
    Grind Boy
    Aug 14, 2003
  2. Matthew Louden
    Replies:
    3
    Views:
    6,318
    Sherif ElMetainy
    Nov 7, 2003
  3. JMaelstrom

    IIS 6 vs IIS 5 ASP.NET Performance Issues

    JMaelstrom, Dec 9, 2003, in forum: ASP .Net
    Replies:
    2
    Views:
    4,885
    shan420
    Apr 30, 2010
  4. darrel
    Replies:
    13
    Views:
    665
    Kevin Spencer
    Mar 3, 2005
  5. HankD
    Replies:
    0
    Views:
    516
    HankD
    May 11, 2005
  6. jon wayne
    Replies:
    9
    Views:
    1,000
    Jim Langston
    Sep 22, 2005
  7. Jon Davis
    Replies:
    3
    Views:
    779
    Jon Davis
    Jun 21, 2007
  8. d
    Replies:
    0
    Views:
    139
Loading...