problem with inluding lapackpp

Discussion in 'C++' started by bufu18@wp.pl, Mar 1, 2007.

  1. Guest

    hi all,

    I've downloaded (unpack etc) lapckpp library from http://sourceforge.net/projects/lapackpp/

    I want to use it but I have problems with including it.

    I have included main file \include\lapackpp\lapackpp.h
    but compiler says that there is no files aversion.h, f2c.h,
    lafnames.h which are in the same directory like lapackpp.h and what
    is more funny there are more files which have to be included from the
    same place but compiler says about only these 3.

    I'm using Code::Blocks and I've tried to change compiler from gcc into
    another but the problem is the same. I've checked it in Builder and
    the same...

    Could anybody try to include it (free soft) maybe I have something
    wrong in my settings...


    thx
    , Mar 1, 2007
    #1
    1. Advertising

  2. wrote:
    > I've downloaded (unpack etc) lapckpp library from
    > http://sourceforge.net/projects/lapackpp/
    >
    > I want to use it but I have problems with including it.
    >
    > I have included main file \include\lapackpp\lapackpp.h
    > but compiler says that there is no files aversion.h, f2c.h,
    > lafnames.h which are in the same directory like lapackpp.h and what
    > is more funny there are more files which have to be included from the
    > same place but compiler says about only these 3.


    Uh... What do you think we can do?

    > I'm using Code::Blocks and I've tried to change compiler from gcc into
    > another but the problem is the same. I've checked it in Builder and
    > the same...


    Well, gcc newsgroup is 'gnu.gcc.help' or 'gnu.g++.help'. Borland C++
    Builder also has its own newsgroups, 'borland.public.cppbuilder.*'.

    > Could anybody try to include it (free soft) maybe I have something
    > wrong in my settings...


    Most likely. But we can't help you with those. You need to ask in
    the newsgroup dedicated to your compiler.

    V
    --
    Please remove capital 'A's when replying by e-mail
    I do not respond to top-posted replies, please don't ask
    Victor Bazarov, Mar 1, 2007
    #2
    1. Advertising

  3. Guest

    > Most likely. But we can't help you with those. You need to ask in
    > the newsgroup dedicated to your compiler.



    ok I will try I thought that this library should be independent on
    compiler especially gcc so I've posted here

    thx
    , Mar 1, 2007
    #3
  4. wrote:
    >> Most likely. But we can't help you with those. You need to ask in
    >> the newsgroup dedicated to your compiler.

    >
    >
    > ok I will try I thought that this library should be independent on
    > compiler especially gcc so I've posted here


    The library can be independent (or it can be made to work with only
    the chosen compilers), but compilation process problems because of
    incorrect settings cannot be compiler-independent. I am not sure I
    understand the "especially gcc" part. Regardless of the fact that
    the library is a GNU project, if your gcc is not set up correctly
    or if you don't provide the necessary commands/settings to it when
    compiling the library, you're going to have problems, most likely.
    And no C++ language feature can help you overcome those.

    Good luck!

    V
    --
    Please remove capital 'A's when replying by e-mail
    I do not respond to top-posted replies, please don't ask
    Victor Bazarov, Mar 1, 2007
    #4
  5. wrote:
    > hi all,
    >
    > I've downloaded (unpack etc) lapckpp library from http://sourceforge.net/projects/lapackpp/
    >
    > I want to use it but I have problems with including it.
    >
    > I have included main file \include\lapackpp\lapackpp.h
    > but compiler says that there is no files aversion.h, f2c.h,
    > lafnames.h which are in the same directory like lapackpp.h and what
    > is more funny there are more files which have to be included from the
    > same place but compiler says about only these 3.
    >
    > I'm using Code::Blocks and I've tried to change compiler from gcc into
    > another but the problem is the same. I've checked it in Builder and
    > the same...
    >
    > Could anybody try to include it (free soft) maybe I have something
    > wrong in my settings...
    >
    >
    > thx
    >


    Well I think your problem is that you've said something like

    #include "include/lapackpp/lapackpp.h"

    instead of telling your compiler to look in the include/lapackpp
    directory. If you have done that it would have found all the header
    files no problem.

    But I'm only guessing since you didn't post any code, or explain what
    compiler options you did use.

    john
    John Harrison, Mar 1, 2007
    #5
  6. John Harrison wrote:
    > [.. some good guesses ..]
    > But I'm only guessing since you didn't post any code, or explain what
    > compiler options you did use.


    Hopefully this is not an invitation to the OP to explain what compiler
    options were used. Compiler options are still off-topic here... :)
    Victor Bazarov, Mar 1, 2007
    #6
  7. Guest

    I am not sure if the problem is in settings because untill today every
    program compiles... Also the problem occures in builder. I will try
    with #include "include/lapackpp" before it was #include "include/
    lapackpp/lapackpp.h"
    Could you try too run it on your compiler?
    , Mar 1, 2007
    #7
  8. wrote:
    > I am not sure if the problem is in settings because untill today every
    > program compiles... Also the problem occures in builder. I will try
    > with #include "include/lapackpp" before it was #include "include/
    > lapackpp/lapackpp.h"
    > Could you try too run it on your compiler?


    What would that accomplish?
    Victor Bazarov, Mar 2, 2007
    #8
  9. On Mar 1, 6:51 pm, wrote:
    > hi all,
    >
    > I've downloaded (unpack etc) lapckpp library fromhttp://sourceforge.net/projects/lapackpp/
    >
    > I want to use it but I have problems with including it.
    >
    > I have included main file \include\lapackpp\lapackpp.h
    > but compiler says that there is no files aversion.h, f2c.h,
    > lafnames.h which are in the same directory like lapackpp.h and


    Very off-topic:
    I might be wrong but I think that Lapackpp requires BLAS, which is a
    set of matrix/matrix and matrix/vector operations. Originally written
    in Fortran but there are C versions of it (some of which are machine-
    translates hence the need for f2c.h (Fortran to C)). Check the
    Lapackpp documentation, I expect it to mention something about it.

    --
    Erik Wikström
    =?iso-8859-1?q?Erik_Wikstr=F6m?=, Mar 2, 2007
    #9
  10. wrote:
    > I am not sure if the problem is in settings because untill today every
    > program compiles... Also the problem occures in builder. I will try
    > with #include "include/lapackpp" before it was #include "include/
    > lapackpp/lapackpp.h"
    > Could you try too run it on your compiler?
    >


    I don't know how much clearer I can be.

    You need to use COMPILER SETTINGS to tell your compiler where to find
    the files, you don't need to say #include "this" or #include "that".

    Sometimes you need different compiler settings to compile different
    programs.

    john
    John Harrison, Mar 2, 2007
    #10
  11. Guest


    > You need to use COMPILER SETTINGS to tell your compiler where to find
    > the files, you don't need to say #include "this" or #include "that".


    Now it compiles without any code. I've added this directory to
    compiler settings.

    But still I do not understand to the end why inlcuding FILE from some
    directory doesn't work when this FILE needs some other things to work
    which are in the same directory as FILE.

    thx for help

    when I would have problems with using lapckpp where should I post?
    , Mar 2, 2007
    #11
  12. wrote:
    > [..]
    > when I would have problems with using lapckpp where should I post?


    http://sourceforge.net/projects/lapackpp seems to have all the
    necessary instructions. Can you not see the "Need Support?" link
    on that page?

    V
    --
    Please remove capital 'A's when replying by e-mail
    I do not respond to top-posted replies, please don't ask
    Victor Bazarov, Mar 2, 2007
    #12
  13. wrote:
    >>You need to use COMPILER SETTINGS to tell your compiler where to find
    >>the files, you don't need to say #include "this" or #include "that".

    >
    >
    > Now it compiles without any code. I've added this directory to
    > compiler settings.
    >
    > But still I do not understand to the end why inlcuding FILE from some
    > directory doesn't work when this FILE needs some other things to work
    > which are in the same directory as FILE.
    >


    That's just the way that compiler works. It may not coincide with your
    expectations but that doesn't mean it is wrong. All this stuff is up to
    compiler writers to decide, and different compilers do it differently.

    > thx for help
    >


    No problemo

    john
    John Harrison, Mar 2, 2007
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Price

    Inluding a file in ASP+

    Andrew Price, Feb 1, 2005, in forum: ASP .Net
    Replies:
    10
    Views:
    796
    Andrew Price
    Feb 1, 2005
  2. H W
    Replies:
    4
    Views:
    1,183
  3. H W
    Replies:
    0
    Views:
    523
  4. Rainer Heynke
    Replies:
    3
    Views:
    384
    James Kanze
    Sep 12, 2008
  5. Mike

    Problem problem problem :( Need Help

    Mike, May 7, 2004, in forum: ASP General
    Replies:
    2
    Views:
    534
    Bullschmidt
    May 11, 2004
Loading...

Share This Page