Problem with state server on new development machine

Discussion in 'ASP .Net' started by B.E.S., Feb 22, 2007.

  1. B.E.S.

    B.E.S. Guest

    Moving to a new development machine. Am getting the following message when
    trying to run applications that require the state server:

    --------8<--------------

    Unable to make the session state request to the session state server. Please
    ensure that the ASP.NET State service is started and that the client and
    server ports are the same. If the server is on a remote machine, please
    ensure that it accepts remote requests by checking the value of
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\aspnet_state\Parameters\AllowRemoteConnection.

    --------8<--------------

    The state server setting in web.config is set to the default
    (127.0.0.1:42424). The service is running.

    The event log contains this info:

    --------8<--------------

    Event Type: Error
    Event Source: ASP.NET 2.0.50727.0
    Event Category: None
    Event ID: 1074
    Date: 2/22/2007
    Time: 4:55:35 PM
    User: N/A
    Computer: VGE030
    Description:
    An error occurred in while processing a request in state server. Major
    callstack: ProcessCompletion-->ProcessReading. Error code: 0x80070057

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.

    --------8<--------------

    I've spent some time searching this out, but the few people who've gotten
    this error (event ID 1074) never seem to get a resolution.

    What is causing the problem and what can I do to fix it?

    Thanks,
    Bryan
    B.E.S., Feb 22, 2007
    #1
    1. Advertising

  2. On Feb 22, 10:58 pm, "B.E.S." <> wrote:
    > Moving to a new development machine. Am getting the following message when
    > trying to run applications that require the state server:
    >
    > --------8<--------------
    >
    > Unable to make the session state request to the session state server. Please
    > ensure that the ASP.NET State service is started and that the client and
    > server ports are the same. If the server is on a remote machine, please
    > ensure that it accepts remote requests by checking the value of
    > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\aspnet_state\ParameterĀ­s\AllowRemoteConnection.
    >
    > --------8<--------------
    >
    > The state server setting in web.config is set to the default
    > (127.0.0.1:42424). The service is running.
    >
    > The event log contains this info:
    >
    > --------8<--------------
    >
    > Event Type: Error
    > Event Source: ASP.NET 2.0.50727.0
    > Event Category: None
    > Event ID: 1074
    > Date: 2/22/2007
    > Time: 4:55:35 PM
    > User: N/A
    > Computer: VGE030
    > Description:
    > An error occurred in while processing a request in state server. Major
    > callstack: ProcessCompletion-->ProcessReading. Error code: 0x80070057
    >
    > For more information, see Help and Support Center athttp://go.microsoft.com/fwlink/events.asp.
    >
    > --------8<--------------
    >
    > I've spent some time searching this out, but the few people who've gotten
    > this error (event ID 1074) never seem to get a resolution.
    >
    > What is causing the problem and what can I do to fix it?
    >
    > Thanks,
    > Bryan



    Bryan, I see some threads regaring the permissions issue with ASPNET
    user

    Could it be your problem?

    http://groups.google.com/group/micr...read/thread/954c0f4e4305b072/48c001321999f532
    Alexey Smirnov, Feb 22, 2007
    #2
    1. Advertising

  3. Hi Bryan,

    Here's my understanding of the issue so far:

    1) You're using ASP.NET 2.0
    2) You've setup a new development machine and want to use a local state
    server as session state store
    3) You encountered error when using the state server. Event ID 1074 and
    error 0x80070057 (E_INVALIDARG) is logged.

    Please help me on following points:

    1) Does this issue occur every time or just occasionally?
    2) Do you have a space in your application name or path?
    3) What's the os and service pack?
    4) Is the state server listening correctly? (Try to use telnet localhost
    42424 to verify)

    I'll follow-up again after you give me above information. Thanks.


    Sincerely,
    Walter Wang (, remove 'online.')
    Microsoft Online Community Support

    ==================================================
    Get notification to my posts through email? Please refer to
    http://msdn.microsoft.com/subscriptions/managednewsgroups/default.aspx#notif
    ications. If you are using Outlook Express, please make sure you clear the
    check box "Tools/Options/Read: Get 300 headers at a time" to see your reply
    promptly.

    Note: The MSDN Managed Newsgroup support offering is for non-urgent issues
    where an initial response from the community or a Microsoft Support
    Engineer within 1 business day is acceptable. Please note that each follow
    up response may take approximately 2 business days as the support
    professional working with you may need further investigation to reach the
    most efficient resolution. The offering is not appropriate for situations
    that require urgent, real-time or phone-based interactions or complex
    project analysis and dump analysis issues. Issues of this nature are best
    handled working with a dedicated Microsoft Support Engineer by contacting
    Microsoft Customer Support Services (CSS) at
    http://msdn.microsoft.com/subscriptions/support/default.aspx.
    ==================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Walter Wang [MSFT], Feb 23, 2007
    #3
  4. B.E.S.

    B.E.S. Guest

    Walter,

    To clarify: I'm using ASP.NET 1.0 (framework version 1.1.4322)

    In answer to your question:

    1) The issue happens every time.
    2) No, the name of the project has no space. The problem occurs in ALL
    projects.
    3) Windows XP Pro, Service Pack 2
    4) The state server is listening. I am able to telnet to localhost on port
    42424

    Thanks,
    Bryan

    "Walter Wang [MSFT]" <> wrote in message
    news:...
    > Hi Bryan,
    >
    > Here's my understanding of the issue so far:
    >
    > 1) You're using ASP.NET 2.0
    > 2) You've setup a new development machine and want to use a local state
    > server as session state store
    > 3) You encountered error when using the state server. Event ID 1074 and
    > error 0x80070057 (E_INVALIDARG) is logged.
    >
    > Please help me on following points:
    >
    > 1) Does this issue occur every time or just occasionally?
    > 2) Do you have a space in your application name or path?
    > 3) What's the os and service pack?
    > 4) Is the state server listening correctly? (Try to use telnet localhost
    > 42424 to verify)
    >
    > I'll follow-up again after you give me above information. Thanks.
    >
    >
    > Sincerely,
    > Walter Wang (, remove 'online.')
    > Microsoft Online Community Support
    >
    > ==================================================
    > Get notification to my posts through email? Please refer to
    > http://msdn.microsoft.com/subscriptions/managednewsgroups/default.aspx#notif
    > ications. If you are using Outlook Express, please make sure you clear the
    > check box "Tools/Options/Read: Get 300 headers at a time" to see your
    > reply
    > promptly.
    >
    > Note: The MSDN Managed Newsgroup support offering is for non-urgent issues
    > where an initial response from the community or a Microsoft Support
    > Engineer within 1 business day is acceptable. Please note that each follow
    > up response may take approximately 2 business days as the support
    > professional working with you may need further investigation to reach the
    > most efficient resolution. The offering is not appropriate for situations
    > that require urgent, real-time or phone-based interactions or complex
    > project analysis and dump analysis issues. Issues of this nature are best
    > handled working with a dedicated Microsoft Support Engineer by contacting
    > Microsoft Customer Support Services (CSS) at
    > http://msdn.microsoft.com/subscriptions/support/default.aspx.
    > ==================================================
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    >
    B.E.S., Feb 23, 2007
    #4
  5. Hi Bryan,

    From the event source in your first message:

    Event Source: ASP.NET 2.0.50727.0

    It seems to me that the site is running under ASP.NET 2.0. Would you please
    check it by using IIS Manager?

    If you're running both ASP.NET 2.0 and 1.1 web sites on the same server,
    make sure you configure them to run in separate AppPool.

    The 2.0 state service should be usable by 1.1 web app, as described here:

    #ASP.NET Side-by-Side Overview
    http://msdn2.microsoft.com/en-us/library/a99txfy5(VS.80).aspx

    Please try to re-register the script map of your web application by running:

    aspnet_regiis -s W3SVC/1/ROOT/SampleApp1

    Since you're using ASP.NET 1.1, make sure you use the aspnet_regiis.exe in
    %windir%\Microsoft.NET\Framework\v1.1.4322\

    Regards,
    Walter Wang (, remove 'online.')
    Microsoft Online Community Support

    ==================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ==================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Walter Wang [MSFT], Feb 26, 2007
    #5
  6. Hi Bryan,

    If you see this message, would you please reply here to let me know the
    status of this post? Thanks.

    Regards,
    Walter Wang (, remove 'online.')
    Microsoft Online Community Support

    ==================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ==================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Walter Wang [MSFT], Mar 1, 2007
    #6
  7. Walter,

    My apologies. I had to disappear for a while because my wife had a baby :)

    I will look at what you said in your previous message (about running 2.0 and
    1.1 side-by-side) and get back with you today.

    Thanks,
    Bryan

    "Walter Wang [MSFT]" <> wrote in message
    news:...
    > Hi Bryan,
    >
    > If you see this message, would you please reply here to let me know the
    > status of this post? Thanks.
    >
    > Regards,
    > Walter Wang (, remove 'online.')
    > Microsoft Online Community Support
    >
    > ==================================================
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    > ==================================================
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    >
    Bryan Slatner, Mar 2, 2007
    #7
  8. Walter,

    I'm still getting the issue. I read through the MSDN article you posted, but
    didn't really see anything that would help. I tried:

    1) running aspnet_iis -i from c:\Windows\Microsoft.NET\Framework\v1.1.4322
    2) running aspnet_iis -s W3SVC/1/ROOT/Verizon ("Verizon" being the name of
    my application)
    3) running aspnet_iis -u from c;\Windows\Microsoft.NET\Framework\v2.0.50727

    I get the error no matter what I do.

    Note that this is running on Windows XP. In a previous post, you mentioned
    something about making sure v1.1 apps run in one app pool and v2.0 apps run
    in another app pool. We do this on our production server, but on my
    development Windows XP machine, there are no app pools available in IIS.

    Thanks,
    Bryan

    "Walter Wang [MSFT]" <> wrote in message
    news:...
    > Hi Bryan,
    >
    > If you see this message, would you please reply here to let me know the
    > status of this post? Thanks.
    >
    > Regards,
    > Walter Wang (, remove 'online.')
    > Microsoft Online Community Support
    >
    > ==================================================
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    > ==================================================
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    >
    Bryan Slatner, Mar 2, 2007
    #8
  9. Incidentally, setting the sesssionState mode to "InProc" or "SQLServer"
    works like a charm. Only "StateServer" has a problem. I don't know if that's
    relevant or not.

    "Walter Wang [MSFT]" <> wrote in message
    news:...
    > Hi Bryan,
    >
    > If you see this message, would you please reply here to let me know the
    > status of this post? Thanks.
    >
    > Regards,
    > Walter Wang (, remove 'online.')
    > Microsoft Online Community Support
    >
    > ==================================================
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    > ==================================================
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    >
    Bryan Slatner, Mar 2, 2007
    #9
  10. Hi Bryan,

    Congratulations!

    Thank you for letting me know the test result regarding the aspnet_regiis.
    Yes the apppool is not available in IIS 5.x, my previous reply regarding
    using separate AppPool can be ignored here.

    I've done some further searching in our internal support database, sorry I
    cannot find more possible causes. This should be environment specific issue.

    If it's possible to use SqlServer during your development, I recommend to
    stick with it on this particular Windows XP dev box. If you want to find
    the root cause, I'm afraid you will have to contact Microsoft Customer
    Support and Service, which can use live debugging or dump analysis to best
    troubleshoot such issue. This is unfortunately not possible for newsgroup
    support.

    Please feel free to let me know if there's anything I can help.


    Regards,
    Walter Wang (, remove 'online.')
    Microsoft Online Community Support

    ==================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ==================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Walter Wang [MSFT], Mar 5, 2007
    #10
  11. Thanks, Walter. I'll use SQL server for the time being. It works just as
    well.

    "Walter Wang [MSFT]" <> wrote in message
    news:jQ%...
    > Hi Bryan,
    >
    > Congratulations!
    >
    > Thank you for letting me know the test result regarding the aspnet_regiis.
    > Yes the apppool is not available in IIS 5.x, my previous reply regarding
    > using separate AppPool can be ignored here.
    >
    > I've done some further searching in our internal support database, sorry I
    > cannot find more possible causes. This should be environment specific
    > issue.
    >
    > If it's possible to use SqlServer during your development, I recommend to
    > stick with it on this particular Windows XP dev box. If you want to find
    > the root cause, I'm afraid you will have to contact Microsoft Customer
    > Support and Service, which can use live debugging or dump analysis to best
    > troubleshoot such issue. This is unfortunately not possible for newsgroup
    > support.
    >
    > Please feel free to let me know if there's anything I can help.
    >
    >
    > Regards,
    > Walter Wang (, remove 'online.')
    > Microsoft Online Community Support
    >
    > ==================================================
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    > ==================================================
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    >
    Bryan Slatner, Mar 5, 2007
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter Row
    Replies:
    0
    Views:
    464
    Peter Row
    Mar 1, 2004
  2. Terry Olsen
    Replies:
    0
    Views:
    452
    Terry Olsen
    Mar 28, 2005
  3. UJ
    Replies:
    2
    Views:
    423
  4. UJ
    Replies:
    2
    Views:
    416
  5. fenster
    Replies:
    3
    Views:
    1,156
    jeppe
    Dec 23, 2011
Loading...

Share This Page