<%=...%> problem

Discussion in 'ASP General' started by Jill Graham, Jun 7, 2004.

  1. Jill Graham

    Jill Graham Guest

    Hi,

    Here is my .aspx page :

    <%@ Page %>
    <%@ Register TagPrefix="Module" Namespace="....." assembly="....." %>
    <html>
    <head></head>
    <body>
    <table>
    <tr>
    <td>
    <%=dayId%>
    </td>
    <td>
    <Module:calendar day="<%=dayId%>" runat="server" />
    </td>
    </tr>
    </table>
    </body>
    </html>

    The first occurence of dayId is replaced by its value as defined in the
    myPage.aspx file. The second occurence of dayId (Module attribute) is NOT
    replaced by its value. How come ?

    Does anyone has any idea on how to use <%=...%> within the attributes of
    custom controls ?

    Jill
     
    Jill Graham, Jun 7, 2004
    #1
    1. Advertisements

  2. http://www.aspfaq.com/5002

    --
    http://www.aspfaq.com/
    (Reverse address to reply.)




    "Jill Graham" <> wrote in message
    news:...
    > Hi,
    >
    > Here is my .aspx page :
    >
    > <%@ Page %>
    > <%@ Register TagPrefix="Module" Namespace="....." assembly="....." %>
    > <html>
    > <head></head>
    > <body>
    > <table>
    > <tr>
    > <td>
    > <%=dayId%>
    > </td>
    > <td>
    > <Module:calendar day="<%=dayId%>" runat="server" />
    > </td>
    > </tr>
    > </table>
    > </body>
    > </html>
    >
    > The first occurence of dayId is replaced by its value as defined in the
    > myPage.aspx file. The second occurence of dayId (Module attribute) is NOT
    > replaced by its value. How come ?
    >
    > Does anyone has any idea on how to use <%=...%> within the attributes of
    > custom controls ?
    >
    > Jill
    >
    >
    >
    >
     
    Aaron [SQL Server MVP], Jun 7, 2004
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andreas Suurkuusk
    Replies:
    0
    Views:
    4,244
    Andreas Suurkuusk
    Jul 27, 2003
  2. Ted Miller
    Replies:
    0
    Views:
    5,489
    Ted Miller
    Sep 13, 2003
  3. Merek
    Replies:
    0
    Views:
    2,164
    Merek
    Dec 3, 2003
  4. Scott Meddows
    Replies:
    1
    Views:
    550
    John Saunders
    Jun 8, 2004
  5. Mustafa Yesilkaya
    Replies:
    0
    Views:
    1,634
    Mustafa Yesilkaya
    Jun 11, 2004
  6. Eric
    Replies:
    0
    Views:
    1,100
  7. Stephen Kellett

    TomCat problem - locale problem?

    Stephen Kellett, Jul 6, 2004, in forum: Java
    Replies:
    4
    Views:
    9,842
    Stephen Kellett
    Jul 8, 2004
  8. Mike

    Problem problem problem :( Need Help

    Mike, May 7, 2004, in forum: ASP General
    Replies:
    2
    Views:
    796
    Bullschmidt
    May 11, 2004
Loading...