Project on the remote server

Discussion in 'ASP .Net' started by Leszek, Nov 12, 2003.

  1. Leszek

    Leszek Guest

    Hi,

    So far I have been creating projects on my local machine (localhost) without
    any problems. Now I need to create a project on a remote server. When I try
    to create a web application on the server, VS.NET returns an error message
    about lack of required permissions. What permissions do I need to set up on
    the remote server?

    My server system: Win2000 Advanced Server with built-in IIS, .NET 1.1

    Thanks in advance,
    Leszek Taratuta
    Leszek, Nov 12, 2003
    #1
    1. Advertising

  2. Hi Leszek,

    Please tell me the detailed error message and the detailed reproducing
    steps.

    Basically the account should have the write permission of the
    \Inetpub\wwwroot folder. A simple work around will be using the
    Administrator account.

    I hope it helps.

    Best regards,

    Jacob Yang
    Microsoft Online Partner Support
    Get Secure! ¨C www.microsoft.com/security
    This posting is provided "as is" with no warranties and confers no rights.
    Jacob Yang [MSFT], Nov 13, 2003
    #2
    1. Advertising

  3. Leszek

    Leszek Guest

    When I try to create a new project on the remote server I receive the
    following error:

    "Web Access Failed"
    "The default Web access mode for this project is set to file share, but the
    project folder at 'http://webserver/myapplication' cannot be opened with the
    path '\\webserver\wwwroot$\myapplication'. The error returned was:
    Unable to create Web project 'myapplication'. The UNC share
    '\\webserver\wwwroot$\myapplication' does not exist or you do not have
    access."

    I have temporarily resolved the problem by selecting the option "Try to open
    the project with FrontPage Server Extensions" but I am not sure if this is
    the right way to do this.

    Thanks,
    Leszek Taratuta

    "Jacob Yang [MSFT]" <> wrote in message
    news:...
    > Hi Leszek,
    >
    > Please tell me the detailed error message and the detailed reproducing
    > steps.
    >
    > Basically the account should have the write permission of the
    > \Inetpub\wwwroot folder. A simple work around will be using the
    > Administrator account.
    >
    > I hope it helps.
    >
    > Best regards,
    >
    > Jacob Yang
    > Microsoft Online Partner Support
    > Get Secure! ¨C www.microsoft.com/security
    > This posting is provided "as is" with no warranties and confers no rights.
    >
    Leszek, Nov 13, 2003
    #3
  4. Hi Leszek,

    Using FPSE is an optional work around for this issue. I have another
    solution for your reference.

    We can follow the following steps to create the project on the
    virtual/remote Web site.

    Once the virtual Web site is created,
    1) Share the physical folder pointed by the virtual Web root.
    2) Provide permissions to VS Developers Group to that folder and make sure
    the user on the client is one of the members of this group on the server.
    3) In an intranet situation, add the virtual web site name/address to hosts
    file on both client and server machine.

    From the client,
    1) Open Visual Studio.NET.
    2) Go to Tools/Options/Projects/Web Settings and on the right hand side
    panel, select "Connection Settings" or you can also open IE and go to
    Tools/Internet Options/Connections.
    3) Click on LAN settings and if you are using proxy, then uncheck all the
    options under "Automatic configuration" section. ("Automatically detect
    settings" and "Use Automatic configuration Script")
    4) Check both options in "Proxy Server" section ("Use Proxy server for your
    LAN .." and "Bypass proxy server for local addresses") and provide the
    details of the proxy server.
    5) Click on the "Advanced" button in Proxy Server section and in the "Proxy
    Server" dialog box, add the host header name to the list that says "Do not
    use proxy server for addresses beginning with the following" and click Ok.
    6) Start creating a new project in VS.NET
    8) In the New Project dialog box, provide the location as
    http://virtualWebsitename/projectname
    9) When you get the Web Access Failed dialog box, provide the proper share
    for the virtual web site that you are going to create project in. e.g.
    \\<machinename>\sharenameforvirtualwebsite\projectname
    10) Now the project should get created under the specified share on the web
    server.

    I hope it helps.

    Best regards,

    Jacob Yang
    Microsoft Online Partner Support
    Get Secure! ¨C www.microsoft.com/security
    This posting is provided "as is" with no warranties and confers no rights.
    Jacob Yang [MSFT], Nov 14, 2003
    #4
  5. Leszek

    Leszek Guest

    Thanks a lot!

    Leszek Taratuta

    "Jacob Yang [MSFT]" <> wrote in message
    news:...
    > Hi Leszek,
    >
    > Using FPSE is an optional work around for this issue. I have another
    > solution for your reference.
    >
    > We can follow the following steps to create the project on the
    > virtual/remote Web site.
    >
    > Once the virtual Web site is created,
    > 1) Share the physical folder pointed by the virtual Web root.
    > 2) Provide permissions to VS Developers Group to that folder and make sure
    > the user on the client is one of the members of this group on the server.
    > 3) In an intranet situation, add the virtual web site name/address to

    hosts
    > file on both client and server machine.
    >
    > From the client,
    > 1) Open Visual Studio.NET.
    > 2) Go to Tools/Options/Projects/Web Settings and on the right hand side
    > panel, select "Connection Settings" or you can also open IE and go to
    > Tools/Internet Options/Connections.
    > 3) Click on LAN settings and if you are using proxy, then uncheck all the
    > options under "Automatic configuration" section. ("Automatically detect
    > settings" and "Use Automatic configuration Script")
    > 4) Check both options in "Proxy Server" section ("Use Proxy server for

    your
    > LAN .." and "Bypass proxy server for local addresses") and provide the
    > details of the proxy server.
    > 5) Click on the "Advanced" button in Proxy Server section and in the

    "Proxy
    > Server" dialog box, add the host header name to the list that says "Do not
    > use proxy server for addresses beginning with the following" and click Ok.
    > 6) Start creating a new project in VS.NET
    > 8) In the New Project dialog box, provide the location as
    > http://virtualWebsitename/projectname
    > 9) When you get the Web Access Failed dialog box, provide the proper share
    > for the virtual web site that you are going to create project in. e.g.
    > \\<machinename>\sharenameforvirtualwebsite\projectname
    > 10) Now the project should get created under the specified share on the

    web
    > server.
    >
    > I hope it helps.
    >
    > Best regards,
    >
    > Jacob Yang
    > Microsoft Online Partner Support
    > Get Secure! ¨C www.microsoft.com/security
    > This posting is provided "as is" with no warranties and confers no rights.
    >
    Leszek, Nov 24, 2003
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. rr
    Replies:
    1
    Views:
    322
    Rob Taylor
    Aug 5, 2003
  2. Douglas Gage

    Publish a web project onto a remote server

    Douglas Gage, Jan 13, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    357
    Curt_C [MVP]
    Jan 13, 2004
  3. Zachary Hilbun
    Replies:
    0
    Views:
    366
    Zachary Hilbun
    Aug 9, 2004
  4. Mike
    Replies:
    0
    Views:
    381
  5. Mike
    Replies:
    0
    Views:
    166
Loading...

Share This Page