Published from Win XP system with VS2005 to Win2003 system with IIS

Discussion in 'ASP .Net' started by Brent White, Nov 6, 2007.

  1. Brent White

    Brent White Guest

    I created and published a web service from my development system
    running XP and IIS to a Windows 2003 Standard server running IIS.
    When I try to access the service on the 2003 box, it keeps asking me
    if I want to download the file, rather than bring up the page for the
    service.

    http://195.1.2.222/Skipjack/service1.asmx

    is the URL. On my development system, it brings up the page that
    shows the operations that can be done on the service. On the 2003
    box, it asks me if I want to download the file, which won't do any
    good because I need to send an XML formatted string to the service URL
    from an outside program.
     
    Brent White, Nov 6, 2007
    #1
    1. Advertising

  2. Have you enabled ASP.NET in IIS?

    --
    Gregory A. Beamer
    MVP, MCP: +I, SE, SD, DBA

    *************************************************
    | Think outside the box!
    |
    *************************************************
    "Brent White" <> wrote in message
    news:...
    >I created and published a web service from my development system
    > running XP and IIS to a Windows 2003 Standard server running IIS.
    > When I try to access the service on the 2003 box, it keeps asking me
    > if I want to download the file, rather than bring up the page for the
    > service.
    >
    > http://195.1.2.222/Skipjack/service1.asmx
    >
    > is the URL. On my development system, it brings up the page that
    > shows the operations that can be done on the service. On the 2003
    > box, it asks me if I want to download the file, which won't do any
    > good because I need to send an XML formatted string to the service URL
    > from an outside program.
    >
     
    Cowboy \(Gregory A. Beamer\), Nov 6, 2007
    #2
    1. Advertising

  3. Brent White

    Brent White Guest

    On Nov 6, 11:25 am, "Cowboy \(Gregory A. Beamer\)"
    <> wrote:
    > Have you enabled ASP.NET in IIS?
    >
    > --
    > Gregory A. Beamer
    > MVP, MCP: +I, SE, SD, DBA
    >
    > *************************************************
    > | Think outside the box!
    > |
    > *************************************************"Brent White" <> wrote in message
    >
    > news:...
    >
    >
    >
    > >I created and published a web service from my development system
    > > running XP and IIS to a Windows 2003 Standard server running IIS.
    > > When I try to access the service on the 2003 box, it keeps asking me
    > > if I want to download the file, rather than bring up the page for the
    > > service.

    >
    > >http://195.1.2.222/Skipjack/service1.asmx

    >
    > > is the URL. On my development system, it brings up the page that
    > > shows the operations that can be done on the service. On the 2003
    > > box, it asks me if I want to download the file, which won't do any
    > > good because I need to send an XML formatted string to the service URL
    > > from an outside program.- Hide quoted text -

    >
    > - Show quoted text -


    I'm showing it is. Is there a specific version that I need to run to
    serve VS 2005 pages, or a setting I need to check within ASP.NET?
     
    Brent White, Nov 6, 2007
    #3
  4. Check to see whether you have 1.1 apps and
    2.0 apps running in the same application pool.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Brent White" <> wrote in message
    news:...
    > On Nov 6, 11:25 am, "Cowboy \(Gregory A. Beamer\)"
    > <> wrote:
    >> Have you enabled ASP.NET in IIS?
    >>
    >> --
    >> Gregory A. Beamer
    >> MVP, MCP: +I, SE, SD, DBA
    >>
    >> *************************************************
    >> | Think outside the box!
    >> |
    >> *************************************************"Brent White" <> wrote in message
    >>
    >> news:...
    >>
    >>
    >>
    >> >I created and published a web service from my development system
    >> > running XP and IIS to a Windows 2003 Standard server running IIS.
    >> > When I try to access the service on the 2003 box, it keeps asking me
    >> > if I want to download the file, rather than bring up the page for the
    >> > service.

    >>
    >> >http://195.1.2.222/Skipjack/service1.asmx

    >>
    >> > is the URL. On my development system, it brings up the page that
    >> > shows the operations that can be done on the service. On the 2003
    >> > box, it asks me if I want to download the file, which won't do any
    >> > good because I need to send an XML formatted string to the service URL
    >> > from an outside program.- Hide quoted text -

    >>
    >> - Show quoted text -

    >
    > I'm showing it is. Is there a specific version that I need to run to
    > serve VS 2005 pages, or a setting I need to check within ASP.NET?
    >
     
    Juan T. Llibre, Nov 6, 2007
    #4
  5. In Windows 2003, ASP.NET is disabled by default, even when you have IIS
    installed. To enable it, open up the IIS Manager on the server and go to web
    service extensions. If ASP.NET 2.0.50727 does not have a checkbox, click on
    it an then allow.

    --
    Gregory A. Beamer
    MVP, MCP: +I, SE, SD, DBA

    *************************************************
    | Think outside the box!
    |
    *************************************************
    "Brent White" <> wrote in message
    news:...
    > On Nov 6, 11:25 am, "Cowboy \(Gregory A. Beamer\)"
    > <> wrote:
    >> Have you enabled ASP.NET in IIS?
    >>
    >> --
    >> Gregory A. Beamer
    >> MVP, MCP: +I, SE, SD, DBA
    >>
    >> *************************************************
    >> | Think outside the box!
    >> |
    >> *************************************************"Brent White"
    >> <> wrote in message
    >>
    >> news:...
    >>
    >>
    >>
    >> >I created and published a web service from my development system
    >> > running XP and IIS to a Windows 2003 Standard server running IIS.
    >> > When I try to access the service on the 2003 box, it keeps asking me
    >> > if I want to download the file, rather than bring up the page for the
    >> > service.

    >>
    >> >http://195.1.2.222/Skipjack/service1.asmx

    >>
    >> > is the URL. On my development system, it brings up the page that
    >> > shows the operations that can be done on the service. On the 2003
    >> > box, it asks me if I want to download the file, which won't do any
    >> > good because I need to send an XML formatted string to the service URL
    >> > from an outside program.- Hide quoted text -

    >>
    >> - Show quoted text -

    >
    > I'm showing it is. Is there a specific version that I need to run to
    > serve VS 2005 pages, or a setting I need to check within ASP.NET?
    >
     
    Cowboy \(Gregory A. Beamer\), Nov 6, 2007
    #5
  6. Brent White

    Brent White Guest

    On Nov 6, 3:45 pm, "Cowboy \(Gregory A. Beamer\)"
    <> wrote:
    > In Windows 2003, ASP.NET is disabled by default, even when you have IIS
    > installed. To enable it, open up the IIS Manager on the server and go to web
    > service extensions. If ASP.NET 2.0.50727 does not have a checkbox, click on
    > it an then allow.
    >
    > --
    > Gregory A. Beamer
    > MVP, MCP: +I, SE, SD, DBA
    >
    > *************************************************
    > | Think outside the box!
    > |
    > *************************************************"Brent White" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > On Nov 6, 11:25 am, "Cowboy \(Gregory A. Beamer\)"
    > > <> wrote:
    > >> Have you enabled ASP.NET in IIS?

    >
    > >> --
    > >> Gregory A. Beamer
    > >> MVP, MCP: +I, SE, SD, DBA

    >
    > >> *************************************************
    > >> | Think outside the box!
    > >> |
    > >> *************************************************"Brent White"
    > >> <> wrote in message

    >
    > >>news:...

    >
    > >> >I created and published a web service from my development system
    > >> > running XP and IIS to a Windows 2003 Standard server running IIS.
    > >> > When I try to access the service on the 2003 box, it keeps asking me
    > >> > if I want to download the file, rather than bring up the page for the
    > >> > service.

    >
    > >> >http://195.1.2.222/Skipjack/service1.asmx

    >
    > >> > is the URL. On my development system, it brings up the page that
    > >> > shows the operations that can be done on the service. On the 2003
    > >> > box, it asks me if I want to download the file, which won't do any
    > >> > good because I need to send an XML formatted string to the service URL
    > >> > from an outside program.- Hide quoted text -

    >
    > >> - Show quoted text -

    >
    > > I'm showing it is. Is there a specific version that I need to run to
    > > serve VS 2005 pages, or a setting I need to check within ASP.NET?- Hide quoted text -

    >
    > - Show quoted text -


    It says allow 2.0.50215 in Web Service Extensions.

    What exactly should I do about the application pooling? It is using
    the default pool. Do I create another one for this app?
     
    Brent White, Nov 7, 2007
    #6
  7. re:
    !> It says allow 2.0.50215 in Web Service Extensions.

    You are using outdated beta software ?

    The release version of the .Net Framework 2.0 is 2.0.50727,
    which fixes many problems with the beta version you're using.

    Download the release version of .Net Framework 2.0 at :
    http://msdn2.microsoft.com/en-us/netframework/aa731542.aspx

    Additionally, if you install Windows XP SP2, Vista, or Windows Server SP2,
    you'll get an updated version of the .Net Framework.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Brent White" <> wrote in message
    news:...
    > On Nov 6, 3:45 pm, "Cowboy \(Gregory A. Beamer\)"
    > <> wrote:
    >> In Windows 2003, ASP.NET is disabled by default, even when you have IIS
    >> installed. To enable it, open up the IIS Manager on the server and go to web
    >> service extensions. If ASP.NET 2.0.50727 does not have a checkbox, click on
    >> it an then allow.
    >>
    >> --
    >> Gregory A. Beamer
    >> MVP, MCP: +I, SE, SD, DBA
    >>
    >> *************************************************
    >> | Think outside the box!
    >> |
    >> *************************************************"Brent White" <> wrote in message
    >>
    >> news:...
    >>
    >>
    >>
    >> > On Nov 6, 11:25 am, "Cowboy \(Gregory A. Beamer\)"
    >> > <> wrote:
    >> >> Have you enabled ASP.NET in IIS?

    >>
    >> >> --
    >> >> Gregory A. Beamer
    >> >> MVP, MCP: +I, SE, SD, DBA

    >>
    >> >> *************************************************
    >> >> | Think outside the box!
    >> >> |
    >> >> *************************************************"Brent White"
    >> >> <> wrote in message

    >>
    >> >>news:...

    >>
    >> >> >I created and published a web service from my development system
    >> >> > running XP and IIS to a Windows 2003 Standard server running IIS.
    >> >> > When I try to access the service on the 2003 box, it keeps asking me
    >> >> > if I want to download the file, rather than bring up the page for the
    >> >> > service.

    >>
    >> >> >http://195.1.2.222/Skipjack/service1.asmx

    >>
    >> >> > is the URL. On my development system, it brings up the page that
    >> >> > shows the operations that can be done on the service. On the 2003
    >> >> > box, it asks me if I want to download the file, which won't do any
    >> >> > good because I need to send an XML formatted string to the service URL
    >> >> > from an outside program.- Hide quoted text -

    >>
    >> >> - Show quoted text -

    >>
    >> > I'm showing it is. Is there a specific version that I need to run to
    >> > serve VS 2005 pages, or a setting I need to check within ASP.NET?- Hide quoted text -

    >>
    >> - Show quoted text -

    >
    > It says allow 2.0.50215 in Web Service Extensions.
    >
    > What exactly should I do about the application pooling? It is using
    > the default pool. Do I create another one for this app?
    >
     
    Juan T. Llibre, Nov 7, 2007
    #7
  8. Brent White

    Brent White Guest

    On Nov 7, 11:11 am, "Juan T. Llibre" <>
    wrote:
    > re:
    > !> It says allow 2.0.50215 in Web Service Extensions.
    >
    > You are using outdated beta software ?
    >

    I didn't know I was. I'll download the .NET framework update tonight.

    > The release version of the .Net Framework 2.0 is 2.0.50727,
    > which fixes many problems with the beta version you're using.
    >
    > Download the release version of .Net Framework 2.0 at :http://msdn2.microsoft.com/en-us/netframework/aa731542.aspx
    >
    > Additionally, if you install Windows XP SP2, Vista, or Windows Server SP2,
    > you'll get an updated version of the .Net Framework.
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Brent White" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > On Nov 6, 3:45 pm, "Cowboy \(Gregory A. Beamer\)"
    > > <> wrote:
    > >> In Windows 2003, ASP.NET is disabled by default, even when you have IIS
    > >> installed. To enable it, open up the IIS Manager on the server and go to web
    > >> service extensions. If ASP.NET 2.0.50727 does not have a checkbox, click on
    > >> it an then allow.

    >
    > >> --
    > >> Gregory A. Beamer
    > >> MVP, MCP: +I, SE, SD, DBA

    >
    > >> *************************************************
    > >> | Think outside the box!
    > >> |
    > >> *************************************************"Brent White" <> wrote in message

    >
    > >>news:...

    >
    > >> > On Nov 6, 11:25 am, "Cowboy \(Gregory A. Beamer\)"
    > >> > <> wrote:
    > >> >> Have you enabled ASP.NET in IIS?

    >
    > >> >> --
    > >> >> Gregory A. Beamer
    > >> >> MVP, MCP: +I, SE, SD, DBA

    >
    > >> >> *************************************************
    > >> >> | Think outside the box!
    > >> >> |
    > >> >> *************************************************"Brent White"
    > >> >> <> wrote in message

    >
    > >> >>news:...

    >
    > >> >> >I created and published a web service from my development system
    > >> >> > running XP and IIS to a Windows 2003 Standard server running IIS.
    > >> >> > When I try to access the service on the 2003 box, it keeps asking me
    > >> >> > if I want to download the file, rather than bring up the page for the
    > >> >> > service.

    >
    > >> >> >http://195.1.2.222/Skipjack/service1.asmx

    >
    > >> >> > is the URL. On my development system, it brings up the page that
    > >> >> > shows the operations that can be done on the service. On the 2003
    > >> >> > box, it asks me if I want to download the file, which won't do any
    > >> >> > good because I need to send an XML formatted string to the service URL
    > >> >> > from an outside program.- Hide quoted text -

    >
    > >> >> - Show quoted text -

    >
    > >> > I'm showing it is. Is there a specific version that I need to run to
    > >> > serve VS 2005 pages, or a setting I need to check within ASP.NET?- Hide quoted text -

    >
    > >> - Show quoted text -

    >
    > > It says allow 2.0.50215 in Web Service Extensions.

    >
    > > What exactly should I do about the application pooling? It is using
    > > the default pool. Do I create another one for this app?- Hide quoted text -

    >
    > - Show quoted text -
     
    Brent White, Nov 8, 2007
    #8
  9. If you are only using 2.0, you can reset the default pool to 2.0. If not,
    you will have to have separate pools for 1.1 and 2.0.

    --
    Gregory A. Beamer
    MVP, MCP: +I, SE, SD, DBA

    *************************************************
    | Think outside the box!
    |
    *************************************************
    "Brent White" <> wrote in message
    news:...
    > On Nov 6, 3:45 pm, "Cowboy \(Gregory A. Beamer\)"
    > <> wrote:
    >> In Windows 2003, ASP.NET is disabled by default, even when you have IIS
    >> installed. To enable it, open up the IIS Manager on the server and go to
    >> web
    >> service extensions. If ASP.NET 2.0.50727 does not have a checkbox, click
    >> on
    >> it an then allow.
    >>
    >> --
    >> Gregory A. Beamer
    >> MVP, MCP: +I, SE, SD, DBA
    >>
    >> *************************************************
    >> | Think outside the box!
    >> |
    >> *************************************************"Brent White"
    >> <> wrote in message
    >>
    >> news:...
    >>
    >>
    >>
    >> > On Nov 6, 11:25 am, "Cowboy \(Gregory A. Beamer\)"
    >> > <> wrote:
    >> >> Have you enabled ASP.NET in IIS?

    >>
    >> >> --
    >> >> Gregory A. Beamer
    >> >> MVP, MCP: +I, SE, SD, DBA

    >>
    >> >> *************************************************
    >> >> | Think outside the box!
    >> >> |
    >> >> *************************************************"Brent White"
    >> >> <> wrote in message

    >>
    >> >>news:...

    >>
    >> >> >I created and published a web service from my development system
    >> >> > running XP and IIS to a Windows 2003 Standard server running IIS.
    >> >> > When I try to access the service on the 2003 box, it keeps asking me
    >> >> > if I want to download the file, rather than bring up the page for
    >> >> > the
    >> >> > service.

    >>
    >> >> >http://195.1.2.222/Skipjack/service1.asmx

    >>
    >> >> > is the URL. On my development system, it brings up the page that
    >> >> > shows the operations that can be done on the service. On the 2003
    >> >> > box, it asks me if I want to download the file, which won't do any
    >> >> > good because I need to send an XML formatted string to the service
    >> >> > URL
    >> >> > from an outside program.- Hide quoted text -

    >>
    >> >> - Show quoted text -

    >>
    >> > I'm showing it is. Is there a specific version that I need to run to
    >> > serve VS 2005 pages, or a setting I need to check within ASP.NET?- Hide
    >> > quoted text -

    >>
    >> - Show quoted text -

    >
    > It says allow 2.0.50215 in Web Service Extensions.
    >
    > What exactly should I do about the application pooling? It is using
    > the default pool. Do I create another one for this app?
    >
     
    Cowboy \(Gregory A. Beamer\), Nov 9, 2007
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?TWFyZWsgRw==?=

    Win2003 IIS and webforms

    =?Utf-8?B?TWFyZWsgRw==?=, Jan 20, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    537
    =?Utf-8?B?TWFyZWsgRw==?=
    Jan 26, 2006
  2. Replies:
    1
    Views:
    361
    Darren Kopp
    Feb 20, 2006
  3. Brent White
    Replies:
    3
    Views:
    439
    Brent White
    Nov 1, 2007
  4. Krist
    Replies:
    6
    Views:
    799
    Arne Vajhøj
    May 7, 2010
  5. Raj
    Replies:
    2
    Views:
    157
    Aaron Bertrand [MVP]
    Apr 14, 2004
Loading...

Share This Page