pysqlite install error on hp ux (ld: Can't find library for-lpython2.5)

Discussion in 'Python' started by Geon., Nov 10, 2008.

  1. Geon.

    Geon. Guest

    hi everyone!

    when i install pysqlite i meet bellow error. ( use easy_install and
    source code building same problem )

    ld: Can't find library for -lpython2.5

    what mean this message? and what i do?

    my system is hp-ux 11i v3. and python2.5 is installed.
    ld command also avaliable.

    please help for me~
     
    Geon., Nov 10, 2008
    #1
    1. Advertising

  2. Geon.

    Geon. Guest

    On 11¿ù10ÀÏ, ¿ÀÀü11½Ã29ºÐ, "Geon." <seveng...@gmail..com> wrote:
    > hi everyone!
    >
    > when i install pysqlite i meet bellow error. ( use easy_install and
    > source code building same problem )
    >
    > ld: Can't find library for -lpython2.5
    >
    > what mean this message? and what i do?
    >
    > my system is hp-ux 11i v3. and python2.5 is installed.
    > ld command also avaliable.
    >
    > please help for me~


    sorry wrong write :)

    bellow -> below
    avaliable -> available
     
    Geon., Nov 10, 2008
    #2
    1. Advertising

  3. Geon.

    Ò»Ê×Ê« Guest

    On Nov 10, 10:29 am, "Geon." <> wrote:
    > hi everyone!
    >
    > when i install pysqlite i meet bellow error. ( use easy_install and
    > source code building same problem )
    >
    > ld: Can't find library for -lpython2.5
    >
    > what mean this message? and what i do?
    >
    > my system is hp-ux 11i v3. and python2.5 is installed.
    > ld command also avaliable.
    >
    > please help for me~


    Hi, as far as I know.

    1. you can use module sqlite3 instead.
    2. you can use these commands on ubuntu:

    sudo apt-get install libsqlite3-dev
    sudo easy_install -Z pysqlite
     
    Ò»Ê×Ê«, Nov 10, 2008
    #3
  4. Geon.

    Geon. Guest

    On 11ì›”10ì¼, 오후1ì‹œ31분, 一首诗 <> wrote:
    > On Nov 10, 10:29 am, "Geon." <> wrote:
    >
    > > hi everyone!

    >
    > > when i install pysqlite i meet bellow error. ( use easy_install and
    > > source code building same problem )

    >
    > > ld: Can't find library for -lpython2.5

    >
    > > what mean this message? and what i do?

    >
    > > my system is hp-ux 11i v3. and python2.5 is installed.
    > > ld command also avaliable.

    >
    > > please help for me~

    >
    > Hi, as far as I know.
    >
    > 1. you can use module sqlite3 instead.
    > 2. you can use these commands on ubuntu:
    >
    > sudo apt-get install libsqlite3-dev
    > sudo easy_install -Z pysqlite


    is possible apt-get on hp unix?
    i think apt-get is only available ubuntu linux system..
     
    Geon., Nov 11, 2008
    #4
  5. Re: pysqlite install error on hp ux (ld: Can't find library for -lpython2.5)

    * Geon. (Mon, 10 Nov 2008 18:00:56 -0800 (PST))
    > On 11?10?, ??1?31?, ??? <> wrote:
    > > On Nov 10, 10:29 am, "Geon." <> wrote:
    > > > when i install pysqlite i meet bellow error. ( use easy_install and
    > > > source code building same problem )

    > >
    > > > ld: Can't find library for -lpython2.5

    > >
    > > > what mean this message? and what i do?

    > >
    > > > my system is hp-ux 11i v3. and python2.5 is installed.
    > > > ld command also avaliable.

    > >
    > > > please help for me~

    > >
    > > Hi, as far as I know.
    > >
    > > 1. you can use module sqlite3 instead.
    > > 2. you can use these commands on ubuntu:
    > >
    > > sudo apt-get install libsqlite3-dev
    > > sudo easy_install -Z pysqlite

    >
    > is possible apt-get on hp unix?
    > i think apt-get is only available ubuntu linux system..


    No, on all Debian based distributions.

    Thorsten
     
    Thorsten Kampe, Nov 11, 2008
    #5
  6. Geon.

    Geon. Guest

    On 11¿ù11ÀÏ, ¿ÀÈÄ6½Ã10ºÐ, Thorsten Kampe <> wrote:
    > * Geon. (Mon, 10 Nov 2008 18:00:56 -0800 (PST))
    >
    >
    >
    >
    >
    > > On 11?10?, ??1?31?, ??? <> wrote:
    > > > On Nov 10, 10:29 am, "Geon." <> wrote:
    > > > > when i install pysqlite i meet bellow error. ( use easy_install and
    > > > > source code building same problem )

    >
    > > > > ld: Can't find library for -lpython2.5

    >
    > > > > what mean this message? and what i do?

    >
    > > > > my system is hp-ux 11i v3. and python2.5 is installed.
    > > > > ld command also avaliable.

    >
    > > > > please help for me~

    >
    > > > Hi, as far as I know.

    >
    > > > 1. you can use module sqlite3 instead.
    > > > 2. you can use these commands on ubuntu:

    >
    > > > sudo apt-get install libsqlite3-dev
    > > > sudo easy_install -Z pysqlite

    >
    > > is possible apt-get on hp unix?
    > > i think apt-get is only available ubuntu linux system..

    >
    > No, on all Debian based distributions.
    >
    > Thorsten- µû¿Â ÅؽºÆ® ¼û±â±â -
    >
    > - µû¿Â ÅؽºÆ® º¸±â -


    thanks, all response
     
    Geon., Nov 12, 2008
    #6
  7. Geon. wrote:
    > hi everyone!
    >
    > when i install pysqlite i meet bellow error. ( use easy_install and
    > source code building same problem )
    >
    > ld: Can't find library for -lpython2.5
    >
    > what mean this message? and what i do?
    >
    > my system is hp-ux 11i v3. and python2.5 is installed.
    > ld command also avaliable.


    I don't know much about HPUX, but here are some ideas.

    Is Python's shared library built at all? Or is Python, for whatever
    reason, built statically? The command to check on Linux is "ldd
    /path/to/python_binary". I don't know if it's ldd on HP UX too or if
    it's something different.

    If Python is built as a shared library, is the shared library somewhere
    the system's dynamic linker will find it? If not, you either have to set
    some environment variable (LD_LIBRARY_PATH on Linux) or configure it
    (/etc/ld.so.conf on Linux).

    -- Gerhard

    PS: On some exotic systems where Java is already installed I found it
    easier to get Jython (the Python implementation for the Java Virtual
    Machine) to run than compiling Python.
     
    Gerhard Häring, Nov 12, 2008
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jari Aalto+usenet
    Replies:
    0
    Views:
    385
    Jari Aalto+usenet
    Aug 19, 2003
  2. Hemanth P.S.
    Replies:
    0
    Views:
    353
    Hemanth P.S.
    Sep 18, 2003
  3. F. GEIGER
    Replies:
    2
    Views:
    547
    F. GEIGER
    May 21, 2005
  4. Gerhard Häring
    Replies:
    3
    Views:
    386
    Gerhard Häring
    Mar 13, 2008
  5. Tilman  Kispersky

    Cannot install pysqlite on Cygwin

    Tilman Kispersky, Sep 29, 2008, in forum: Python
    Replies:
    4
    Views:
    795
    Tilman Kispersky
    Sep 29, 2008
Loading...

Share This Page