QT Designer, puic, and kLed

Discussion in 'Perl Misc' started by Dad, Nov 24, 2004.

  1. Dad

    Dad Guest

    I'm using QT Designer and puic to add a simple gui to a perl script. Two
    things are happening that I'm not sure about. First, QT Designer
    complains about the xml (.ui) file being the wrong version. I have to
    manually change the version in the .ui file from 3.3 to 3.2 for puic to
    work. When I run the .pl file I get the error "No method to call for :
    Qt::Led(QGroupBox, 'kLed3') at mydialog.pl line 66." Line 66 of the
    script is:
    kLed3 = Qt::Led(groupBox1, "kLed3");

    puic -version gives PerlQt User Interface Compiler v0.70 for Qt version 3.3.1
    KDE is 3.3.1, QT Designer is 3.3.1 and all the latest qt rpm's have been
    installed from suse/supplementary/KDE. I'm running SuSE 9.1 pro.

    Any and all help is greatly appreciated.
     
    Dad, Nov 24, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. SStory
    Replies:
    2
    Views:
    289
    SStory
    Aug 1, 2003
  2. Eric Biggs

    vs designer and code-behind inheritence

    Eric Biggs, Apr 14, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    313
    Eric Biggs
    Apr 14, 2004
  3. Steve B.
    Replies:
    4
    Views:
    977
    Cheryl D Wise
    Jun 1, 2007
  4. Alexander Higgins
    Replies:
    3
    Views:
    1,086
    Teemu Keiski
    Jul 30, 2007
  5. Alexander Higgins
    Replies:
    0
    Views:
    453
    Alexander Higgins
    Jul 21, 2007
Loading...

Share This Page