question regarding overriding of web.config in the root directory..in a web app in a virtual directo

Discussion in 'ASP .Net' started by dotnetprogram, Dec 26, 2003.

  1. I have a web application in the parent directory(http://localhost/). it has
    a web.config setting as follows:

    <authentication mode="Forms">
    <forms loginUrl="Login.aspx" name="UserToken" protection="All"
    timeout="60" path="/">
    <credentials passwordFormat="MD5">
    </credentials>
    </forms>
    </authentication>

    i installed another web application in a virtual directory named webapp1 (
    http://localhost/webapp1) .

    it has web.config as follows:

    <authentication mode="Forms">
    <forms name=".ASPXAUTH" protection="All" timeout="60" />

    </authentication>

    My problem would be that when i access my new web app1 like

    http://localhost/webapp1/

    instead of it redirected to default.aspx...it is redirected to the
    login.aspx of the parent web app and it can't find the login.aspx..becuase
    it doesn't have one..is there any way to override the auythentication
    settings of the parent root directory...

    Thanks....
     
    dotnetprogram, Dec 26, 2003
    #1
    1. Advertisements

  2. dotnetprogram

    Joey Powell Guest

    Insert a <location> tag in the parent app with allow users=*. This
    will "free up" the access control from the parent app. Control should
    then roll down to the web.config of the app that you are trying to
    use. I have not tried this...just an idea.

    "dotnetprogram" <> wrote in message news:<>...
    > I have a web application in the parent directory(http://localhost/). it has
    > a web.config setting as follows:
    >
    > <authentication mode="Forms">
    > <forms loginUrl="Login.aspx" name="UserToken" protection="All"
    > timeout="60" path="/">
    > <credentials passwordFormat="MD5">
    > </credentials>
    > </forms>
    > </authentication>
    >
    > i installed another web application in a virtual directory named webapp1 (
    > http://localhost/webapp1) .
    >
    > it has web.config as follows:
    >
    > <authentication mode="Forms">
    > <forms name=".ASPXAUTH" protection="All" timeout="60" />
    >
    > </authentication>
    >
    > My problem would be that when i access my new web app1 like
    >
    > http://localhost/webapp1/
    >
    > instead of it redirected to default.aspx...it is redirected to the
    > login.aspx of the parent web app and it can't find the login.aspx..becuase
    > it doesn't have one..is there any way to override the auythentication
    > settings of the parent root directory...
    >
    > Thanks....
     
    Joey Powell, Dec 27, 2003
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sheila Jones

    application root versus virtual directory?

    Sheila Jones, Feb 17, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    2,093
    Chad Z. Hower aka Kudzu
    Feb 17, 2004
  2. Wm. Scott Miller

    Web.Config and Virtual Directory

    Wm. Scott Miller, May 5, 2004, in forum: ASP .Net
    Replies:
    10
    Views:
    798
    Wm. Scott Miller
    May 6, 2004
  3. Raghu
    Replies:
    6
    Views:
    4,721
    Curt_C [MVP]
    May 27, 2004
  4. Curt_C [MVP]
    Replies:
    4
    Views:
    516
    Curt_C [MVP]
    Jul 19, 2004
  5. Joel Leong
    Replies:
    1
    Views:
    1,051
    MattC
    Jan 6, 2005
  6. Benny Ng
    Replies:
    9
    Views:
    10,952
    Benny Ng
    Oct 13, 2005
  7. savajx1
    Replies:
    1
    Views:
    2,808
    savajx1
    Jan 19, 2006
  8. CSharpner
    Replies:
    0
    Views:
    1,414
    CSharpner
    Apr 9, 2007
Loading...