Rdoc does not document UTF-8 files?

Discussion in 'Ruby' started by Marvin Gülker, Jun 10, 2009.

  1. Hi,

    yesterday I tried to document a piece of code I had written in Ruby 1.9.
    But it turned out that Rdoc wasn't able to document my UTF-8 encoded
    file! Reduced to a minimal example, this file...

    #Encoding: UTF-8
    #test file

    #test class
    class A

    #test method
    def a
    puts "a"
    end

    end

    ...can't be documented if encoded in UTF-8. When I tried it again with
    an encoding of Windows-1252 (yes, I'm using Ruby on Windows...) it
    worked fine. I tried both the versions 2.2.2 and 2.4.3 of Rdoc but
    neither of it worked - regardless of whether I used an additional "-c
    UTF-8" parameter or not.

    I'm using ruby 1.9.1-p129 on Windows XP SP3. Because I was telled at the
    German Ruby forum
    (http://forum.ruby-portal.de/viewtopic.php?f=22&t=9792) that this worked
    fine on OS X I suspect that this is a Windows issue. Is there some fix
    about it or am I just doing something wrong?

    Marvin
    --
    Posted via http://www.ruby-forum.com/.
     
    Marvin Gülker, Jun 10, 2009
    #1
    1. Advertising

  2. Marvin Gülker

    Eric Hodel Guest

    On Jun 10, 2009, at 12:00, Marvin G=FClker wrote:
    > yesterday I tried to document a piece of code I had written in Ruby =20=


    > 1.9.
    > But it turned out that Rdoc wasn't able to document my UTF-8 encoded
    > file! Reduced to a minimal example, this file...
    >
    > #Encoding: UTF-8
    > #test file
    >
    > #test class
    > class A
    >
    > #test method
    > def a
    > puts "a"
    > end
    >
    > end
    >
    > ...can't be documented if encoded in UTF-8. When I tried it again with
    > an encoding of Windows-1252 (yes, I'm using Ruby on Windows...) it
    > worked fine. I tried both the versions 2.2.2 and 2.4.3 of Rdoc but
    > neither of it worked - regardless of whether I used an additional "-c
    > UTF-8" parameter or not.


    The -c parameter currently only controls the value that shows up in =20
    the HTML meta element. Eventually it will control the encoding of the =20=

    output files, but never the input files.

    > I'm using ruby 1.9.1-p129 on Windows XP SP3. Because I was telled at =20=


    > the
    > German Ruby forum
    > (http://forum.ruby-portal.de/viewtopic.php?f=3D22&t=3D9792) that this =20=


    > worked
    > fine on OS X I suspect that this is a Windows issue. Is there some fix
    > about it or am I just doing something wrong?


    It doesn't work for me on OS X, please file a bug.
     
    Eric Hodel, Jun 10, 2009
    #2
    1. Advertising

  3. Eric Hodel wrote:
    > It doesn't work for me on OS X, please file a bug.


    Sorry, but I've never filed a Rdoc or even Ruby bug before. Where can I
    do this?

    Marvin
    --
    Posted via http://www.ruby-forum.com/.
     
    Marvin Gülker, Jun 10, 2009
    #3
  4. Marvin Gülker

    Eric Hodel Guest

    Eric Hodel, Jun 11, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andreas Schwarz
    Replies:
    6
    Views:
    278
    Randy W. Sims
    Jan 1, 2004
  2. Brian Schröder
    Replies:
    5
    Views:
    161
    Dave Thomas
    Sep 18, 2004
  3. Daniel Berger
    Replies:
    1
    Views:
    155
    Dave Thomas
    Nov 2, 2004
  4. Iwan van der Kleyn

    rdoc: how to add readme.rdoc as index.html?

    Iwan van der Kleyn, Apr 26, 2005, in forum: Ruby
    Replies:
    1
    Views:
    259
    Stefan Lang
    Apr 26, 2005
  5. Iñaki Baz Castillo

    darkfish-rdoc (1.1.5) not working with rdoc (2.4.3)

    Iñaki Baz Castillo, Apr 4, 2009, in forum: Ruby
    Replies:
    2
    Views:
    151
    Iñaki Baz Castillo
    Apr 6, 2009
Loading...

Share This Page