Re: Cannot use more than one link tag?

Discussion in 'HTML' started by richard, Jun 5, 2013.

  1. richard

    richard Guest

    On 04 Jun 2013 22:34:57 GMT, Marty wrote:

    > This is driving me nuts.
    >
    > In the CSS file I have:
    >
    > a.blue { display:block ;
    > width:120px ;
    > height:120px ;
    > background:url("bluepicture.gif") no-repeat ;
    > }
    >
    > a.blue:hover {
    >
    > background:url("differentbluepicture.jpg") no-repeat ;
    > }​
    >
    > a.red { display:block ;
    > width:120px ;
    > height:120px ;
    > background:url("redpicture.gif") no-repeat ;
    > }
    >
    > a.red:hover {
    >
    > background:url("differentredpicture.jpg") no-repeat ;
    > }​
    >
    > In the code I use:
    >
    > <td width="140px"><a class="blue" href="gotobluesite.php"></a></td>
    > <td width="140px"><a class="red" href="gotoredsite.php"></a></td>
    >
    > The blue picture and the hover picture will work for blue but not for
    > red. If I reverse the order of the css, then the top one will work not
    > the second.
    >
    > What stupid mistake am I making?


    I copied and pasted your css code and ran it through a CSS validator.
    When you do this, you will find two hidden "?".
    I use notepad++. It's an excellent tool for html and css.
    it's free too.
    richard, Jun 5, 2013
    #1
    1. Advertising

  2. richard

    Tim Streater Guest

    In article <51af530f$0$1741$c3e8da3$>,
    Marty <> wrote:

    > On Wed, 05 Jun 2013 00:51:54 -0400, richard wrote:
    >
    >
    > >
    > > I copied and pasted your css code and ran it through a CSS validator.
    > > When you do this, you will find two hidden "?".
    > > I use notepad++. It's an excellent tool for html and css.
    > > it's free too.

    >
    > I want to thank everyone who made an effort to help me. Even those who
    > focused on the perfection of the code and not the problem at hand.
    >
    > I did find a parse error and all I had to do was type in the code once
    > again from scratch. I did not change a thing and it works perfectly now.
    >
    > I unfortunately cannot see hidden characters in Bluefish. Maybe there is
    > a way that I have not learned about. But, in most other respects it does
    > the job. I might try another editor but it has to work with Ubuntu.
    >
    > Again, thank you all.


    Glad it worked. But do look to see if there is some Bluefish feature to
    "show invisibles", or, failing that, see if you can find another editor
    which can - even if you only use it for that purpose.

    --
    Tim

    "That excessive bail ought not to be required, nor excessive fines imposed,
    nor cruel and unusual punishments inflicted" -- Bill of Rights 1689
    Tim Streater, Jun 5, 2013
    #2
    1. Advertising

  3. On Wed, 05 Jun 2013 16:25:24 +0100, Tim Streater wrote:

    > Glad it worked. But do look to see if there is some Bluefish feature to
    > "show invisibles", or, failing that, see if you can find another editor
    > which can - even if you only use it for that purpose.


    The closest option I could find in bluefish was:

    edit / preferences / visible whitespace mode -> all

    gedit (which I use) usually shows weird characters as a square box
    containing 4 miniaturised hex values, or refuses to load the file if it
    finds character codes that are incompatible with what it thinks it should
    be displaying.

    --
    Denis McMahon,
    Denis McMahon, Jun 5, 2013
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Merciadri Luca
    Replies:
    4
    Views:
    796
  2. JJ
    Replies:
    15
    Views:
    567
    123Jim
    Jun 7, 2013
  3. richard
    Replies:
    0
    Views:
    480
    richard
    Jun 5, 2013
  4. Steven D'Aprano
    Replies:
    0
    Views:
    75
    Steven D'Aprano
    Dec 23, 2013
  5. Replies:
    3
    Views:
    68
    Gary Herron
    Dec 23, 2013
Loading...

Share This Page