Re: Disallowing the caching of pages

Discussion in 'ASP .Net' started by Patrice, Sep 21, 2004.

  1. Patrice

    Patrice Guest

    I would start to check :

    - is the local date/time correct ? I saw once a problem with a PC that was a
    bit desynchronized. That's why I prefer now to use even something smaller
    than -1 such as -1440 (at least the day should be correct !)
    - it may also be altered by local IE settings. Did you check how the browser
    is conffigured regarding expiration ?

    Patrice

    --

    "Sujith V.P" <Sujith > a écrit dans le message
    de news:...
    > Hi All,
    >
    > I am Disallowing the Caching of Pages.but this work in some
    > machines..but not in others.Below is my code.
    >
    > <%
    >
    > Response.CacheControl = "no-cache";
    > Response.AddHeader("Pragma", "no-cache");
    > Response.Expires = -1;
    >
    > %>
    > In the login page load am setting the session value to null.so when the

    back
    > button of the browser is used from home page to login page, some machines

    the
    > page load is firing and some not.
    > is this problem occuring coz of any browser settings or based on the

    browser
    > versions? can anybody give me a solution for this.
    >
    > Thanks in advance
    >
    > Sujith
     
    Patrice, Sep 21, 2004
    #1
    1. Advertising

  2. Hi Patrice,
    i changed to -1440, still its working if i use
    http://localhost/ss/s.aspx..but if i use http://111.11.11.11/ss/s.aspx, its
    not working..
    i had made changes to IE settings also..still am not successful.

    Any other suggestions.

    Thanks

    Sujith

    "Patrice" wrote:

    > I would start to check :
    >
    > - is the local date/time correct ? I saw once a problem with a PC that was a
    > bit desynchronized. That's why I prefer now to use even something smaller
    > than -1 such as -1440 (at least the day should be correct !)
    > - it may also be altered by local IE settings. Did you check how the browser
    > is conffigured regarding expiration ?
    >
    > Patrice
    >
    > --
    >
    > "Sujith V.P" <Sujith > a écrit dans le message
    > de news:...
    > > Hi All,
    > >
    > > I am Disallowing the Caching of Pages.but this work in some
    > > machines..but not in others.Below is my code.
    > >
    > > <%
    > >
    > > Response.CacheControl = "no-cache";
    > > Response.AddHeader("Pragma", "no-cache");
    > > Response.Expires = -1;
    > >
    > > %>
    > > In the login page load am setting the session value to null.so when the

    > back
    > > button of the browser is used from home page to login page, some machines

    > the
    > > page load is firing and some not.
    > > is this problem occuring coz of any browser settings or based on the

    > browser
    > > versions? can anybody give me a solution for this.
    > >
    > > Thanks in advance
    > >
    > > Sujith

    >
    >
    >
     
    =?Utf-8?B?U3VqaXRoIFYuUA==?=, Sep 22, 2004
    #2
    1. Advertising

  3. Patrice

    Patrice Guest

    Do you have some hardware in beetween such as a proxy ? Other than that I'll
    have to scratch my head ;-)

    Good luck.

    Patrice

    --

    "Sujith V.P" <Sujith > a écrit dans le message
    de news:...
    > Hi Patrice,
    > i changed to -1440, still its working if i use
    > http://localhost/ss/s.aspx..but if i use http://111.11.11.11/ss/s.aspx,

    its
    > not working..
    > i had made changes to IE settings also..still am not successful.
    >
    > Any other suggestions.
    >
    > Thanks
    >
    > Sujith
    >
    > "Patrice" wrote:
    >
    > > I would start to check :
    > >
    > > - is the local date/time correct ? I saw once a problem with a PC that

    was a
    > > bit desynchronized. That's why I prefer now to use even something

    smaller
    > > than -1 such as -1440 (at least the day should be correct !)
    > > - it may also be altered by local IE settings. Did you check how the

    browser
    > > is conffigured regarding expiration ?
    > >
    > > Patrice
    > >
    > > --
    > >
    > > "Sujith V.P" <Sujith > a écrit dans le

    message
    > > de news:...
    > > > Hi All,
    > > >
    > > > I am Disallowing the Caching of Pages.but this work in some
    > > > machines..but not in others.Below is my code.
    > > >
    > > > <%
    > > >
    > > > Response.CacheControl = "no-cache";
    > > > Response.AddHeader("Pragma", "no-cache");
    > > > Response.Expires = -1;
    > > >
    > > > %>
    > > > In the login page load am setting the session value to null.so when

    the
    > > back
    > > > button of the browser is used from home page to login page, some

    machines
    > > the
    > > > page load is firing and some not.
    > > > is this problem occuring coz of any browser settings or based on the

    > > browser
    > > > versions? can anybody give me a solution for this.
    > > >
    > > > Thanks in advance
    > > >
    > > > Sujith

    > >
    > >
    > >
     
    Patrice, Sep 22, 2004
    #3
  4. nope..nothing..its just the normal aspx pages

    "Patrice" wrote:

    > Do you have some hardware in beetween such as a proxy ? Other than that I'll
    > have to scratch my head ;-)
    >
    > Good luck.
    >
    > Patrice
    >
    > --
    >
    > "Sujith V.P" <Sujith > a écrit dans le message
    > de news:...
    > > Hi Patrice,
    > > i changed to -1440, still its working if i use
    > > http://localhost/ss/s.aspx..but if i use http://111.11.11.11/ss/s.aspx,

    > its
    > > not working..
    > > i had made changes to IE settings also..still am not successful.
    > >
    > > Any other suggestions.
    > >
    > > Thanks
    > >
    > > Sujith
    > >
    > > "Patrice" wrote:
    > >
    > > > I would start to check :
    > > >
    > > > - is the local date/time correct ? I saw once a problem with a PC that

    > was a
    > > > bit desynchronized. That's why I prefer now to use even something

    > smaller
    > > > than -1 such as -1440 (at least the day should be correct !)
    > > > - it may also be altered by local IE settings. Did you check how the

    > browser
    > > > is conffigured regarding expiration ?
    > > >
    > > > Patrice
    > > >
    > > > --
    > > >
    > > > "Sujith V.P" <Sujith > a écrit dans le

    > message
    > > > de news:...
    > > > > Hi All,
    > > > >
    > > > > I am Disallowing the Caching of Pages.but this work in some
    > > > > machines..but not in others.Below is my code.
    > > > >
    > > > > <%
    > > > >
    > > > > Response.CacheControl = "no-cache";
    > > > > Response.AddHeader("Pragma", "no-cache");
    > > > > Response.Expires = -1;
    > > > >
    > > > > %>
    > > > > In the login page load am setting the session value to null.so when

    > the
    > > > back
    > > > > button of the browser is used from home page to login page, some

    > machines
    > > > the
    > > > > page load is firing and some not.
    > > > > is this problem occuring coz of any browser settings or based on the
    > > > browser
    > > > > versions? can anybody give me a solution for this.
    > > > >
    > > > > Thanks in advance
    > > > >
    > > > > Sujith
    > > >
    > > >
    > > >

    >
    >
    >
     
    =?Utf-8?B?U3VqaXRoIFYuUA==?=, Sep 23, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mantorok

    Disallowing back after submit

    Mantorok, Sep 9, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    361
    S. Justin Gengo
    Sep 14, 2005
  2. Replies:
    5
    Views:
    354
    Terry
    Apr 25, 2005
  3. Henry
    Replies:
    1
    Views:
    103
    M. Burnett
    Apr 21, 2006
  4. Zeng
    Replies:
    1
    Views:
    154
    Svein Terje Gaup
    Sep 15, 2004
  5. Chumley the Walrus

    Disallowing certain fields to be viewed in datagrids

    Chumley the Walrus, Jul 20, 2004, in forum: ASP .Net Web Controls
    Replies:
    0
    Views:
    116
    Chumley the Walrus
    Jul 20, 2004
Loading...

Share This Page