Re: FormsAuthentication - <http://localhost> Works, <http://RealMachineName> Does Not

Discussion in 'ASP .Net' started by Paul Glavich [MVP - ASP.NET], Jun 20, 2004.

  1. Need a bit mnore information on how yu have things setup. Can you provide
    details on the contents of the autentication element in your web.config, as
    well as the IIS configuration for your *deployed* web site.

    --
    - Paul Glavich
    Microsoft MVP - ASP.NET


    "T. Regan" <> wrote in message
    news:8LeBc.19022$...
    > I have a test app where I have Forms Authentication set up.
    >
    > When I build and run the app as http://localhost/testapp/login.aspx, it

    runs
    > correctly. I get the login prompt and the proper redirection to the

    secured
    > page.
    >
    > When I run the app as http://<RealMachineName>/testapp/login.aspx, I get

    the
    > login page, but after logging in, I stay on the login page. The URL

    address
    > shows
    >

    http://<RealMachineName>/testapp/LoginPage.aspx?ReturnUrl=%2ftestapp%2fSecuredPage.aspx.
    >
    > Can anyone tell me what I need to change here? Thanks.
    >
    >
    >
    >
    Paul Glavich [MVP - ASP.NET], Jun 20, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jiong Feng
    Replies:
    0
    Views:
    817
    Jiong Feng
    Nov 19, 2003
  2. T. Regan
    Replies:
    3
    Views:
    708
    T. Regan
    Jun 21, 2004
  3. Alex
    Replies:
    4
    Views:
    565
    Hasani Blackwell
    Feb 8, 2005
  4. =?Utf-8?B?S2VuTGVl?=
    Replies:
    5
    Views:
    2,708
  5. Caleb Mei
    Replies:
    4
    Views:
    240
    Caleb Mei
    Aug 17, 2007
Loading...

Share This Page