Re: Help! Basic namespace problem when i combine Schemas, XSLT, and XML

Discussion in 'XML' started by mr.deepak.verma@gmail.com, Dec 15, 2004.

  1. Guest

    With this

    <root
    xmlns:scott="http://scottchill.com">

    gets added to root element of output xml. To suppress this I used

    exclude-result-prefixes="scott" in stylesheet tag. Works fine except
    for one problem..now I get
    xmlns="" added to my elements in output xml.
    Any ideas on how to fix it?
     
    , Dec 15, 2004
    #1
    1. Advertising

  2. .now I get
    xmlns="" added to my elements in output xml.
    Any ideas on how to fix it?

    If you get that then you ar generating an element in some namespace but
    then as children of that element you are generateing elements in
    no-namespace so the system has to add xmlns="" to ensure that those
    children stay in no namespace.

    If that isn't what you want generate all your result elements in the
    smae namespace. (usually by mutting xmlns="whatever" on your
    xsl:stylesheet element).

    David
     
    David Carlisle, Dec 15, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Soeren
    Replies:
    2
    Views:
    362
    Waxolunist
    Sep 22, 2004
  2. Tony Prichard
    Replies:
    0
    Views:
    742
    Tony Prichard
    Dec 12, 2003
  3. Steve George
    Replies:
    1
    Views:
    1,909
    Martin Honnen
    Apr 12, 2005
  4. Sascha Kerschhofer
    Replies:
    1
    Views:
    1,115
    Priscilla Walmsley
    Aug 16, 2005
  5. Andy B
    Replies:
    0
    Views:
    380
    Andy B
    Aug 7, 2008
Loading...

Share This Page