Re: "jar: `-u' mode unimplemented."?!?

Discussion in 'Java' started by Joseph Millar, Jul 14, 2003.

  1. On Mon, 14 Jul 2003 12:26:20 -0400, Ian Brandt <> wrote:
    > I just upgraded to 1.4.2, and coincidentally I needed to use jar for
    > the first time in ages. All my attempts to update an archive (e.g. "jar
    > umf ../manifest myjar.jar") result in a "jar: `-u' mode unimplemented"
    > error. Am I missing something here? I see nothing in the release notes
    > or documentation or bug database related to this.


    I get no such message using jar.exe from the 1.4.2 JDK on WinXP
    or Linux. Is it possible you are picking up an old jar tool for
    somewhere other than the 1.4.2 JDK? I'd use a which/where tool
    for find out jar.exe is coming from.

    --Joe
    Joseph Millar, Jul 14, 2003
    #1
    1. Advertising

  2. Joseph Millar

    Ian Brandt Guest

    Joseph Millar wrote:
    >
    > I get no such message using jar.exe from the 1.4.2 JDK on WinXP
    > or Linux. Is it possible you are picking up an old jar tool for
    > somewhere other than the 1.4.2 JDK? I'd use a which/where tool
    > for find out jar.exe is coming from.
    >
    > --Joe


    That was it. I was picking up /usr/bin/jar.exe from the Cygwin GCC
    package. I didn't even think there'd be another instance of jar on my
    system.

    Thanks!

    Ian
    Ian Brandt, Jul 14, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page