Re: my web server uses old version of aspx pages

Discussion in 'ASP .Net' started by Tim Stephenson, Oct 15, 2003.

  1. Do your pages have any form of caching enabled, or does IIS have page output
    caching turned on in its config settings?

    It sounds like maybe as you're only changing the ASPX files & not the .VB's
    perhaps IIS is not realising that you've changed the page, and still serving
    the cached version?

    One place to start might be to try checking to see if your production
    server's config matches the development machine....

    Tim

    --
    Regards

    Tim Stephenson MCSD.NET
    Charted MCAD & MCSD.NET Early Achiever


    "Francesca" <> wrote in message
    news:...
    > Hi, I'm afraid I've read your reply just now.
    > The problem is the same on the server: I can see the old version of the

    page
    > even if I browse the page from IIS console!
    > And the problem is the same if I make changes to the aspx page instead of
    > the vb page.
    >
    >
    > "Tim Stephenson" <> wrote in message
    > news:...
    > > Which version of the page is served if you browse directly on the

    server's
    > > console ?
    > >
    > > --
    > > Regards
    > >
    > > Tim Stephenson MCSD.NET
    > > Charted MCAD & MCSD.NET Early Achiever
    > >
    > >
    > > "Francesca" <> wrote in message
    > > news:...
    > > > Hi everybody, I've a problem with my ASP.NET web application (version

    > 1.1,
    > > > language vb).
    > > > The application seems to work fine, so I've brougth it to the

    definitive
    > > Web
    > > > Server , using the "copy project" utility in Visual Studio 2003.
    > > > After that, I had to modify something in one of the Site aspx pages

    (the
    > > top
    > > > frame in the Home Page): it was such a stupid change what I did...just

    a
    > > > comment on a line of the codebehind...
    > > >
    > > > There was something like <<mylabel.text="hello">> that now is << '
    > > > mylabel.text="hello">>. On my local server everything works.
    > > >
    > > > Ok, I've built the project, done a backup of the previous version on

    the
    > > > server, and then put on the new version (dll and aspx files): the

    > problem
    > > is
    > > > that when I call the home page what I see is the old version yet,

    with
    > my
    > > > label "hello"...
    > > >
    > > > Here is what I tried to solve the problem: delete everything, re-buil

    > and
    > > > re-copy the project, stop and restart IIS, clean the browser cache on

    > the
    > > > client (but the broblem is the same on each client), remove and create

    > the
    > > > web application again...
    > > > The page continue showing the old message! But the page on server is
    > > > correct, I'm sure...
    > > >
    > > > Any suggestion? I'm really going crazy with it...
    > > > Ask me for more details, if needed.
    > > >
    > > > Thanks
    > > >
    > > > Francesca
    > > >
    > > >

    > >
    > >

    >
    >
     
    Tim Stephenson, Oct 15, 2003
    #1
    1. Advertising

  2. Tim Stephenson

    Francesca Guest

    How can I check IIS config settings?
    Here is the code in my webconfig: the only difference between thi production
    and the development one is the connection string (and the debug mode).
    Hope this helps.
    **********************************************************

    <?xml version="1.0" encoding="utf-8" ?>

    <configuration><appSettings>

    <!--STRINGA DI CONNESSIONE AL DB DI PRODUZIONE--><add key="ConnectionString"
    value="Network Library=DBMSSOCN;Server=DBTEMPES;DataBase=SitoTempes;Connect
    Timeout=30;uid=XX;pwd=XXX"/>



    <!--STRINGA DI CONNESSIONE AL DB DI TEST <add key="ConnectionString"
    value="Network Library=DBMSSOCN;Server=XXXX;DataBase=SitoTempes;Connect
    Timeout=30;uid=XX;pwd=XXX"/>->

    <!--STRINGA DI CONNESSIONE AL DBDI SVILUPPO<add key="ConnectionString"
    value="Network Library=DBMSSOCN;Server=XXXX;DataBase=SitoTempes;Connect
    Timeout=30;uid=XX;pwd=XXX"/>-->

    <add key="DBType" value="SQLSERVER"/></appSettings>

    <system.web><compilation defaultLanguage="vb" debug="false" />

    <customErrors mode="RemoteOnly" defaultRedirect="/errorpage.aspx"/>



    <authentication mode="Forms">

    <forms path="/" name=".AUTHTEMPES" loginUrl="Home.aspx?Test=2"
    protection="All" timeout="30"></forms>

    </authentication>



    <authorization><allow users="*" /> </authorization>








    <trace enabled="false" requestLimit="10" pageOutput="false"
    traceMode="SortByTime" localOnly="true" />

    <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424"
    sqlConnectionString="data source=127.0.0.1;user id=sa;password="
    cookieless="false" timeout="20" />

    <globalization requestEncoding="utf-8" responseEncoding="utf-8" />


    </system.web>

    <location path="superutente"> <system.web><authorization><deny
    users="?"/><deny roles="1,3,4,5,6,7"/><allow roles="2"/>
    </authorization></system.web></location>

    <location path="candidati"> <system.web><authorization><deny
    users="?"/><deny roles="1,2,3,5,6,7"/><allow roles="4"/>
    </authorization></system.web></location>

    <location path="GestioneFormazione"><system.web><authorization><deny
    users="?"/><deny roles="1,2,3,4,6,7"/><allow roles="5"/>
    </authorization></system.web></location>

    <location path="Partners"><system.web><authorization><deny users="?"/><deny
    roles="1,2,3,4,5,7"/><allow roles="6"/>
    </authorization></system.web></location>


    </configuration>

    **********************************************************



    "Tim Stephenson" <> wrote in message
    news:...
    > Do your pages have any form of caching enabled, or does IIS have page

    output
    > caching turned on in its config settings?
    >
    > It sounds like maybe as you're only changing the ASPX files & not the

    ..VB's
    > perhaps IIS is not realising that you've changed the page, and still

    serving
    > the cached version?
    >
    > One place to start might be to try checking to see if your production
    > server's config matches the development machine....
    >
    > Tim
    >
    > --
    > Regards
    >
    > Tim Stephenson MCSD.NET
    > Charted MCAD & MCSD.NET Early Achiever
     
    Francesca, Oct 15, 2003
    #2
    1. Advertising

  3. The easiest way is to open up the Internet Information Services
    administration applet within your server's administration tools group
    (either Start / Programs / Administration Tools or Start / Settings/ Control
    Panel / Administration Tools).

    From there, right click the webserver nodes and select properties. Have a
    look through the major tabs, and see if there are any substantial
    differences. You don't need to worry about minor settings, as these will
    generally differ between servers.

    If this doesn't resolve it, your best option will probably be to redeploy
    all files within the project....

    --
    Regards

    Tim Stephenson MCSD.NET
    Charted MCAD & MCSD.NET Early Achiever

    "Francesca" <> wrote in message
    news:...
    > How can I check IIS config settings?
    > Here is the code in my webconfig: the only difference between thi

    production
    > and the development one is the connection string (and the debug mode).
    > Hope this helps.
    > **********************************************************
    >
    > <?xml version="1.0" encoding="utf-8" ?>
    >
    > <configuration><appSettings>
    >
    > <!--STRINGA DI CONNESSIONE AL DB DI PRODUZIONE--><add

    key="ConnectionString"
    > value="Network

    Library=DBMSSOCN;Server=DBTEMPES;DataBase=SitoTempes;Connect
    > Timeout=30;uid=XX;pwd=XXX"/>
    >
    >
    >
    > <!--STRINGA DI CONNESSIONE AL DB DI TEST <add key="ConnectionString"
    > value="Network Library=DBMSSOCN;Server=XXXX;DataBase=SitoTempes;Connect
    > Timeout=30;uid=XX;pwd=XXX"/>->
    >
    > <!--STRINGA DI CONNESSIONE AL DBDI SVILUPPO<add key="ConnectionString"
    > value="Network Library=DBMSSOCN;Server=XXXX;DataBase=SitoTempes;Connect
    > Timeout=30;uid=XX;pwd=XXX"/>-->
    >
    > <add key="DBType" value="SQLSERVER"/></appSettings>
    >
    > <system.web><compilation defaultLanguage="vb" debug="false" />
    >
    > <customErrors mode="RemoteOnly" defaultRedirect="/errorpage.aspx"/>
    >
    >
    >
    > <authentication mode="Forms">
    >
    > <forms path="/" name=".AUTHTEMPES" loginUrl="Home.aspx?Test=2"
    > protection="All" timeout="30"></forms>
    >
    > </authentication>
    >
    >
    >
    > <authorization><allow users="*" /> </authorization>
    >
    >
    >
    >
    >
    >
    >
    >
    > <trace enabled="false" requestLimit="10" pageOutput="false"
    > traceMode="SortByTime" localOnly="true" />
    >
    > <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424"
    > sqlConnectionString="data source=127.0.0.1;user id=sa;password="
    > cookieless="false" timeout="20" />
    >
    > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    >
    >
    > </system.web>
    >
    > <location path="superutente"> <system.web><authorization><deny
    > users="?"/><deny roles="1,3,4,5,6,7"/><allow roles="2"/>
    > </authorization></system.web></location>
    >
    > <location path="candidati"> <system.web><authorization><deny
    > users="?"/><deny roles="1,2,3,5,6,7"/><allow roles="4"/>
    > </authorization></system.web></location>
    >
    > <location path="GestioneFormazione"><system.web><authorization><deny
    > users="?"/><deny roles="1,2,3,4,6,7"/><allow roles="5"/>
    > </authorization></system.web></location>
    >
    > <location path="Partners"><system.web><authorization><deny

    users="?"/><deny
    > roles="1,2,3,4,5,7"/><allow roles="6"/>
    > </authorization></system.web></location>
    >
    >
    > </configuration>
    >
    > **********************************************************
    >
    >
    >
    > "Tim Stephenson" <> wrote in message
    > news:...
    > > Do your pages have any form of caching enabled, or does IIS have page

    > output
    > > caching turned on in its config settings?
    > >
    > > It sounds like maybe as you're only changing the ASPX files & not the

    > .VB's
    > > perhaps IIS is not realising that you've changed the page, and still

    > serving
    > > the cached version?
    > >
    > > One place to start might be to try checking to see if your production
    > > server's config matches the development machine....
    > >
    > > Tim
    > >
    > > --
    > > Regards
    > >
    > > Tim Stephenson MCSD.NET
    > > Charted MCAD & MCSD.NET Early Achiever

    >
    >
    >
     
    Tim Stephenson, Oct 15, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tim Stephenson
    Replies:
    1
    Views:
    340
    Francesca
    Oct 16, 2003
  2. V Green
    Replies:
    0
    Views:
    902
    V Green
    Feb 5, 2008
  3. PA Bear [MS MVP]
    Replies:
    0
    Views:
    1,017
    PA Bear [MS MVP]
    Feb 5, 2008
  4. RadioSignal

    passing variables from .aspx.cs code pages to .aspx pages

    RadioSignal, Sep 12, 2005, in forum: ASP .Net Web Controls
    Replies:
    7
    Views:
    2,337
    Mirronelli
    Oct 22, 2005
  5. Chris Angelico
    Replies:
    0
    Views:
    118
    Chris Angelico
    May 12, 2013
Loading...

Share This Page