Re: PyGresql 4.1.1 for python2.7

Discussion in 'Python' started by alexandra, Feb 3, 2013.

  1. alexandra

    alexandra Guest

    body p { margin-bottom: 0cm; margin-top: 0pt; } Using dependency walker revealed that the following are missing from libpq:
    PQescapeLiteral
    PQescapeIdentifier
    These are only defined in postgresql 9.
    Documentation states that PyGresql 4.1.1 is compatible with PostgreSQL 8.3 or higher and I'm using 8.4.
    Has anyone else had this problem?



    On 01/31/2013 03:03 PM, alexandra wrote:


    Hello,

    I'm trying to upgrade to python2.7.
    Installed PyGresql 4.1.1 for python 2.7.
    When running "import pg" command I get the following error:

    from _pg import *
    ImportError: DLL load failed: The operating system cannot run %1.

    I'm using Windows XP SP3, and have PostgreSQL 8.4 installed.
    The command runs fine in python 2.6.

    Is this due to having multiple versions of python installed? Or some kind of dll incompatibility with 2.7 (maybe libpq.dll)?

    Thanks for the help
     
    alexandra, Feb 3, 2013
    #1
    1. Advertising

  2. alexandra

    Guest

    On Sunday, February 3, 2013 4:14:34 AM UTC-7, alexandra wrote:
    > Using dependency walker revealed that the following are missing from
    > libpq:
    >
    > PQescapeLiteral
    >
    > PQescapeIdentifier
    >
    > These are only defined in postgresql 9.
    >
    > Documentation states that PyGresql 4.1.1 is compatible with
    > PostgreSQL 8.3 or higher and I'm using 8.4.
    >
    > Has anyone else had this problem?
    >
    >
    >
    >
    > On 01/31/2013 03:03 PM, alexandra
    > wrote:
    >
    >
    >
    >
    > Hello,
    >
    >
    >
    > I'm trying to upgrade to python2.7.
    >
    > Installed PyGresql 4.1.1 for python 2.7.
    >
    > When running "import pg" command I get the following error:
    >
    >
    >
    > from _pg import *
    >
    > ImportError: DLL load failed: The operating system cannot run %1.
    >
    >
    >
    > I'm using Windows XP SP3, and have PostgreSQL 8.4 installed.
    >
    > The command runs fine in python 2.6.
    >
    >
    >
    > Is this due to having multiple versions of python installed? Or
    > some kind of dll incompatibility with 2.7 (maybe libpq.dll)?
    >
    >
    >
    > Thanks for the help


    Yes I'm having this problem also. Did you ever find a solution?

    J
     
    , Jun 14, 2013
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Xavier
    Replies:
    0
    Views:
    452
    Xavier
    Aug 6, 2003
  2. Skip Montanaro
    Replies:
    1
    Views:
    459
    Thomas Heller
    Aug 7, 2003
  3. snacktime
    Replies:
    13
    Views:
    586
    Dan Sommers
    Feb 22, 2005
  4. Uwe Mayer

    changing from python2.3 to python2.4

    Uwe Mayer, Apr 8, 2005, in forum: Python
    Replies:
    1
    Views:
    322
    =?ISO-8859-1?Q?=22Martin_v=2E_L=F6wis=22?=
    Apr 9, 2005
  5. alexandra

    PyGresql 4.1.1 for python2.7

    alexandra, Jan 31, 2013, in forum: Python
    Replies:
    0
    Views:
    138
    alexandra
    Jan 31, 2013
Loading...

Share This Page