RE: Strange problem running app remotely

Discussion in 'ASP .Net' started by Jim Cheshire [MSFT], Jul 21, 2004.

  1. John,

    Did you make the indicated changes to the web.config file?

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.


    --------------------
    >From: "John" <>
    >Subject: Strange problem running app remotely
    >Date: Wed, 21 Jul 2004 14:28:34 +0100
    >Lines: 346
    >X-Priority: 3
    >X-MSMail-Priority: Normal
    >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >Message-ID: <#>
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:248782
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hi
    >
    >I have a very simply app (attached) which works fine on my local win2k
    >server but when I upload to a remote server I get the error given at the
    >end. As I can see no specific error message, I have no idea what the

    problem
    >is. How can I proceed form here to solve this problem?
    >
    >Thanks
    >
    >Regards
    >
    >
    >Server Error in '/' Application.
    >
    >Runtime Error
    >Description: An application error occurred on the server. The current

    custom
    >error settings for this application prevent the details of the application
    >error from being viewed remotely (for security reasons). It could, however,
    >be viewed by browsers running on the local server machine.
    >
    >Details: To enable the details of this specific error message to be

    viewable
    >on remote machines, please create a <customErrors> tag within a

    "web.config"
    >configuration file located in the root directory of the current web
    >application. This <customErrors> tag should then have its "mode" attribute
    >set to "Off".
    >
    >
    >
    >
     
    Jim Cheshire [MSFT], Jul 21, 2004
    #1
    1. Advertising

  2. Jim Cheshire [MSFT]

    John Guest

    I think I have done it correctly. Here is the web.config. file I am using.

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
    <system.web>
    <compilation defaultLanguage="vb" debug="true" />
    <customErrors mode="Off" />
    <authentication mode="None" />
    <authorization>
    <allow users="*" /> <!-- Allow all users -->
    </authorization>
    <trace enabled="true" requestLimit="10" pageOutput="true"
    traceMode="SortByTime" localOnly="true" />
    <sessionState
    mode="InProc"
    stateConnectionString="tcpip=127.0.0.1:42424"
    sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    cookieless="false"
    timeout="20"
    />
    <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    </system.web>
    </configuration>

    "Jim Cheshire [MSFT]" <> wrote in message
    news:...
    > John,
    >
    > Did you make the indicated changes to the web.config file?
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    > >From: "John" <>
    > >Subject: Strange problem running app remotely
    > >Date: Wed, 21 Jul 2004 14:28:34 +0100
    > >Lines: 346
    > >X-Priority: 3
    > >X-MSMail-Priority: Normal
    > >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >Message-ID: <#>
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    > >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:248782
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >Hi
    > >
    > >I have a very simply app (attached) which works fine on my local win2k
    > >server but when I upload to a remote server I get the error given at the
    > >end. As I can see no specific error message, I have no idea what the

    > problem
    > >is. How can I proceed form here to solve this problem?
    > >
    > >Thanks
    > >
    > >Regards
    > >
    > >
    > >Server Error in '/' Application.
    > >
    > >Runtime Error
    > >Description: An application error occurred on the server. The current

    > custom
    > >error settings for this application prevent the details of the

    application
    > >error from being viewed remotely (for security reasons). It could,

    however,
    > >be viewed by browsers running on the local server machine.
    > >
    > >Details: To enable the details of this specific error message to be

    > viewable
    > >on remote machines, please create a <customErrors> tag within a

    > "web.config"
    > >configuration file located in the root directory of the current web
    > >application. This <customErrors> tag should then have its "mode"

    attribute
    > >set to "Off".
    > >
    > >
    > >
    > >

    >
     
    John, Jul 21, 2004
    #2
    1. Advertising

  3. John,

    If you made that change and this is still happening, it indicates an error
    occurring before the processing of the web.config file. Can you browse the
    server from the console? If not, can you try an ASPX page in a different
    site on the same box?

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.


    --------------------
    >From: "John" <>
    >References: <#>

    <>
    >Subject: Re: Strange problem running app remotely
    >Date: Wed, 21 Jul 2004 19:26:30 +0100
    >Lines: 95
    >X-Priority: 3
    >X-MSMail-Priority: Normal
    >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >Message-ID: <>
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    >Path:

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10
    .phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:248917
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >
    >I think I have done it correctly. Here is the web.config. file I am using.
    >
    ><?xml version="1.0" encoding="utf-8" ?>
    ><configuration>
    > <system.web>
    > <compilation defaultLanguage="vb" debug="true" />
    > <customErrors mode="Off" />
    > <authentication mode="None" />
    > <authorization>
    > <allow users="*" /> <!-- Allow all users -->
    > </authorization>
    > <trace enabled="true" requestLimit="10" pageOutput="true"
    >traceMode="SortByTime" localOnly="true" />
    > <sessionState
    > mode="InProc"
    > stateConnectionString="tcpip=127.0.0.1:42424"
    > sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    > cookieless="false"
    > timeout="20"
    > />
    > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    > </system.web>
    ></configuration>
    >
    >"Jim Cheshire [MSFT]" <> wrote in message
    >news:...
    >> John,
    >>
    >> Did you make the indicated changes to the web.config file?
    >>
    >> Jim Cheshire [MSFT]
    >> MCP+I, MCSE, MCSD, MCDBA
    >> Microsoft Developer Support
    >>
    >>
    >> This post is provided "AS-IS" with no warranties and confers no rights.
    >>
    >>
    >> --------------------
    >> >From: "John" <>
    >> >Subject: Strange problem running app remotely
    >> >Date: Wed, 21 Jul 2004 14:28:34 +0100
    >> >Lines: 346
    >> >X-Priority: 3
    >> >X-MSMail-Priority: Normal
    >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >> >Message-ID: <#>
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    >> >Xref: cpmsftngxa06.phx.gbl

    >microsoft.public.dotnet.framework.aspnet:248782
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Hi
    >> >
    >> >I have a very simply app (attached) which works fine on my local win2k
    >> >server but when I upload to a remote server I get the error given at the
    >> >end. As I can see no specific error message, I have no idea what the

    >> problem
    >> >is. How can I proceed form here to solve this problem?
    >> >
    >> >Thanks
    >> >
    >> >Regards
    >> >
    >> >
    >> >Server Error in '/' Application.
    >> >
    >> >Runtime Error
    >> >Description: An application error occurred on the server. The current

    >> custom
    >> >error settings for this application prevent the details of the

    >application
    >> >error from being viewed remotely (for security reasons). It could,

    >however,
    >> >be viewed by browsers running on the local server machine.
    >> >
    >> >Details: To enable the details of this specific error message to be

    >> viewable
    >> >on remote machines, please create a <customErrors> tag within a

    >> "web.config"
    >> >configuration file located in the root directory of the current web
    >> >application. This <customErrors> tag should then have its "mode"

    >attribute
    >> >set to "Off".
    >> >
    >> >
    >> >
    >> >

    >>

    >
    >
    >
     
    Jim Cheshire [MSFT], Jul 21, 2004
    #3
  4. Jim Cheshire [MSFT]

    John Guest

    The app doesn't run from the site root folder as well. Any ideas?

    Thanks

    Regards


    "Jim Cheshire [MSFT]" <> wrote in message
    news:...
    > John,
    >
    > If you made that change and this is still happening, it indicates an error
    > occurring before the processing of the web.config file. Can you browse

    the
    > server from the console? If not, can you try an ASPX page in a different
    > site on the same box?
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    > >From: "John" <>
    > >References: <#>

    > <>
    > >Subject: Re: Strange problem running app remotely
    > >Date: Wed, 21 Jul 2004 19:26:30 +0100
    > >Lines: 95
    > >X-Priority: 3
    > >X-MSMail-Priority: Normal
    > >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >Message-ID: <>
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > >Path:

    >

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10
    > phx.gbl
    > >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:248917
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >
    > >I think I have done it correctly. Here is the web.config. file I am

    using.
    > >
    > ><?xml version="1.0" encoding="utf-8" ?>
    > ><configuration>
    > > <system.web>
    > > <compilation defaultLanguage="vb" debug="true" />
    > > <customErrors mode="Off" />
    > > <authentication mode="None" />
    > > <authorization>
    > > <allow users="*" /> <!-- Allow all users -->
    > > </authorization>
    > > <trace enabled="true" requestLimit="10" pageOutput="true"
    > >traceMode="SortByTime" localOnly="true" />
    > > <sessionState
    > > mode="InProc"
    > > stateConnectionString="tcpip=127.0.0.1:42424"
    > > sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    > > cookieless="false"
    > > timeout="20"
    > > />
    > > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    > > </system.web>
    > ></configuration>
    > >
    > >"Jim Cheshire [MSFT]" <> wrote in message
    > >news:...
    > >> John,
    > >>
    > >> Did you make the indicated changes to the web.config file?
    > >>
    > >> Jim Cheshire [MSFT]
    > >> MCP+I, MCSE, MCSD, MCDBA
    > >> Microsoft Developer Support
    > >>
    > >>
    > >> This post is provided "AS-IS" with no warranties and confers no rights.
    > >>
    > >>
    > >> --------------------
    > >> >From: "John" <>
    > >> >Subject: Strange problem running app remotely
    > >> >Date: Wed, 21 Jul 2004 14:28:34 +0100
    > >> >Lines: 346
    > >> >X-Priority: 3
    > >> >X-MSMail-Priority: Normal
    > >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >> >Message-ID: <#>
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    > >> >Xref: cpmsftngxa06.phx.gbl

    > >microsoft.public.dotnet.framework.aspnet:248782
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >Hi
    > >> >
    > >> >I have a very simply app (attached) which works fine on my local win2k
    > >> >server but when I upload to a remote server I get the error given at

    the
    > >> >end. As I can see no specific error message, I have no idea what the
    > >> problem
    > >> >is. How can I proceed form here to solve this problem?
    > >> >
    > >> >Thanks
    > >> >
    > >> >Regards
    > >> >
    > >> >
    > >> >Server Error in '/' Application.
    > >> >
    > >> >Runtime Error
    > >> >Description: An application error occurred on the server. The current
    > >> custom
    > >> >error settings for this application prevent the details of the

    > >application
    > >> >error from being viewed remotely (for security reasons). It could,

    > >however,
    > >> >be viewed by browsers running on the local server machine.
    > >> >
    > >> >Details: To enable the details of this specific error message to be
    > >> viewable
    > >> >on remote machines, please create a <customErrors> tag within a
    > >> "web.config"
    > >> >configuration file located in the root directory of the current web
    > >> >application. This <customErrors> tag should then have its "mode"

    > >attribute
    > >> >set to "Off".
    > >> >
    > >> >
    > >> >
    > >> >
    > >>

    > >
    > >
    > >

    >
     
    John, Jul 22, 2004
    #4
  5. Jim Cheshire [MSFT]

    John Guest

    OK. I am using a second remote server and am getting the below message. Any
    ideas?

    Thanks

    Parser Error Message: It is an error to use a section registered as
    allowDefinition='MachineToApplication' beyond application level. This error
    can be caused by a virtual directory not being configured as an application
    in IIS.

    Source Error:

    Line 4: <compilation defaultLanguage="vb" debug="true" />
    Line 5: <customErrors mode="Off" />
    Line 6: <authentication mode="None" />
    Line 7: <authorization>
    Line 8: <allow users="*" /> <!-- Allow all users -->


    "Jim Cheshire [MSFT]" <> wrote in message
    news:...
    > John,
    >
    > If you made that change and this is still happening, it indicates an error
    > occurring before the processing of the web.config file. Can you browse

    the
    > server from the console? If not, can you try an ASPX page in a different
    > site on the same box?
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    > >From: "John" <>
    > >References: <#>

    > <>
    > >Subject: Re: Strange problem running app remotely
    > >Date: Wed, 21 Jul 2004 19:26:30 +0100
    > >Lines: 95
    > >X-Priority: 3
    > >X-MSMail-Priority: Normal
    > >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >Message-ID: <>
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > >Path:

    >

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10
    > phx.gbl
    > >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:248917
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >
    > >I think I have done it correctly. Here is the web.config. file I am

    using.
    > >
    > ><?xml version="1.0" encoding="utf-8" ?>
    > ><configuration>
    > > <system.web>
    > > <compilation defaultLanguage="vb" debug="true" />
    > > <customErrors mode="Off" />
    > > <authentication mode="None" />
    > > <authorization>
    > > <allow users="*" /> <!-- Allow all users -->
    > > </authorization>
    > > <trace enabled="true" requestLimit="10" pageOutput="true"
    > >traceMode="SortByTime" localOnly="true" />
    > > <sessionState
    > > mode="InProc"
    > > stateConnectionString="tcpip=127.0.0.1:42424"
    > > sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    > > cookieless="false"
    > > timeout="20"
    > > />
    > > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    > > </system.web>
    > ></configuration>
    > >
    > >"Jim Cheshire [MSFT]" <> wrote in message
    > >news:...
    > >> John,
    > >>
    > >> Did you make the indicated changes to the web.config file?
    > >>
    > >> Jim Cheshire [MSFT]
    > >> MCP+I, MCSE, MCSD, MCDBA
    > >> Microsoft Developer Support
    > >>
    > >>
    > >> This post is provided "AS-IS" with no warranties and confers no rights.
    > >>
    > >>
    > >> --------------------
    > >> >From: "John" <>
    > >> >Subject: Strange problem running app remotely
    > >> >Date: Wed, 21 Jul 2004 14:28:34 +0100
    > >> >Lines: 346
    > >> >X-Priority: 3
    > >> >X-MSMail-Priority: Normal
    > >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >> >Message-ID: <#>
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    > >> >Xref: cpmsftngxa06.phx.gbl

    > >microsoft.public.dotnet.framework.aspnet:248782
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >Hi
    > >> >
    > >> >I have a very simply app (attached) which works fine on my local win2k
    > >> >server but when I upload to a remote server I get the error given at

    the
    > >> >end. As I can see no specific error message, I have no idea what the
    > >> problem
    > >> >is. How can I proceed form here to solve this problem?
    > >> >
    > >> >Thanks
    > >> >
    > >> >Regards
    > >> >
    > >> >
    > >> >Server Error in '/' Application.
    > >> >
    > >> >Runtime Error
    > >> >Description: An application error occurred on the server. The current
    > >> custom
    > >> >error settings for this application prevent the details of the

    > >application
    > >> >error from being viewed remotely (for security reasons). It could,

    > >however,
    > >> >be viewed by browsers running on the local server machine.
    > >> >
    > >> >Details: To enable the details of this specific error message to be
    > >> viewable
    > >> >on remote machines, please create a <customErrors> tag within a
    > >> "web.config"
    > >> >configuration file located in the root directory of the current web
    > >> >application. This <customErrors> tag should then have its "mode"

    > >attribute
    > >> >set to "Off".
    > >> >
    > >> >
    > >> >
    > >> >
    > >>

    > >
    > >
    > >

    >
     
    John, Jul 22, 2004
    #5
  6. Jim Cheshire [MSFT]

    John Guest

    PS: The error is on line 6. The site url is;
    http://yahya01.europe.webmatrixhosting.net/WebApplication2/webform1.aspx

    "John" <> wrote in message
    news:O63U3$...
    > OK. I am using a second remote server and am getting the below message.

    Any
    > ideas?
    >
    > Thanks
    >
    > Parser Error Message: It is an error to use a section registered as
    > allowDefinition='MachineToApplication' beyond application level. This

    error
    > can be caused by a virtual directory not being configured as an

    application
    > in IIS.
    >
    > Source Error:
    >
    > Line 4: <compilation defaultLanguage="vb" debug="true" />
    > Line 5: <customErrors mode="Off" />
    > Line 6: <authentication mode="None" />
    > Line 7: <authorization>
    > Line 8: <allow users="*" /> <!-- Allow all users -->
    >
    >
    > "Jim Cheshire [MSFT]" <> wrote in message
    > news:...
    > > John,
    > >
    > > If you made that change and this is still happening, it indicates an

    error
    > > occurring before the processing of the web.config file. Can you browse

    > the
    > > server from the console? If not, can you try an ASPX page in a

    different
    > > site on the same box?
    > >
    > > Jim Cheshire [MSFT]
    > > MCP+I, MCSE, MCSD, MCDBA
    > > Microsoft Developer Support
    > >
    > >
    > > This post is provided "AS-IS" with no warranties and confers no rights.
    > >
    > >
    > > --------------------
    > > >From: "John" <>
    > > >References: <#>

    > > <>
    > > >Subject: Re: Strange problem running app remotely
    > > >Date: Wed, 21 Jul 2004 19:26:30 +0100
    > > >Lines: 95
    > > >X-Priority: 3
    > > >X-MSMail-Priority: Normal
    > > >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > > >Message-ID: <>
    > > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > > >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > > >Path:

    > >

    >

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10
    > > phx.gbl
    > > >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:248917
    > > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > > >
    > > >
    > > >I think I have done it correctly. Here is the web.config. file I am

    > using.
    > > >
    > > ><?xml version="1.0" encoding="utf-8" ?>
    > > ><configuration>
    > > > <system.web>
    > > > <compilation defaultLanguage="vb" debug="true" />
    > > > <customErrors mode="Off" />
    > > > <authentication mode="None" />
    > > > <authorization>
    > > > <allow users="*" /> <!-- Allow all users -->
    > > > </authorization>
    > > > <trace enabled="true" requestLimit="10" pageOutput="true"
    > > >traceMode="SortByTime" localOnly="true" />
    > > > <sessionState
    > > > mode="InProc"
    > > > stateConnectionString="tcpip=127.0.0.1:42424"
    > > > sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    > > > cookieless="false"
    > > > timeout="20"
    > > > />
    > > > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    > > > </system.web>
    > > ></configuration>
    > > >
    > > >"Jim Cheshire [MSFT]" <> wrote in message
    > > >news:...
    > > >> John,
    > > >>
    > > >> Did you make the indicated changes to the web.config file?
    > > >>
    > > >> Jim Cheshire [MSFT]
    > > >> MCP+I, MCSE, MCSD, MCDBA
    > > >> Microsoft Developer Support
    > > >>
    > > >>
    > > >> This post is provided "AS-IS" with no warranties and confers no

    rights.
    > > >>
    > > >>
    > > >> --------------------
    > > >> >From: "John" <>
    > > >> >Subject: Strange problem running app remotely
    > > >> >Date: Wed, 21 Jul 2004 14:28:34 +0100
    > > >> >Lines: 346
    > > >> >X-Priority: 3
    > > >> >X-MSMail-Priority: Normal
    > > >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > > >> >Message-ID: <#>
    > > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > > >> >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    > > >> >Xref: cpmsftngxa06.phx.gbl
    > > >microsoft.public.dotnet.framework.aspnet:248782
    > > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > > >> >
    > > >> >Hi
    > > >> >
    > > >> >I have a very simply app (attached) which works fine on my local

    win2k
    > > >> >server but when I upload to a remote server I get the error given at

    > the
    > > >> >end. As I can see no specific error message, I have no idea what the
    > > >> problem
    > > >> >is. How can I proceed form here to solve this problem?
    > > >> >
    > > >> >Thanks
    > > >> >
    > > >> >Regards
    > > >> >
    > > >> >
    > > >> >Server Error in '/' Application.
    > > >> >
    > > >> >Runtime Error
    > > >> >Description: An application error occurred on the server. The

    current
    > > >> custom
    > > >> >error settings for this application prevent the details of the
    > > >application
    > > >> >error from being viewed remotely (for security reasons). It could,
    > > >however,
    > > >> >be viewed by browsers running on the local server machine.
    > > >> >
    > > >> >Details: To enable the details of this specific error message to be
    > > >> viewable
    > > >> >on remote machines, please create a <customErrors> tag within a
    > > >> "web.config"
    > > >> >configuration file located in the root directory of the current web
    > > >> >application. This <customErrors> tag should then have its "mode"
    > > >attribute
    > > >> >set to "Off".
    > > >> >
    > > >> >
    > > >> >
    > > >> >
    > > >>
    > > >
    > > >
    > > >

    > >

    >
    >
     
    John, Jul 22, 2004
    #6
  7. Jim Cheshire [MSFT]

    Greg Burns Guest

    You can have have web.config in subdirectories of your Virtual Directory.
    But those web.config can only be a subset of your main one at the top level.
    In other words, you cannot have most of that stuff in a sub web.config.

    Hope that was clear.
    Greg

    "John" <> wrote in message
    news:O63U3$...
    > OK. I am using a second remote server and am getting the below message.

    Any
    > ideas?
    >
    > Thanks
    >
    > Parser Error Message: It is an error to use a section registered as
    > allowDefinition='MachineToApplication' beyond application level. This

    error
    > can be caused by a virtual directory not being configured as an

    application
    > in IIS.
    >
    > Source Error:
    >
    > Line 4: <compilation defaultLanguage="vb" debug="true" />
    > Line 5: <customErrors mode="Off" />
    > Line 6: <authentication mode="None" />
    > Line 7: <authorization>
    > Line 8: <allow users="*" /> <!-- Allow all users -->
    >
    >
    > "Jim Cheshire [MSFT]" <> wrote in message
    > news:...
    > > John,
    > >
    > > If you made that change and this is still happening, it indicates an

    error
    > > occurring before the processing of the web.config file. Can you browse

    > the
    > > server from the console? If not, can you try an ASPX page in a

    different
    > > site on the same box?
    > >
    > > Jim Cheshire [MSFT]
    > > MCP+I, MCSE, MCSD, MCDBA
    > > Microsoft Developer Support
    > >
    > >
    > > This post is provided "AS-IS" with no warranties and confers no rights.
    > >
    > >
    > > --------------------
    > > >From: "John" <>
    > > >References: <#>

    > > <>
    > > >Subject: Re: Strange problem running app remotely
    > > >Date: Wed, 21 Jul 2004 19:26:30 +0100
    > > >Lines: 95
    > > >X-Priority: 3
    > > >X-MSMail-Priority: Normal
    > > >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > > >Message-ID: <>
    > > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > > >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > > >Path:

    > >

    >

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10
    > > phx.gbl
    > > >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:248917
    > > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > > >
    > > >
    > > >I think I have done it correctly. Here is the web.config. file I am

    > using.
    > > >
    > > ><?xml version="1.0" encoding="utf-8" ?>
    > > ><configuration>
    > > > <system.web>
    > > > <compilation defaultLanguage="vb" debug="true" />
    > > > <customErrors mode="Off" />
    > > > <authentication mode="None" />
    > > > <authorization>
    > > > <allow users="*" /> <!-- Allow all users -->
    > > > </authorization>
    > > > <trace enabled="true" requestLimit="10" pageOutput="true"
    > > >traceMode="SortByTime" localOnly="true" />
    > > > <sessionState
    > > > mode="InProc"
    > > > stateConnectionString="tcpip=127.0.0.1:42424"
    > > > sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    > > > cookieless="false"
    > > > timeout="20"
    > > > />
    > > > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    > > > </system.web>
    > > ></configuration>
    > > >
    > > >"Jim Cheshire [MSFT]" <> wrote in message
    > > >news:...
    > > >> John,
    > > >>
    > > >> Did you make the indicated changes to the web.config file?
    > > >>
    > > >> Jim Cheshire [MSFT]
    > > >> MCP+I, MCSE, MCSD, MCDBA
    > > >> Microsoft Developer Support
    > > >>
    > > >>
    > > >> This post is provided "AS-IS" with no warranties and confers no

    rights.
    > > >>
    > > >>
    > > >> --------------------
    > > >> >From: "John" <>
    > > >> >Subject: Strange problem running app remotely
    > > >> >Date: Wed, 21 Jul 2004 14:28:34 +0100
    > > >> >Lines: 346
    > > >> >X-Priority: 3
    > > >> >X-MSMail-Priority: Normal
    > > >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > > >> >Message-ID: <#>
    > > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > > >> >NNTP-Posting-Host: 81-86-132-31.dsl.pipex.com 81.86.132.31
    > > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    > > >> >Xref: cpmsftngxa06.phx.gbl
    > > >microsoft.public.dotnet.framework.aspnet:248782
    > > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > > >> >
    > > >> >Hi
    > > >> >
    > > >> >I have a very simply app (attached) which works fine on my local

    win2k
    > > >> >server but when I upload to a remote server I get the error given at

    > the
    > > >> >end. As I can see no specific error message, I have no idea what the
    > > >> problem
    > > >> >is. How can I proceed form here to solve this problem?
    > > >> >
    > > >> >Thanks
    > > >> >
    > > >> >Regards
    > > >> >
    > > >> >
    > > >> >Server Error in '/' Application.
    > > >> >
    > > >> >Runtime Error
    > > >> >Description: An application error occurred on the server. The

    current
    > > >> custom
    > > >> >error settings for this application prevent the details of the
    > > >application
    > > >> >error from being viewed remotely (for security reasons). It could,
    > > >however,
    > > >> >be viewed by browsers running on the local server machine.
    > > >> >
    > > >> >Details: To enable the details of this specific error message to be
    > > >> viewable
    > > >> >on remote machines, please create a <customErrors> tag within a
    > > >> "web.config"
    > > >> >configuration file located in the root directory of the current web
    > > >> >application. This <customErrors> tag should then have its "mode"
    > > >attribute
    > > >> >set to "Off".
    > > >> >
    > > >> >
    > > >> >
    > > >> >
    > > >>
    > > >
    > > >
    > > >

    > >

    >
    >
     
    Greg Burns, Jul 22, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John
    Replies:
    3
    Views:
    380
    John Saunders
    Jul 21, 2004
  2. John

    Error running site remotely

    John, Oct 7, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    3,616
    Shiva
    Oct 7, 2004
  3. John

    Error when running site remotely

    John, Oct 7, 2004, in forum: ASP .Net
    Replies:
    8
    Views:
    394
  4. Francesco

    Linux c app, called remotely by web.

    Francesco, Jan 27, 2006, in forum: C Programming
    Replies:
    15
    Views:
    464
    Vladimir S. Oka
    Jan 28, 2006
  5. Sean DiZazzo

    Run wxPython app remotely under XWindows

    Sean DiZazzo, Feb 28, 2008, in forum: Python
    Replies:
    8
    Views:
    346
    Sean DiZazzo
    Mar 1, 2008
Loading...

Share This Page