Re: Validation controls work differently on remote server

Discussion in 'ASP .Net' started by Peter Afonin, Apr 3, 2004.

  1. Peter Afonin

    Peter Afonin Guest

    You were correct. I asked my provider to follow your instructions and to
    install javascript includes, they did it and now it all works fine. Thank
    you!

    "P.J. Pirrello" <> wrote in message
    news:...
    > It's possibly that the remote server doesn't have the aspnet_client
    > javascript includes installed. If they aren't available, I believe the
    > client side validation will not function, and you will only get the server
    > side validation (which validates only after a postback) You should get a
    > javascript error though, so not 100% sure. You can install the client

    side
    > includes by running aspnet_regiis -c.
    >
    > You can get more info on all of what you can do with aspnet_regiis at:
    >

    http://msdn.microsoft.com/library/d...aspnetiisregistrationtoolaspnet_regiisexe.asp
    >
    > Hope that helps,
    > -PJ Pirrello
    >
    > "Peter Afonin" <> wrote in message
    > news:%...
    > > Hello:
    > >
    > > I have several aspx pages with multiple validation controls. On my PC

    they
    > > work as they should - if validation fails, the error messages are

    > displayed
    > > and the page is not submitted.
    > >
    > > When I upload my web site to the remote server (which is my web hosting
    > > provider's server) they work differently. The error messages are still
    > > displayed if validation fails, however, it doesn't prevent the page from
    > > being submitted.
    > >
    > > Why is this happening? Can I do something about it, or I should ask my
    > > hosting provider to modify something?
    > >
    > > I would appreciate your advice.
    > >
    > > Thank you,
    > >
    > > --
    > > Peter Afonin
    > >
    > >

    >
    >
    Peter Afonin, Apr 3, 2004
    #1
    1. Advertising

  2. Peter Afonin wrote:
    > You were correct. I asked my provider to follow your instructions and to


    > "P.J. Pirrello" <> wrote in message
    > news:...
    >


    >>includes by running aspnet_regiis -c.
    >>



    man, thanks for posting that.

    you saved my ass on a project with that shit !
    It's New! It's Beige!, Apr 17, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matt
    Replies:
    14
    Views:
    4,092
    Chad Z. Hower aka Kudzu
    Jan 30, 2004
  2. Peter Row
    Replies:
    0
    Views:
    464
    Peter Row
    Mar 1, 2004
  3. Paul M
    Replies:
    0
    Views:
    401
    Paul M
    Apr 11, 2004
  4. Keith Free Ellis
    Replies:
    4
    Views:
    4,167
    Steven Cheng[MSFT]
    Jul 14, 2004
  5. Just D.
    Replies:
    3
    Views:
    375
    Just D.
    Mar 4, 2006
Loading...

Share This Page