RegexAssembly?_0.dll and Zero-touch deployment

Discussion in 'ASP .Net' started by Alan Seunarayan, Jun 5, 2004.

  1. Hello all,
    I am in the process of developing a Windows Forms application that is
    distributed via zero-touch. Unfortunately I have come across an obstacle! A
    3rd party control that I am using seems to dynamically create an assembly.
    When I run the .EXE locally on the development PC it is fine, if I also copy
    all the files to the test PC it runs fine. But when I run it via
    http://myIIS/ztd/app/ztd.exe from the test pc it fails and the cordbg
    displays the following:

    Microsoft (R) Common Language Runtime Test Debugger Shell Version 1.0.3705.0
    Copyright (C) Microsoft Corporation 1998-2001. All rights reserved.

    (cordbg) a 0x4d0
    Process 1232/0x4d0 created.
    Warning: couldn't load symbols for
    c:\winnt\microsoft.net\framework\v1.1.4322\ms
    corlib.dll
    Warning: couldn't load symbols for
    C:\WINNT\Microsoft.NET\Framework\v1.1.4322\IE
    Exec.exe
    Warning: couldn't load symbols for
    c:\winnt\assembly\gac\ieexecremote\1.0.5000.0
    __b03f5f7f11d50a3a\ieexecremote.dll
    Warning: couldn't load symbols for
    c:\winnt\assembly\gac\system\1.0.5000.0__b77a
    5c561934e089\system.dll
    Warning: couldn't load symbols for
    c:\winnt\assembly\gac\system.drawing\1.0.5000
    ..0__b03f5f7f11d50a3a\system.drawing.dll
    Warning: couldn't load symbols for
    c:\winnt\microsoft.net\framework\v1.1.4322\ms
    corlib.dll
    Warning: couldn't load symbols for
    c:\winnt\assembly\gac\system\1.0.5000.0__b77a
    5c561934e089\system.dll
    Warning: couldn't load symbols for
    c:\winnt\assembly\gac\system.drawing\1.0.5000
    ..0__b03f5f7f11d50a3a\system.drawing.dll
    Warning: couldn't load symbols for
    c:\winnt\assembly\gac\ieexecremote\1.0.5000.0
    __b03f5f7f11d50a3a\ieexecremote.dll
    Warning: couldn't load symbols for c:\documents and settings\swadmin\local
    setti
    ngs\application
    data\assembly\dl2\djzlwazx.1tk\x1r91ey8.dqq\bc19fa57\00171d2b_d6
    4ac401\ztdlauncher.exe
    Warning: couldn't load symbols for c:\documents and settings\swadmin\local
    setti
    ngs\application
    data\assembly\dl2\djzlwazx.1tk\x1r91ey8.dqq\90c3c914\00171d2b_d6
    4ac401\ztd2.dll
    Warning: couldn't load symbols for
    c:\winnt\assembly\gac\system.windows.forms\1.
    0.5000.0__b77a5c561934e089\system.windows.forms.dll
    [thread 0x480] Thread created.
    Unable to determine existence of prolog, if any
    [thread 0x48c] Thread created.
    [thread 0x358] Thread created.
    [thread 0x480] Unhandled exception generated: (0x04aac748)
    <System.Security.Secu
    rityException>
    permissionType=<null>
    permissionState=(0x04ab7af8) "<IPermission
    class="System.Security.Permissions.
    SecurityPermission, mscorlib, Version=1.0.5000.0, Culture=neutral,
    PublicKeyToke
    n=b77a5c561934e089"
    version="1"
    Flags="ControlAppDomain"/>
    "
    grantedSet=<null>
    refusedSet=<null>
    _className=(0x04aad6ec) "System.Security.SecurityException"
    _exceptionMethod=<null>
    _exceptionMethodString=(0x04ab479c) "8 CheckTokenBasedSetHelper mscorlib,
    Vers
    ion=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    System.Security
    ..CodeAccessSecurityEngine Void CheckTokenBasedSetHelper(Boolean,
    System.Security
    ..Util.TokenBasedSet, System.Security.Util.TokenBasedSet,
    System.Security.Util.To
    kenBasedSet)"
    _message=(0x04aaeac0) "Request for the permission of type
    System.Security.Perm
    issions.SecurityPermission, mscorlib, Version=1.0.5000.0, Culture=neutral,
    Publi
    cKeyToken=b77a5c561934e089 failed."
    _innerException=<null>
    _helpURL=<null>
    _stackTrace=(0x04ab8a3c) array with dims=[12]
    _stackTraceString=<null>
    _remoteStackTraceString=<null>
    _remoteStackIndex=0x00000000
    _HResult=0x8013150a
    _source=(0x04ab6804) "mscorlib"
    _xptrs=0x00000000
    _xcode=0x00000000

    [05f5] int 3
    (cordbg)

    I hope someone can help!

    Regards,

    Alan Seunarayan
    Alan Seunarayan, Jun 5, 2004
    #1
    1. Advertising

  2. figured out the solution.

    thanks
    "Alan Seunarayan" <> wrote in message
    news:...
    > Hello all,
    > I am in the process of developing a Windows Forms application that is
    > distributed via zero-touch. Unfortunately I have come across an obstacle!

    A
    > 3rd party control that I am using seems to dynamically create an assembly.
    > When I run the .EXE locally on the development PC it is fine, if I also

    copy
    > all the files to the test PC it runs fine. But when I run it via
    > http://myIIS/ztd/app/ztd.exe from the test pc it fails and the cordbg
    > displays the following:
    >
    > Microsoft (R) Common Language Runtime Test Debugger Shell Version

    1.0.3705.0
    > Copyright (C) Microsoft Corporation 1998-2001. All rights reserved.
    >
    > (cordbg) a 0x4d0
    > Process 1232/0x4d0 created.
    > Warning: couldn't load symbols for
    > c:\winnt\microsoft.net\framework\v1.1.4322\ms
    > corlib.dll
    > Warning: couldn't load symbols for
    > C:\WINNT\Microsoft.NET\Framework\v1.1.4322\IE
    > Exec.exe
    > Warning: couldn't load symbols for
    > c:\winnt\assembly\gac\ieexecremote\1.0.5000.0
    > __b03f5f7f11d50a3a\ieexecremote.dll
    > Warning: couldn't load symbols for
    > c:\winnt\assembly\gac\system\1.0.5000.0__b77a
    > 5c561934e089\system.dll
    > Warning: couldn't load symbols for
    > c:\winnt\assembly\gac\system.drawing\1.0.5000
    > .0__b03f5f7f11d50a3a\system.drawing.dll
    > Warning: couldn't load symbols for
    > c:\winnt\microsoft.net\framework\v1.1.4322\ms
    > corlib.dll
    > Warning: couldn't load symbols for
    > c:\winnt\assembly\gac\system\1.0.5000.0__b77a
    > 5c561934e089\system.dll
    > Warning: couldn't load symbols for
    > c:\winnt\assembly\gac\system.drawing\1.0.5000
    > .0__b03f5f7f11d50a3a\system.drawing.dll
    > Warning: couldn't load symbols for
    > c:\winnt\assembly\gac\ieexecremote\1.0.5000.0
    > __b03f5f7f11d50a3a\ieexecremote.dll
    > Warning: couldn't load symbols for c:\documents and settings\swadmin\local
    > setti
    > ngs\application
    > data\assembly\dl2\djzlwazx.1tk\x1r91ey8.dqq\bc19fa57\00171d2b_d6
    > 4ac401\ztdlauncher.exe
    > Warning: couldn't load symbols for c:\documents and settings\swadmin\local
    > setti
    > ngs\application
    > data\assembly\dl2\djzlwazx.1tk\x1r91ey8.dqq\90c3c914\00171d2b_d6
    > 4ac401\ztd2.dll
    > Warning: couldn't load symbols for
    > c:\winnt\assembly\gac\system.windows.forms\1.
    > 0.5000.0__b77a5c561934e089\system.windows.forms.dll
    > [thread 0x480] Thread created.
    > Unable to determine existence of prolog, if any
    > [thread 0x48c] Thread created.
    > [thread 0x358] Thread created.
    > [thread 0x480] Unhandled exception generated: (0x04aac748)
    > <System.Security.Secu
    > rityException>
    > permissionType=<null>
    > permissionState=(0x04ab7af8) "<IPermission
    > class="System.Security.Permissions.
    > SecurityPermission, mscorlib, Version=1.0.5000.0, Culture=neutral,
    > PublicKeyToke
    > n=b77a5c561934e089"
    > version="1"
    > Flags="ControlAppDomain"/>
    > "
    > grantedSet=<null>
    > refusedSet=<null>
    > _className=(0x04aad6ec) "System.Security.SecurityException"
    > _exceptionMethod=<null>
    > _exceptionMethodString=(0x04ab479c) "8 CheckTokenBasedSetHelper

    mscorlib,
    > Vers
    > ion=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    > System.Security
    > .CodeAccessSecurityEngine Void CheckTokenBasedSetHelper(Boolean,
    > System.Security
    > .Util.TokenBasedSet, System.Security.Util.TokenBasedSet,
    > System.Security.Util.To
    > kenBasedSet)"
    > _message=(0x04aaeac0) "Request for the permission of type
    > System.Security.Perm
    > issions.SecurityPermission, mscorlib, Version=1.0.5000.0, Culture=neutral,
    > Publi
    > cKeyToken=b77a5c561934e089 failed."
    > _innerException=<null>
    > _helpURL=<null>
    > _stackTrace=(0x04ab8a3c) array with dims=[12]
    > _stackTraceString=<null>
    > _remoteStackTraceString=<null>
    > _remoteStackIndex=0x00000000
    > _HResult=0x8013150a
    > _source=(0x04ab6804) "mscorlib"
    > _xptrs=0x00000000
    > _xcode=0x00000000
    >
    > [05f5] int 3
    > (cordbg)
    >
    > I hope someone can help!
    >
    > Regards,
    >
    > Alan Seunarayan
    >
    >
    Alan Seunarayan, Jun 6, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mats-Erik Grundh

    No Touch Deployment and Web Services.

    Mats-Erik Grundh, Sep 30, 2003, in forum: ASP .Net Web Services
    Replies:
    2
    Views:
    114
    Mats-Erik Grundh
    Oct 2, 2003
  2. Mats-Erik Grundh

    No Touch Deployment and Web Services.

    Mats-Erik Grundh, Oct 4, 2003, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    134
    Mats-Erik Grundh
    Oct 4, 2003
  3. Mats-Erik Grundh

    No Touch Deployment and Web Services.

    Mats-Erik Grundh, Oct 14, 2003, in forum: ASP .Net Web Services
    Replies:
    3
    Views:
    122
    Mats-Erik Grundh
    Oct 17, 2003
  4. Mats-Erik Grundh

    No Touch Deployment and Web Services.

    Mats-Erik Grundh, Oct 15, 2003, in forum: ASP .Net Web Services
    Replies:
    10
    Views:
    216
  5. Han Holl
    Replies:
    4
    Views:
    336
    Nobuyoshi Nakada
    Oct 12, 2006
Loading...

Share This Page