release mode Compile error BC2014

Discussion in 'ASP .Net' started by news.microsoft.com, Jul 13, 2007.

  1. I have an asp.net 2.0 project that when I change the build configuration to
    release I get the following error:

    Command line error BC2014: the value 'None' is invalid for option
    'debug'.

    If I go into the projects Advanced Compile Options and change the Generate
    Debug Info dropdown from None to PDB-Only the error goes away. Can anyone
    explain why I have to do this and what can I do to get the one option to
    work on a asp.net project? It is causing problems because the common
    project is shared with a VB project that gets an error on release mode
    compile if it is set to pdb-only.

    Thanks for your help.
     
    news.microsoft.com, Jul 13, 2007
    #1
    1. Advertising

  2. Just add this entry to the web.config file :


    <compilation debug="true" />



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "news.microsoft.com" <> wrote in message news:...
    >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:
    >
    > Command line error BC2014: the value 'None' is invalid for option 'debug'.
    >
    > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
    > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
    > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
    > release mode compile if it is set to pdb-only.
    >
    > Thanks for your help.
    >
     
    Juan T. Llibre, Jul 13, 2007
    #2
    1. Advertising

  3. news.microsoft.com

    nahid Guest

    On Jul 14, 12:20 am, "Juan T. Llibre" <>
    wrote:
    > Just add this entry to the web.config file :
    >
    > <compilation debug="true" />
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================
    >
    >
    >
    > "news.microsoft.com" <> wrote in messagenews:...
    > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

    >
    > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

    >
    > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
    > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
    > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
    > > release mode compile if it is set to pdb-only.

    >
    > > Thanks for your help.- Hide quoted text -

    >
    > - Show quoted text -


    hai,
    he try build in release mode better set
    <compilation debug="false" />

    nahid
    http://nahidulkibria.blogspot.com/
    http://www.kaz.com.bd
     
    nahid, Jul 13, 2007
    #3
  4. re:
    !> he try build in release mode better set
    !> <compilation debug="false" />

    No. He said that when :

    !> I change the build configuration to release

    ....the error occurs, therefore setting it to debug="true" should fix it.

    Your suggestion, debug="false", is the same as setting the application
    to release mode, so he would likely continue to get the same error as
    whenhe manually sets it to "release" mode.





    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "nahid" <> wrote in message news:...
    On Jul 14, 12:20 am, "Juan T. Llibre" <>
    wrote:
    > Just add this entry to the web.config file :
    >
    > <compilation debug="true" />
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================
    >
    >
    >
    > "news.microsoft.com" <> wrote in messagenews:...
    > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

    >
    > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

    >
    > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
    > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
    > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
    > > on
    > > release mode compile if it is set to pdb-only.

    >
    > > Thanks for your help.- Hide quoted text -

    >
    > - Show quoted text -


    hai,
    he try build in release mode better set
    <compilation debug="false" />

    nahid
    http://nahidulkibria.blogspot.com/
    http://www.kaz.com.bd
     
    Juan T. Llibre, Jul 13, 2007
    #4
  5. news.microsoft.com

    nahid Guest

    On Jul 14, 12:53 am, "Juan T. Llibre" <>
    wrote:
    > re:
    > !> he try build in release mode better set
    > !> <compilation debug="false" />
    >
    > No. He said that when :
    >
    > !> I change the build configuration to release
    >
    > ...the error occurs, therefore setting it to debug="true" should fix it.
    >
    > Your suggestion, debug="false", is the same as setting the application
    > to release mode, so he would likely continue to get the same error as
    > whenhe manually sets it to "release" mode.
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"nahid" <> wrote in messagenews:...
    >
    > On Jul 14, 12:20 am, "Juan T. Llibre" <>
    > wrote:
    >
    >
    >
    >
    >
    > > Just add this entry to the web.config file :

    >
    > > <compilation debug="true" />

    >
    > > Juan T. Llibre, asp.net MVP
    > > asp.net faq :http://asp.net.do/faq/
    > > foros de asp.net, en español :http://asp.net.do/foros/
    > > ======================================

    >
    > > "news.microsoft.com" <> wrote in messagenews:...
    > > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

    >
    > > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

    >
    > > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
    > > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
    > > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
    > > > on
    > > > release mode compile if it is set to pdb-only.

    >
    > > > Thanks for your help.- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > hai,
    > he try build in release mode better set
    > <compilation debug="false" />
    >
    > nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted text -
    >
    > - Show quoted text -


    well so what is basically main problem, say i'm not prefer set
    <compilation debug="true" /> because of loss some performance

    nahid
    http://nahidulkibria.blogspot.com/
    http://www.kaz.com.bd
     
    nahid, Jul 13, 2007
    #5
  6. re:
    !> well so what is basically main problem, say i'm not prefer set
    !> <compilation debug="true" /> because of loss some performance

    True enough, but to resolve the *current* problem ( that the app won't run ),
    the solution is get get the app working *first* and then *later* we worry about performance.



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "nahid" <> wrote in message news:...
    On Jul 14, 12:53 am, "Juan T. Llibre" <>
    wrote:
    > re:
    > !> he try build in release mode better set
    > !> <compilation debug="false" />
    >
    > No. He said that when :
    >
    > !> I change the build configuration to release
    >
    > ...the error occurs, therefore setting it to debug="true" should fix it.
    >
    > Your suggestion, debug="false", is the same as setting the application
    > to release mode, so he would likely continue to get the same error as
    > whenhe manually sets it to "release" mode.
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"nahid" <> wrote in
    > messagenews:...
    >
    > On Jul 14, 12:20 am, "Juan T. Llibre" <>
    > wrote:
    >
    >
    >
    >
    >
    > > Just add this entry to the web.config file :

    >
    > > <compilation debug="true" />

    >
    > > Juan T. Llibre, asp.net MVP
    > > asp.net faq :http://asp.net.do/faq/
    > > foros de asp.net, en español :http://asp.net.do/foros/
    > > ======================================

    >
    > > "news.microsoft.com" <> wrote in messagenews:...
    > > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

    >
    > > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

    >
    > > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to
    > > > PDB-Only
    > > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on
    > > > a
    > > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
    > > > on
    > > > release mode compile if it is set to pdb-only.

    >
    > > > Thanks for your help.- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > hai,
    > he try build in release mode better set
    > <compilation debug="false" />
    >
    > nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted text -
    >
    > - Show quoted text -


    well so what is basically main problem, say i'm not prefer set
    <compilation debug="true" /> because of loss some performance

    nahid
    http://nahidulkibria.blogspot.com/
    http://www.kaz.com.bd
     
    Juan T. Llibre, Jul 13, 2007
    #6
  7. I already have in my web config file <compilation defaultLanguage="vb"
    debug="true"/>
    and I am getting this message if the debug is set to true or false in the
    web.config file.



    "Juan T. Llibre" <> wrote in message
    news:%...
    > re:
    > !> well so what is basically main problem, say i'm not prefer set
    > !> <compilation debug="true" /> because of loss some performance
    >
    > True enough, but to resolve the *current* problem ( that the app won't
    > run ),
    > the solution is get get the app working *first* and then *later* we worry
    > about performance.
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "nahid" <> wrote in message
    > news:...
    > On Jul 14, 12:53 am, "Juan T. Llibre" <>
    > wrote:
    >> re:
    >> !> he try build in release mode better set
    >> !> <compilation debug="false" />
    >>
    >> No. He said that when :
    >>
    >> !> I change the build configuration to release
    >>
    >> ...the error occurs, therefore setting it to debug="true" should fix it.
    >>
    >> Your suggestion, debug="false", is the same as setting the application
    >> to release mode, so he would likely continue to get the same error as
    >> whenhe manually sets it to "release" mode.
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq :http://asp.net.do/faq/
    >> foros de asp.net, en español :http://asp.net.do/foros/
    >> ======================================"nahid" <> wrote
    >> in messagenews:...
    >>
    >> On Jul 14, 12:20 am, "Juan T. Llibre" <>
    >> wrote:
    >>
    >>
    >>
    >>
    >>
    >> > Just add this entry to the web.config file :

    >>
    >> > <compilation debug="true" />

    >>
    >> > Juan T. Llibre, asp.net MVP
    >> > asp.net faq :http://asp.net.do/faq/
    >> > foros de asp.net, en español :http://asp.net.do/foros/
    >> > ======================================

    >>
    >> > "news.microsoft.com" <> wrote in
    >> > messagenews:...
    >> > >I have an asp.net 2.0 project that when I change the build
    >> > >configuration to release I get the following error:

    >>
    >> > > Command line error BC2014: the value 'None' is invalid for option
    >> > > 'debug'.

    >>
    >> > > If I go into the projects Advanced Compile Options and change the
    >> > > Generate Debug Info dropdown from None to PDB-Only
    >> > > the error goes away. Can anyone explain why I have to do this and
    >> > > what can I do to get the one option to work on a
    >> > > asp.net project? It is causing problems because the common project
    >> > > is shared with a VB project that gets an error
    >> > > on
    >> > > release mode compile if it is set to pdb-only.

    >>
    >> > > Thanks for your help.- Hide quoted text -

    >>
    >> > - Show quoted text -

    >>
    >> hai,
    >> he try build in release mode better set
    >> <compilation debug="false" />
    >>
    >> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted
    >> text -
    >>
    >> - Show quoted text -

    >
    > well so what is basically main problem, say i'm not prefer set
    > <compilation debug="true" /> because of loss some performance
    >
    > nahid
    > http://nahidulkibria.blogspot.com/
    > http://www.kaz.com.bd
    >
    >
     
    news.microsoft.com, Jul 13, 2007
    #7
  8. I already have in my web config file <compilation defaultLanguage="vb"
    debug="true"/>
    and I am getting this message if the debug is set to true or false in the
    web.config file if I am trying to compile in release mode with the Generate
    Debug Info dropdown set to None. If I change the Generate Debug Info
    dropdown set to PDB-Only or Full then the project compiles fine reguardless
    of release or debug mode. I hope this clarifies the problem I am having.


    "news.microsoft.com" <> wrote in message
    news:OdSO1$...
    >I already have in my web config file <compilation defaultLanguage="vb"
    >debug="true"/>
    > and I am getting this message if the debug is set to true or false in the
    > web.config file.
    >
    >
    >
    > "Juan T. Llibre" <> wrote in message
    > news:%...
    >> re:
    >> !> well so what is basically main problem, say i'm not prefer set
    >> !> <compilation debug="true" /> because of loss some performance
    >>
    >> True enough, but to resolve the *current* problem ( that the app won't
    >> run ),
    >> the solution is get get the app working *first* and then *later* we worry
    >> about performance.
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ======================================
    >> "nahid" <> wrote in message
    >> news:...
    >> On Jul 14, 12:53 am, "Juan T. Llibre" <>
    >> wrote:
    >>> re:
    >>> !> he try build in release mode better set
    >>> !> <compilation debug="false" />
    >>>
    >>> No. He said that when :
    >>>
    >>> !> I change the build configuration to release
    >>>
    >>> ...the error occurs, therefore setting it to debug="true" should fix it.
    >>>
    >>> Your suggestion, debug="false", is the same as setting the application
    >>> to release mode, so he would likely continue to get the same error as
    >>> whenhe manually sets it to "release" mode.
    >>>
    >>> Juan T. Llibre, asp.net MVP
    >>> asp.net faq :http://asp.net.do/faq/
    >>> foros de asp.net, en español :http://asp.net.do/foros/
    >>> ======================================"nahid" <> wrote
    >>> in messagenews:...
    >>>
    >>> On Jul 14, 12:20 am, "Juan T. Llibre" <>
    >>> wrote:
    >>>
    >>>
    >>>
    >>>
    >>>
    >>> > Just add this entry to the web.config file :
    >>>
    >>> > <compilation debug="true" />
    >>>
    >>> > Juan T. Llibre, asp.net MVP
    >>> > asp.net faq :http://asp.net.do/faq/
    >>> > foros de asp.net, en español :http://asp.net.do/foros/
    >>> > ======================================
    >>>
    >>> > "news.microsoft.com" <> wrote in
    >>> > messagenews:...
    >>> > >I have an asp.net 2.0 project that when I change the build
    >>> > >configuration to release I get the following error:
    >>>
    >>> > > Command line error BC2014: the value 'None' is invalid for option
    >>> > > 'debug'.
    >>>
    >>> > > If I go into the projects Advanced Compile Options and change the
    >>> > > Generate Debug Info dropdown from None to PDB-Only
    >>> > > the error goes away. Can anyone explain why I have to do this and
    >>> > > what can I do to get the one option to work on a
    >>> > > asp.net project? It is causing problems because the common project
    >>> > > is shared with a VB project that gets an error
    >>> > > on
    >>> > > release mode compile if it is set to pdb-only.
    >>>
    >>> > > Thanks for your help.- Hide quoted text -
    >>>
    >>> > - Show quoted text -
    >>>
    >>> hai,
    >>> he try build in release mode better set
    >>> <compilation debug="false" />
    >>>
    >>> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide
    >>> quoted text -
    >>>
    >>> - Show quoted text -

    >>
    >> well so what is basically main problem, say i'm not prefer set
    >> <compilation debug="true" /> because of loss some performance
    >>
    >> nahid
    >> http://nahidulkibria.blogspot.com/
    >> http://www.kaz.com.bd
    >>
    >>

    >
    >
     
    news.microsoft.com, Jul 13, 2007
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dave
    Replies:
    0
    Views:
    645
  2. =?Utf-8?B?TWF4?=
    Replies:
    0
    Views:
    467
    =?Utf-8?B?TWF4?=
    Feb 11, 2006
  3. rbg
    Replies:
    0
    Views:
    430
  4. Steve Mauldin
    Replies:
    0
    Views:
    540
    Steve Mauldin
    Jul 31, 2007
  5. sujeet
    Replies:
    5
    Views:
    577
    Bart van Ingen Schenau
    Sep 16, 2007
Loading...

Share This Page