Removing traces of System.Web.Extensions.dll 3.5

Discussion in 'ASP .Net' started by Adam Salisbury, Aug 21, 2008.

  1. **To members of microsoft.public.dotnet.framework, apologies for the
    crosspost. I originally posted this message into that group however
    have since realised this may have been a better destination**

    Hi all,

    Wondering if anyone can help me out with an assemblies problem I'm
    having.


    I've got a .net 2.0 web application using AJAX 1 created with VS2005.
    I also had VS2008 & .net 3.5 installed. I have since taken off
    2008/3.5 and have started getting the error below when accessing one
    of my pages...


    Could not load file or assembly 'System.Web.Extensions,
    Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or
    one of its dependencies. The located assembly's manifest definition
    does not match the assembly reference. (Exception from HRESULT:
    0x80131040)


    === Pre-bind state information ===
    LOG: User = Unknown
    LOG: DisplayName = System.Web.Extensions, Version=3.5.0.0,
    Culture=neutral, PublicKeyToken=31bf3856ad364e35
    (Fully-specified)
    LOG: Appbase = file:///C:/Repository/APS/Client/Web/
    LOG: Initial PrivatePath = C:\Repository\AMP\Client\Rio\Web\bin
    Calling assembly : APS.Client.Web.HomeScreen, Version=6.0.0.332,
    Culture=neutral, PublicKeyToken=1916d4122ec2e2e8.
    ===
    LOG: This bind starts in default load context.
    LOG: Using application configuration file: C:\Repository\AMP\Client
    \Rio
    \Web\web.config
    LOG: Using host configuration file: C:\WINDOWS\Microsoft.NET
    \Framework
    \v2.0.50727\aspnet.config
    LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET
    \Framework\v2.0.50727\config\machine.config.
    LOG: Post-policy reference: System.Web.Extensions, Version=3.5.0.0,
    Culture=neutral, PublicKeyToken=31bf3856ad364e35
    LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary
    ASP.NET Files/rio/424e24e9/2a74040f/System.Web.Extensions.DLL.
    LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary
    ASP.NET Files/rio/424e24e9/2a74040f/System.Web.Extensions/
    System.Web.Extensions.DLL.
    LOG: Attempting download of new URL
    file:///C:/Repository/AMP/Client/Rio/Web/bin/System.Web.Extensions.DLL.
    WRN: Comparing the assembly name resulted in the mismatch: Major
    Version
    ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing
    terminated.


    My project references System.Web.Extensions v1.0.61025.0 and as far
    as
    I can see have absoluetly no references to the v3.5 incarnation of
    System.Web.Extensions however it refuses to use v1, no matter how
    many
    times I readd the reference, set "Specifc Type" property to true etc.


    Before I removed 3.5 I was getting this error...


    Parser Error Message: The base class includes the field
    'ScriptManager2', but its type (System.Web.UI.ScriptManager) is not
    compatible with the type of control (System.Web.UI.ScriptManager).
    Line 62: <form id="form1" runat="server">
    Line 63: <div style="text-align: center; width:100%;">
    Line 64: <asp:ScriptManager ID="ScriptManager2"
    runat="server">
    Line 65: </asp:ScriptManager>
    Line 66: <div class="ControlBox" style="text-align:
    center; ">


    ....I had checked my project to make sure that I was referencing 1.0.6
    but upon compiling it appears it decided to use 3.5 regardless, so I
    assumed that removing 3.5 all together would give it no option but to
    use 1.0.6, however as you can see it is still trying to find 3.5.


    I've scanned by system for the 3.5 version of the DLL and can not
    find
    it anywhere, the closes I can see it a native image file in the GAC.


    Does anyone have any ideas as to where the requirement for the 3.5
    DLL
    is coming from or how to get rid of it. As I said before I'm sure it
    isn't from my project (very sure because the project was created on a
    serperate machine with no 3.5).


    Any thoughts/help would be greately appriciated...


    Thanks
    Adam


    PS I've already tried clearing my temp ASP.Net files.
    Adam Salisbury, Aug 21, 2008
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Michael Borgwardt

    Re: Unknown source in Exception traces

    Michael Borgwardt, Sep 16, 2003, in forum: Java
    Replies:
    1
    Views:
    425
    Lordy
    Sep 16, 2003
  2. otf
    Replies:
    5
    Views:
    3,728
    Roedy Green
    Nov 29, 2005
  3. Twisted
    Replies:
    1
    Views:
    1,048
    Twisted
    Feb 24, 2006
  4. Derek Fountain

    Tcl style traces

    Derek Fountain, Jan 28, 2004, in forum: Python
    Replies:
    8
    Views:
    348
    Cameron Laird
    Jan 28, 2004
  5. David Bailey
    Replies:
    0
    Views:
    137
    David Bailey
    Mar 7, 2006
Loading...

Share This Page