Ruby 1.9 binary on ruby-lang.org not built with zlib?

Discussion in 'Ruby' started by Lee Griffiths, Nov 24, 2008.

  1. Hello Ruby fans.
    The binary 1.9 package that's foudn on the ruby website doesn't seem to
    either a) contain zlib.dll or b) have it statically linked in. This
    causes problems when trying to run gem.

    I personally solved this by just installing my 1.9 over my old 1.8 and
    copying zlib1.dll to zlib.dll (found in ./bin).

    Is this intended or an oversight? I imagine it'd stump people who go
    straight for the 1.9 download...
    --
    Posted via http://www.ruby-forum.com/.
     
    Lee Griffiths, Nov 24, 2008
    #1
    1. Advertising

  2. Lee Griffiths

    Roger Pack Guest

    > Is this intended or an oversight? I imagine it'd stump people who go
    > straight for the 1.9 download...


    I'd ask core :)
    -=R
    --
    Posted via http://www.ruby-forum.com/.
     
    Roger Pack, Nov 25, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Brett
    Replies:
    4
    Views:
    1,189
    Matthew Brett
    May 9, 2010
  2. Daniel Berger
    Replies:
    5
    Views:
    271
    Roger Pack
    Jun 21, 2009
  3. Nicholas Wieland

    Most simple usage of zlib or pr-zlib

    Nicholas Wieland, Mar 9, 2011, in forum: Ruby
    Replies:
    4
    Views:
    355
    Jeremy Bopp
    Mar 10, 2011
  4. PerlFAQ Server
    Replies:
    0
    Views:
    735
    PerlFAQ Server
    Feb 3, 2011
  5. PerlFAQ Server
    Replies:
    0
    Views:
    742
    PerlFAQ Server
    Apr 4, 2011
Loading...

Share This Page