Ruby 1.9 build requirements

Discussion in 'Ruby' started by tirins.play, Aug 29, 2009.

  1. tirins.play

    tirins.play Guest

    I have just installed Ubuntu 9.04 Server Edition. I followed the
    instructions on the Ubuntu site to build Ruby 1.9
    (p243) from scratch. The build appeared to work, but gem installs
    complain about missing zlib.

    I have found a number of sites that list the prerequisite packages,
    but there is some amount of disagreement about what needs to be
    installed prior to making Ruby 1.9. Does anyone have a definitive list
    of prerequisite packages?

    Thanks for your help.
     
    tirins.play, Aug 29, 2009
    #1
    1. Advertising

  2. http://wiki.rubyonrails.org/getting-started/installation/linux

    On Sun, Aug 30, 2009 at 12:55 AM, tirins.play<> wrote:
    > I have just installed Ubuntu 9.04 Server Edition. I followed the
    > instructions on the Ubuntu site to build Ruby 1.9
    > (p243) from scratch. The build appeared to work, but gem installs
    > complain about missing zlib.
    >
    > I have found a number of sites that list the prerequisite packages,
    > but there is some amount of disagreement about what needs to be
    > installed prior to making Ruby 1.9. Does anyone have a definitive list
    > of prerequisite packages?
    >
    > Thanks for your help.
    >
    >




    --
    -----
    Kenji Yamauchi
     
    Kenji Yamauchi, Aug 30, 2009
    #2
    1. Advertising

  3. tirins.play

    Tom Cloyd Guest

    Kenji Yamauchi wrote:
    > http://wiki.rubyonrails.org/getting-started/installation/linux
    >
    > On Sun, Aug 30, 2009 at 12:55 AM, tirins.play<> wrote:
    >
    >> I have just installed Ubuntu 9.04 Server Edition. I followed the
    >> instructions on the Ubuntu site to build Ruby 1.9
    >> (p243) from scratch. The build appeared to work, but gem installs
    >> complain about missing zlib.
    >>
    >> I have found a number of sites that list the prerequisite packages,
    >> but there is some amount of disagreement about what needs to be
    >> installed prior to making Ruby 1.9. Does anyone have a definitive list
    >> of prerequisite packages?
    >>
    >> Thanks for your help
    >>
    >>
    >>

    Having problems - I have installed the prequisites, and unzipped the
    source package for ruby-1.9.1-p243, and I'm . I've installed from source
    before, but not ruby 1.9. I cannot get beyond this:


    > tomc@tomc-desktop:~/software_archive/ruby-1.9.1/ruby-1.9.1-p243$
    > ./configure --prefix=/usr/local --with-openssl-dir=/usr
    > --with-readline-dir=/usr --with-zlib-dir=/usr
    > bash: ./configure: Permission denied
    > tomc@tomc-desktop:~/software_archive/ruby-1.9.1/ruby-1.9.1-p243$ sudo
    > ./configure --prefix=/usr/local --with-openssl-dir=/usr
    > --with-readline-dir=/usr --with-zlib-dir=/usr
    > sudo: ./configure: command not found

    I really don't understand enough what I'm doing to see the problem.

    Can someone help me?

    Tks,

    Tom

    --

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
    Bellingham, Washington, U.S.A: (360) 920-1226
    << >> (email)
    << TomCloyd.com >> (website)
    << sleightmind.wordpress.com >> (mental health weblog)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
    Tom Cloyd, Aug 31, 2009
    #3
  4. tirins.play

    Tom Cloyd Guest

    Kenji Yamauchi wrote:
    > http://wiki.rubyonrails.org/getting-started/installation/linux
    >
    > On Sun, Aug 30, 2009 at 12:55 AM, tirins.play<> wrote:
    >
    >> I have just installed Ubuntu 9.04 Server Edition. I followed the
    >> instructions on the Ubuntu site to build Ruby 1.9
    >> (p243) from scratch. The build appeared to work, but gem installs
    >> complain about missing zlib.
    >>
    >> I have found a number of sites that list the prerequisite packages,
    >> but there is some amount of disagreement about what needs to be
    >> installed prior to making Ruby 1.9. Does anyone have a definitive list
    >> of prerequisite packages?
    >>
    >> Thanks for your help.
    >>
    >>
    >>

    >
    >
    >
    >

    Re: previous email and my problems with ./configure - !@#$##@!

    I just cannot remember to make that thing EXECUTABLE. Does make a
    difference. Sigh.

    Sorry for the stumble.

    t.

    --

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
    Bellingham, Washington, U.S.A: (360) 920-1226
    << >> (email)
    << TomCloyd.com >> (website)
    << sleightmind.wordpress.com >> (mental health weblog)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
    Tom Cloyd, Aug 31, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Vagif Abilov
    Replies:
    2
    Views:
    599
    Vagif Abilov
    Jul 7, 2004
  2. Pavel Arno¹t

    ruby+webrick memory requirements

    Pavel Arno¹t, Feb 2, 2004, in forum: Ruby
    Replies:
    0
    Views:
    138
    Pavel Arno¹t
    Feb 2, 2004
  3. Brian Candler
    Replies:
    1
    Views:
    231
    Brian Candler
    Oct 21, 2004
  4. Markus Kolb
    Replies:
    3
    Views:
    222
    Markus Kolb
    Apr 2, 2006
  5. Alexandru Popescu

    additional requirements for a Ruby env

    Alexandru Popescu, Jul 16, 2006, in forum: Ruby
    Replies:
    16
    Views:
    204
    Austin Ziegler
    Jul 19, 2006
Loading...

Share This Page