SBS2003 and ASP.net

Discussion in 'ASP .Net' started by =?Utf-8?B?U3Vic3RhbmRhcmRTbm93bWFu?=, Sep 9, 2004.

  1. When I'm trying to deploy an ASP.Net app to Small Business Server 2003 I
    can't allow the ASPNET user access to the directory because it isn't found in
    active directory. I have run aspnet_regiis.exe -i and it does not add the
    user. I have other sites on this server that are running ASP.Net apps without
    a problem. How do I fix this?
    =?Utf-8?B?U3Vic3RhbmRhcmRTbm93bWFu?=, Sep 9, 2004
    #1
    1. Advertising

  2. I also have an ASP.NET application running on SBS2003. Seems ASPNET account
    access setting is not required at all.
    I just copy the access right settings from another ADs running ASP.NET
    application and it works fine.

    "SubstandardSnowman" <> ¦b¶l¥ó
    news: ¤¤¼¶¼g...
    > When I'm trying to deploy an ASP.Net app to Small Business Server 2003 I
    > can't allow the ASPNET user access to the directory because it isn't found

    in
    > active directory. I have run aspnet_regiis.exe -i and it does not add the
    > user. I have other sites on this server that are running ASP.Net apps

    without
    > a problem. How do I fix this?
    Lau Lei Cheong, Sep 9, 2004
    #2
    1. Advertising

  3. It looks like you're right. After reading your response I finally found this
    article
    http://support.microsoft.com/default.aspx?kbid=316721
    it says that on Windows 2003 (and SBS 2003) You don't use the aspnet account
    but you use the Network Service account. Once I allowed that account read &
    execute, list, and read rights it started working.
    Thanks for your help.

    "Lau Lei Cheong" wrote:

    > I also have an ASP.NET application running on SBS2003. Seems ASPNET account
    > access setting is not required at all.
    > I just copy the access right settings from another ADs running ASP.NET
    > application and it works fine.
    >
    > "SubstandardSnowman" <> ¦b¶l¥ó
    > news: ¤¤¼¶¼g...
    > > When I'm trying to deploy an ASP.Net app to Small Business Server 2003 I
    > > can't allow the ASPNET user access to the directory because it isn't found

    > in
    > > active directory. I have run aspnet_regiis.exe -i and it does not add the
    > > user. I have other sites on this server that are running ASP.Net apps

    > without
    > > a problem. How do I fix this?

    >
    >
    >
    =?Utf-8?B?U3Vic3RhbmRhcmRTbm93bWFu?=, Sep 9, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tobias Redelberger

    Customize RWW in SBS2003

    Tobias Redelberger, May 13, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    793
    Tobias Redelberger
    May 13, 2004
  2. Tony Girgenti
    Replies:
    2
    Views:
    614
    Morten Wennevik
    Sep 15, 2006
  3. Tony Girgenti

    How to install ASP.NET Web Application on SBS2003 server

    Tony Girgenti, Sep 14, 2006, in forum: ASP .Net Security
    Replies:
    1
    Views:
    111
    Morten Wennevik
    Sep 15, 2006
  4. Tony Girgenti

    How to install ASP.NET Web Application on SBS2003 server

    Tony Girgenti, Sep 14, 2006, in forum: ASP .Net Web Services
    Replies:
    1
    Views:
    156
    Morten Wennevik
    Sep 15, 2006
  5. Tony Girgenti
    Replies:
    1
    Views:
    117
    Morten Wennevik
    Sep 15, 2006
Loading...

Share This Page