Script Timeout Not working

Discussion in 'ASP .Net' started by Prad Bok via .NET 247, Mar 30, 2005.

  1. (Type your message here)

    --------------------------------
    From: Prad Bok

    I have a web page that takes long time(more than 3 minutes) tofinish.
    I am running IIS6 on windows 2003 server.

    I have tried all the following but they are not working. Sameapplication works fine on Windows 2000.

    1. Server.ScriptTimeout = 1200; in the ASPX page
    2. Web.config : <httpRuntime executionTimeout="1200"maxRequestLength="4096" useFullyQualifiedRedirectUrl="false"minFreeThreads="8" minLocalRequestFreeThreads="4"appRequestQueueLimit="100" />
    3. Mechine.config : <processModel enable="true"timeout="Infinite" idleTimeout="Infinite"shutdownTimeout="0:00:05" requestLimit="Infinite"requestQueueLimit="5000" restartQueueLimit="10" memoryLimit="60"webGarden="false" cpuMask="0xffffffff" userName="machine"password="AutoGenerate" logLevel="Errors"clientConnectedCheck="0:00:05" comAuthenticationLevel="Connect"comImpersonationLevel="Impersonate"responseDeadlockInterval="00:23:00" maxWorkerThreads="20"maxIoThreads="20"/>
    4. I have also modified IIS vitual directory setting to reflectASP Script time to 1200

    -----------------------
    Posted by a user from .NET 247 (http://www.dotnet247.com/)

    <Id>AdN9iaWtYUuU3BhF6NTFvQ==</Id>
     
    Prad Bok via .NET 247, Mar 30, 2005
    #1
    1. Advertising

  2. Prad,

    Are you accessing a database on this page? There is a connection timeout
    associated with that as well. What is the actual error you are receiving?

    Ian Suttle
    http://www.IanSuttle.com

    "Prad Bok via .NET 247" wrote:

    > (Type your message here)
    >
    > --------------------------------
    > From: Prad Bok
    >
    > I have a web page that takes long time(more than 3 minutes) to finish.
    > I am running IIS6 on windows 2003 server.
    >
    > I have tried all the following but they are not working. Same application works fine on Windows 2000.
    >
    > 1. Server.ScriptTimeout = 1200; in the ASPX page
    > 2. Web.config : <httpRuntime executionTimeout="1200" maxRequestLength="4096" useFullyQualifiedRedirectUrl="false" minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100" />
    > 3. Mechine.config : <processModel enable="true" timeout="Infinite" idleTimeout="Infinite" shutdownTimeout="0:00:05" requestLimit="Infinite" requestQueueLimit="5000" restartQueueLimit="10" memoryLimit="60" webGarden="false" cpuMask="0xffffffff" userName="machine" password="AutoGenerate" logLevel="Errors" clientConnectedCheck="0:00:05" comAuthenticationLevel="Connect" comImpersonationLevel="Impersonate" responseDeadlockInterval="00:23:00" maxWorkerThreads="20" maxIoThreads="20"/>
    > 4. I have also modified IIS vitual directory setting to reflect ASP Script time to 1200
    >
    > -----------------------
    > Posted by a user from .NET 247 (http://www.dotnet247.com/)
    >
    > <Id>AdN9iaWtYUuU3BhF6NTFvQ==</Id>
    >
     
    =?Utf-8?B?SWFuIFN1dHRsZQ==?=, Mar 30, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Bob Johnson
    Replies:
    0
    Views:
    3,825
    Bob Johnson
    Aug 7, 2003
  2. Do
    Replies:
    2
    Views:
    6,452
  3. Guoqi Zheng
    Replies:
    4
    Views:
    13,124
    Guoqi Zheng
    Jun 3, 2004
  4. Mark Probert

    Timeout::timeout and Socket timeout

    Mark Probert, Oct 6, 2004, in forum: Ruby
    Replies:
    1
    Views:
    1,362
    Brian Candler
    Oct 6, 2004
  5. lawrence
    Replies:
    8
    Views:
    265
    lawrence
    May 5, 2004
Loading...

Share This Page