Server Application unavailable error

Discussion in 'ASP .Net' started by =?Utf-8?B?RGF2ZQ==?=, May 18, 2007.

  1. I have set up a virtual directory using IIS. Whenever, I load a web page of
    type .htm, I have no problem. Whenever I run a .aspx page I get the statement
    below. I am running on XP Pro, both Microsoft .Net 1.1 & 2.0 installed. How
    do I remedy this error?

    //Error below

    Server Application Unavailable

    The web application you are attempting to access on this web server is
    currently unavailable. Please hit the "Refresh" button in your web browser
    to retry your request.

    Administrator Note: An error message detailing the cause of this specific
    request failure can be found in the application event log of the web server.
    Please review this log entry to discover what caused this error to occur
    --
    L. A. Jones
    =?Utf-8?B?RGF2ZQ==?=, May 18, 2007
    #1
    1. Advertising

  2. re:
    !> Administrator Note: An error message detailing the cause of this specific
    !> request failure can be found in the application event log of the web server.
    !> Please review this log entry to discover what caused this error to occur

    What does the application event log entry state ?



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Dave" <> wrote in message
    news:...
    >I have set up a virtual directory using IIS. Whenever, I load a web page of
    > type .htm, I have no problem. Whenever I run a .aspx page I get the statement
    > below. I am running on XP Pro, both Microsoft .Net 1.1 & 2.0 installed. How
    > do I remedy this error?
    >
    > //Error below
    >
    > Server Application Unavailable
    >
    > The web application you are attempting to access on this web server is
    > currently unavailable. Please hit the "Refresh" button in your web browser
    > to retry your request.
    >
    > Administrator Note: An error message detailing the cause of this specific
    > request failure can be found in the application event log of the web server.
    > Please review this log entry to discover what caused this error to occur
    > --
    > L. A. Jones
    Juan T. Llibre, May 18, 2007
    #2
    1. Advertising

  3. Warning message:
    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: None
    Event ID: 1073
    Date: 18/05/2007
    Time: 05:19:46 PM
    User: N/A
    Computer: LJONES
    Description:
    Failed to initialize the AppDomain:/LM/W3SVC/1/Root/webRetail

    Exception: System.IO.FileLoadException
    Message: Could not load file or assembly 'System.Web, Version=2.0.0.0,
    Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
    Access is denied.
    StackTrace: at System.Reflection.Assembly.nLoad(AssemblyName fileName,
    String codeBase, Evidence assemblySecurity, Assembly locationHint,
    StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean
    forIntrospection)
    at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef,
    Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean
    forIntrospection)
    at System.Reflection.Assembly.InternalLoad(String assemblyString,
    Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean
    forIntrospection)
    at System.Activator.CreateInstance(String assemblyName, String typeName,
    Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args,
    CultureInfo culture, Object[] activationAttributes, Evidence securityInfo,
    StackCrawlMark& stackMark)
    at System.Activator.CreateInstance(String assemblyName, String typeName)
    at System.AppDomain.CreateInstance(String assemblyName, String typeName)
    at System.AppDomain.CreateInstance(String assemblyName, String typeName)
    at
    System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String
    appId, IApplicationHost appHost, HostingEnvironmentParameters
    hostingParameters)
    at
    System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String
    appId, IApplicationHost appHost, HostingEnvironmentParameters
    hostingParameters)

    Error 1:
    Event Type: Error
    Event Source: ASP.NET 2.0.50727.0
    Event Category: None
    Event ID: 1089
    Date: 18/05/2007
    Time: 05:19:46 PM
    User: N/A
    Computer: LJONES
    Description:
    Failed to execute the request because the ASP.NET process identity does not
    have read permissions to the global assembly cache. Error: 0x80070005 Access
    is denied.

    Error 2:
    Event Type: Error
    Event Source: ASP.NET 2.0.50727.0
    Event Category: None
    Event ID: 1000
    Date: 18/05/2007
    Time: 05:19:46 PM
    User: N/A
    Computer: LJONES
    Description:
    aspnet_wp.exe (PID: 4800) stopped unexpectedly.



    --
    L. A. Jones


    "Juan T. Llibre" wrote:

    > re:
    > !> Administrator Note: An error message detailing the cause of this specific
    > !> request failure can be found in the application event log of the web server.
    > !> Please review this log entry to discover what caused this error to occur
    >
    > What does the application event log entry state ?
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Dave" <> wrote in message
    > news:...
    > >I have set up a virtual directory using IIS. Whenever, I load a web page of
    > > type .htm, I have no problem. Whenever I run a .aspx page I get the statement
    > > below. I am running on XP Pro, both Microsoft .Net 1.1 & 2.0 installed. How
    > > do I remedy this error?
    > >
    > > //Error below
    > >
    > > Server Application Unavailable
    > >
    > > The web application you are attempting to access on this web server is
    > > currently unavailable. Please hit the "Refresh" button in your web browser
    > > to retry your request.
    > >
    > > Administrator Note: An error message detailing the cause of this specific
    > > request failure can be found in the application event log of the web server.
    > > Please review this log entry to discover what caused this error to occur
    > > --
    > > L. A. Jones

    >
    >
    >
    =?Utf-8?B?RGF2ZQ==?=, May 19, 2007
    #3
  4. The critical part of the error message is this :

    !> Failed to execute the request because the ASP.NET process identity
    !> does not have read permissions to the global assembly cache.

    Are you impersonating the ASP.NET identity ?

    You are running on XP.
    XP's default ASP.NET identity is the ASPNET account.

    run :

    aspnet_regiis -ga machinename\aspnet
    ( substitute *your* machine's name for "machinename"... )

    ....from a command window in the .Net Framework 2.0 directory :
    Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

    I'm not sure if you can get away with running just :

    aspnet_regiis -ga aspnet

    That should get you up and running again.



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Dave" <> wrote in message
    news:...
    > Warning message:
    > Event Type: Warning
    > Event Source: ASP.NET 2.0.50727.0
    > Event Category: None
    > Event ID: 1073
    > Date: 18/05/2007
    > Time: 05:19:46 PM
    > User: N/A
    > Computer: LJONES
    > Description:
    > Failed to initialize the AppDomain:/LM/W3SVC/1/Root/webRetail
    >
    > Exception: System.IO.FileLoadException
    > Message: Could not load file or assembly 'System.Web, Version=2.0.0.0,
    > Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
    > Access is denied.
    > StackTrace: at System.Reflection.Assembly.nLoad(AssemblyName fileName,
    > String codeBase, Evidence assemblySecurity, Assembly locationHint,
    > StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean
    > forIntrospection)
    > at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef,
    > Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean
    > forIntrospection)
    > at System.Reflection.Assembly.InternalLoad(String assemblyString,
    > Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean
    > forIntrospection)
    > at System.Activator.CreateInstance(String assemblyName, String typeName,
    > Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args,
    > CultureInfo culture, Object[] activationAttributes, Evidence securityInfo,
    > StackCrawlMark& stackMark)
    > at System.Activator.CreateInstance(String assemblyName, String typeName)
    > at System.AppDomain.CreateInstance(String assemblyName, String typeName)
    > at System.AppDomain.CreateInstance(String assemblyName, String typeName)
    > at
    > System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String
    > appId, IApplicationHost appHost, HostingEnvironmentParameters
    > hostingParameters)
    > at
    > System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String
    > appId, IApplicationHost appHost, HostingEnvironmentParameters
    > hostingParameters)
    >
    > Error 1:
    > Event Type: Error
    > Event Source: ASP.NET 2.0.50727.0
    > Event Category: None
    > Event ID: 1089
    > Date: 18/05/2007
    > Time: 05:19:46 PM
    > User: N/A
    > Computer: LJONES
    > Description:
    > Failed to execute the request because the ASP.NET process identity does not
    > have read permissions to the global assembly cache. Error: 0x80070005 Access
    > is denied.
    >
    > Error 2:
    > Event Type: Error
    > Event Source: ASP.NET 2.0.50727.0
    > Event Category: None
    > Event ID: 1000
    > Date: 18/05/2007
    > Time: 05:19:46 PM
    > User: N/A
    > Computer: LJONES
    > Description:
    > aspnet_wp.exe (PID: 4800) stopped unexpectedly.
    >
    >
    >
    > --
    > L. A. Jones
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> re:
    >> !> Administrator Note: An error message detailing the cause of this specific
    >> !> request failure can be found in the application event log of the web server.
    >> !> Please review this log entry to discover what caused this error to occur
    >>
    >> What does the application event log entry state ?
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ======================================
    >> "Dave" <> wrote in message
    >> news:...
    >> >I have set up a virtual directory using IIS. Whenever, I load a web page of
    >> > type .htm, I have no problem. Whenever I run a .aspx page I get the statement
    >> > below. I am running on XP Pro, both Microsoft .Net 1.1 & 2.0 installed. How
    >> > do I remedy this error?
    >> >
    >> > //Error below
    >> >
    >> > Server Application Unavailable
    >> >
    >> > The web application you are attempting to access on this web server is
    >> > currently unavailable. Please hit the "Refresh" button in your web browser
    >> > to retry your request.
    >> >
    >> > Administrator Note: An error message detailing the cause of this specific
    >> > request failure can be found in the application event log of the web server.
    >> > Please review this log entry to discover what caused this error to occur
    >> > --
    >> > L. A. Jones

    >>
    >>
    >>
    Juan T. Llibre, May 19, 2007
    #4
  5. I did all you told me to do and the problem persists. This is the error
    event log data. It seems the same as shown below.

    Event Type: Error
    Event Source: ASP.NET 2.0.50727.0
    Event Category: None
    Event ID: 1089
    Date: 18/05/2007
    Time: 07:57:37 PM
    User: N/A
    Computer: LJONES
    Description:
    Failed to execute the request because the ASP.NET process identity does not
    have read permissions to the global assembly cache. Error: 0x80070005 Access
    is denied.





    --
    L. A. Jones


    "Juan T. Llibre" wrote:

    > The critical part of the error message is this :
    >
    > !> Failed to execute the request because the ASP.NET process identity
    > !> does not have read permissions to the global assembly cache.
    >
    > Are you impersonating the ASP.NET identity ?
    >
    > You are running on XP.
    > XP's default ASP.NET identity is the ASPNET account.
    >
    > run :
    >
    > aspnet_regiis -ga machinename\aspnet
    > ( substitute *your* machine's name for "machinename"... )
    >
    > ....from a command window in the .Net Framework 2.0 directory :
    > Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    >
    > I'm not sure if you can get away with running just :
    >
    > aspnet_regiis -ga aspnet
    >
    >

    --
    L. A. Jones


    "Juan T. Llibre" wrote:

    > The critical part of the error message is this :
    >
    > !> Failed to execute the request because the ASP.NET process identity
    > !> does not have read permissions to the global assembly cache.
    >
    > Are you impersonating the ASP.NET identity ?
    >
    > You are running on XP.
    > XP's default ASP.NET identity is the ASPNET account.
    >
    > run :
    >
    > aspnet_regiis -ga machinename\aspnet
    > ( substitute *your* machine's name for "machinename"... )
    >
    > ....from a command window in the .Net Framework 2.0 directory :
    > Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    >
    > I'm not sure if you can get away with running just :
    >
    > aspnet_regiis -ga aspnet
    >
    > That should get you up and running again.
    >
    >
    >
    >
    =?Utf-8?B?RGF2ZQ==?=, May 19, 2007
    #5
  6. I suspect you fumbled the command which gives *any*
    account *all* the permissions ASP.NET needs to run.

    In spite of that, Try to give access permissions to
    the ASPNET account to the GAC directory itself.

    The GAC directory is Drive:\WINDOWS\assembly




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Dave" <> wrote in message
    news:D...
    > I did all you told me to do and the problem persists. This is the error
    > event log data. It seems the same as shown below.
    >
    > Event Type: Error
    > Event Source: ASP.NET 2.0.50727.0
    > Event Category: None
    > Event ID: 1089
    > Date: 18/05/2007
    > Time: 07:57:37 PM
    > User: N/A
    > Computer: LJONES
    > Description:
    > Failed to execute the request because the ASP.NET process identity does not
    > have read permissions to the global assembly cache. Error: 0x80070005 Access
    > is denied.
    >
    >
    >
    >
    >
    > --
    > L. A. Jones
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> The critical part of the error message is this :
    >>
    >> !> Failed to execute the request because the ASP.NET process identity
    >> !> does not have read permissions to the global assembly cache.
    >>
    >> Are you impersonating the ASP.NET identity ?
    >>
    >> You are running on XP.
    >> XP's default ASP.NET identity is the ASPNET account.
    >>
    >> run :
    >>
    >> aspnet_regiis -ga machinename\aspnet
    >> ( substitute *your* machine's name for "machinename"... )
    >>
    >> ....from a command window in the .Net Framework 2.0 directory :
    >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    >>
    >> I'm not sure if you can get away with running just :
    >>
    >> aspnet_regiis -ga aspnet
    >>
    >>

    > --
    > L. A. Jones
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> The critical part of the error message is this :
    >>
    >> !> Failed to execute the request because the ASP.NET process identity
    >> !> does not have read permissions to the global assembly cache.
    >>
    >> Are you impersonating the ASP.NET identity ?
    >>
    >> You are running on XP.
    >> XP's default ASP.NET identity is the ASPNET account.
    >>
    >> run :
    >>
    >> aspnet_regiis -ga machinename\aspnet
    >> ( substitute *your* machine's name for "machinename"... )
    >>
    >> ....from a command window in the .Net Framework 2.0 directory :
    >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    >>
    >> I'm not sure if you can get away with running just :
    >>
    >> aspnet_regiis -ga aspnet
    >>
    >> That should get you up and running again.
    >>
    >>
    >>
    >>
    Juan T. Llibre, May 19, 2007
    #6
  7. Not sure of the steps to this. Could you enumerate the steps. Thanks
    --
    L. A. Jones


    "Juan T. Llibre" wrote:

    > I suspect you fumbled the command which gives *any*
    > account *all* the permissions ASP.NET needs to run.
    >
    > In spite of that, Try to give access permissions to
    > the ASPNET account to the GAC directory itself.
    >
    > The GAC directory is Drive:\WINDOWS\assembly
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Dave" <> wrote in message
    > news:D...
    > > I did all you told me to do and the problem persists. This is the error
    > > event log data. It seems the same as shown below.
    > >
    > > Event Type: Error
    > > Event Source: ASP.NET 2.0.50727.0
    > > Event Category: None
    > > Event ID: 1089
    > > Date: 18/05/2007
    > > Time: 07:57:37 PM
    > > User: N/A
    > > Computer: LJONES
    > > Description:
    > > Failed to execute the request because the ASP.NET process identity does not
    > > have read permissions to the global assembly cache. Error: 0x80070005 Access
    > > is denied.
    > >
    > >
    > >
    > >
    > >
    > > --
    > > L. A. Jones
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> The critical part of the error message is this :
    > >>
    > >> !> Failed to execute the request because the ASP.NET process identity
    > >> !> does not have read permissions to the global assembly cache.
    > >>
    > >> Are you impersonating the ASP.NET identity ?
    > >>
    > >> You are running on XP.
    > >> XP's default ASP.NET identity is the ASPNET account.
    > >>
    > >> run :
    > >>
    > >> aspnet_regiis -ga machinename\aspnet
    > >> ( substitute *your* machine's name for "machinename"... )
    > >>
    > >> ....from a command window in the .Net Framework 2.0 directory :
    > >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    > >>
    > >> I'm not sure if you can get away with running just :
    > >>
    > >> aspnet_regiis -ga aspnet
    > >>
    > >>

    > > --
    > > L. A. Jones
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> The critical part of the error message is this :
    > >>
    > >> !> Failed to execute the request because the ASP.NET process identity
    > >> !> does not have read permissions to the global assembly cache.
    > >>
    > >> Are you impersonating the ASP.NET identity ?
    > >>
    > >> You are running on XP.
    > >> XP's default ASP.NET identity is the ASPNET account.
    > >>
    > >> run :
    > >>
    > >> aspnet_regiis -ga machinename\aspnet
    > >> ( substitute *your* machine's name for "machinename"... )
    > >>
    > >> ....from a command window in the .Net Framework 2.0 directory :
    > >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    > >>
    > >> I'm not sure if you can get away with running just :
    > >>
    > >> aspnet_regiis -ga aspnet
    > >>
    > >> That should get you up and running again.
    > >>
    > >>
    > >>
    > >>

    >
    >
    >
    =?Utf-8?B?RGF2ZQ==?=, May 19, 2007
    #7
  8. Hi,
    check out below link:
    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=135969&SiteID=1
    --
    Thanks and Regards.
    Manish Bafna.
    MCP and MCTS.



    "Dave" wrote:

    > Not sure of the steps to this. Could you enumerate the steps. Thanks
    > --
    > L. A. Jones
    >
    >
    > "Juan T. Llibre" wrote:
    >
    > > I suspect you fumbled the command which gives *any*
    > > account *all* the permissions ASP.NET needs to run.
    > >
    > > In spite of that, Try to give access permissions to
    > > the ASPNET account to the GAC directory itself.
    > >
    > > The GAC directory is Drive:\WINDOWS\assembly
    > >
    > >
    > >
    > >
    > > Juan T. Llibre, asp.net MVP
    > > asp.net faq : http://asp.net.do/faq/
    > > foros de asp.net, en español : http://asp.net.do/foros/
    > > ======================================
    > > "Dave" <> wrote in message
    > > news:D...
    > > > I did all you told me to do and the problem persists. This is the error
    > > > event log data. It seems the same as shown below.
    > > >
    > > > Event Type: Error
    > > > Event Source: ASP.NET 2.0.50727.0
    > > > Event Category: None
    > > > Event ID: 1089
    > > > Date: 18/05/2007
    > > > Time: 07:57:37 PM
    > > > User: N/A
    > > > Computer: LJONES
    > > > Description:
    > > > Failed to execute the request because the ASP.NET process identity does not
    > > > have read permissions to the global assembly cache. Error: 0x80070005 Access
    > > > is denied.
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > --
    > > > L. A. Jones
    > > >
    > > >
    > > > "Juan T. Llibre" wrote:
    > > >
    > > >> The critical part of the error message is this :
    > > >>
    > > >> !> Failed to execute the request because the ASP.NET process identity
    > > >> !> does not have read permissions to the global assembly cache.
    > > >>
    > > >> Are you impersonating the ASP.NET identity ?
    > > >>
    > > >> You are running on XP.
    > > >> XP's default ASP.NET identity is the ASPNET account.
    > > >>
    > > >> run :
    > > >>
    > > >> aspnet_regiis -ga machinename\aspnet
    > > >> ( substitute *your* machine's name for "machinename"... )
    > > >>
    > > >> ....from a command window in the .Net Framework 2.0 directory :
    > > >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    > > >>
    > > >> I'm not sure if you can get away with running just :
    > > >>
    > > >> aspnet_regiis -ga aspnet
    > > >>
    > > >>
    > > > --
    > > > L. A. Jones
    > > >
    > > >
    > > > "Juan T. Llibre" wrote:
    > > >
    > > >> The critical part of the error message is this :
    > > >>
    > > >> !> Failed to execute the request because the ASP.NET process identity
    > > >> !> does not have read permissions to the global assembly cache.
    > > >>
    > > >> Are you impersonating the ASP.NET identity ?
    > > >>
    > > >> You are running on XP.
    > > >> XP's default ASP.NET identity is the ASPNET account.
    > > >>
    > > >> run :
    > > >>
    > > >> aspnet_regiis -ga machinename\aspnet
    > > >> ( substitute *your* machine's name for "machinename"... )
    > > >>
    > > >> ....from a command window in the .Net Framework 2.0 directory :
    > > >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    > > >>
    > > >> I'm not sure if you can get away with running just :
    > > >>
    > > >> aspnet_regiis -ga aspnet
    > > >>
    > > >> That should get you up and running again.
    > > >>
    > > >>
    > > >>
    > > >>

    > >
    > >
    > >
    =?Utf-8?B?TWFuaXNoIEJhZm5h?=, May 19, 2007
    #8
  9. re
    !> Not sure of the steps to this. Could you enumerate the steps. Thanks

    The best way to approach this, since you can't set the access permissions
    to the GAC directly, is to annul and recreate the ASPNET account.

    To do that, run, from a command window in the .Net Framework directory:

    aspnet_regiis -u

    and, immediately after that, run :

    aspnet_regiis -i

    That will, first, annul the ASPNET account and, then, recreate it,
    assigning all necessary permissions to all the needed directories,
    including the GAC.





    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Dave" <> wrote in message
    news:...
    > Not sure of the steps to this. Could you enumerate the steps. Thanks
    > --
    > L. A. Jones
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> I suspect you fumbled the command which gives *any*
    >> account *all* the permissions ASP.NET needs to run.
    >>
    >> In spite of that, Try to give access permissions to
    >> the ASPNET account to the GAC directory itself.
    >>
    >> The GAC directory is Drive:\WINDOWS\assembly
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ======================================
    >> "Dave" <> wrote in message
    >> news:D...
    >> > I did all you told me to do and the problem persists. This is the error
    >> > event log data. It seems the same as shown below.


    >> > Failed to execute the request because the ASP.NET process identity does not
    >> > have read permissions to the global assembly cache. Error: 0x80070005 Access
    >> > is denied.


    >> >> You are running on XP.
    >> >> XP's default ASP.NET identity is the ASPNET account.
    >> >>
    >> >> run :
    >> >>
    >> >> aspnet_regiis -ga machinename\aspnet
    >> >> ( substitute *your* machine's name for "machinename"... )
    >> >>
    >> >> ....from a command window in the .Net Framework 2.0 directory :
    >> >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    >> >>
    >> >> I'm not sure if you can get away with running just :
    >> >>
    >> >> aspnet_regiis -ga aspnet
    >> >>
    >> >> That should get you up and running again.
    Juan T. Llibre, May 19, 2007
    #9
  10. Still does not help. I'm thinking of re-installing IIS, ASP. Net and Visual
    Studio.
    --
    L. A. Jones


    "Juan T. Llibre" wrote:

    > re
    > !> Not sure of the steps to this. Could you enumerate the steps. Thanks
    >
    > The best way to approach this, since you can't set the access permissions
    > to the GAC directly, is to annul and recreate the ASPNET account.
    >
    > To do that, run, from a command window in the .Net Framework directory:
    >
    > aspnet_regiis -u
    >
    > and, immediately after that, run :
    >
    > aspnet_regiis -i
    >
    > That will, first, annul the ASPNET account and, then, recreate it,
    > assigning all necessary permissions to all the needed directories,
    > including the GAC.
    >
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Dave" <> wrote in message
    > news:...
    > > Not sure of the steps to this. Could you enumerate the steps. Thanks
    > > --
    > > L. A. Jones
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> I suspect you fumbled the command which gives *any*
    > >> account *all* the permissions ASP.NET needs to run.
    > >>
    > >> In spite of that, Try to give access permissions to
    > >> the ASPNET account to the GAC directory itself.
    > >>
    > >> The GAC directory is Drive:\WINDOWS\assembly
    > >>
    > >>
    > >> Juan T. Llibre, asp.net MVP
    > >> asp.net faq : http://asp.net.do/faq/
    > >> foros de asp.net, en español : http://asp.net.do/foros/
    > >> ======================================
    > >> "Dave" <> wrote in message
    > >> news:D...
    > >> > I did all you told me to do and the problem persists. This is the error
    > >> > event log data. It seems the same as shown below.

    >
    > >> > Failed to execute the request because the ASP.NET process identity does not
    > >> > have read permissions to the global assembly cache. Error: 0x80070005 Access
    > >> > is denied.

    >
    > >> >> You are running on XP.
    > >> >> XP's default ASP.NET identity is the ASPNET account.
    > >> >>
    > >> >> run :
    > >> >>
    > >> >> aspnet_regiis -ga machinename\aspnet
    > >> >> ( substitute *your* machine's name for "machinename"... )
    > >> >>
    > >> >> ....from a command window in the .Net Framework 2.0 directory :
    > >> >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    > >> >>
    > >> >> I'm not sure if you can get away with running just :
    > >> >>
    > >> >> aspnet_regiis -ga aspnet
    > >> >>
    > >> >> That should get you up and running again.

    >
    >
    >
    =?Utf-8?B?RGF2ZQ==?=, May 19, 2007
    #10
  11. I am so, so so, ahhhhhh. What is wrong? I can't believe that I've spent the
    better part of 4 days trying to figure out this without success. If Apache
    could have done it I would have switched long ago. I've been using Apache and
    PHP for years and no problem to configure the web server. This is my first
    try at using ASP.Net. When I check the Internet, I see a plethora of
    questions about the same issue and there seem to be so many ad-hoc
    patches/solutions. The only thing I see on Microsoft site which resembles my
    problem, has to do with problems in ASP.Net 1.0 issues. I have not seen any
    solution to ASP.Net 2.0 problems. If I had not invested so time and effort in
    this I would toss all this .net technology aside.
    --
    L. A. Jones


    "Juan T. Llibre" wrote:

    > re
    > !> Not sure of the steps to this. Could you enumerate the steps. Thanks
    >
    > The best way to approach this, since you can't set the access permissions
    > to the GAC directly, is to annul and recreate the ASPNET account.
    >
    > To do that, run, from a command window in the .Net Framework directory:
    >
    > aspnet_regiis -u
    >
    > and, immediately after that, run :
    >
    > aspnet_regiis -i
    >
    > That will, first, annul the ASPNET account and, then, recreate it,
    > assigning all necessary permissions to all the needed directories,
    > including the GAC.
    >
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Dave" <> wrote in message
    > news:...
    > > Not sure of the steps to this. Could you enumerate the steps. Thanks
    > > --
    > > L. A. Jones
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> I suspect you fumbled the command which gives *any*
    > >> account *all* the permissions ASP.NET needs to run.
    > >>
    > >> In spite of that, Try to give access permissions to
    > >> the ASPNET account to the GAC directory itself.
    > >>
    > >> The GAC directory is Drive:\WINDOWS\assembly
    > >>
    > >>
    > >> Juan T. Llibre, asp.net MVP
    > >> asp.net faq : http://asp.net.do/faq/
    > >> foros de asp.net, en español : http://asp.net.do/foros/
    > >> ======================================
    > >> "Dave" <> wrote in message
    > >> news:D...
    > >> > I did all you told me to do and the problem persists. This is the error
    > >> > event log data. It seems the same as shown below.

    >
    > >> > Failed to execute the request because the ASP.NET process identity does not
    > >> > have read permissions to the global assembly cache. Error: 0x80070005 Access
    > >> > is denied.

    >
    > >> >> You are running on XP.
    > >> >> XP's default ASP.NET identity is the ASPNET account.
    > >> >>
    > >> >> run :
    > >> >>
    > >> >> aspnet_regiis -ga machinename\aspnet
    > >> >> ( substitute *your* machine's name for "machinename"... )
    > >> >>
    > >> >> ....from a command window in the .Net Framework 2.0 directory :
    > >> >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    > >> >>
    > >> >> I'm not sure if you can get away with running just :
    > >> >>
    > >> >> aspnet_regiis -ga aspnet
    > >> >>
    > >> >> That should get you up and running again.

    >
    >
    >
    =?Utf-8?B?RGF2ZQ==?=, May 19, 2007
    #11
  12. On your first message you said that the problem
    is with *one* of several ASP.NET applications:

    !> I have some asp.net applications running on a IIS server. No problem.
    !> This morning, i wanted to start an asp.net application, but i get the error:
    !> "Server Application Unavailable; the web application you are attempting to
    !> access on this web server is currently unavailable.

    Can you run *any* asp.net application on your IIS server ?
    Or, does the problem extend to *all* asp.net applications ?



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Dave" <> wrote in message
    news:...
    >I am so, so so, ahhhhhh. What is wrong? I can't believe that I've spent the
    > better part of 4 days trying to figure out this without success. If Apache
    > could have done it I would have switched long ago. I've been using Apache and
    > PHP for years and no problem to configure the web server. This is my first
    > try at using ASP.Net. When I check the Internet, I see a plethora of
    > questions about the same issue and there seem to be so many ad-hoc
    > patches/solutions. The only thing I see on Microsoft site which resembles my
    > problem, has to do with problems in ASP.Net 1.0 issues. I have not seen any
    > solution to ASP.Net 2.0 problems. If I had not invested so time and effort in
    > this I would toss all this .net technology aside.
    > --
    > L. A. Jones
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> re
    >> !> Not sure of the steps to this. Could you enumerate the steps. Thanks
    >>
    >> The best way to approach this, since you can't set the access permissions
    >> to the GAC directly, is to annul and recreate the ASPNET account.
    >>
    >> To do that, run, from a command window in the .Net Framework directory:
    >>
    >> aspnet_regiis -u
    >>
    >> and, immediately after that, run :
    >>
    >> aspnet_regiis -i
    >>
    >> That will, first, annul the ASPNET account and, then, recreate it,
    >> assigning all necessary permissions to all the needed directories,
    >> including the GAC.
    >>
    >>
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ======================================
    >> "Dave" <> wrote in message
    >> news:...
    >> > Not sure of the steps to this. Could you enumerate the steps. Thanks
    >> > --
    >> > L. A. Jones
    >> >
    >> >
    >> > "Juan T. Llibre" wrote:
    >> >
    >> >> I suspect you fumbled the command which gives *any*
    >> >> account *all* the permissions ASP.NET needs to run.
    >> >>
    >> >> In spite of that, Try to give access permissions to
    >> >> the ASPNET account to the GAC directory itself.
    >> >>
    >> >> The GAC directory is Drive:\WINDOWS\assembly
    >> >>
    >> >>
    >> >> Juan T. Llibre, asp.net MVP
    >> >> asp.net faq : http://asp.net.do/faq/
    >> >> foros de asp.net, en español : http://asp.net.do/foros/
    >> >> ======================================
    >> >> "Dave" <> wrote in message
    >> >> news:D...
    >> >> > I did all you told me to do and the problem persists. This is the error
    >> >> > event log data. It seems the same as shown below.

    >>
    >> >> > Failed to execute the request because the ASP.NET process identity does not
    >> >> > have read permissions to the global assembly cache. Error: 0x80070005 Access
    >> >> > is denied.

    >>
    >> >> >> You are running on XP.
    >> >> >> XP's default ASP.NET identity is the ASPNET account.
    >> >> >>
    >> >> >> run :
    >> >> >>
    >> >> >> aspnet_regiis -ga machinename\aspnet
    >> >> >> ( substitute *your* machine's name for "machinename"... )
    >> >> >>
    >> >> >> ....from a command window in the .Net Framework 2.0 directory :
    >> >> >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    >> >> >>
    >> >> >> I'm not sure if you can get away with running just :
    >> >> >>
    >> >> >> aspnet_regiis -ga aspnet
    >> >> >>
    >> >> >> That should get you up and running again.

    >>
    >>
    >>
    Juan T. Llibre, May 19, 2007
    #12
  13. Actually, I meant 1 application. I have never been able to run an ASP.Net
    from IIS application only using VS 2005.
    --
    L. A. Jones


    "Juan T. Llibre" wrote:

    > On your first message you said that the problem
    > is with *one* of several ASP.NET applications:
    >
    > !> I have some asp.net applications running on a IIS server. No problem.
    > !> This morning, i wanted to start an asp.net application, but i get the error:
    > !> "Server Application Unavailable; the web application you are attempting to
    > !> access on this web server is currently unavailable.
    >
    > Can you run *any* asp.net application on your IIS server ?
    > Or, does the problem extend to *all* asp.net applications ?
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Dave" <> wrote in message
    > news:...
    > >I am so, so so, ahhhhhh. What is wrong? I can't believe that I've spent the
    > > better part of 4 days trying to figure out this without success. If Apache
    > > could have done it I would have switched long ago. I've been using Apache and
    > > PHP for years and no problem to configure the web server. This is my first
    > > try at using ASP.Net. When I check the Internet, I see a plethora of
    > > questions about the same issue and there seem to be so many ad-hoc
    > > patches/solutions. The only thing I see on Microsoft site which resembles my
    > > problem, has to do with problems in ASP.Net 1.0 issues. I have not seen any
    > > solution to ASP.Net 2.0 problems. If I had not invested so time and effort in
    > > this I would toss all this .net technology aside.
    > > --
    > > L. A. Jones
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> re
    > >> !> Not sure of the steps to this. Could you enumerate the steps. Thanks
    > >>
    > >> The best way to approach this, since you can't set the access permissions
    > >> to the GAC directly, is to annul and recreate the ASPNET account.
    > >>
    > >> To do that, run, from a command window in the .Net Framework directory:
    > >>
    > >> aspnet_regiis -u
    > >>
    > >> and, immediately after that, run :
    > >>
    > >> aspnet_regiis -i
    > >>
    > >> That will, first, annul the ASPNET account and, then, recreate it,
    > >> assigning all necessary permissions to all the needed directories,
    > >> including the GAC.
    > >>
    > >>
    > >>
    > >>
    > >>
    > >> Juan T. Llibre, asp.net MVP
    > >> asp.net faq : http://asp.net.do/faq/
    > >> foros de asp.net, en español : http://asp.net.do/foros/
    > >> ======================================
    > >> "Dave" <> wrote in message
    > >> news:...
    > >> > Not sure of the steps to this. Could you enumerate the steps. Thanks
    > >> > --
    > >> > L. A. Jones
    > >> >
    > >> >
    > >> > "Juan T. Llibre" wrote:
    > >> >
    > >> >> I suspect you fumbled the command which gives *any*
    > >> >> account *all* the permissions ASP.NET needs to run.
    > >> >>
    > >> >> In spite of that, Try to give access permissions to
    > >> >> the ASPNET account to the GAC directory itself.
    > >> >>
    > >> >> The GAC directory is Drive:\WINDOWS\assembly
    > >> >>
    > >> >>
    > >> >> Juan T. Llibre, asp.net MVP
    > >> >> asp.net faq : http://asp.net.do/faq/
    > >> >> foros de asp.net, en español : http://asp.net.do/foros/
    > >> >> ======================================
    > >> >> "Dave" <> wrote in message
    > >> >> news:D...
    > >> >> > I did all you told me to do and the problem persists. This is the error
    > >> >> > event log data. It seems the same as shown below.
    > >>
    > >> >> > Failed to execute the request because the ASP.NET process identity does not
    > >> >> > have read permissions to the global assembly cache. Error: 0x80070005 Access
    > >> >> > is denied.
    > >>
    > >> >> >> You are running on XP.
    > >> >> >> XP's default ASP.NET identity is the ASPNET account.
    > >> >> >>
    > >> >> >> run :
    > >> >> >>
    > >> >> >> aspnet_regiis -ga machinename\aspnet
    > >> >> >> ( substitute *your* machine's name for "machinename"... )
    > >> >> >>
    > >> >> >> ....from a command window in the .Net Framework 2.0 directory :
    > >> >> >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    > >> >> >>
    > >> >> >> I'm not sure if you can get away with running just :
    > >> >> >>
    > >> >> >> aspnet_regiis -ga aspnet
    > >> >> >>
    > >> >> >> That should get you up and running again.
    > >>
    > >>
    > >>

    >
    >
    >
    =?Utf-8?B?RGF2ZQ==?=, May 19, 2007
    #13
  14. If that's the case, it's a good assumption that you have a bad install.
    Nuke ( fully uninstall ) IIS and the .Net Framework.

    "Start", "Settings", "Control Panel", "Add or Remove Programs".

    The .Net Framework 2.0 removal icon should be visible
    when you open "Add or Remove Programs".

    You can, afterwards, uninstall IIS by clicking "Add/Remove Windows Components".

    Then, after rebooting, install *first* IIS, and then the .Net Framework 2.0

    Please postback your results.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Dave" <> wrote in message
    news:D...
    > Actually, I meant 1 application. I have never been able to run an ASP.Net
    > from IIS application only using VS 2005.
    > --
    > L. A. Jones
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> On your first message you said that the problem
    >> is with *one* of several ASP.NET applications:
    >>
    >> !> I have some asp.net applications running on a IIS server. No problem.
    >> !> This morning, i wanted to start an asp.net application, but i get the error:
    >> !> "Server Application Unavailable; the web application you are attempting to
    >> !> access on this web server is currently unavailable.
    >>
    >> Can you run *any* asp.net application on your IIS server ?
    >> Or, does the problem extend to *all* asp.net applications ?
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ======================================
    >> "Dave" <> wrote in message
    >> news:...
    >> >I am so, so so, ahhhhhh. What is wrong? I can't believe that I've spent the
    >> > better part of 4 days trying to figure out this without success. If Apache
    >> > could have done it I would have switched long ago. I've been using Apache and
    >> > PHP for years and no problem to configure the web server. This is my first
    >> > try at using ASP.Net. When I check the Internet, I see a plethora of
    >> > questions about the same issue and there seem to be so many ad-hoc
    >> > patches/solutions. The only thing I see on Microsoft site which resembles my
    >> > problem, has to do with problems in ASP.Net 1.0 issues. I have not seen any
    >> > solution to ASP.Net 2.0 problems. If I had not invested so time and effort in
    >> > this I would toss all this .net technology aside.
    >> > --
    >> > L. A. Jones
    >> >
    >> >
    >> > "Juan T. Llibre" wrote:
    >> >
    >> >> re
    >> >> !> Not sure of the steps to this. Could you enumerate the steps. Thanks
    >> >>
    >> >> The best way to approach this, since you can't set the access permissions
    >> >> to the GAC directly, is to annul and recreate the ASPNET account.
    >> >>
    >> >> To do that, run, from a command window in the .Net Framework directory:
    >> >>
    >> >> aspnet_regiis -u
    >> >>
    >> >> and, immediately after that, run :
    >> >>
    >> >> aspnet_regiis -i
    >> >>
    >> >> That will, first, annul the ASPNET account and, then, recreate it,
    >> >> assigning all necessary permissions to all the needed directories,
    >> >> including the GAC.
    >> >>
    >> >>
    >> >>
    >> >>
    >> >>
    >> >> Juan T. Llibre, asp.net MVP
    >> >> asp.net faq : http://asp.net.do/faq/
    >> >> foros de asp.net, en español : http://asp.net.do/foros/
    >> >> ======================================
    >> >> "Dave" <> wrote in message
    >> >> news:...
    >> >> > Not sure of the steps to this. Could you enumerate the steps. Thanks
    >> >> > --
    >> >> > L. A. Jones
    >> >> >
    >> >> >
    >> >> > "Juan T. Llibre" wrote:
    >> >> >
    >> >> >> I suspect you fumbled the command which gives *any*
    >> >> >> account *all* the permissions ASP.NET needs to run.
    >> >> >>
    >> >> >> In spite of that, Try to give access permissions to
    >> >> >> the ASPNET account to the GAC directory itself.
    >> >> >>
    >> >> >> The GAC directory is Drive:\WINDOWS\assembly
    >> >> >>
    >> >> >>
    >> >> >> Juan T. Llibre, asp.net MVP
    >> >> >> asp.net faq : http://asp.net.do/faq/
    >> >> >> foros de asp.net, en español : http://asp.net.do/foros/
    >> >> >> ======================================
    >> >> >> "Dave" <> wrote in message
    >> >> >> news:D...
    >> >> >> > I did all you told me to do and the problem persists. This is the error
    >> >> >> > event log data. It seems the same as shown below.
    >> >>
    >> >> >> > Failed to execute the request because the ASP.NET process identity does not
    >> >> >> > have read permissions to the global assembly cache. Error: 0x80070005 Access
    >> >> >> > is denied.
    >> >>
    >> >> >> >> You are running on XP.
    >> >> >> >> XP's default ASP.NET identity is the ASPNET account.
    >> >> >> >>
    >> >> >> >> run :
    >> >> >> >>
    >> >> >> >> aspnet_regiis -ga machinename\aspnet
    >> >> >> >> ( substitute *your* machine's name for "machinename"... )
    >> >> >> >>
    >> >> >> >> ....from a command window in the .Net Framework 2.0 directory :
    >> >> >> >> Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
    >> >> >> >>
    >> >> >> >> I'm not sure if you can get away with running just :
    >> >> >> >>
    >> >> >> >> aspnet_regiis -ga aspnet
    >> >> >> >>
    >> >> >> >> That should get you up and running again.
    >> >>
    >> >>
    >> >>

    >>
    >>
    >>
    Juan T. Llibre, May 19, 2007
    #14
  15. > "Start", "Settings", "Control Panel", "Add or Remove Programs".
    >
    > The .Net Framework 2.0 removal icon should be visible
    > when you open "Add or Remove Programs".
    >
    > You can, afterwards, uninstall IIS by clicking "Add/Remove Windows Components".
    >
    > Then, after rebooting, install *first* IIS, and then the .Net Framework 2.0
    >
    > Please postback your results.
    >
    >
    >
    >


    No change. Do you think I need to re-install from the OS? That is what I've
    seen in some newsgroups. I notice that if I try to use Firefox to access
    localhost/mysite, I am being prompted for username and password. That is not
    the case with IE6
    --
    L. A. Jones
    =?Utf-8?B?RGF2ZQ==?=, May 19, 2007
    #15
  16. Hi,
    You have mentioned that both .NET 1.0 and .NET 2.0 are installed .So
    probably both ASP.NET 1.0 and ASP.NET 2.0 are installed on your machine.If
    that is the case then you need to tell IIS which version you want it to run
    with.Steps for these are:
    The ASP.NET MMC Snapin is integrated into the IIS MMC administration tool.
    To use the snapin, use the following steps:
    [1]Open the IIS MMC console, by using Administrative Tools/Internet
    Information Services.
    [2]Select the application or directory you want to debug, and select
    Properties from the Action menu.
    [3]From the property sheet, click on the ASP.NET tab.
    On this tab, you can review or change the ASP.NET version used for the
    current application. Any change you make to this setting applies to all child
    applications.
    from this tab you can change version to 2.0 or 1.1.
    However I wanted to make sure that if you are using IIS 6
    --
    Thanks and Regards.
    Manish Bafna.
    MCP and MCTS.



    "Dave" wrote:

    > I have set up a virtual directory using IIS. Whenever, I load a web page of
    > type .htm, I have no problem. Whenever I run a .aspx page I get the statement
    > below. I am running on XP Pro, both Microsoft .Net 1.1 & 2.0 installed. How
    > do I remedy this error?
    >
    > //Error below
    >
    > Server Application Unavailable
    >
    > The web application you are attempting to access on this web server is
    > currently unavailable. Please hit the "Refresh" button in your web browser
    > to retry your request.
    >
    > Administrator Note: An error message detailing the cause of this specific
    > request failure can be found in the application event log of the web server.
    > Please review this log entry to discover what caused this error to occur
    > --
    > L. A. Jones
    =?Utf-8?B?TWFuaXNoIEJhZm5h?=, May 20, 2007
    #16
  17. Dave,

    I was plagued by this exact error as well as "Access Denied" errors until I
    figured out the file encryption software my company installs as part of our
    standard image was causing this.

    -Dave

    "Dave" wrote:

    > I have set up a virtual directory using IIS. Whenever, I load a web page of
    > type .htm, I have no problem. Whenever I run a .aspx page I get the statement
    > below. I am running on XP Pro, both Microsoft .Net 1.1 & 2.0 installed. How
    > do I remedy this error?
    >
    > //Error below
    >
    > Server Application Unavailable
    >
    > The web application you are attempting to access on this web server is
    > currently unavailable. Please hit the "Refresh" button in your web browser
    > to retry your request.
    >
    > Administrator Note: An error message detailing the cause of this specific
    > request failure can be found in the application event log of the web server.
    > Please review this log entry to discover what caused this error to occur
    > --
    > L. A. Jones
    =?Utf-8?B?RGF2ZQ==?=, May 21, 2007
    #17
  18. I am surprised that you say you uninstalled IIS and the .Net Framework,
    and reinstalled them both, in only the 1 1/2 hours that passed between
    my suggestion and the time you reported that implementing them didn't work.

    Are you *sure* you followed my suggestion *exactly* as explained ?

    It's impossible to uninstall/reinstall *both* IIS
    *and* the .Net Framework in less than 1 1/2 hours.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Dave" <> wrote in message
    news:...
    >> "Start", "Settings", "Control Panel", "Add or Remove Programs".
    >>
    >> The .Net Framework 2.0 removal icon should be visible
    >> when you open "Add or Remove Programs".
    >>
    >> You can, afterwards, uninstall IIS by clicking "Add/Remove Windows Components".
    >>
    >> Then, after rebooting, install *first* IIS, and then the .Net Framework 2.0
    >>
    >> Please postback your results.


    > No change. Do you think I need to re-install from the OS? That is what I've
    > seen in some newsgroups. I notice that if I try to use Firefox to access
    > localhost/mysite, I am being prompted for username and password. That is not
    > the case with IE6
    > --
    > L. A. Jones
    >
    >
    >
    Juan T. Llibre, May 21, 2007
    #18
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Simon Devlin
    Replies:
    1
    Views:
    466
    Jim Cheshire [MSFT]
    Jul 12, 2004
  2. Robert Halford
    Replies:
    1
    Views:
    4,617
    David Lloyd
    May 13, 2005
  3. =?Utf-8?B?RGFtb24gUm9iZXJ0cw==?=

    Win 2003 Server / IIS6 / Server Application Unavailable

    =?Utf-8?B?RGFtb24gUm9iZXJ0cw==?=, May 17, 2005, in forum: ASP .Net
    Replies:
    6
    Views:
    7,347
    =?Utf-8?B?Y21zMTIz?=
    Jun 23, 2005
  4. =?Utf-8?B?TS5rYW1yYW4=?=

    Server Application Unavailable on windows 2003 server.

    =?Utf-8?B?TS5rYW1yYW4=?=, Jul 19, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    2,011
    =?Utf-8?B?TS5rYW1yYW4=?=
    Jul 20, 2005
  5. hutty
    Replies:
    1
    Views:
    597
    hutty
    Sep 11, 2006
Loading...

Share This Page