Server is displaying "Enter Network Password" logon box when trying to access files

Discussion in 'ASP .Net' started by Ezra, Oct 11, 2004.

  1. Ezra

    Ezra Guest

    Our company's web server is trying to access graphics files on another
    server. When I run the app from Visual Studio (1.0) on my localhost,
    the server in question is available (which is accessed a virtual
    directory) and I'm able to display the files. However, when we logon
    to the intranet through a browser, and click the link which will
    display the files, we get the "Enter Network Password" logon box. We
    set the proper permissions on the folder in question, yet this still
    happens. On my localhost, I was having the same problem until I put
    identity impersonate="true"
    into my web.config file, and it worked fine. I did the same to our
    web server's web.config, yet the problem persisted. I also compared
    my machine.config to the web server's web config, and there weren't
    any differences as far as username="machine" is concerned. The
    permissions to the folder on the file server in question include:
    Everyone, aspnet_wp account, and asp.net machine account. In iis on
    my localhost, I am set to connect to the file server as administrator,
    and the same settings are on the iis on the web server. Also, the
    intranet on the web server was built without using Visual Studio. So,
    the question remains, why am I able to access the file server through
    my localhost, but not through the web server?

    Thanks,

    EA
     
    Ezra, Oct 11, 2004
    #1
    1. Advertising

  2. Ezra

    bruce barker Guest

    you are running into the one hop rule. it works on your local box because
    the browser is running on the webserver box. try hitting your box from
    another and you will see the same behavior.

    you can create a vdir on the webserver to share the images (this will
    require a domain account), or set a domain account for asp.net to
    inpersonate in the web config (fill in the userName and password)

    -- bruce (sqlwork.com)



    "Ezra" <> wrote in message
    news:...
    > Our company's web server is trying to access graphics files on another
    > server. When I run the app from Visual Studio (1.0) on my localhost,
    > the server in question is available (which is accessed a virtual
    > directory) and I'm able to display the files. However, when we logon
    > to the intranet through a browser, and click the link which will
    > display the files, we get the "Enter Network Password" logon box. We
    > set the proper permissions on the folder in question, yet this still
    > happens. On my localhost, I was having the same problem until I put
    > identity impersonate="true"
    > into my web.config file, and it worked fine. I did the same to our
    > web server's web.config, yet the problem persisted. I also compared
    > my machine.config to the web server's web config, and there weren't
    > any differences as far as username="machine" is concerned. The
    > permissions to the folder on the file server in question include:
    > Everyone, aspnet_wp account, and asp.net machine account. In iis on
    > my localhost, I am set to connect to the file server as administrator,
    > and the same settings are on the iis on the web server. Also, the
    > intranet on the web server was built without using Visual Studio. So,
    > the question remains, why am I able to access the file server through
    > my localhost, but not through the web server?
    >
    > Thanks,
    >
    > EA
     
    bruce barker, Oct 11, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. tshad
    Replies:
    5
    Views:
    640
    Patrick Olurotimi Ige
    Dec 8, 2004
  2. J-T
    Replies:
    2
    Views:
    2,873
  3. armandotop
    Replies:
    2
    Views:
    392
    Peter Jansson
    Apr 13, 2005
  4. J-T
    Replies:
    6
    Views:
    159
  5. Kjell Kristiansson
    Replies:
    0
    Views:
    313
    Kjell Kristiansson
    Nov 30, 2005
Loading...

Share This Page