Server response with header attribute mustunderstand="1"

Discussion in 'ASP .Net Web Services' started by angellvl@gmail.com, Sep 29, 2006.

  1. Guest

    Hi everybody, I'm stucked with a web service response... When I call a
    web service I must add a Header calles TransactionID with the
    mustunderstand attribute set to "1". The web service response it's ok
    but includes the same header with mustunderstand="1", and client proxy
    class is unable to process this response. The message I'm getting is:

    "Soap Header TransactionID was not understood"

    It seems like my client proxy class canĀ“t understand the TransactionID
    header. How can I tell my client class thar TransactionID is
    understand? Is it possible not check the mustunderstand attribute? Any
    other idea?



    Thanks in advance

    Angel
    , Sep 29, 2006
    #1
    1. Advertising

  2. Guest

    >
    > Use WSE-enabled client.
    >


    Thanks!! I've implemented a SoapFilter that remove the header from de
    response and now works ok.
    , Oct 2, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Bostonasian
    Replies:
    1
    Views:
    809
    Joris Gillis
    Sep 18, 2005
  2. Replies:
    2
    Views:
    1,066
    Henry S. Thompson
    Mar 6, 2006
  3. Reg
    Replies:
    2
    Views:
    4,287
    acsimsek
    Jan 28, 2013
  4. mlt
    Replies:
    2
    Views:
    817
    Jean-Marc Bourguet
    Jan 31, 2009
  5. Katie
    Replies:
    8
    Views:
    254
    Anthony Jones
    Aug 17, 2006
Loading...

Share This Page