Setting a schema path that contains whitespaces (Xerces)

Discussion in 'XML' started by Prawdziwa Blondynka, Mar 7, 2005.

  1. Hi,
    I would like to do the following with C++ and Xerces:

    set the schema path in an XML file to parse in this way:

    XMLCh* schemaLocation = XMLString::transcode(namespaceAndPath);
    //namespaceAndPath stands for the namespace and schema path containing
    whitespaces

    parser->setProperty(XMLUni::fgXercesSchemaExternalSchemaLocation,
    schemaLocation);

    unfortunately, when I want to parse the file, I get the following
    error:
    The schemaLocation attribute does not contain pairs of values.

    It seems to be caused by whitespaces (parsing works if the schema path
    does not contain any) - probably Xerces understands the as multiple
    namespaces and paths.

    Is there any way of setting such a schema path?

    Thanks in advance,
    Blondie
     
    Prawdziwa Blondynka, Mar 7, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. James Dyer
    Replies:
    5
    Views:
    651
  2. Markus
    Replies:
    1
    Views:
    1,580
    Markus
    Nov 23, 2005
  3. Nicolas VanOrton

    How do I get Schema path with Xerces ?

    Nicolas VanOrton, Jul 16, 2004, in forum: XML
    Replies:
    0
    Views:
    480
    Nicolas VanOrton
    Jul 16, 2004
  4. cvissy
    Replies:
    0
    Views:
    616
    cvissy
    Nov 16, 2004
  5. Stanimir Stamenkov
    Replies:
    3
    Views:
    1,277
    Stanimir Stamenkov
    Apr 25, 2005
Loading...

Share This Page