Setting up ASP.NET Configuration in Visual Studio 2005

Discussion in 'ASP .Net Security' started by Jibey Jacob, Jul 9, 2007.

  1. Jibey Jacob

    Jibey Jacob Guest

    Hi:

    I'm having trouble setting this up. I placed the following information in
    web.config:

    <membership userIsOnlineTimeWindow="20">
    <providers>
    <add connectionStringName="SqlServices"
    enablePasswordRetrieval="false"
    enablePasswordReset="true" requiresQuestionAndAnswer="true"
    passwordFormat="Hashed" applicationName="jibey.jacob"
    name="SqlProvider"
    type="System.Web.Security.SqlMembershipProvider" />
    </providers>
    </membership>

    When I launch the ASP.NET Configuration wizard from Visual Studio, and flip
    to the Security tab, I can see one provider listed (I selected single
    provider for all site management), which is AspNetSqlProvider. The
    connnection string "SqlServices" exists in web.config. The problem is the
    wizard always comes back with an error that says "unable to establish a
    connection to the database".

    Before I placed all this information in web.config, I had started with a
    bare-bones web.config that VS2005 had created. And I created the membership
    database in SQL Server using aspnet_regsql.

    What am I doing wrong?

    Thanks.
     
    Jibey Jacob, Jul 9, 2007
    #1
    1. Advertising

  2. Jibey Jacob

    Jibey Jacob Guest

    There's just this one other thing that bothers me about this: how does the
    ASP.NET Configuration Wizard know which host and sql server instance name to
    look for?

    Thanks.

    "Jibey Jacob" wrote:

    > Hi:
    >
    > I'm having trouble setting this up. I placed the following information in
    > web.config:
    >
    > <membership userIsOnlineTimeWindow="20">
    > <providers>
    > <add connectionStringName="SqlServices"
    > enablePasswordRetrieval="false"
    > enablePasswordReset="true" requiresQuestionAndAnswer="true"
    > passwordFormat="Hashed" applicationName="jibey.jacob"
    > name="SqlProvider"
    > type="System.Web.Security.SqlMembershipProvider" />
    > </providers>
    > </membership>
    >
    > When I launch the ASP.NET Configuration wizard from Visual Studio, and flip
    > to the Security tab, I can see one provider listed (I selected single
    > provider for all site management), which is AspNetSqlProvider. The
    > connnection string "SqlServices" exists in web.config. The problem is the
    > wizard always comes back with an error that says "unable to establish a
    > connection to the database".
    >
    > Before I placed all this information in web.config, I had started with a
    > bare-bones web.config that VS2005 had created. And I created the membership
    > database in SQL Server using aspnet_regsql.
    >
    > What am I doing wrong?
    >
    > Thanks.
    >
     
    Jibey Jacob, Jul 9, 2007
    #2
    1. Advertising

  3. On Jul 9, 5:08 am, Jibey Jacob <>
    wrote:
    > There's just this one other thing that bothers me about this: how does the
    > ASP.NET Configuration Wizard know which host and sql server instance name to
    > look for?
    >
    > Thanks.
    >
    >
    >
    > "Jibey Jacob" wrote:
    > > Hi:

    >
    > > I'm having trouble setting this up. I placed the following information in
    > > web.config:

    >
    > > <membership userIsOnlineTimeWindow="20">
    > > <providers>
    > > <add connectionStringName="SqlServices"
    > > enablePasswordRetrieval="false"
    > > enablePasswordReset="true" requiresQuestionAndAnswer="true"
    > > passwordFormat="Hashed" applicationName="jibey.jacob"
    > > name="SqlProvider"
    > > type="System.Web.Security.SqlMembershipProvider" />
    > > </providers>
    > > </membership>

    >
    > > When I launch the ASP.NET Configuration wizard from Visual Studio, and flip
    > > to the Security tab, I can see one provider listed (I selected single
    > > provider for all site management), which is AspNetSqlProvider. The
    > > connnection string "SqlServices" exists in web.config. The problem is the
    > > wizard always comes back with an error that says "unable to establish a
    > > connection to the database".

    >
    > > Before I placed all this information in web.config, I had started with a
    > > bare-bones web.config that VS2005 had created. And I created the membership
    > > database in SQL Server using aspnet_regsql.

    >
    > > What am I doing wrong?

    >
    > > Thanks.- Hide quoted text -

    >
    > - Show quoted text -


    Jubey,

    I think your problem is in the defaultProvider property which is not
    specified.

    Quote: When specifying the membership Element (ASP.NET Settings
    Schema) section, you must specify the defaultProvider attribute. If
    you do not specify a membership Element (ASP.NET Settings Schema)
    section in your Web.config, the values from the machine configuration
    are used and the SqlMembershipProvider instance named
    AspNetSqlProvider is established as the defaultProvider.

    http://msdn2.microsoft.com/en-us/library/system.web.security.membership.providers.aspx

    Hope this helps
     
    Alexey Smirnov, Jul 9, 2007
    #3
  4. Jibey Jacob

    Jibey Jacob Guest

    Yes, it helped. I also had to create separate providers for roles and
    memberships and I had to remove the default AspNetSqlProvider as a membership
    provider.

    Thanks,

    Jibey

    "Alexey Smirnov" wrote:

    > On Jul 9, 5:08 am, Jibey Jacob <>
    > wrote:
    > > There's just this one other thing that bothers me about this: how does the
    > > ASP.NET Configuration Wizard know which host and sql server instance name to
    > > look for?
    > >
    > > Thanks.
    > >
    > >
    > >
    > > "Jibey Jacob" wrote:
    > > > Hi:

    > >
    > > > I'm having trouble setting this up. I placed the following information in
    > > > web.config:

    > >
    > > > <membership userIsOnlineTimeWindow="20">
    > > > <providers>
    > > > <add connectionStringName="SqlServices"
    > > > enablePasswordRetrieval="false"
    > > > enablePasswordReset="true" requiresQuestionAndAnswer="true"
    > > > passwordFormat="Hashed" applicationName="jibey.jacob"
    > > > name="SqlProvider"
    > > > type="System.Web.Security.SqlMembershipProvider" />
    > > > </providers>
    > > > </membership>

    > >
    > > > When I launch the ASP.NET Configuration wizard from Visual Studio, and flip
    > > > to the Security tab, I can see one provider listed (I selected single
    > > > provider for all site management), which is AspNetSqlProvider. The
    > > > connnection string "SqlServices" exists in web.config. The problem is the
    > > > wizard always comes back with an error that says "unable to establish a
    > > > connection to the database".

    > >
    > > > Before I placed all this information in web.config, I had started with a
    > > > bare-bones web.config that VS2005 had created. And I created the membership
    > > > database in SQL Server using aspnet_regsql.

    > >
    > > > What am I doing wrong?

    > >
    > > > Thanks.- Hide quoted text -

    > >
    > > - Show quoted text -

    >
    > Jubey,
    >
    > I think your problem is in the defaultProvider property which is not
    > specified.
    >
    > Quote: When specifying the membership Element (ASP.NET Settings
    > Schema) section, you must specify the defaultProvider attribute. If
    > you do not specify a membership Element (ASP.NET Settings Schema)
    > section in your Web.config, the values from the machine configuration
    > are used and the SqlMembershipProvider instance named
    > AspNetSqlProvider is established as the defaultProvider.
    >
    > http://msdn2.microsoft.com/en-us/library/system.web.security.membership.providers.aspx
    >
    > Hope this helps
    >
    >
     
    Jibey Jacob, Jul 9, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. wh
    Replies:
    2
    Views:
    571
    Cowboy \(Gregory A. Beamer\)
    Jan 16, 2004
  2. rockdale
    Replies:
    1
    Views:
    671
    Juan T. Llibre
    Aug 23, 2006
  3. hunkgym
    Replies:
    1
    Views:
    2,011
    =?Utf-8?B?TGVvbiBNYXluZQ==?=
    Oct 30, 2006
  4. xman
    Replies:
    0
    Views:
    550
  5. xman
    Replies:
    1
    Views:
    645
    Victor Bazarov
    Aug 17, 2005
Loading...

Share This Page