SmartNavigation + IE: Check for newer version of pages: Every visi

Discussion in 'ASP .Net' started by =?Utf-8?B?bV9sYWNp?=, Oct 13, 2004.

  1. Hello there,

    We have encountered a strange error with our ASP.NET applications in
    combination with SmartNavigation and the setting from Internet Explorer:
    ‘Check for newer version of pages: Every visit to the pagesâ€. With this
    option is set in Internet Explorer, after postback displaying information on
    screen behaves differently than expected. Behaviour is dependent on different
    IE versions / installations. Controls are not anymore aligned correctly on
    screen (positioning is controlled via CSS files); this is the most common
    behavior. On other computer when the problem occurs, combo boxes looses their
    drop-down list, just the current element is visible.
    Pages needs to be complex enough, we did tried to isolate the issue in a
    small sample, but did not managed.
    We also think we did manage to isolate where the problem occurs in
    SmartNav.js, of course we might be wrong, but currently this seams to solve
    our problem.

    When response is received after a post-back the code from Smartnav.js is
    copying elements from the hidden frame, reconstructing the page. With the
    mentioned setting from Internet Explorer, this results that when dealing with
    the LINK elements, their readyState can be still “loadingâ€, in which moments
    the problem occurs.

    Adding an alert before “document.body.clearAttributes†seams to make sure
    the problem does not occurs; this leaded us to the idea that it is a timing
    problem and started to check readyStates.

    By extending the special exceptions which are done for BASEFONT also to
    LINK, seams like the problem does not occurs anymore.

    Of course this is probably not “the solutionâ€, just was a way to get some
    extra info what is happening.

    versions: Microsoft .NET Framework 1.1 + Visual Studio .NET 2003
    IE: 6.0.2800.1106.xpsp2..... on XP Profesional SP1 English
    IE: 6.0.2800.1106.xpsp2..... on XP Profesional SP1 Dutch

    Anybody has some ideas, suggestions how should be this problem dealt with?


    Thanks in advance,

    Laci
     
    =?Utf-8?B?bV9sYWNp?=, Oct 13, 2004
    #1
    1. Advertising

  2. Turn off smartNav. It's horribly broken.
     
    =?Utf-8?B?U2NvdHQgU2ltb25z?=, Oct 13, 2004
    #2
    1. Advertising

  3. SmartNavigation + IE: Check for newer version of pages: Every

    Any other ideas besides do not use?
     
    =?Utf-8?B?bV9sYWNp?=, Oct 15, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RWQgU3RhZmZpbg==?=

    How to set when "Check for newer versions of stored pages" happens

    =?Utf-8?B?RWQgU3RhZmZpbg==?=, Feb 8, 2006, in forum: ASP .Net
    Replies:
    2
    Views:
    7,688
    =?Utf-8?B?UmljaGFyZA==?=
    Apr 3, 2006
  2. Replies:
    1
    Views:
    768
  3. Replies:
    2
    Views:
    364
    Gabriel Genellina
    Feb 20, 2007
  4. V Green
    Replies:
    0
    Views:
    923
    V Green
    Feb 5, 2008
  5. PA Bear [MS MVP]
    Replies:
    0
    Views:
    1,034
    PA Bear [MS MVP]
    Feb 5, 2008
Loading...

Share This Page