SQL Network Interfaces, error: 26

Discussion in 'ASP .Net' started by AAaron123, Jul 17, 2008.

  1. AAaron123

    AAaron123 Guest

    I downloaded the personal website starter kit and when I run it I get the
    error shown below.
    I found a way of using Launch Surface Area Configuration that is supposed
    to fix the remote setting but I tried it and still get the error.

    I do not have SQL Server 2005 installed (thought I did once). I do have SQL
    Server 2008 installed.

    I don't see anywhere in the code where SQL Server 2005 is referenced.

    Don't I have to tell in the code that I want to use SQL Server 2008?
    Suppose I hade both on my machine?

    Do I have some registry entry that did not get up dated from the 2005 to the
    2008 versions?

    Thanks for any help.



    An error has occurred while establishing a connection to the server. When
    connecting to SQL Server 2005, this failure may be caused by the fact that
    under the default settings SQL Server does not allow remote connections.
    (provider: SQL Network Interfaces, error: 26 - Error Locating
    Server/Instance Specified)
    Description: An unhandled exception occurred during the execution of the
    current web request. Please review the stack trace for more information
    about the error and where it originated in the code.

    Exception Details: System.Data.SqlClient.SqlException: An error has occurred
    while establishing a connection to the server. When connecting to SQL
    Server 2005, this failure may be caused by the fact that under the default
    settings SQL Server does not allow remote connections. (provider: SQL
    Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

    Source Error:

    Line 194: Using command As New SqlCommand("GetNonEmptyAlbums", connection)
    Line 195: command.CommandType = CommandType.StoredProcedure
    Line 196: connection.Open()
    Line 197: Dim list As New Generic.List(Of Album)()
    Line 198: Using reader As SqlDataReader = command.ExecuteReader

    Source File: I:\MyDocuments\Visual Studio
    2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
     
    AAaron123, Jul 17, 2008
    #1
    1. Advertising

  2. Hello AAaron123,

    Check the web.config, where should be the "connectionstring" attribute, where
    they specify where to connect
    of this can be somewhere in code

    ---
    WBR,
    Michael Nemtsev [Microsoft MVP] :: blog: http://spaces.live.com/laflour

    "The greatest danger for most of us is not that our aim is too high and we
    miss it, but that it is too low and we reach it" (c) Michelangelo


    A> I downloaded the personal website starter kit and when I run it I get
    A> the
    A> error shown below.
    A> I found a way of using Launch Surface Area Configuration that is
    A> supposed
    A> to fix the remote setting but I tried it and still get the error.
    A> I do not have SQL Server 2005 installed (thought I did once). I do
    A> have SQL Server 2008 installed.
    A>
    A> I don't see anywhere in the code where SQL Server 2005 is referenced.
    A>
    A> Don't I have to tell in the code that I want to use SQL Server 2008?
    A> Suppose I hade both on my machine?
    A>
    A> Do I have some registry entry that did not get up dated from the 2005
    A> to the 2008 versions?
    A>
    A> Thanks for any help.
    A>
    A> An error has occurred while establishing a connection to the server.
    A> When
    A> connecting to SQL Server 2005, this failure may be caused by the fact
    A> that
    A> under the default settings SQL Server does not allow remote
    A> connections.
    A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    A> Server/Instance Specified)
    A> Description: An unhandled exception occurred during the execution of
    A> the
    A> current web request. Please review the stack trace for more
    A> information
    A> about the error and where it originated in the code.
    A> Exception Details: System.Data.SqlClient.SqlException: An error has
    A> occurred while establishing a connection to the server. When
    A> connecting to SQL Server 2005, this failure may be caused by the fact
    A> that under the default settings SQL Server does not allow remote
    A> connections. (provider: SQL Network Interfaces, error: 26 - Error
    A> Locating Server/Instance Specified)
    A>
    A> Source Error:
    A>
    A> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    A> connection)
    A> Line 195: command.CommandType = CommandType.StoredProcedure
    A> Line 196: connection.Open()
    A> Line 197: Dim list As New Generic.List(Of Album)()
    A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    A> Source File: I:\MyDocuments\Visual Studio
    A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    A>
     
    Michael Nemtsev [MVP], Jul 18, 2008
    #2
    1. Advertising

  3. AAaron123

    AAaron123 Guest

    I do have SQL Server 2005 installed.
    I previously had SQL Server 2008 Express installed.

    I downloaded the personal website starter kit and when I run it I get the
    error shown below.

    I found a way of using Launch Surface Area Configuration that is supposed
    to fix the remote setting but I tried it and still get the error.

    I don't see anywhere in the code where SQL Server 2005 is referenced.

    Don't I have to tell in the code that I want to use SQL Server 2005?
    Suppose I hade mutilple versions on my machine?

    Do I have some registry entry that did not get up dated from the 2008
    express
    to the 2005 versions?

    Thanks for any help.



    An error has occurred while establishing a connection to the server. When
    connecting to SQL Server 2005, this failure may be caused by the fact that
    under the default settings SQL Server does not allow remote connections.
    (provider: SQL Network Interfaces, error: 26 - Error Locating
    Server/Instance Specified)
    Description: An unhandled exception occurred during the execution of the
    current web request. Please review the stack trace for more information
    about the error and where it originated in the code.

    Exception Details: System.Data.SqlClient.SqlException: An error has
    occurred
    while establishing a connection to the server. When connecting to SQL
    Server 2005, this failure may be caused by the fact that under the default
    settings SQL Server does not allow remote connections. (provider: SQL
    Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

    Source Error:

    Line 194: Using command As New SqlCommand("GetNonEmptyAlbums", connection)
    Line 195: command.CommandType = CommandType.StoredProcedure
    Line 196: connection.Open()
    Line 197: Dim list As New Generic.List(Of Album)()
    Line 198: Using reader As SqlDataReader = command.ExecuteReader

    Source File: I:\MyDocuments\Visual Studio
    2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
     
    AAaron123, Jul 18, 2008
    #3
  4. AAaron123

    bruce barker Guest

    the error means the sqlserver specified in the connection string was not
    found. if you had both sqlserver 2005 & 2008, the 2008 is probably not the
    default instance. either specify the instance, or create a new default
    instance (reinstall sqlserver 2008)

    -- bruce (sqlwork.com)


    "AAaron123" wrote:

    >
    > I downloaded the personal website starter kit and when I run it I get the
    > error shown below.
    > I found a way of using Launch Surface Area Configuration that is supposed
    > to fix the remote setting but I tried it and still get the error.
    >
    > I do not have SQL Server 2005 installed (thought I did once). I do have SQL
    > Server 2008 installed.
    >
    > I don't see anywhere in the code where SQL Server 2005 is referenced.
    >
    > Don't I have to tell in the code that I want to use SQL Server 2008?
    > Suppose I hade both on my machine?
    >
    > Do I have some registry entry that did not get up dated from the 2005 to the
    > 2008 versions?
    >
    > Thanks for any help.
    >
    >
    >
    > An error has occurred while establishing a connection to the server. When
    > connecting to SQL Server 2005, this failure may be caused by the fact that
    > under the default settings SQL Server does not allow remote connections.
    > (provider: SQL Network Interfaces, error: 26 - Error Locating
    > Server/Instance Specified)
    > Description: An unhandled exception occurred during the execution of the
    > current web request. Please review the stack trace for more information
    > about the error and where it originated in the code.
    >
    > Exception Details: System.Data.SqlClient.SqlException: An error has occurred
    > while establishing a connection to the server. When connecting to SQL
    > Server 2005, this failure may be caused by the fact that under the default
    > settings SQL Server does not allow remote connections. (provider: SQL
    > Network Interfaces, error: 26 - Error Locating Server/Instance Specified)
    >
    > Source Error:
    >
    > Line 194: Using command As New SqlCommand("GetNonEmptyAlbums", connection)
    > Line 195: command.CommandType = CommandType.StoredProcedure
    > Line 196: connection.Open()
    > Line 197: Dim list As New Generic.List(Of Album)()
    > Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >
    > Source File: I:\MyDocuments\Visual Studio
    > 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    >
    >
    >
    >
     
    bruce barker, Jul 18, 2008
    #4
  5. AAaron123

    AAaron123 Guest

    I find two such strings as shown below.

    I see now that who ever wrote this assumed it would be used with the Express
    version.
    How do I change it to point to the SQL Server2005?


    Also, I do see the file Personal.mdf in the solution list of file names.
    But I do not see the file aspnetdb.mdf there. Do you thing the program might
    create it when it runs?

    Finally, the error message mentioned SQL2005 as if it converted from the
    Express to 2005 since that is what it found. If that's the case why didn't
    it make the connection?

    Very confusing!

    Thanks for the help



    ....
    <add name="Personal" connectionString="Data Source=.\SQLExpress;Integrated
    Security=True;User
    Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
    providerName="System.Data.SqlClient"/>
    <remove name="LocalSqlServer"/>
    <add name="LocalSqlServer" connectionString="Data
    Source=.\SQLExpress;Integrated Security=True;User
    Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf"/>
    </connectionStrings>



    "Michael Nemtsev [MVP]" <> wrote in message
    news:...
    > Hello AAaron123,
    >
    > Check the web.config, where should be the "connectionstring" attribute,
    > where they specify where to connect
    > of this can be somewhere in code
    >
    > ---
    > WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    > http://spaces.live.com/laflour
    > "The greatest danger for most of us is not that our aim is too high and we
    > miss it, but that it is too low and we reach it" (c) Michelangelo
    >
    > A> I downloaded the personal website starter kit and when I run it I get
    > A> the
    > A> error shown below.
    > A> I found a way of using Launch Surface Area Configuration that is
    > A> supposed
    > A> to fix the remote setting but I tried it and still get the error.
    > A> I do not have SQL Server 2005 installed (thought I did once). I do
    > A> have SQL Server 2008 installed.
    > A> A> I don't see anywhere in the code where SQL Server 2005 is
    > referenced.
    > A> A> Don't I have to tell in the code that I want to use SQL Server 2008?
    > A> Suppose I hade both on my machine?
    > A> A> Do I have some registry entry that did not get up dated from the
    > 2005
    > A> to the 2008 versions?
    > A> A> Thanks for any help.
    > A> A> An error has occurred while establishing a connection to the server.
    > A> When
    > A> connecting to SQL Server 2005, this failure may be caused by the fact
    > A> that
    > A> under the default settings SQL Server does not allow remote
    > A> connections.
    > A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    > A> Server/Instance Specified)
    > A> Description: An unhandled exception occurred during the execution of
    > A> the
    > A> current web request. Please review the stack trace for more
    > A> information
    > A> about the error and where it originated in the code.
    > A> Exception Details: System.Data.SqlClient.SqlException: An error has
    > A> occurred while establishing a connection to the server. When
    > A> connecting to SQL Server 2005, this failure may be caused by the fact
    > A> that under the default settings SQL Server does not allow remote
    > A> connections. (provider: SQL Network Interfaces, error: 26 - Error
    > A> Locating Server/Instance Specified)
    > A> A> Source Error:
    > A> A> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    > A> connection)
    > A> Line 195: command.CommandType = CommandType.StoredProcedure
    > A> Line 196: connection.Open()
    > A> Line 197: Dim list As New Generic.List(Of Album)()
    > A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    > A> Source File: I:\MyDocuments\Visual Studio
    > A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    > A>
    >
     
    AAaron123, Jul 18, 2008
    #5
  6. AAaron123

    AAaron123 Guest

    I'll ask you the same questions I asked Michael Nemtsev.

    I find two such strings as shown below.

    I see now that who ever wrote this assumed it would be used with the Express
    version.
    How do I change it to point to the SQL Server2005?


    Also, I do see the file Personal.mdf in the solution list of file names.
    But I do not see the file aspnetdb.mdf there. Do you thing the program might
    create it when it runs?

    Finally, the error message mentioned SQL2005 as if it converted from the
    Express to 2005 since that is what it found. If that's the case why didn't
    it make the connection?

    Very confusing!

    Thanks for the help

    "bruce barker" <> wrote in message
    news:...
    > the error means the sqlserver specified in the connection string was not
    > found. if you had both sqlserver 2005 & 2008, the 2008 is probably not the
    > default instance. either specify the instance, or create a new default
    > instance (reinstall sqlserver 2008)
    >
    > -- bruce (sqlwork.com)
    >
    >
    > "AAaron123" wrote:
    >
    >>
    >> I downloaded the personal website starter kit and when I run it I get the
    >> error shown below.
    >> I found a way of using Launch Surface Area Configuration that is
    >> supposed
    >> to fix the remote setting but I tried it and still get the error.
    >>
    >> I do not have SQL Server 2005 installed (thought I did once). I do have
    >> SQL
    >> Server 2008 installed.
    >>
    >> I don't see anywhere in the code where SQL Server 2005 is referenced.
    >>
    >> Don't I have to tell in the code that I want to use SQL Server 2008?
    >> Suppose I hade both on my machine?
    >>
    >> Do I have some registry entry that did not get up dated from the 2005 to
    >> the
    >> 2008 versions?
    >>
    >> Thanks for any help.
    >>
    >>
    >>
    >> An error has occurred while establishing a connection to the server.
    >> When
    >> connecting to SQL Server 2005, this failure may be caused by the fact
    >> that
    >> under the default settings SQL Server does not allow remote connections.
    >> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >> Server/Instance Specified)
    >> Description: An unhandled exception occurred during the execution of the
    >> current web request. Please review the stack trace for more information
    >> about the error and where it originated in the code.
    >>
    >> Exception Details: System.Data.SqlClient.SqlException: An error has
    >> occurred
    >> while establishing a connection to the server. When connecting to SQL
    >> Server 2005, this failure may be caused by the fact that under the
    >> default
    >> settings SQL Server does not allow remote connections. (provider: SQL
    >> Network Interfaces, error: 26 - Error Locating Server/Instance Specified)
    >>
    >> Source Error:
    >>
    >> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    >> connection)
    >> Line 195: command.CommandType = CommandType.StoredProcedure
    >> Line 196: connection.Open()
    >> Line 197: Dim list As New Generic.List(Of Album)()
    >> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>
    >> Source File: I:\MyDocuments\Visual Studio
    >> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    >>
    >>
    >>
    >>
     
    AAaron123, Jul 18, 2008
    #6
  7. Hello AAaron123,

    ".\SQLExpress" means that you are connecting to SQL Express server. It's
    standard build-in name
    If you want to connect to SQL Server (not express) you need to change this
    line on "(local)".

    Btw, if you have SQL Management Studio installed (install if you not) then
    you cant check which sevices you have and their names)

    Alternatively, you can use Server tabs in visual studio and it shows available
    SQL server around you. After u connect to one of them in shows your connection
    string in properties. You can copy paste that connection string into your
    web.config

    ---
    WBR,
    Michael Nemtsev [Microsoft MVP] :: blog: http://spaces.live.com/laflour

    "The greatest danger for most of us is not that our aim is too high and we
    miss it, but that it is too low and we reach it" (c) Michelangelo


    A> I find two such strings as shown below.
    A>
    A> I see now that who ever wrote this assumed it would be used with the
    A> Express
    A> version.
    A> How do I change it to point to the SQL Server2005?
    A> Also, I do see the file Personal.mdf in the solution list of file
    A> names.
    A> But I do not see the file aspnetdb.mdf there. Do you thing the
    A> program might
    A> create it when it runs?
    A> Finally, the error message mentioned SQL2005 as if it converted from
    A> the Express to 2005 since that is what it found. If that's the case
    A> why didn't it make the connection?
    A>
    A> Very confusing!
    A>
    A> Thanks for the help
    A>
    A> ...
    A> <add name="Personal" connectionString="Data
    A> Source=.\SQLExpress;Integrated
    A> Security=True;User
    A> Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
    A> providerName="System.Data.SqlClient"/>
    A> <remove name="LocalSqlServer"/>
    A> <add name="LocalSqlServer" connectionString="Data
    A> Source=.\SQLExpress;Integrated Security=True;User
    A> Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf"/>
    A> </connectionStrings>
    A> "Michael Nemtsev [MVP]" <> wrote in message
    A> news:...
    A>
    >> Hello AAaron123,
    >>
    >> Check the web.config, where should be the "connectionstring"
    >> attribute,
    >> where they specify where to connect
    >> of this can be somewhere in code
    >> ---
    >> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >> http://spaces.live.com/laflour
    >> "The greatest danger for most of us is not that our aim is too high
    >> and we
    >> miss it, but that it is too low and we reach it" (c) Michelangelo
    >> A> I downloaded the personal website starter kit and when I run it I
    >> get
    >> A> the
    >> A> error shown below.
    >> A> I found a way of using Launch Surface Area Configuration that is
    >> A> supposed
    >> A> to fix the remote setting but I tried it and still get the error.
    >> A> I do not have SQL Server 2005 installed (thought I did once). I do
    >> A> have SQL Server 2008 installed.
    >> A> A> I don't see anywhere in the code where SQL Server 2005 is
    >> referenced.
    >> A> A> Don't I have to tell in the code that I want to use SQL Server
    >> 2008?
    >> A> Suppose I hade both on my machine?
    >> A> A> Do I have some registry entry that did not get up dated from
    >> the
    >> 2005
    >> A> to the 2008 versions?
    >> A> A> Thanks for any help.
    >> A> A> An error has occurred while establishing a connection to the
    >> server.
    >> A> When
    >> A> connecting to SQL Server 2005, this failure may be caused by the
    >> fact
    >> A> that
    >> A> under the default settings SQL Server does not allow remote
    >> A> connections.
    >> A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >> A> Server/Instance Specified)
    >> A> Description: An unhandled exception occurred during the execution
    >> of
    >> A> the
    >> A> current web request. Please review the stack trace for more
    >> A> information
    >> A> about the error and where it originated in the code.
    >> A> Exception Details: System.Data.SqlClient.SqlException: An error
    >> has
    >> A> occurred while establishing a connection to the server. When
    >> A> connecting to SQL Server 2005, this failure may be caused by the
    >> fact
    >> A> that under the default settings SQL Server does not allow remote
    >> A> connections. (provider: SQL Network Interfaces, error: 26 - Error
    >> A> Locating Server/Instance Specified)
    >> A> A> Source Error:
    >> A> A> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    >> A> connection)
    >> A> Line 195: command.CommandType = CommandType.StoredProcedure
    >> A> Line 196: connection.Open()
    >> A> Line 197: Dim list As New Generic.List(Of Album)()
    >> A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >> A> Source File: I:\MyDocuments\Visual Studio
    >> A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line:
    >> 196
    >> A>
     
    Michael Nemtsev [MVP], Jul 18, 2008
    #7
  8. AAaron123

    bruce barker Guest

    a mdf file is a detached database. to create one you create a database
    in sqlserver, then detach it (via a sql command).

    in the connect string you can specify a mdf to auto attach which is
    useful for simple sites. you can upload the database then attach on the
    first connect.

    from a programs point of view there is no difference between sqlexpress
    and sqlserver 2005. only the license is different, and the tools
    supplied.

    to connect to a sqlserver you need to know the server its on and the
    instance name. this is specified in the connect string, along with
    default database, and an attach command if desired.

    if you have sql2005, then run the management studio and browse for
    sqlservers. this will list the instance names.


    read the docs on sqlserver connect strings

    -- bruce (sqlwork.com)



    AAaron123 wrote:
    > I'll ask you the same questions I asked Michael Nemtsev.
    >
    > I find two such strings as shown below.
    >
    > I see now that who ever wrote this assumed it would be used with the Express
    > version.
    > How do I change it to point to the SQL Server2005?
    >
    >
    > Also, I do see the file Personal.mdf in the solution list of file names.
    > But I do not see the file aspnetdb.mdf there. Do you thing the program might
    > create it when it runs?
    >
    > Finally, the error message mentioned SQL2005 as if it converted from the
    > Express to 2005 since that is what it found. If that's the case why didn't
    > it make the connection?
    >
    > Very confusing!
    >
    > Thanks for the help
    >
    > "bruce barker" <> wrote in message
    > news:...
    >> the error means the sqlserver specified in the connection string was not
    >> found. if you had both sqlserver 2005 & 2008, the 2008 is probably not the
    >> default instance. either specify the instance, or create a new default
    >> instance (reinstall sqlserver 2008)
    >>
    >> -- bruce (sqlwork.com)
    >>
    >>
    >> "AAaron123" wrote:
    >>
    >>> I downloaded the personal website starter kit and when I run it I get the
    >>> error shown below.
    >>> I found a way of using Launch Surface Area Configuration that is
    >>> supposed
    >>> to fix the remote setting but I tried it and still get the error.
    >>>
    >>> I do not have SQL Server 2005 installed (thought I did once). I do have
    >>> SQL
    >>> Server 2008 installed.
    >>>
    >>> I don't see anywhere in the code where SQL Server 2005 is referenced.
    >>>
    >>> Don't I have to tell in the code that I want to use SQL Server 2008?
    >>> Suppose I hade both on my machine?
    >>>
    >>> Do I have some registry entry that did not get up dated from the 2005 to
    >>> the
    >>> 2008 versions?
    >>>
    >>> Thanks for any help.
    >>>
    >>>
    >>>
    >>> An error has occurred while establishing a connection to the server.
    >>> When
    >>> connecting to SQL Server 2005, this failure may be caused by the fact
    >>> that
    >>> under the default settings SQL Server does not allow remote connections.
    >>> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>> Server/Instance Specified)
    >>> Description: An unhandled exception occurred during the execution of the
    >>> current web request. Please review the stack trace for more information
    >>> about the error and where it originated in the code.
    >>>
    >>> Exception Details: System.Data.SqlClient.SqlException: An error has
    >>> occurred
    >>> while establishing a connection to the server. When connecting to SQL
    >>> Server 2005, this failure may be caused by the fact that under the
    >>> default
    >>> settings SQL Server does not allow remote connections. (provider: SQL
    >>> Network Interfaces, error: 26 - Error Locating Server/Instance Specified)
    >>>
    >>> Source Error:
    >>>
    >>> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    >>> connection)
    >>> Line 195: command.CommandType = CommandType.StoredProcedure
    >>> Line 196: connection.Open()
    >>> Line 197: Dim list As New Generic.List(Of Album)()
    >>> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>
    >>> Source File: I:\MyDocuments\Visual Studio
    >>> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    >>>
    >>>
    >>>
    >>>

    >
    >
     
    bruce barker, Jul 18, 2008
    #8
  9. AAaron123

    AAaron123 Guest

    "Michael Nemtsev [MVP]" <> wrote in message
    news:...
    > Hello AAaron123,
    >
    > ".\SQLExpress" means that you are connecting to SQL Express server. It's
    > standard build-in name
    > If you want to connect to SQL Server (not express) you need to change this
    > line on "(local)".
    >
    > Btw, if you have SQL Management Studio installed (install if you not) then
    > you cant check which sevices you have and their names)



    The default instance is unnamed and is shown as the computer name.
    How do I reference that in the
    connectionString="Data Source=

    thanks for staying with me

    >
    > Alternatively, you can use Server tabs in visual studio and it shows
    > available SQL server around you. After u connect to one of them in shows
    > your connection string in properties. You can copy paste that connection
    > string into your web.config
    >
    > ---
    > WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    > http://spaces.live.com/laflour
    > "The greatest danger for most of us is not that our aim is too high and we
    > miss it, but that it is too low and we reach it" (c) Michelangelo
    >
    > A> I find two such strings as shown below.
    > A> A> I see now that who ever wrote this assumed it would be used with the
    > A> Express
    > A> version.
    > A> How do I change it to point to the SQL Server2005?
    > A> Also, I do see the file Personal.mdf in the solution list of file
    > A> names.
    > A> But I do not see the file aspnetdb.mdf there. Do you thing the
    > A> program might
    > A> create it when it runs?
    > A> Finally, the error message mentioned SQL2005 as if it converted from
    > A> the Express to 2005 since that is what it found. If that's the case
    > A> why didn't it make the connection?
    > A> A> Very confusing!
    > A> A> Thanks for the help
    > A> A> ...
    > A> <add name="Personal" connectionString="Data
    > A> Source=.\SQLExpress;Integrated
    > A> Security=True;User
    > A> Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
    > A> providerName="System.Data.SqlClient"/>
    > A> <remove name="LocalSqlServer"/>
    > A> <add name="LocalSqlServer" connectionString="Data
    > A> Source=.\SQLExpress;Integrated Security=True;User
    > A> Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf"/>
    > A> </connectionStrings>
    > A> "Michael Nemtsev [MVP]" <> wrote in message
    > A> news:...
    > A>
    >>> Hello AAaron123,
    >>>
    >>> Check the web.config, where should be the "connectionstring"
    >>> attribute,
    >>> where they specify where to connect
    >>> of this can be somewhere in code
    >>> ---
    >>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>> http://spaces.live.com/laflour
    >>> "The greatest danger for most of us is not that our aim is too high
    >>> and we
    >>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>> A> I downloaded the personal website starter kit and when I run it I
    >>> get
    >>> A> the
    >>> A> error shown below.
    >>> A> I found a way of using Launch Surface Area Configuration that is
    >>> A> supposed
    >>> A> to fix the remote setting but I tried it and still get the error.
    >>> A> I do not have SQL Server 2005 installed (thought I did once). I do
    >>> A> have SQL Server 2008 installed.
    >>> A> A> I don't see anywhere in the code where SQL Server 2005 is
    >>> referenced.
    >>> A> A> Don't I have to tell in the code that I want to use SQL Server
    >>> 2008?
    >>> A> Suppose I hade both on my machine?
    >>> A> A> Do I have some registry entry that did not get up dated from
    >>> the
    >>> 2005
    >>> A> to the 2008 versions?
    >>> A> A> Thanks for any help.
    >>> A> A> An error has occurred while establishing a connection to the
    >>> server.
    >>> A> When
    >>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>> fact
    >>> A> that
    >>> A> under the default settings SQL Server does not allow remote
    >>> A> connections.
    >>> A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>> A> Server/Instance Specified)
    >>> A> Description: An unhandled exception occurred during the execution
    >>> of
    >>> A> the
    >>> A> current web request. Please review the stack trace for more
    >>> A> information
    >>> A> about the error and where it originated in the code.
    >>> A> Exception Details: System.Data.SqlClient.SqlException: An error
    >>> has
    >>> A> occurred while establishing a connection to the server. When
    >>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>> fact
    >>> A> that under the default settings SQL Server does not allow remote
    >>> A> connections. (provider: SQL Network Interfaces, error: 26 - Error
    >>> A> Locating Server/Instance Specified)
    >>> A> A> Source Error:
    >>> A> A> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    >>> A> connection)
    >>> A> Line 195: command.CommandType = CommandType.StoredProcedure
    >>> A> Line 196: connection.Open()
    >>> A> Line 197: Dim list As New Generic.List(Of Album)()
    >>> A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>> A> Source File: I:\MyDocuments\Visual Studio
    >>> A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line:
    >>> 196
    >>> A>

    >
    >
     
    AAaron123, Jul 18, 2008
    #9
  10. AAaron123

    AAaron123 Guest

    "bruce barker" <> wrote in message
    news:e$...
    >a mdf file is a detached database. to create one you create a database in
    >sqlserver, then detach it (via a sql command).
    >
    > in the connect string you can specify a mdf to auto attach which is useful
    > for simple sites. you can upload the database then attach on the first
    > connect.
    >
    > from a programs point of view there is no difference between sqlexpress
    > and sqlserver 2005. only the license is different, and the tools supplied.
    >
    > to connect to a sqlserver you need to know the server its on and the
    > instance name. this is specified in the connect string, along with default
    > database, and an attach command if desired.
    >
    > if you have sql2005, then run the management studio and browse for
    > sqlservers. this will list the instance names.




    The default instance is unnamed and is shown as the computer name.
    How do I reference that in the
    connectionString="Data Source=

    thanks for staying with me


    >
    >
    > read the docs on sqlserver connect strings


    This helped using management studio

    >
    > -- bruce (sqlwork.com)
    >
    >
    >
    > AAaron123 wrote:
    >> I'll ask you the same questions I asked Michael Nemtsev.
    >>
    >> I find two such strings as shown below.
    >>
    >> I see now that who ever wrote this assumed it would be used with the
    >> Express version.
    >> How do I change it to point to the SQL Server2005?
    >>
    >>
    >> Also, I do see the file Personal.mdf in the solution list of file names.
    >> But I do not see the file aspnetdb.mdf there. Do you thing the program
    >> might create it when it runs?
    >>
    >> Finally, the error message mentioned SQL2005 as if it converted from the
    >> Express to 2005 since that is what it found. If that's the case why
    >> didn't it make the connection?
    >>
    >> Very confusing!
    >>
    >> Thanks for the help
    >>
    >> "bruce barker" <> wrote in message
    >> news:...
    >>> the error means the sqlserver specified in the connection string was not
    >>> found. if you had both sqlserver 2005 & 2008, the 2008 is probably not
    >>> the
    >>> default instance. either specify the instance, or create a new default
    >>> instance (reinstall sqlserver 2008)
    >>>
    >>> -- bruce (sqlwork.com)
    >>>
    >>>
    >>> "AAaron123" wrote:
    >>>
    >>>> I downloaded the personal website starter kit and when I run it I get
    >>>> the
    >>>> error shown below.
    >>>> I found a way of using Launch Surface Area Configuration that is
    >>>> supposed
    >>>> to fix the remote setting but I tried it and still get the error.
    >>>>
    >>>> I do not have SQL Server 2005 installed (thought I did once). I do have
    >>>> SQL
    >>>> Server 2008 installed.
    >>>>
    >>>> I don't see anywhere in the code where SQL Server 2005 is referenced.
    >>>>
    >>>> Don't I have to tell in the code that I want to use SQL Server 2008?
    >>>> Suppose I hade both on my machine?
    >>>>
    >>>> Do I have some registry entry that did not get up dated from the 2005
    >>>> to the
    >>>> 2008 versions?
    >>>>
    >>>> Thanks for any help.
    >>>>
    >>>>
    >>>>
    >>>> An error has occurred while establishing a connection to the server.
    >>>> When
    >>>> connecting to SQL Server 2005, this failure may be caused by the fact
    >>>> that
    >>>> under the default settings SQL Server does not allow remote
    >>>> connections.
    >>>> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>>> Server/Instance Specified)
    >>>> Description: An unhandled exception occurred during the execution of
    >>>> the
    >>>> current web request. Please review the stack trace for more information
    >>>> about the error and where it originated in the code.
    >>>>
    >>>> Exception Details: System.Data.SqlClient.SqlException: An error has
    >>>> occurred
    >>>> while establishing a connection to the server. When connecting to SQL
    >>>> Server 2005, this failure may be caused by the fact that under the
    >>>> default
    >>>> settings SQL Server does not allow remote connections. (provider: SQL
    >>>> Network Interfaces, error: 26 - Error Locating Server/Instance
    >>>> Specified)
    >>>>
    >>>> Source Error:
    >>>>
    >>>> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    >>>> connection)
    >>>> Line 195: command.CommandType = CommandType.StoredProcedure
    >>>> Line 196: connection.Open()
    >>>> Line 197: Dim list As New Generic.List(Of Album)()
    >>>> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>>
    >>>> Source File: I:\MyDocuments\Visual Studio
    >>>> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    >>>>
    >>>>
    >>>>
    >>>>

    >>
     
    AAaron123, Jul 18, 2008
    #10
  11. re:
    !> How do I reference that in the connectionString="Data Source=

    Use the same name which the SQL Server Service Manager shows.

    You should have an icon for the SQL Server Service Manager in your Taskbar Tray.
    Double click it...and use the exact name it shows.

    If the service manager isn't running, run it from
    "Start Menu", "Programs", "SQL Server", "Service Manager".





    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "AAaron123" <> wrote in message news:...
    >
    > "bruce barker" <> wrote in message news:e$...
    >>a mdf file is a detached database. to create one you create a database in sqlserver, then detach it (via a sql
    >>command).
    >>
    >> in the connect string you can specify a mdf to auto attach which is useful for simple sites. you can upload the
    >> database then attach on the first connect.
    >>
    >> from a programs point of view there is no difference between sqlexpress and sqlserver 2005. only the license is
    >> different, and the tools supplied.
    >>
    >> to connect to a sqlserver you need to know the server its on and the instance name. this is specified in the connect
    >> string, along with default database, and an attach command if desired.
    >>
    >> if you have sql2005, then run the management studio and browse for sqlservers. this will list the instance names.

    >
    >
    >
    > The default instance is unnamed and is shown as the computer name.
    > How do I reference that in the
    > connectionString="Data Source=
    >
    > thanks for staying with me
    >
    >
    >>
    >>
    >> read the docs on sqlserver connect strings

    >
    > This helped using management studio
    >
    >>
    >> -- bruce (sqlwork.com)
    >>
    >>
    >>
    >> AAaron123 wrote:
    >>> I'll ask you the same questions I asked Michael Nemtsev.
    >>>
    >>> I find two such strings as shown below.
    >>>
    >>> I see now that who ever wrote this assumed it would be used with the Express version.
    >>> How do I change it to point to the SQL Server2005?
    >>>
    >>>
    >>> Also, I do see the file Personal.mdf in the solution list of file names.
    >>> But I do not see the file aspnetdb.mdf there. Do you thing the program might create it when it runs?
    >>>
    >>> Finally, the error message mentioned SQL2005 as if it converted from the Express to 2005 since that is what it
    >>> found. If that's the case why didn't it make the connection?
    >>>
    >>> Very confusing!
    >>>
    >>> Thanks for the help
    >>>
    >>> "bruce barker" <> wrote in message
    >>> news:...
    >>>> the error means the sqlserver specified in the connection string was not
    >>>> found. if you had both sqlserver 2005 & 2008, the 2008 is probably not the
    >>>> default instance. either specify the instance, or create a new default
    >>>> instance (reinstall sqlserver 2008)
    >>>>
    >>>> -- bruce (sqlwork.com)
    >>>>
    >>>>
    >>>> "AAaron123" wrote:
    >>>>
    >>>>> I downloaded the personal website starter kit and when I run it I get the
    >>>>> error shown below.
    >>>>> I found a way of using Launch Surface Area Configuration that is supposed
    >>>>> to fix the remote setting but I tried it and still get the error.
    >>>>>
    >>>>> I do not have SQL Server 2005 installed (thought I did once). I do have SQL
    >>>>> Server 2008 installed.
    >>>>>
    >>>>> I don't see anywhere in the code where SQL Server 2005 is referenced.
    >>>>>
    >>>>> Don't I have to tell in the code that I want to use SQL Server 2008?
    >>>>> Suppose I hade both on my machine?
    >>>>>
    >>>>> Do I have some registry entry that did not get up dated from the 2005 to the
    >>>>> 2008 versions?
    >>>>>
    >>>>> Thanks for any help.
    >>>>>
    >>>>>
    >>>>>
    >>>>> An error has occurred while establishing a connection to the server. When
    >>>>> connecting to SQL Server 2005, this failure may be caused by the fact that
    >>>>> under the default settings SQL Server does not allow remote connections.
    >>>>> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>>>> Server/Instance Specified)
    >>>>> Description: An unhandled exception occurred during the execution of the
    >>>>> current web request. Please review the stack trace for more information
    >>>>> about the error and where it originated in the code.
    >>>>>
    >>>>> Exception Details: System.Data.SqlClient.SqlException: An error has occurred
    >>>>> while establishing a connection to the server. When connecting to SQL
    >>>>> Server 2005, this failure may be caused by the fact that under the default
    >>>>> settings SQL Server does not allow remote connections. (provider: SQL
    >>>>> Network Interfaces, error: 26 - Error Locating Server/Instance Specified)
    >>>>>
    >>>>> Source Error:
    >>>>>
    >>>>> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums", connection)
    >>>>> Line 195: command.CommandType = CommandType.StoredProcedure
    >>>>> Line 196: connection.Open()
    >>>>> Line 197: Dim list As New Generic.List(Of Album)()
    >>>>> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>>>
    >>>>> Source File: I:\MyDocuments\Visual Studio
    >>>>> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>

    >
     
    Juan T. Llibre, Jul 18, 2008
    #11
  12. AAaron123

    AAaron123 Guest

    One of my earlier tries was to simply changed Data Source=./SQLExpress to
    Data Source=./zz

    where zz is the name SQL Server Service Manager shows which is just the
    computer name followed by nothing else. Guess that's the way the default
    instance is named.

    That did not work but when I removed the .\ it worked.

    What does the dot stand for?



    What if I run the program on another machine? Maybe using just the dot means
    use the default instance. I'll try that now to see if it works. Comment?



    I also had to remove User Instance=True which I guess is unique to the
    Express version. Read the help but still don't know if removing will bite me
    later. Think so?



    SQL Server Service Manager Studio does not appear in my Taskbar tray when
    it's running. Maybe there's an option I have to find for that to happen.

    Thanks a lot


    "Juan T. Llibre" <> wrote in message
    news:...
    > re:
    > !> How do I reference that in the connectionString="Data Source=
    >
    > Use the same name which the SQL Server Service Manager shows.
    >
    > You should have an icon for the SQL Server Service Manager in your Taskbar
    > Tray.
    > Double click it...and use the exact name it shows.
    >
    > If the service manager isn't running, run it from
    > "Start Menu", "Programs", "SQL Server", "Service Manager".
    >
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "AAaron123" <> wrote in message
    > news:...
    >>
    >> "bruce barker" <> wrote in message
    >> news:e$...
    >>>a mdf file is a detached database. to create one you create a database in
    >>>sqlserver, then detach it (via a sql command).
    >>>
    >>> in the connect string you can specify a mdf to auto attach which is
    >>> useful for simple sites. you can upload the database then attach on the
    >>> first connect.
    >>>
    >>> from a programs point of view there is no difference between sqlexpress
    >>> and sqlserver 2005. only the license is different, and the tools
    >>> supplied.
    >>>
    >>> to connect to a sqlserver you need to know the server its on and the
    >>> instance name. this is specified in the connect string, along with
    >>> default database, and an attach command if desired.
    >>>
    >>> if you have sql2005, then run the management studio and browse for
    >>> sqlservers. this will list the instance names.

    >>
    >>
    >>
    >> The default instance is unnamed and is shown as the computer name.
    >> How do I reference that in the
    >> connectionString="Data Source=
    >>
    >> thanks for staying with me
    >>
    >>
    >>>
    >>>
    >>> read the docs on sqlserver connect strings

    >>
    >> This helped using management studio
    >>
    >>>
    >>> -- bruce (sqlwork.com)
    >>>
    >>>
    >>>
    >>> AAaron123 wrote:
    >>>> I'll ask you the same questions I asked Michael Nemtsev.
    >>>>
    >>>> I find two such strings as shown below.
    >>>>
    >>>> I see now that who ever wrote this assumed it would be used with the
    >>>> Express version.
    >>>> How do I change it to point to the SQL Server2005?
    >>>>
    >>>>
    >>>> Also, I do see the file Personal.mdf in the solution list of file
    >>>> names.
    >>>> But I do not see the file aspnetdb.mdf there. Do you thing the program
    >>>> might create it when it runs?
    >>>>
    >>>> Finally, the error message mentioned SQL2005 as if it converted from
    >>>> the Express to 2005 since that is what it found. If that's the case why
    >>>> didn't it make the connection?
    >>>>
    >>>> Very confusing!
    >>>>
    >>>> Thanks for the help
    >>>>
    >>>> "bruce barker" <> wrote in message
    >>>> news:...
    >>>>> the error means the sqlserver specified in the connection string was
    >>>>> not
    >>>>> found. if you had both sqlserver 2005 & 2008, the 2008 is probably not
    >>>>> the
    >>>>> default instance. either specify the instance, or create a new default
    >>>>> instance (reinstall sqlserver 2008)
    >>>>>
    >>>>> -- bruce (sqlwork.com)
    >>>>>
    >>>>>
    >>>>> "AAaron123" wrote:
    >>>>>
    >>>>>> I downloaded the personal website starter kit and when I run it I get
    >>>>>> the
    >>>>>> error shown below.
    >>>>>> I found a way of using Launch Surface Area Configuration that is
    >>>>>> supposed
    >>>>>> to fix the remote setting but I tried it and still get the error.
    >>>>>>
    >>>>>> I do not have SQL Server 2005 installed (thought I did once). I do
    >>>>>> have SQL
    >>>>>> Server 2008 installed.
    >>>>>>
    >>>>>> I don't see anywhere in the code where SQL Server 2005 is referenced.
    >>>>>>
    >>>>>> Don't I have to tell in the code that I want to use SQL Server 2008?
    >>>>>> Suppose I hade both on my machine?
    >>>>>>
    >>>>>> Do I have some registry entry that did not get up dated from the 2005
    >>>>>> to the
    >>>>>> 2008 versions?
    >>>>>>
    >>>>>> Thanks for any help.
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> An error has occurred while establishing a connection to the server.
    >>>>>> When
    >>>>>> connecting to SQL Server 2005, this failure may be caused by the fact
    >>>>>> that
    >>>>>> under the default settings SQL Server does not allow remote
    >>>>>> connections.
    >>>>>> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>>>>> Server/Instance Specified)
    >>>>>> Description: An unhandled exception occurred during the execution of
    >>>>>> the
    >>>>>> current web request. Please review the stack trace for more
    >>>>>> information
    >>>>>> about the error and where it originated in the code.
    >>>>>>
    >>>>>> Exception Details: System.Data.SqlClient.SqlException: An error has
    >>>>>> occurred
    >>>>>> while establishing a connection to the server. When connecting to
    >>>>>> SQL
    >>>>>> Server 2005, this failure may be caused by the fact that under the
    >>>>>> default
    >>>>>> settings SQL Server does not allow remote connections. (provider: SQL
    >>>>>> Network Interfaces, error: 26 - Error Locating Server/Instance
    >>>>>> Specified)
    >>>>>>
    >>>>>> Source Error:
    >>>>>>
    >>>>>> Line 194: Using command As New SqlCommand("GetNonEmptyAlbums",
    >>>>>> connection)
    >>>>>> Line 195: command.CommandType = CommandType.StoredProcedure
    >>>>>> Line 196: connection.Open()
    >>>>>> Line 197: Dim list As New Generic.List(Of Album)()
    >>>>>> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>>>>
    >>>>>> Source File: I:\MyDocuments\Visual Studio
    >>>>>> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line: 196
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>

    >>

    >
    >
     
    AAaron123, Jul 18, 2008
    #12
  13. Hello AAaron123,

    Just specify you PC name in the connection string
    instead of "Data Source=.\SQLExpress;
    use "Data Source=YOUPCNAME;

    ---
    WBR,
    Michael Nemtsev [Microsoft MVP] :: blog: http://spaces.live.com/laflour

    "The greatest danger for most of us is not that our aim is too high and we
    miss it, but that it is too low and we reach it" (c) Michelangelo


    A> "Michael Nemtsev [MVP]" <> wrote in message
    A> news:...
    A>
    >> Hello AAaron123,
    >>
    >> ".\SQLExpress" means that you are connecting to SQL Express server.
    >> It's
    >> standard build-in name
    >> If you want to connect to SQL Server (not express) you need to change
    >> this
    >> line on "(local)".
    >> Btw, if you have SQL Management Studio installed (install if you not)
    >> then you cant check which sevices you have and their names)
    >>

    A> The default instance is unnamed and is shown as the computer name.
    A> How do I reference that in the
    A> connectionString="Data Source=
    A> thanks for staying with me
    A>
    >> Alternatively, you can use Server tabs in visual studio and it shows
    >> available SQL server around you. After u connect to one of them in
    >> shows your connection string in properties. You can copy paste that
    >> connection string into your web.config
    >>
    >> ---
    >> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >> http://spaces.live.com/laflour
    >> "The greatest danger for most of us is not that our aim is too high
    >> and we
    >> miss it, but that it is too low and we reach it" (c) Michelangelo
    >> A> I find two such strings as shown below.
    >> A> A> I see now that who ever wrote this assumed it would be used
    >> with the
    >> A> Express
    >> A> version.
    >> A> How do I change it to point to the SQL Server2005?
    >> A> Also, I do see the file Personal.mdf in the solution list of file
    >> A> names.
    >> A> But I do not see the file aspnetdb.mdf there. Do you thing the
    >> A> program might
    >> A> create it when it runs?
    >> A> Finally, the error message mentioned SQL2005 as if it converted
    >> from
    >> A> the Express to 2005 since that is what it found. If that's the
    >> case
    >> A> why didn't it make the connection?
    >> A> A> Very confusing!
    >> A> A> Thanks for the help
    >> A> A> ...
    >> A> <add name="Personal" connectionString="Data
    >> A> Source=.\SQLExpress;Integrated
    >> A> Security=True;User
    >> A> Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
    >> A> providerName="System.Data.SqlClient"/>
    >> A> <remove name="LocalSqlServer"/>
    >> A> <add name="LocalSqlServer" connectionString="Data
    >> A> Source=.\SQLExpress;Integrated Security=True;User
    >> A> Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf"/>
    >> A> </connectionStrings>
    >> A> "Michael Nemtsev [MVP]" <> wrote in message
    >> A> news:...
    >> A>
    >>>> Hello AAaron123,
    >>>>
    >>>> Check the web.config, where should be the "connectionstring"
    >>>> attribute,
    >>>> where they specify where to connect
    >>>> of this can be somewhere in code
    >>>> ---
    >>>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>>> http://spaces.live.com/laflour
    >>>> "The greatest danger for most of us is not that our aim is too high
    >>>> and we
    >>>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>>> A> I downloaded the personal website starter kit and when I run it
    >>>> I
    >>>> get
    >>>> A> the
    >>>> A> error shown below.
    >>>> A> I found a way of using Launch Surface Area Configuration that
    >>>> is
    >>>> A> supposed
    >>>> A> to fix the remote setting but I tried it and still get the
    >>>> error.
    >>>> A> I do not have SQL Server 2005 installed (thought I did once). I
    >>>> do
    >>>> A> have SQL Server 2008 installed.
    >>>> A> A> I don't see anywhere in the code where SQL Server 2005 is
    >>>> referenced.
    >>>> A> A> Don't I have to tell in the code that I want to use SQL
    >>>> Server
    >>>> 2008?
    >>>> A> Suppose I hade both on my machine?
    >>>> A> A> Do I have some registry entry that did not get up dated from
    >>>> the
    >>>> 2005
    >>>> A> to the 2008 versions?
    >>>> A> A> Thanks for any help.
    >>>> A> A> An error has occurred while establishing a connection to the
    >>>> server.
    >>>> A> When
    >>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>> fact
    >>>> A> that
    >>>> A> under the default settings SQL Server does not allow remote
    >>>> A> connections.
    >>>> A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>>> A> Server/Instance Specified)
    >>>> A> Description: An unhandled exception occurred during the
    >>>> execution
    >>>> of
    >>>> A> the
    >>>> A> current web request. Please review the stack trace for more
    >>>> A> information
    >>>> A> about the error and where it originated in the code.
    >>>> A> Exception Details: System.Data.SqlClient.SqlException: An error
    >>>> has
    >>>> A> occurred while establishing a connection to the server. When
    >>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>> fact
    >>>> A> that under the default settings SQL Server does not allow remote
    >>>> A> connections. (provider: SQL Network Interfaces, error: 26 -
    >>>> Error
    >>>> A> Locating Server/Instance Specified)
    >>>> A> A> Source Error:
    >>>> A> A> Line 194: Using command As New
    >>>> SqlCommand("GetNonEmptyAlbums",
    >>>> A> connection)
    >>>> A> Line 195: command.CommandType = CommandType.StoredProcedure
    >>>> A> Line 196: connection.Open()
    >>>> A> Line 197: Dim list As New Generic.List(Of Album)()
    >>>> A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>> A> Source File: I:\MyDocuments\Visual Studio
    >>>> A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line:
    >>>> 196
    >>>> A>
     
    Michael Nemtsev [MVP], Jul 19, 2008
    #13
  14. AAaron123

    AAaron123 Guest

    That works!

    But now the code will only run on my machine (I assume).
    "Data Source=.; also appears to work.
    Will that use the default instance on any machine the code is loaded on?


    How do people prepare code to work on multiple machines without hard coding
    for the default instance?

    Thanks


    "Michael Nemtsev [MVP]" <> wrote in message
    news:...
    > Hello AAaron123,
    >
    > Just specify you PC name in the connection string
    > instead of "Data Source=.\SQLExpress;
    > use "Data Source=YOUPCNAME;
    >
    > ---
    > WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    > http://spaces.live.com/laflour
    > "The greatest danger for most of us is not that our aim is too high and we
    > miss it, but that it is too low and we reach it" (c) Michelangelo
    >
    > A> "Michael Nemtsev [MVP]" <> wrote in message
    > A> news:...
    > A>
    >>> Hello AAaron123,
    >>>
    >>> ".\SQLExpress" means that you are connecting to SQL Express server.
    >>> It's
    >>> standard build-in name
    >>> If you want to connect to SQL Server (not express) you need to change
    >>> this
    >>> line on "(local)".
    >>> Btw, if you have SQL Management Studio installed (install if you not)
    >>> then you cant check which sevices you have and their names)
    >>>

    > A> The default instance is unnamed and is shown as the computer name.
    > A> How do I reference that in the
    > A> connectionString="Data Source=
    > A> thanks for staying with me
    > A>
    >>> Alternatively, you can use Server tabs in visual studio and it shows
    >>> available SQL server around you. After u connect to one of them in
    >>> shows your connection string in properties. You can copy paste that
    >>> connection string into your web.config
    >>>
    >>> ---
    >>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>> http://spaces.live.com/laflour
    >>> "The greatest danger for most of us is not that our aim is too high
    >>> and we
    >>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>> A> I find two such strings as shown below.
    >>> A> A> I see now that who ever wrote this assumed it would be used
    >>> with the
    >>> A> Express
    >>> A> version.
    >>> A> How do I change it to point to the SQL Server2005?
    >>> A> Also, I do see the file Personal.mdf in the solution list of file
    >>> A> names.
    >>> A> But I do not see the file aspnetdb.mdf there. Do you thing the
    >>> A> program might
    >>> A> create it when it runs?
    >>> A> Finally, the error message mentioned SQL2005 as if it converted
    >>> from
    >>> A> the Express to 2005 since that is what it found. If that's the
    >>> case
    >>> A> why didn't it make the connection?
    >>> A> A> Very confusing!
    >>> A> A> Thanks for the help
    >>> A> A> ...
    >>> A> <add name="Personal" connectionString="Data
    >>> A> Source=.\SQLExpress;Integrated
    >>> A> Security=True;User
    >>> A> Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
    >>> A> providerName="System.Data.SqlClient"/>
    >>> A> <remove name="LocalSqlServer"/>
    >>> A> <add name="LocalSqlServer" connectionString="Data
    >>> A> Source=.\SQLExpress;Integrated Security=True;User
    >>> A> Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf"/>
    >>> A> </connectionStrings>
    >>> A> "Michael Nemtsev [MVP]" <> wrote in message
    >>> A> news:...
    >>> A>
    >>>>> Hello AAaron123,
    >>>>>
    >>>>> Check the web.config, where should be the "connectionstring"
    >>>>> attribute,
    >>>>> where they specify where to connect
    >>>>> of this can be somewhere in code
    >>>>> ---
    >>>>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>>>> http://spaces.live.com/laflour
    >>>>> "The greatest danger for most of us is not that our aim is too high
    >>>>> and we
    >>>>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>>>> A> I downloaded the personal website starter kit and when I run it
    >>>>> I
    >>>>> get
    >>>>> A> the
    >>>>> A> error shown below.
    >>>>> A> I found a way of using Launch Surface Area Configuration that
    >>>>> is
    >>>>> A> supposed
    >>>>> A> to fix the remote setting but I tried it and still get the
    >>>>> error.
    >>>>> A> I do not have SQL Server 2005 installed (thought I did once). I
    >>>>> do
    >>>>> A> have SQL Server 2008 installed.
    >>>>> A> A> I don't see anywhere in the code where SQL Server 2005 is
    >>>>> referenced.
    >>>>> A> A> Don't I have to tell in the code that I want to use SQL
    >>>>> Server
    >>>>> 2008?
    >>>>> A> Suppose I hade both on my machine?
    >>>>> A> A> Do I have some registry entry that did not get up dated from
    >>>>> the
    >>>>> 2005
    >>>>> A> to the 2008 versions?
    >>>>> A> A> Thanks for any help.
    >>>>> A> A> An error has occurred while establishing a connection to the
    >>>>> server.
    >>>>> A> When
    >>>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>>> fact
    >>>>> A> that
    >>>>> A> under the default settings SQL Server does not allow remote
    >>>>> A> connections.
    >>>>> A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>>>> A> Server/Instance Specified)
    >>>>> A> Description: An unhandled exception occurred during the
    >>>>> execution
    >>>>> of
    >>>>> A> the
    >>>>> A> current web request. Please review the stack trace for more
    >>>>> A> information
    >>>>> A> about the error and where it originated in the code.
    >>>>> A> Exception Details: System.Data.SqlClient.SqlException: An error
    >>>>> has
    >>>>> A> occurred while establishing a connection to the server. When
    >>>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>>> fact
    >>>>> A> that under the default settings SQL Server does not allow remote
    >>>>> A> connections. (provider: SQL Network Interfaces, error: 26 -
    >>>>> Error
    >>>>> A> Locating Server/Instance Specified)
    >>>>> A> A> Source Error:
    >>>>> A> A> Line 194: Using command As New
    >>>>> SqlCommand("GetNonEmptyAlbums",
    >>>>> A> connection)
    >>>>> A> Line 195: command.CommandType = CommandType.StoredProcedure
    >>>>> A> Line 196: connection.Open()
    >>>>> A> Line 197: Dim list As New Generic.List(Of Album)()
    >>>>> A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>>> A> Source File: I:\MyDocuments\Visual Studio
    >>>>> A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line:
    >>>>> 196
    >>>>> A>

    >
    >
     
    AAaron123, Jul 19, 2008
    #14
  15. re:
    !> "Data Source=.; also appears to work.

    Indeed, because the dot ( . ) signifies the default instance.

    re:
    !> Will that use the default instance on any machine the code is loaded on?

    Yes, but remember that not all instances are default instances.
    Some are *named* instances.

    In the case of the SQL Express named instance ( Data Source=.\SQLExpress )
    what happens is that SQLExpress is the default name used for its named instance.

    So, the dot ( . ) plus the default named instance, creates the full name for the named instance.

    For SQL Server 2000, it's the same.

    You can use the dot for the default instance, which equates to the machine's name,
    but most installations create a named instance which needs to be added in order to
    get a fully qualified instance name.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "AAaron123" <> wrote in message news:...
    > That works!
    >
    > But now the code will only run on my machine (I assume).
    > "Data Source=.; also appears to work.
    > Will that use the default instance on any machine the code is loaded on?
    >
    >
    > How do people prepare code to work on multiple machines without hard coding for the default instance?
    >
    > Thanks
    >
    >
    > "Michael Nemtsev [MVP]" <> wrote in message news:...
    >> Hello AAaron123,
    >>
    >> Just specify you PC name in the connection string
    >> instead of "Data Source=.\SQLExpress;
    >> use "Data Source=YOUPCNAME;
    >>
    >> ---
    >> WBR, Michael Nemtsev [Microsoft MVP] :: blog: http://spaces.live.com/laflour
    >> "The greatest danger for most of us is not that our aim is too high and we miss it, but that it is too low and we
    >> reach it" (c) Michelangelo
    >>
    >> A> "Michael Nemtsev [MVP]" <> wrote in message
    >> A> news:...
    >> A>
    >>>> Hello AAaron123,
    >>>>
    >>>> ".\SQLExpress" means that you are connecting to SQL Express server.
    >>>> It's
    >>>> standard build-in name
    >>>> If you want to connect to SQL Server (not express) you need to change
    >>>> this
    >>>> line on "(local)".
    >>>> Btw, if you have SQL Management Studio installed (install if you not)
    >>>> then you cant check which sevices you have and their names)
    >>>>

    >> A> The default instance is unnamed and is shown as the computer name.
    >> A> How do I reference that in the
    >> A> connectionString="Data Source=
    >> A> thanks for staying with me
    >> A>
    >>>> Alternatively, you can use Server tabs in visual studio and it shows
    >>>> available SQL server around you. After u connect to one of them in
    >>>> shows your connection string in properties. You can copy paste that
    >>>> connection string into your web.config
    >>>>
    >>>> ---
    >>>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>>> http://spaces.live.com/laflour
    >>>> "The greatest danger for most of us is not that our aim is too high
    >>>> and we
    >>>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>>> A> I find two such strings as shown below.
    >>>> A> A> I see now that who ever wrote this assumed it would be used
    >>>> with the
    >>>> A> Express
    >>>> A> version.
    >>>> A> How do I change it to point to the SQL Server2005?
    >>>> A> Also, I do see the file Personal.mdf in the solution list of file
    >>>> A> names.
    >>>> A> But I do not see the file aspnetdb.mdf there. Do you thing the
    >>>> A> program might
    >>>> A> create it when it runs?
    >>>> A> Finally, the error message mentioned SQL2005 as if it converted
    >>>> from
    >>>> A> the Express to 2005 since that is what it found. If that's the
    >>>> case
    >>>> A> why didn't it make the connection?
    >>>> A> A> Very confusing!
    >>>> A> A> Thanks for the help
    >>>> A> A> ...
    >>>> A> <add name="Personal" connectionString="Data
    >>>> A> Source=.\SQLExpress;Integrated
    >>>> A> Security=True;User
    >>>> A> Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
    >>>> A> providerName="System.Data.SqlClient"/>
    >>>> A> <remove name="LocalSqlServer"/>
    >>>> A> <add name="LocalSqlServer" connectionString="Data
    >>>> A> Source=.\SQLExpress;Integrated Security=True;User
    >>>> A> Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf"/>
    >>>> A> </connectionStrings>
    >>>> A> "Michael Nemtsev [MVP]" <> wrote in message
    >>>> A> news:...
    >>>> A>
    >>>>>> Hello AAaron123,
    >>>>>>
    >>>>>> Check the web.config, where should be the "connectionstring"
    >>>>>> attribute,
    >>>>>> where they specify where to connect
    >>>>>> of this can be somewhere in code
    >>>>>> ---
    >>>>>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>>>>> http://spaces.live.com/laflour
    >>>>>> "The greatest danger for most of us is not that our aim is too high
    >>>>>> and we
    >>>>>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>>>>> A> I downloaded the personal website starter kit and when I run it
    >>>>>> I
    >>>>>> get
    >>>>>> A> the
    >>>>>> A> error shown below.
    >>>>>> A> I found a way of using Launch Surface Area Configuration that
    >>>>>> is
    >>>>>> A> supposed
    >>>>>> A> to fix the remote setting but I tried it and still get the
    >>>>>> error.
    >>>>>> A> I do not have SQL Server 2005 installed (thought I did once). I
    >>>>>> do
    >>>>>> A> have SQL Server 2008 installed.
    >>>>>> A> A> I don't see anywhere in the code where SQL Server 2005 is
    >>>>>> referenced.
    >>>>>> A> A> Don't I have to tell in the code that I want to use SQL
    >>>>>> Server
    >>>>>> 2008?
    >>>>>> A> Suppose I hade both on my machine?
    >>>>>> A> A> Do I have some registry entry that did not get up dated from
    >>>>>> the
    >>>>>> 2005
    >>>>>> A> to the 2008 versions?
    >>>>>> A> A> Thanks for any help.
    >>>>>> A> A> An error has occurred while establishing a connection to the
    >>>>>> server.
    >>>>>> A> When
    >>>>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>>>> fact
    >>>>>> A> that
    >>>>>> A> under the default settings SQL Server does not allow remote
    >>>>>> A> connections.
    >>>>>> A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>>>>> A> Server/Instance Specified)
    >>>>>> A> Description: An unhandled exception occurred during the
    >>>>>> execution
    >>>>>> of
    >>>>>> A> the
    >>>>>> A> current web request. Please review the stack trace for more
    >>>>>> A> information
    >>>>>> A> about the error and where it originated in the code.
    >>>>>> A> Exception Details: System.Data.SqlClient.SqlException: An error
    >>>>>> has
    >>>>>> A> occurred while establishing a connection to the server. When
    >>>>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>>>> fact
    >>>>>> A> that under the default settings SQL Server does not allow remote
    >>>>>> A> connections. (provider: SQL Network Interfaces, error: 26 -
    >>>>>> Error
    >>>>>> A> Locating Server/Instance Specified)
    >>>>>> A> A> Source Error:
    >>>>>> A> A> Line 194: Using command As New
    >>>>>> SqlCommand("GetNonEmptyAlbums",
    >>>>>> A> connection)
    >>>>>> A> Line 195: command.CommandType = CommandType.StoredProcedure
    >>>>>> A> Line 196: connection.Open()
    >>>>>> A> Line 197: Dim list As New Generic.List(Of Album)()
    >>>>>> A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>>>> A> Source File: I:\MyDocuments\Visual Studio
    >>>>>> A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line:
    >>>>>> 196
    >>>>>> A>

    >>
    >>

    >
    >
     
    Juan T. Llibre, Jul 20, 2008
    #15
  16. AAaron123

    AAaron123 Guest

    Thanks a lot
    "Juan T. Llibre" <> wrote in message
    news:...
    > re:
    > !> "Data Source=.; also appears to work.
    >
    > Indeed, because the dot ( . ) signifies the default instance.
    >
    > re:
    > !> Will that use the default instance on any machine the code is loaded
    > on?
    >
    > Yes, but remember that not all instances are default instances.
    > Some are *named* instances.
    >
    > In the case of the SQL Express named instance ( Data Source=.\SQLExpress )
    > what happens is that SQLExpress is the default name used for its named
    > instance.
    >
    > So, the dot ( . ) plus the default named instance, creates the full name
    > for the named instance.
    >
    > For SQL Server 2000, it's the same.
    >
    > You can use the dot for the default instance, which equates to the
    > machine's name,
    > but most installations create a named instance which needs to be added in
    > order to
    > get a fully qualified instance name.
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "AAaron123" <> wrote in message
    > news:...
    >> That works!
    >>
    >> But now the code will only run on my machine (I assume).
    >> "Data Source=.; also appears to work.
    >> Will that use the default instance on any machine the code is loaded on?
    >>
    >>
    >> How do people prepare code to work on multiple machines without hard
    >> coding for the default instance?
    >>
    >> Thanks
    >>
    >>
    >> "Michael Nemtsev [MVP]" <> wrote in message
    >> news:...
    >>> Hello AAaron123,
    >>>
    >>> Just specify you PC name in the connection string
    >>> instead of "Data Source=.\SQLExpress;
    >>> use "Data Source=YOUPCNAME;
    >>>
    >>> ---
    >>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>> http://spaces.live.com/laflour
    >>> "The greatest danger for most of us is not that our aim is too high and
    >>> we miss it, but that it is too low and we reach it" (c) Michelangelo
    >>>
    >>> A> "Michael Nemtsev [MVP]" <> wrote in message
    >>> A> news:...
    >>> A>
    >>>>> Hello AAaron123,
    >>>>>
    >>>>> ".\SQLExpress" means that you are connecting to SQL Express server.
    >>>>> It's
    >>>>> standard build-in name
    >>>>> If you want to connect to SQL Server (not express) you need to change
    >>>>> this
    >>>>> line on "(local)".
    >>>>> Btw, if you have SQL Management Studio installed (install if you not)
    >>>>> then you cant check which sevices you have and their names)
    >>>>>
    >>> A> The default instance is unnamed and is shown as the computer name.
    >>> A> How do I reference that in the
    >>> A> connectionString="Data Source=
    >>> A> thanks for staying with me
    >>> A>
    >>>>> Alternatively, you can use Server tabs in visual studio and it shows
    >>>>> available SQL server around you. After u connect to one of them in
    >>>>> shows your connection string in properties. You can copy paste that
    >>>>> connection string into your web.config
    >>>>>
    >>>>> ---
    >>>>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>>>> http://spaces.live.com/laflour
    >>>>> "The greatest danger for most of us is not that our aim is too high
    >>>>> and we
    >>>>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>>>> A> I find two such strings as shown below.
    >>>>> A> A> I see now that who ever wrote this assumed it would be used
    >>>>> with the
    >>>>> A> Express
    >>>>> A> version.
    >>>>> A> How do I change it to point to the SQL Server2005?
    >>>>> A> Also, I do see the file Personal.mdf in the solution list of file
    >>>>> A> names.
    >>>>> A> But I do not see the file aspnetdb.mdf there. Do you thing the
    >>>>> A> program might
    >>>>> A> create it when it runs?
    >>>>> A> Finally, the error message mentioned SQL2005 as if it converted
    >>>>> from
    >>>>> A> the Express to 2005 since that is what it found. If that's the
    >>>>> case
    >>>>> A> why didn't it make the connection?
    >>>>> A> A> Very confusing!
    >>>>> A> A> Thanks for the help
    >>>>> A> A> ...
    >>>>> A> <add name="Personal" connectionString="Data
    >>>>> A> Source=.\SQLExpress;Integrated
    >>>>> A> Security=True;User
    >>>>> A> Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
    >>>>> A> providerName="System.Data.SqlClient"/>
    >>>>> A> <remove name="LocalSqlServer"/>
    >>>>> A> <add name="LocalSqlServer" connectionString="Data
    >>>>> A> Source=.\SQLExpress;Integrated Security=True;User
    >>>>> A> Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf"/>
    >>>>> A> </connectionStrings>
    >>>>> A> "Michael Nemtsev [MVP]" <> wrote in message
    >>>>> A> news:...
    >>>>> A>
    >>>>>>> Hello AAaron123,
    >>>>>>>
    >>>>>>> Check the web.config, where should be the "connectionstring"
    >>>>>>> attribute,
    >>>>>>> where they specify where to connect
    >>>>>>> of this can be somewhere in code
    >>>>>>> ---
    >>>>>>> WBR, Michael Nemtsev [Microsoft MVP] :: blog:
    >>>>>>> http://spaces.live.com/laflour
    >>>>>>> "The greatest danger for most of us is not that our aim is too high
    >>>>>>> and we
    >>>>>>> miss it, but that it is too low and we reach it" (c) Michelangelo
    >>>>>>> A> I downloaded the personal website starter kit and when I run it
    >>>>>>> I
    >>>>>>> get
    >>>>>>> A> the
    >>>>>>> A> error shown below.
    >>>>>>> A> I found a way of using Launch Surface Area Configuration that
    >>>>>>> is
    >>>>>>> A> supposed
    >>>>>>> A> to fix the remote setting but I tried it and still get the
    >>>>>>> error.
    >>>>>>> A> I do not have SQL Server 2005 installed (thought I did once). I
    >>>>>>> do
    >>>>>>> A> have SQL Server 2008 installed.
    >>>>>>> A> A> I don't see anywhere in the code where SQL Server 2005 is
    >>>>>>> referenced.
    >>>>>>> A> A> Don't I have to tell in the code that I want to use SQL
    >>>>>>> Server
    >>>>>>> 2008?
    >>>>>>> A> Suppose I hade both on my machine?
    >>>>>>> A> A> Do I have some registry entry that did not get up dated from
    >>>>>>> the
    >>>>>>> 2005
    >>>>>>> A> to the 2008 versions?
    >>>>>>> A> A> Thanks for any help.
    >>>>>>> A> A> An error has occurred while establishing a connection to the
    >>>>>>> server.
    >>>>>>> A> When
    >>>>>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>>>>> fact
    >>>>>>> A> that
    >>>>>>> A> under the default settings SQL Server does not allow remote
    >>>>>>> A> connections.
    >>>>>>> A> (provider: SQL Network Interfaces, error: 26 - Error Locating
    >>>>>>> A> Server/Instance Specified)
    >>>>>>> A> Description: An unhandled exception occurred during the
    >>>>>>> execution
    >>>>>>> of
    >>>>>>> A> the
    >>>>>>> A> current web request. Please review the stack trace for more
    >>>>>>> A> information
    >>>>>>> A> about the error and where it originated in the code.
    >>>>>>> A> Exception Details: System.Data.SqlClient.SqlException: An error
    >>>>>>> has
    >>>>>>> A> occurred while establishing a connection to the server. When
    >>>>>>> A> connecting to SQL Server 2005, this failure may be caused by the
    >>>>>>> fact
    >>>>>>> A> that under the default settings SQL Server does not allow remote
    >>>>>>> A> connections. (provider: SQL Network Interfaces, error: 26 -
    >>>>>>> Error
    >>>>>>> A> Locating Server/Instance Specified)
    >>>>>>> A> A> Source Error:
    >>>>>>> A> A> Line 194: Using command As New
    >>>>>>> SqlCommand("GetNonEmptyAlbums",
    >>>>>>> A> connection)
    >>>>>>> A> Line 195: command.CommandType = CommandType.StoredProcedure
    >>>>>>> A> Line 196: connection.Open()
    >>>>>>> A> Line 197: Dim list As New Generic.List(Of Album)()
    >>>>>>> A> Line 198: Using reader As SqlDataReader = command.ExecuteReader
    >>>>>>> A> Source File: I:\MyDocuments\Visual Studio
    >>>>>>> A> 2008\WebSites\PersonalWebSite1\App_Code\PhotoManager.vb Line:
    >>>>>>> 196
    >>>>>>> A>
    >>>
    >>>

    >>
    >>

    >
    >
     
    AAaron123, Jul 20, 2008
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Kal
    Replies:
    1
    Views:
    9,582
    Kevin Spencer
    Jun 21, 2004
  2. Jane Davis

    Network Service account over network

    Jane Davis, Jun 22, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    477
    Kevin Spencer
    Jun 22, 2005
  3. Matthew K Jensen

    detecting enabled network interfaces in win32

    Matthew K Jensen, Oct 17, 2004, in forum: Python
    Replies:
    4
    Views:
    486
    Tim Golden
    Oct 18, 2004
  4. fabrizio
    Replies:
    6
    Views:
    643
    Larry I Smith
    Dec 8, 2005
  5. Alessio Pace
    Replies:
    0
    Views:
    654
    Alessio Pace
    Jan 7, 2009
Loading...

Share This Page