SQL Server on Windows XP Pro and ASP

Discussion in 'ASP General' started by Nathan Sokalski, Dec 19, 2003.

  1. I want to set up SQL Server on Windows XP Pro so that I can use the database
    capabilities of ASP and IIS. I am probably using some incorrect settings,
    but I am not sure what they are. Here is what I am currently doing:


    When I run sqlservr.exe I see the following:

    2003-12-19 15:51:28.20 server Microsoft SQL Server 2000 - 8.00.760
    (Intel X8
    6)
    Dec 17 2002 14:22:05
    Copyright (c) 1988-2003 Microsoft Corporation
    Desktop Engine on Windows NT 5.1 (Build 2600: Service Pack 1)

    2003-12-19 15:51:28.20 server Copyright (C) 1988-2002 Microsoft
    Corporation.

    2003-12-19 15:51:28.20 server All rights reserved.
    2003-12-19 15:51:28.20 server Server Process ID is 2992.
    2003-12-19 15:51:28.21 server Logging SQL Server messages in file
    'C:\Program
    Files\Microsoft SQL Server\MSSQL\LOG\ERRORLOG'.
    2003-12-19 15:51:28.28 server SQL Server is starting at priority class
    'norma
    l'(2 CPUs detected).
    2003-12-19 15:51:28.56 server SQL Server configured for thread mode
    processin
    g.
    2003-12-19 15:51:28.57 server Using dynamic lock allocation. [500] Lock
    Block
    s, [1000] Lock Owner Blocks.
    2003-12-19 15:51:28.79 spid4 Starting up database 'master'.
    2003-12-19 15:51:29.14 spid4 0 transactions rolled back in database
    'master'
    (1).
    2003-12-19 15:51:29.14 spid4 Recovery is checkpointing database 'master'
    (1)

    2003-12-19 15:51:29.23 server Using 'SSNETLIB.DLL' version '8.0.766'.
    2003-12-19 15:51:29.23 spid5 Starting up database 'model'.
    2003-12-19 15:51:29.28 spid4 Server name is 'NJS'.
    2003-12-19 15:51:29.28 spid4 Starting up database 'msdb'.
    2003-12-19 15:51:29.59 spid5 Clearing tempdb database.
    2003-12-19 15:51:30.15 spid5 Starting up database 'tempdb'.
    2003-12-19 15:51:30.26 spid4 Recovery complete.
    2003-12-19 15:51:30.28 spid4 SQL global counter collection task is
    created.
    2003-12-19 15:51:32.18 server SQL server listening on Shared Memory.
    2003-12-19 15:51:32.20 server SQL Server is ready for client connections


    When I go to Data Sources (ODBC) --> System DSN --> Configure I see the
    following after choosing my settings:

    Microsoft SQL Server ODBC Driver Version 03.81.9041

    Data Source Name: NJS
    Data Source Description:
    Server: NJS
    Database: (Default)
    Language: (Default)
    Translate Character Data: Yes
    Log Long Running Queries: No
    Log Driver Statistics: No
    Use Integrated Security: Yes
    Use Regional Settings: No
    Prepared Statements Option: Do not create temporary procedures
    Use Failover Server: No
    Use ANSI Quoted Identifiers: Yes
    Use ANSI Null, Paddings and Warnings: Yes
    Data Encryption: No

    And running Test Data Source... gives me the following:

    Microsoft SQL Server ODBC Driver Version 03.81.9041

    Running connectivity tests...

    Attempting connection
    Connection established
    Verifying option settings
    Disconnecting from server

    TESTS COMPLETED SUCCESSFULLY!


    My ASP code that is supposed to connect to the Database is:

    Set conn=Server.CreateObject("ADODB.Connection")
    connectstring="Provider=SQLOLEDB.1;Data Source=NJS;Initial
    Catalog=pubs;Integrated Security=SSPI"
    conn.Open connectstring


    And the error I receive when I open the ASP page is:

    Technical Information (for support personnel)

    a.. Error Type:
    Microsoft OLE DB Provider for SQL Server (0x80004005)
    [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access
    denied.
    /testdb.asp, line 25


    b.. Browser Type:
    Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; FunWebProducts; .NET
    CLR 1.0.3705; .NET CLR 1.1.4322)

    c.. Page:
    GET /testdb.asp

    d.. Time:
    Friday, December 19, 2003, 3:49:59 PM

    If anyone is able to help me or tell me specific instructions on how to give
    XP Pro's IIS DB capabilities, I would GREATLY appreciate it. Thank you.
    --
    Nathan Sokalski
     
    Nathan Sokalski, Dec 19, 2003
    #1
    1. Advertising

  2. See http://www.aspfaq.com/2126 for valid connection strings.

    Followups set to microsoft.public.inetserver.asp.db only.

    --
    Aaron Bertrand
    SQL Server MVP
    http://www.aspfaq.com/




    "Nathan Sokalski" <> wrote in message
    news:#...
    > I want to set up SQL Server on Windows XP Pro so that I can use the

    database
    > capabilities of ASP and IIS. I am probably using some incorrect settings,
    > but I am not sure what they are. Here is what I am currently doing:
    >
    >
    > When I run sqlservr.exe I see the following:
    >
    > 2003-12-19 15:51:28.20 server Microsoft SQL Server 2000 - 8.00.760
    > (Intel X8
    > 6)
    > Dec 17 2002 14:22:05
    > Copyright (c) 1988-2003 Microsoft Corporation
    > Desktop Engine on Windows NT 5.1 (Build 2600: Service Pack 1)
    >
    > 2003-12-19 15:51:28.20 server Copyright (C) 1988-2002 Microsoft
    > Corporation.
    >
    > 2003-12-19 15:51:28.20 server All rights reserved.
    > 2003-12-19 15:51:28.20 server Server Process ID is 2992.
    > 2003-12-19 15:51:28.21 server Logging SQL Server messages in file
    > 'C:\Program
    > Files\Microsoft SQL Server\MSSQL\LOG\ERRORLOG'.
    > 2003-12-19 15:51:28.28 server SQL Server is starting at priority class
    > 'norma
    > l'(2 CPUs detected).
    > 2003-12-19 15:51:28.56 server SQL Server configured for thread mode
    > processin
    > g.
    > 2003-12-19 15:51:28.57 server Using dynamic lock allocation. [500] Lock
    > Block
    > s, [1000] Lock Owner Blocks.
    > 2003-12-19 15:51:28.79 spid4 Starting up database 'master'.
    > 2003-12-19 15:51:29.14 spid4 0 transactions rolled back in database
    > 'master'
    > (1).
    > 2003-12-19 15:51:29.14 spid4 Recovery is checkpointing database

    'master'
    > (1)
    >
    > 2003-12-19 15:51:29.23 server Using 'SSNETLIB.DLL' version '8.0.766'.
    > 2003-12-19 15:51:29.23 spid5 Starting up database 'model'.
    > 2003-12-19 15:51:29.28 spid4 Server name is 'NJS'.
    > 2003-12-19 15:51:29.28 spid4 Starting up database 'msdb'.
    > 2003-12-19 15:51:29.59 spid5 Clearing tempdb database.
    > 2003-12-19 15:51:30.15 spid5 Starting up database 'tempdb'.
    > 2003-12-19 15:51:30.26 spid4 Recovery complete.
    > 2003-12-19 15:51:30.28 spid4 SQL global counter collection task is
    > created.
    > 2003-12-19 15:51:32.18 server SQL server listening on Shared Memory.
    > 2003-12-19 15:51:32.20 server SQL Server is ready for client

    connections
    >
    >
    > When I go to Data Sources (ODBC) --> System DSN --> Configure I see the
    > following after choosing my settings:
    >
    > Microsoft SQL Server ODBC Driver Version 03.81.9041
    >
    > Data Source Name: NJS
    > Data Source Description:
    > Server: NJS
    > Database: (Default)
    > Language: (Default)
    > Translate Character Data: Yes
    > Log Long Running Queries: No
    > Log Driver Statistics: No
    > Use Integrated Security: Yes
    > Use Regional Settings: No
    > Prepared Statements Option: Do not create temporary procedures
    > Use Failover Server: No
    > Use ANSI Quoted Identifiers: Yes
    > Use ANSI Null, Paddings and Warnings: Yes
    > Data Encryption: No
    >
    > And running Test Data Source... gives me the following:
    >
    > Microsoft SQL Server ODBC Driver Version 03.81.9041
    >
    > Running connectivity tests...
    >
    > Attempting connection
    > Connection established
    > Verifying option settings
    > Disconnecting from server
    >
    > TESTS COMPLETED SUCCESSFULLY!
    >
    >
    > My ASP code that is supposed to connect to the Database is:
    >
    > Set conn=Server.CreateObject("ADODB.Connection")
    > connectstring="Provider=SQLOLEDB.1;Data Source=NJS;Initial
    > Catalog=pubs;Integrated Security=SSPI"
    > conn.Open connectstring
    >
    >
    > And the error I receive when I open the ASP page is:
    >
    > Technical Information (for support personnel)
    >
    > a.. Error Type:
    > Microsoft OLE DB Provider for SQL Server (0x80004005)
    > [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or

    access
    > denied.
    > /testdb.asp, line 25
    >
    >
    > b.. Browser Type:
    > Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; FunWebProducts; .NET
    > CLR 1.0.3705; .NET CLR 1.1.4322)
    >
    > c.. Page:
    > GET /testdb.asp
    >
    > d.. Time:
    > Friday, December 19, 2003, 3:49:59 PM
    >
    > If anyone is able to help me or tell me specific instructions on how to

    give
    > XP Pro's IIS DB capabilities, I would GREATLY appreciate it. Thank you.
    > --
    > Nathan Sokalski
    >
    >
    >
     
    Aaron Bertrand - MVP, Dec 19, 2003
    #2
    1. Advertising

  3. Nathan Sokalski

    Naijacoder Guest

    I guess Aaron Bertrand site should solve ur Question.
    Good Site Aaron Bertrand...
    Let me know is u have any other questions!!
    Patrick


    >-----Original Message-----
    >See http://www.aspfaq.com/2126 for valid connection

    strings.
    >
    >Followups set to microsoft.public.inetserver.asp.db only.
    >
    >--
    >Aaron Bertrand
    >SQL Server MVP
    >http://www.aspfaq.com/
    >
    >
    >
    >
    >"Nathan Sokalski" <> wrote in

    message
    >news:#...
    >> I want to set up SQL Server on Windows XP Pro so that I

    can use the
    >database
    >> capabilities of ASP and IIS. I am probably using some

    incorrect settings,
    >> but I am not sure what they are. Here is what I am

    currently doing:
    >>
    >>
    >> When I run sqlservr.exe I see the following:
    >>
    >> 2003-12-19 15:51:28.20 server Microsoft SQL Server

    2000 - 8.00.760
    >> (Intel X8
    >> 6)
    >> Dec 17 2002 14:22:05
    >> Copyright (c) 1988-2003 Microsoft Corporation
    >> Desktop Engine on Windows NT 5.1 (Build 2600:

    Service Pack 1)
    >>
    >> 2003-12-19 15:51:28.20 server Copyright (C) 1988-

    2002 Microsoft
    >> Corporation.
    >>
    >> 2003-12-19 15:51:28.20 server All rights reserved.
    >> 2003-12-19 15:51:28.20 server Server Process ID is

    2992.
    >> 2003-12-19 15:51:28.21 server Logging SQL Server

    messages in file
    >> 'C:\Program
    >> Files\Microsoft SQL Server\MSSQL\LOG\ERRORLOG'.
    >> 2003-12-19 15:51:28.28 server SQL Server is starting

    at priority class
    >> 'norma
    >> l'(2 CPUs detected).
    >> 2003-12-19 15:51:28.56 server SQL Server configured

    for thread mode
    >> processin
    >> g.
    >> 2003-12-19 15:51:28.57 server Using dynamic lock

    allocation. [500] Lock
    >> Block
    >> s, [1000] Lock Owner Blocks.
    >> 2003-12-19 15:51:28.79 spid4 Starting up

    database 'master'.
    >> 2003-12-19 15:51:29.14 spid4 0 transactions rolled

    back in database
    >> 'master'
    >> (1).
    >> 2003-12-19 15:51:29.14 spid4 Recovery is

    checkpointing database
    >'master'
    >> (1)
    >>
    >> 2003-12-19 15:51:29.23 server Using 'SSNETLIB.DLL'

    version '8.0.766'.
    >> 2003-12-19 15:51:29.23 spid5 Starting up

    database 'model'.
    >> 2003-12-19 15:51:29.28 spid4 Server name is 'NJS'.
    >> 2003-12-19 15:51:29.28 spid4 Starting up

    database 'msdb'.
    >> 2003-12-19 15:51:29.59 spid5 Clearing tempdb

    database.
    >> 2003-12-19 15:51:30.15 spid5 Starting up

    database 'tempdb'.
    >> 2003-12-19 15:51:30.26 spid4 Recovery complete.
    >> 2003-12-19 15:51:30.28 spid4 SQL global counter

    collection task is
    >> created.
    >> 2003-12-19 15:51:32.18 server SQL server listening

    on Shared Memory.
    >> 2003-12-19 15:51:32.20 server SQL Server is ready

    for client
    >connections
    >>
    >>
    >> When I go to Data Sources (ODBC) --> System DSN -->

    Configure I see the
    >> following after choosing my settings:
    >>
    >> Microsoft SQL Server ODBC Driver Version 03.81.9041
    >>
    >> Data Source Name: NJS
    >> Data Source Description:
    >> Server: NJS
    >> Database: (Default)
    >> Language: (Default)
    >> Translate Character Data: Yes
    >> Log Long Running Queries: No
    >> Log Driver Statistics: No
    >> Use Integrated Security: Yes
    >> Use Regional Settings: No
    >> Prepared Statements Option: Do not create temporary

    procedures
    >> Use Failover Server: No
    >> Use ANSI Quoted Identifiers: Yes
    >> Use ANSI Null, Paddings and Warnings: Yes
    >> Data Encryption: No
    >>
    >> And running Test Data Source... gives me the following:
    >>
    >> Microsoft SQL Server ODBC Driver Version 03.81.9041
    >>
    >> Running connectivity tests...
    >>
    >> Attempting connection
    >> Connection established
    >> Verifying option settings
    >> Disconnecting from server
    >>
    >> TESTS COMPLETED SUCCESSFULLY!
    >>
    >>
    >> My ASP code that is supposed to connect to the Database

    is:
    >>
    >> Set conn=Server.CreateObject("ADODB.Connection")
    >> connectstring="Provider=SQLOLEDB.1;Data

    Source=NJS;Initial
    >> Catalog=pubs;Integrated Security=SSPI"
    >> conn.Open connectstring
    >>
    >>
    >> And the error I receive when I open the ASP page is:
    >>
    >> Technical Information (for support personnel)
    >>
    >> a.. Error Type:
    >> Microsoft OLE DB Provider for SQL Server (0x80004005)
    >> [DBNETLIB][ConnectionOpen (Connect()).]SQL Server

    does not exist or
    >access
    >> denied.
    >> /testdb.asp, line 25
    >>
    >>
    >> b.. Browser Type:
    >> Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1;

    FunWebProducts; .NET
    >> CLR 1.0.3705; .NET CLR 1.1.4322)
    >>
    >> c.. Page:
    >> GET /testdb.asp
    >>
    >> d.. Time:
    >> Friday, December 19, 2003, 3:49:59 PM
    >>
    >> If anyone is able to help me or tell me specific

    instructions on how to
    >give
    >> XP Pro's IIS DB capabilities, I would GREATLY

    appreciate it. Thank you.
    >> --
    >> Nathan Sokalski
    >>
    >>
    >>

    >
    >
    >.
    >
     
    Naijacoder, Dec 20, 2003
    #3
  4. I agree that the site about what the connection strings should look like is
    a very good site, but I think my problem is in the settings in my
    configuration. I am having trouble figuring out what settings I need to
    change, and what I need to change them to. I think it would help me more if
    someone told some of the changes I need to make in control panel, because I
    am new to server configuration. Any help would be greatly appreciated.
    Thanks.
    --
    Nathan Sokalski

    "Naijacoder" <> wrote in message
    news:008001c3c73d$414e5150$...
    > I guess Aaron Bertrand site should solve ur Question.
    > Good Site Aaron Bertrand...
    > Let me know is u have any other questions!!
    > Patrick
    >
    >
    > >-----Original Message-----
    > >See http://www.aspfaq.com/2126 for valid connection

    > strings.
    > >
    > >Followups set to microsoft.public.inetserver.asp.db only.
    > >
    > >--
    > >Aaron Bertrand
    > >SQL Server MVP
    > >http://www.aspfaq.com/
    > >
    > >
    > >
    > >
    > >"Nathan Sokalski" <> wrote in

    > message
    > >news:#...
    > >> I want to set up SQL Server on Windows XP Pro so that I

    > can use the
    > >database
    > >> capabilities of ASP and IIS. I am probably using some

    > incorrect settings,
    > >> but I am not sure what they are. Here is what I am

    > currently doing:
    > >>
    > >>
    > >> When I run sqlservr.exe I see the following:
    > >>
    > >> 2003-12-19 15:51:28.20 server Microsoft SQL Server

    > 2000 - 8.00.760
    > >> (Intel X8
    > >> 6)
    > >> Dec 17 2002 14:22:05
    > >> Copyright (c) 1988-2003 Microsoft Corporation
    > >> Desktop Engine on Windows NT 5.1 (Build 2600:

    > Service Pack 1)
    > >>
    > >> 2003-12-19 15:51:28.20 server Copyright (C) 1988-

    > 2002 Microsoft
    > >> Corporation.
    > >>
    > >> 2003-12-19 15:51:28.20 server All rights reserved.
    > >> 2003-12-19 15:51:28.20 server Server Process ID is

    > 2992.
    > >> 2003-12-19 15:51:28.21 server Logging SQL Server

    > messages in file
    > >> 'C:\Program
    > >> Files\Microsoft SQL Server\MSSQL\LOG\ERRORLOG'.
    > >> 2003-12-19 15:51:28.28 server SQL Server is starting

    > at priority class
    > >> 'norma
    > >> l'(2 CPUs detected).
    > >> 2003-12-19 15:51:28.56 server SQL Server configured

    > for thread mode
    > >> processin
    > >> g.
    > >> 2003-12-19 15:51:28.57 server Using dynamic lock

    > allocation. [500] Lock
    > >> Block
    > >> s, [1000] Lock Owner Blocks.
    > >> 2003-12-19 15:51:28.79 spid4 Starting up

    > database 'master'.
    > >> 2003-12-19 15:51:29.14 spid4 0 transactions rolled

    > back in database
    > >> 'master'
    > >> (1).
    > >> 2003-12-19 15:51:29.14 spid4 Recovery is

    > checkpointing database
    > >'master'
    > >> (1)
    > >>
    > >> 2003-12-19 15:51:29.23 server Using 'SSNETLIB.DLL'

    > version '8.0.766'.
    > >> 2003-12-19 15:51:29.23 spid5 Starting up

    > database 'model'.
    > >> 2003-12-19 15:51:29.28 spid4 Server name is 'NJS'.
    > >> 2003-12-19 15:51:29.28 spid4 Starting up

    > database 'msdb'.
    > >> 2003-12-19 15:51:29.59 spid5 Clearing tempdb

    > database.
    > >> 2003-12-19 15:51:30.15 spid5 Starting up

    > database 'tempdb'.
    > >> 2003-12-19 15:51:30.26 spid4 Recovery complete.
    > >> 2003-12-19 15:51:30.28 spid4 SQL global counter

    > collection task is
    > >> created.
    > >> 2003-12-19 15:51:32.18 server SQL server listening

    > on Shared Memory.
    > >> 2003-12-19 15:51:32.20 server SQL Server is ready

    > for client
    > >connections
    > >>
    > >>
    > >> When I go to Data Sources (ODBC) --> System DSN -->

    > Configure I see the
    > >> following after choosing my settings:
    > >>
    > >> Microsoft SQL Server ODBC Driver Version 03.81.9041
    > >>
    > >> Data Source Name: NJS
    > >> Data Source Description:
    > >> Server: NJS
    > >> Database: (Default)
    > >> Language: (Default)
    > >> Translate Character Data: Yes
    > >> Log Long Running Queries: No
    > >> Log Driver Statistics: No
    > >> Use Integrated Security: Yes
    > >> Use Regional Settings: No
    > >> Prepared Statements Option: Do not create temporary

    > procedures
    > >> Use Failover Server: No
    > >> Use ANSI Quoted Identifiers: Yes
    > >> Use ANSI Null, Paddings and Warnings: Yes
    > >> Data Encryption: No
    > >>
    > >> And running Test Data Source... gives me the following:
    > >>
    > >> Microsoft SQL Server ODBC Driver Version 03.81.9041
    > >>
    > >> Running connectivity tests...
    > >>
    > >> Attempting connection
    > >> Connection established
    > >> Verifying option settings
    > >> Disconnecting from server
    > >>
    > >> TESTS COMPLETED SUCCESSFULLY!
    > >>
    > >>
    > >> My ASP code that is supposed to connect to the Database

    > is:
    > >>
    > >> Set conn=Server.CreateObject("ADODB.Connection")
    > >> connectstring="Provider=SQLOLEDB.1;Data

    > Source=NJS;Initial
    > >> Catalog=pubs;Integrated Security=SSPI"
    > >> conn.Open connectstring
    > >>
    > >>
    > >> And the error I receive when I open the ASP page is:
    > >>
    > >> Technical Information (for support personnel)
    > >>
    > >> a.. Error Type:
    > >> Microsoft OLE DB Provider for SQL Server (0x80004005)
    > >> [DBNETLIB][ConnectionOpen (Connect()).]SQL Server

    > does not exist or
    > >access
    > >> denied.
    > >> /testdb.asp, line 25
    > >>
    > >>
    > >> b.. Browser Type:
    > >> Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1;

    > FunWebProducts; .NET
    > >> CLR 1.0.3705; .NET CLR 1.1.4322)
    > >>
    > >> c.. Page:
    > >> GET /testdb.asp
    > >>
    > >> d.. Time:
    > >> Friday, December 19, 2003, 3:49:59 PM
    > >>
    > >> If anyone is able to help me or tell me specific

    > instructions on how to
    > >give
    > >> XP Pro's IIS DB capabilities, I would GREATLY

    > appreciate it. Thank you.
    > >> --
    > >> Nathan Sokalski
    > >>
    > >>
    > >>

    > >
    > >
    > >.
    > >
     
    Nathan Sokalski, Dec 20, 2003
    #4
  5. Nathan Sokalski

    Bob Barrows Guest

    Nathan Sokalski wrote:
    > I agree that the site about what the connection strings should look
    > like is a very good site, but I think my problem is in the settings
    > in my configuration. I am having trouble figuring out what settings I
    > need to change, and what I need to change them to. I think it would
    > help me more if someone told some of the changes I need to make in
    > control panel,


    No one has told you any because there aren't any. As long as you have MDAC
    installed (which is very likely due to the fact that you did not get a
    "could not create object" error, you should be able to connect to the
    database without making any settings in the control panel.

    I suspect your problem is due to your attempt to use integrated security.
    Beginners usually do not realize that asp is not running under their
    security: the Internet Guest account is the account used when asp pages are
    running.

    Instead of attempting to use integrated security, I suggest creating a SQL
    login using SQL Enterprise Manager (have you installed the SQL client
    tools?).

    Bob Barrows

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
     
    Bob Barrows, Dec 21, 2003
    #5
  6. You are attempting a connection from an app that allows anonymous access. It
    uses the IUSR account to connect when a non-domain account connects.

    You have choices:
    1) Get rid of anon access and force all users to log in
    2) Switch to mixed mode authentication (ie, adding a user name and password)
    NOTE: SQL Server will have to be set up mixed mode.
    3) Add IUSR_ComputerName (where ComputerName is the name of the computer in
    question) to the SQL Server (works real well, but a major security hole).

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA

    **********************************************************************
    Think Outside the Box!
    **********************************************************************
    "Nathan Sokalski" <> wrote in message
    news:%...
    > I want to set up SQL Server on Windows XP Pro so that I can use the

    database
    > capabilities of ASP and IIS. I am probably using some incorrect settings,
    > but I am not sure what they are. Here is what I am currently doing:
    >
    >
    > When I run sqlservr.exe I see the following:
    >
    > 2003-12-19 15:51:28.20 server Microsoft SQL Server 2000 - 8.00.760
    > (Intel X8
    > 6)
    > Dec 17 2002 14:22:05
    > Copyright (c) 1988-2003 Microsoft Corporation
    > Desktop Engine on Windows NT 5.1 (Build 2600: Service Pack 1)
    >
    > 2003-12-19 15:51:28.20 server Copyright (C) 1988-2002 Microsoft
    > Corporation.
    >
    > 2003-12-19 15:51:28.20 server All rights reserved.
    > 2003-12-19 15:51:28.20 server Server Process ID is 2992.
    > 2003-12-19 15:51:28.21 server Logging SQL Server messages in file
    > 'C:\Program
    > Files\Microsoft SQL Server\MSSQL\LOG\ERRORLOG'.
    > 2003-12-19 15:51:28.28 server SQL Server is starting at priority class
    > 'norma
    > l'(2 CPUs detected).
    > 2003-12-19 15:51:28.56 server SQL Server configured for thread mode
    > processin
    > g.
    > 2003-12-19 15:51:28.57 server Using dynamic lock allocation. [500] Lock
    > Block
    > s, [1000] Lock Owner Blocks.
    > 2003-12-19 15:51:28.79 spid4 Starting up database 'master'.
    > 2003-12-19 15:51:29.14 spid4 0 transactions rolled back in database
    > 'master'
    > (1).
    > 2003-12-19 15:51:29.14 spid4 Recovery is checkpointing database

    'master'
    > (1)
    >
    > 2003-12-19 15:51:29.23 server Using 'SSNETLIB.DLL' version '8.0.766'.
    > 2003-12-19 15:51:29.23 spid5 Starting up database 'model'.
    > 2003-12-19 15:51:29.28 spid4 Server name is 'NJS'.
    > 2003-12-19 15:51:29.28 spid4 Starting up database 'msdb'.
    > 2003-12-19 15:51:29.59 spid5 Clearing tempdb database.
    > 2003-12-19 15:51:30.15 spid5 Starting up database 'tempdb'.
    > 2003-12-19 15:51:30.26 spid4 Recovery complete.
    > 2003-12-19 15:51:30.28 spid4 SQL global counter collection task is
    > created.
    > 2003-12-19 15:51:32.18 server SQL server listening on Shared Memory.
    > 2003-12-19 15:51:32.20 server SQL Server is ready for client

    connections
    >
    >
    > When I go to Data Sources (ODBC) --> System DSN --> Configure I see the
    > following after choosing my settings:
    >
    > Microsoft SQL Server ODBC Driver Version 03.81.9041
    >
    > Data Source Name: NJS
    > Data Source Description:
    > Server: NJS
    > Database: (Default)
    > Language: (Default)
    > Translate Character Data: Yes
    > Log Long Running Queries: No
    > Log Driver Statistics: No
    > Use Integrated Security: Yes
    > Use Regional Settings: No
    > Prepared Statements Option: Do not create temporary procedures
    > Use Failover Server: No
    > Use ANSI Quoted Identifiers: Yes
    > Use ANSI Null, Paddings and Warnings: Yes
    > Data Encryption: No
    >
    > And running Test Data Source... gives me the following:
    >
    > Microsoft SQL Server ODBC Driver Version 03.81.9041
    >
    > Running connectivity tests...
    >
    > Attempting connection
    > Connection established
    > Verifying option settings
    > Disconnecting from server
    >
    > TESTS COMPLETED SUCCESSFULLY!
    >
    >
    > My ASP code that is supposed to connect to the Database is:
    >
    > Set conn=Server.CreateObject("ADODB.Connection")
    > connectstring="Provider=SQLOLEDB.1;Data Source=NJS;Initial
    > Catalog=pubs;Integrated Security=SSPI"
    > conn.Open connectstring
    >
    >
    > And the error I receive when I open the ASP page is:
    >
    > Technical Information (for support personnel)
    >
    > a.. Error Type:
    > Microsoft OLE DB Provider for SQL Server (0x80004005)
    > [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or

    access
    > denied.
    > /testdb.asp, line 25
    >
    >
    > b.. Browser Type:
    > Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; FunWebProducts; .NET
    > CLR 1.0.3705; .NET CLR 1.1.4322)
    >
    > c.. Page:
    > GET /testdb.asp
    >
    > d.. Time:
    > Friday, December 19, 2003, 3:49:59 PM
    >
    > If anyone is able to help me or tell me specific instructions on how to

    give
    > XP Pro's IIS DB capabilities, I would GREATLY appreciate it. Thank you.
    > --
    > Nathan Sokalski
    >
    >
    >
     
    Cowboy \(Gregory A. Beamer\), Dec 23, 2003
    #6
  7. P.S. I hate DSNs.

    Adds a lot of weight to the app and no benefit. Forces you to use ODBC
    instead of OleDb. Very messy overall.

    Correct SQL Server connString for mixed mode (example):

    Provider=SQLOLEDB.1;Server={Server Name Here};Database={DB name
    here};UID={User name here};
    PWD={password here};



    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA

    **********************************************************************
    Think Outside the Box!
    **********************************************************************
    "Nathan Sokalski" <> wrote in message
    news:%...
    > I want to set up SQL Server on Windows XP Pro so that I can use the

    database
    > capabilities of ASP and IIS. I am probably using some incorrect settings,
    > but I am not sure what they are. Here is what I am currently doing:
    >
    >
    > When I run sqlservr.exe I see the following:
    >
    > 2003-12-19 15:51:28.20 server Microsoft SQL Server 2000 - 8.00.760
    > (Intel X8
    > 6)
    > Dec 17 2002 14:22:05
    > Copyright (c) 1988-2003 Microsoft Corporation
    > Desktop Engine on Windows NT 5.1 (Build 2600: Service Pack 1)
    >
    > 2003-12-19 15:51:28.20 server Copyright (C) 1988-2002 Microsoft
    > Corporation.
    >
    > 2003-12-19 15:51:28.20 server All rights reserved.
    > 2003-12-19 15:51:28.20 server Server Process ID is 2992.
    > 2003-12-19 15:51:28.21 server Logging SQL Server messages in file
    > 'C:\Program
    > Files\Microsoft SQL Server\MSSQL\LOG\ERRORLOG'.
    > 2003-12-19 15:51:28.28 server SQL Server is starting at priority class
    > 'norma
    > l'(2 CPUs detected).
    > 2003-12-19 15:51:28.56 server SQL Server configured for thread mode
    > processin
    > g.
    > 2003-12-19 15:51:28.57 server Using dynamic lock allocation. [500] Lock
    > Block
    > s, [1000] Lock Owner Blocks.
    > 2003-12-19 15:51:28.79 spid4 Starting up database 'master'.
    > 2003-12-19 15:51:29.14 spid4 0 transactions rolled back in database
    > 'master'
    > (1).
    > 2003-12-19 15:51:29.14 spid4 Recovery is checkpointing database

    'master'
    > (1)
    >
    > 2003-12-19 15:51:29.23 server Using 'SSNETLIB.DLL' version '8.0.766'.
    > 2003-12-19 15:51:29.23 spid5 Starting up database 'model'.
    > 2003-12-19 15:51:29.28 spid4 Server name is 'NJS'.
    > 2003-12-19 15:51:29.28 spid4 Starting up database 'msdb'.
    > 2003-12-19 15:51:29.59 spid5 Clearing tempdb database.
    > 2003-12-19 15:51:30.15 spid5 Starting up database 'tempdb'.
    > 2003-12-19 15:51:30.26 spid4 Recovery complete.
    > 2003-12-19 15:51:30.28 spid4 SQL global counter collection task is
    > created.
    > 2003-12-19 15:51:32.18 server SQL server listening on Shared Memory.
    > 2003-12-19 15:51:32.20 server SQL Server is ready for client

    connections
    >
    >
    > When I go to Data Sources (ODBC) --> System DSN --> Configure I see the
    > following after choosing my settings:
    >
    > Microsoft SQL Server ODBC Driver Version 03.81.9041
    >
    > Data Source Name: NJS
    > Data Source Description:
    > Server: NJS
    > Database: (Default)
    > Language: (Default)
    > Translate Character Data: Yes
    > Log Long Running Queries: No
    > Log Driver Statistics: No
    > Use Integrated Security: Yes
    > Use Regional Settings: No
    > Prepared Statements Option: Do not create temporary procedures
    > Use Failover Server: No
    > Use ANSI Quoted Identifiers: Yes
    > Use ANSI Null, Paddings and Warnings: Yes
    > Data Encryption: No
    >
    > And running Test Data Source... gives me the following:
    >
    > Microsoft SQL Server ODBC Driver Version 03.81.9041
    >
    > Running connectivity tests...
    >
    > Attempting connection
    > Connection established
    > Verifying option settings
    > Disconnecting from server
    >
    > TESTS COMPLETED SUCCESSFULLY!
    >
    >
    > My ASP code that is supposed to connect to the Database is:
    >
    > Set conn=Server.CreateObject("ADODB.Connection")
    > connectstring="Provider=SQLOLEDB.1;Data Source=NJS;Initial
    > Catalog=pubs;Integrated Security=SSPI"
    > conn.Open connectstring
    >
    >
    > And the error I receive when I open the ASP page is:
    >
    > Technical Information (for support personnel)
    >
    > a.. Error Type:
    > Microsoft OLE DB Provider for SQL Server (0x80004005)
    > [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or

    access
    > denied.
    > /testdb.asp, line 25
    >
    >
    > b.. Browser Type:
    > Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; FunWebProducts; .NET
    > CLR 1.0.3705; .NET CLR 1.1.4322)
    >
    > c.. Page:
    > GET /testdb.asp
    >
    > d.. Time:
    > Friday, December 19, 2003, 3:49:59 PM
    >
    > If anyone is able to help me or tell me specific instructions on how to

    give
    > XP Pro's IIS DB capabilities, I would GREATLY appreciate it. Thank you.
    > --
    > Nathan Sokalski
    >
    >
    >
     
    Cowboy \(Gregory A. Beamer\), Dec 23, 2003
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Michael Johnson Sr.
    Replies:
    0
    Views:
    731
    Michael Johnson Sr.
    Feb 4, 2004
  2. =?Utf-8?B?dW1pbG1pODE=?=
    Replies:
    2
    Views:
    554
  3. =?Utf-8?B?UmV6YQ==?=
    Replies:
    3
    Views:
    18,048
    Carlos Barini
    Jun 7, 2004
  4. Miguel Dias Moura

    SQL and Windows XP Pro Question

    Miguel Dias Moura, Oct 13, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    294
    Greg Burns
    Oct 13, 2004
  5. Wayne Erfling
    Replies:
    0
    Views:
    363
    Wayne Erfling
    Nov 18, 2006
Loading...

Share This Page