SQLMembershipProvider

Discussion in 'ASP .Net' started by Ryan, Jan 18, 2007.

  1. Ryan

    Ryan Guest

    Hello,

    I have a question on the default: AspNetSqlProvider. I know that, by
    default, this looks for a database created locally in the appdata
    directory. Although I have learned how to change the connection, it
    involves modifying the web.config file manually, which made me wonder:

    -Is the default connection stored anywhere globally? If not, is it
    simply a part of the object?

    Next, I see that when you go to select the provider in the ASP.Net
    Configuration tool, you will get a message (should the local DB not
    exist yet) that you should use the aspnet_regsql tool at the command
    line. While this tool CREATES the database whereever you want, it does
    not change the settings of the ASPNetSQLProvider connection string (at
    least for me).

    -Is that normal behavior?

    I guess I am just trying to get an understanding of where the values of
    these things are stored, whether in some global config file somewhere,
    in the objects themselves, or elsewhere AND making sure that my GUI is
    working properly. I saw a lot of things talking about how the GUI
    could really assist in creating the web config file, but perhaps some
    things need to be done by hand???


    Lastly, I upgraded from Visual Studio 2003 and have IIS 4.0. I do not
    see any of my 2005 web projects.

    -Is that normal? Do I need to upgrade to IIS 5.0 or higher in order to
    fully manage by .net 2.0 apps?

    Thanks,
    Ryan
     
    Ryan, Jan 18, 2007
    #1
    1. Advertising

  2. Ryan

    sticky Guest

    hi ryan

    read through this article

    http://aspnet.4guysfromrolla.com/articles/040506-1.aspx

    it explains the provider model in detail

    Ryan wrote:
    > Hello,
    >
    > I have a question on the default: AspNetSqlProvider. I know that, by
    > default, this looks for a database created locally in the appdata
    > directory. Although I have learned how to change the connection, it
    > involves modifying the web.config file manually, which made me wonder:
    >
    > -Is the default connection stored anywhere globally? If not, is it
    > simply a part of the object?
    >
    > Next, I see that when you go to select the provider in the ASP.Net
    > Configuration tool, you will get a message (should the local DB not
    > exist yet) that you should use the aspnet_regsql tool at the command
    > line. While this tool CREATES the database whereever you want, it does
    > not change the settings of the ASPNetSQLProvider connection string (at
    > least for me).
    >
    > -Is that normal behavior?
    >
    > I guess I am just trying to get an understanding of where the values of
    > these things are stored, whether in some global config file somewhere,
    > in the objects themselves, or elsewhere AND making sure that my GUI is
    > working properly. I saw a lot of things talking about how the GUI
    > could really assist in creating the web config file, but perhaps some
    > things need to be done by hand???
    >
    >
    > Lastly, I upgraded from Visual Studio 2003 and have IIS 4.0. I do not
    > see any of my 2005 web projects.
    >
    > -Is that normal? Do I need to upgrade to IIS 5.0 or higher in order to
    > fully manage by .net 2.0 apps?
    >
    > Thanks,
    > Ryan
     
    sticky, Jan 18, 2007
    #2
    1. Advertising

  3. Ryan

    Ryan Guest

    Thanks. I am still not clear about a few things. Per that article, It
    does look like the only way to over ride the default database setting
    is by editing the web config file by hand. I have done this and it
    seems I was successful, BUT I notice that when I navigate to the
    Provider selection page under ASP.NET configuration, the provider name
    that I created in my application's web.config file does not appear.
    Only the default ASPNetSQLProvider appears (unchecked). I seem to be
    connecting to a database other than ASPNEWSQLProvider, but am wondering
    why the name of the membership provider I setup does not appear as an
    option in the list.

    Thanks,
    Ryan

    sticky wrote:
    > hi ryan
    >
    > read through this article
    >
    > http://aspnet.4guysfromrolla.com/articles/040506-1.aspx
    >
    > it explains the provider model in detail
    >
    > Ryan wrote:
    > > Hello,
    > >
    > > I have a question on the default: AspNetSqlProvider. I know that, by
    > > default, this looks for a database created locally in the appdata
    > > directory. Although I have learned how to change the connection, it
    > > involves modifying the web.config file manually, which made me wonder:
    > >
    > > -Is the default connection stored anywhere globally? If not, is it
    > > simply a part of the object?
    > >
    > > Next, I see that when you go to select the provider in the ASP.Net
    > > Configuration tool, you will get a message (should the local DB not
    > > exist yet) that you should use the aspnet_regsql tool at the command
    > > line. While this tool CREATES the database whereever you want, it does
    > > not change the settings of the ASPNetSQLProvider connection string (at
    > > least for me).
    > >
    > > -Is that normal behavior?
    > >
    > > I guess I am just trying to get an understanding of where the values of
    > > these things are stored, whether in some global config file somewhere,
    > > in the objects themselves, or elsewhere AND making sure that my GUI is
    > > working properly. I saw a lot of things talking about how the GUI
    > > could really assist in creating the web config file, but perhaps some
    > > things need to be done by hand???
    > >
    > >
    > > Lastly, I upgraded from Visual Studio 2003 and have IIS 4.0. I do not
    > > see any of my 2005 web projects.
    > >
    > > -Is that normal? Do I need to upgrade to IIS 5.0 or higher in order to
    > > fully manage by .net 2.0 apps?
    > >
    > > Thanks,
    > > Ryan
     
    Ryan, Jan 18, 2007
    #3
  4. Ryan

    sticky Guest

    im not sure why the provider that you have specified is not showing up
    in the config tool. I never use it so i cant really comment.

    if your site is using the provider that you have specified, then it
    must be a problem with the config tool.
    they show up when i look at them through the config tool
    make sure your membership provider declaration looks something like
    this

    <membership defaultProvider="SqlMemProvider">
    <providers>
    <add name="SqlMemProvider"
    connectionStringName="SystemConnection"
    applicationName="BookingSystem"
    type="System.Web.Security.SqlMembershipProvider"
    enablePasswordRetrieval="false"
    enablePasswordReset="true"
    requiresQuestionAndAnswer="true"
    requiresUniqueEmail="true"
    passwordFormat="Hashed" />
    </providers>
    </membership>



    On Jan 18, 8:21 pm, "Ryan" <> wrote:
    > Thanks. I am still not clear about a few things. Per that article, It
    > does look like the only way to over ride thedefaultdatabase setting
    > is by editing the web config file by hand. Ihavedone this and it
    > seems I was successful, BUT I notice that when I navigate to the
    > Provider selection page under ASP.NET configuration, the provider name
    > that I created in my application's web.config file does not appear.
    > Only thedefaultASPNetSQLProviderappears (unchecked). I seem to be
    > connecting to a database other than ASPNEWSQLProvider, but am wondering
    > why the name of the membership provider I setup does not appear as an
    > option in the list.
    >
    > Thanks,
    > Ryan
    >
    > sticky wrote:
    > > hi ryan

    >
    > > read through this article

    >
    > >http://aspnet.4guysfromrolla.com/articles/040506-1.aspx

    >
    > > it explains the provider model in detail

    >
    > > Ryan wrote:
    > > > Hello,

    >
    > > > Ihaveaquestionon thedefault:AspNetSqlProvider. I know that, by
    > > >default, this looks for a database created locally in the appdata
    > > > directory. Although Ihavelearned how to change the connection, it
    > > > involves modifying the web.config file manually, which made me wonder:

    >
    > > > -Is thedefaultconnection stored anywhere globally? If not, is it
    > > > simply a part of the object?

    >
    > > > Next, I see that when you go to select the provider in the ASP.Net
    > > > Configuration tool, you will get a message (should the local DB not
    > > > exist yet) that you should use the aspnet_regsql tool at the command
    > > > line. While this tool CREATES the database whereever you want, it does
    > > > not change the settings of theASPNetSQLProviderconnection string (at
    > > > least for me).

    >
    > > > -Is that normal behavior?

    >
    > > > I guess I am just trying to get an understanding of where the values of
    > > > these things are stored, whether in some global config file somewhere,
    > > > in the objects themselves, or elsewhere AND making sure that my GUI is
    > > > working properly. I saw a lot of things talking about how the GUI
    > > > could really assist in creating the web config file, but perhaps some
    > > > things need to be done by hand???

    >
    > > > Lastly, I upgraded from Visual Studio 2003 andhaveIIS 4.0. I do not
    > > > see any of my 2005 web projects.

    >
    > > > -Is that normal? Do I need to upgrade to IIS 5.0 or higher in order to
    > > > fully manage by .net 2.0 apps?

    >
    > > > Thanks,
    > > > Ryan
     
    sticky, Jan 29, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ibiza
    Replies:
    0
    Views:
    453
    ibiza
    Jan 24, 2006
  2. Replies:
    3
    Views:
    549
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=
    Mar 5, 2006
  3. Mwob
    Replies:
    0
    Views:
    693
  4. Glenn
    Replies:
    0
    Views:
    635
    Glenn
    Jun 21, 2007
  5. Glenn
    Replies:
    0
    Views:
    1,127
    Glenn
    Jun 28, 2007
Loading...

Share This Page