strange problem with asp.net web app calling web service. sometimes 403 sometimes not

Discussion in 'ASP .Net' started by gkellymail@gmail.com, Nov 29, 2006.

  1. Guest

    I have a visual studio solutions that contains for example the
    following projects:
    project.Admin (web app and web service entry points)
    project.Web (web app )
    project.Lib ( common stuff that Admin and Web use )

    When I rebuild and run the app, Web will call an Admin web service to
    authenticate. however, it will get a 403 error with no sub code being
    revealed. If I wait a few minutes then it will work. This makes
    testing a real pain. I didn't not have this problem before I
    reinstalled the os. I have reloaded IIS a couple of times with no
    change. What is interesting is that "while" Web will get a 403 trying
    to access an Admin web service, I can access the web service just fine
    by accessing it directly using IE. The only thing that I've been able
    to do is to remove Admin from the solution and just work on Lib and
    Web. This was fine for a while, but now I need to work on all three.
    I have set the IIS max connections to 40 on this computer, which btw is
    xp pro sp2. Also, this is still using VS2k3 w/fw 1.1

    any help is appreciated.

    gkelly
     
    , Nov 29, 2006
    #1
    1. Advertising

  2. gkelly Guest

    Re: strange problem with asp.net web app calling web service. sometimes 403 sometimes not

    solution: disable keep-alives in IIS properties in 'web site' tab
     
    gkelly, Nov 29, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Saunders
    Replies:
    0
    Views:
    478
    John Saunders
    Aug 28, 2003
  2. Nehmo Sergheyev
    Replies:
    1
    Views:
    514
    Andrew Urquhart
    May 9, 2004
  3. Marcin Vorbrodt

    ::std sometimes needed, sometimes not

    Marcin Vorbrodt, Sep 16, 2003, in forum: C++
    Replies:
    24
    Views:
    783
    Jerry Coffin
    Sep 17, 2003
  4. Peter Sedman

    403 Error Web App to Web App with Client Certificates

    Peter Sedman, Sep 30, 2004, in forum: ASP .Net Security
    Replies:
    18
    Views:
    295
    jlento
    Nov 18, 2004
  5. willem joubert

    Error 403-Error 403-Error 403

    willem joubert, Feb 8, 2005, in forum: ASP .Net Web Services
    Replies:
    1
    Views:
    191
    Bruce Johnson [C# MVP]
    Feb 8, 2005
Loading...

Share This Page