Strange problem with Forms authentication: After successfull login, login page is still displayed

Discussion in 'ASP .Net Security' started by Pascal Blanchard, Aug 17, 2004.

  1. Hi there

    I have a quite strange problem with my ASP.NET-Application.

    The application has being deployed one year ago and worked fine till
    last month.
    It's a frame application. So that the user has to enter his
    credentials to login in the mainframe. This data is validated on a
    database. If username and password are validated, then the secured
    content is displayed. I'm working with two web.config files. One
    Web.Config in the root folder and the other one in the securefolder.

    All frames are in the same domain. When I try to login. The
    databasevaldation works fine, but the cookie is not written on the
    client side, so that the loginpage is redisplayed. More strange:
    Sometime it works. It's quite difficult to reproduce the problem. On 5
    tries, 2 fails. I think that this problem could be related to a
    IE-Security patch. As I said, the problem was observed for the first
    time last month. Has anybody observed a similar problem?

    Thanks for your help

    Pascal Blanchard
     
    Pascal Blanchard, Aug 17, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Nitin Verma
    Replies:
    1
    Views:
    314
    Patrick.O.Ige
    Aug 8, 2006
  2. Pascal Blanchard
    Replies:
    1
    Views:
    281
    Pascal Blanchard
    Aug 18, 2004
  3. mortb
    Replies:
    3
    Views:
    137
    mortb
    Dec 3, 2004
  4. Eric
    Replies:
    2
    Views:
    559
  5. A. Farber
    Replies:
    2
    Views:
    145
    Uri Guttman
    May 14, 2010
Loading...

Share This Page