stunnel and slow perl cgi

Discussion in 'Perl Misc' started by joe, May 13, 2004.

  1. joe

    joe Guest

    Hi I am running a demo of my webmail client
    at http://www.wittyadmin.com
    When i run the demo without stunnel the cgi works fast. when i run it using
    stunnel it runs slow and sometimes i must submit forms a couple of times.
    If i use sslwrap it gets even worse.
    would this improve using the speedy back end?
    I wonder how does webmin use stunnel to do the same thing with out
    perfomance problems?
    thanks
     
    joe, May 13, 2004
    #1
    1. Advertising

  2. joe

    joe Guest

    client=no
    socket = r:TCP_NODELAY=1
    cert=/etc/webmin/miniserv.pem
    connect=10.0.1.3:80

    ok i found the problem nodelay does the trick
     
    joe, May 13, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jürgen Exner

    Re: CGI Perl "use CGI" statement fail

    Jürgen Exner, Jul 31, 2003, in forum: Perl
    Replies:
    0
    Views:
    1,511
    Jürgen Exner
    Jul 31, 2003
  2. mike
    Replies:
    3
    Views:
    404
    Virgil Green
    Jul 11, 2005
  3. Ktm
    Replies:
    0
    Views:
    347
  4. Richard Maher
    Replies:
    4
    Views:
    2,101
    =?ISO-8859-1?Q?Arne_Vajh=F8j?=
    Jul 4, 2007
  5. kath
    Replies:
    4
    Views:
    700
    J. Gleixner
    Apr 9, 2007
Loading...

Share This Page