Suppressing logon window

Discussion in 'ASP .Net Security' started by 1SALz, Oct 28, 2003.

  1. 1SALz

    1SALz Guest

    Hi,

    Within a web application, I have secured folder/aspx pages using the
    location tag in web.config.

    Now whenever an unauthorized user tries to access that page, a popup dialog
    is displayed - which i dont want.
    I want to show a nicer message like 'you dont have access to this area' on a
    possibly redirected page.

    How can I do that?

    TIA.

    Other configuration:
    - Under IIS security, only integrated authentication is allowed. (All others
    are unchecked)
    - Under web.config, I have secured the pages using location tag with roles
    set to Active Directory groups.
    1SALz, Oct 28, 2003
    #1
    1. Advertising

  2. 1SALz

    MSFT Guest

    MSFT, Oct 29, 2003
    #2
    1. Advertising

  3. 1SALz

    1SALz Guest

    Thanks but that didnt help.

    Within system.web, here is what I added (beside the authorization block):

    <customErrors defaultRedirect="~/noaccess.htm" mode="RemoteOnly">
    <error statusCode="401.2" redirect="~/noaccess.htm"/>
    </customErrors>

    Still the login dialog is displayed and user is given 3 attempts to login
    successfully.
    What I am trying to do is to redirect user to noaccess page without showing
    any login dialog.


    "MSFT" <> wrote in message
    news:...
    > Hello,
    >
    > You may take a look at customErrors tag in web.config:
    >
    >

    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/cpgenref/ht
    > ml/gngrfcustomerrorssection.asp
    >
    > When you found a special error occur, you can redirect customer a special
    > page by this setting. (This error message page should be able to accessed
    > by everyone)
    >
    > Hope this help,
    >
    > Luke
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    1SALz, Nov 11, 2003
    #3
  4. 1SALz

    MSFT Guest

    To disable the Login dialog, you may make some changes on the virtual
    directory's security, for example, use intergrated windows authentication
    instead of basic authentication.

    Luke
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
    MSFT, Nov 12, 2003
    #4
  5. 1SALz

    MSFT Guest

    If you which to get rid of the dialog, then you need to allow anonymous
    access and handle your security some other way, for example form
    authentication.

    Luke
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
    MSFT, Nov 14, 2003
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Elliot M. Rodriguez

    suppressing Submit command with a Delete button

    Elliot M. Rodriguez, Dec 16, 2003, in forum: ASP .Net
    Replies:
    4
    Views:
    440
    Elliot M. Rodriguez
    Dec 17, 2003
  2. =?Utf-8?B?S2VubmV0aCBQ?=

    Suppressing the URL in a asp.net app

    =?Utf-8?B?S2VubmV0aCBQ?=, Nov 4, 2004, in forum: ASP .Net
    Replies:
    7
    Views:
    703
    =?Utf-8?B?S2VubmV0aCBQ?=
    Dec 24, 2004
  3. suppressing the console window

    , Jun 22, 2006, in forum: C Programming
    Replies:
    4
    Views:
    405
    jacob navia
    Jun 22, 2006
  4. Replies:
    2
    Views:
    359
  5. Kjell Kristiansson
    Replies:
    0
    Views:
    283
    Kjell Kristiansson
    Nov 30, 2005
Loading...

Share This Page