Syntax highlighting in perl debugger

Discussion in 'Perl Misc' started by Mark Shaw, Aug 5, 2005.

  1. Mark Shaw

    Mark Shaw Guest

    How does one turn OFF the syntax highlighting in the perl
    debugger?

    I'm running 5.8.0 under linux.

    Thanks!

    --
    Mark Shaw
    ========================================================================
    "Labor to keep alive in your breast that little spark of mnshaw@
    celestial fire called conscience." - George Washington gmail.com
     
    Mark Shaw, Aug 5, 2005
    #1
    1. Advertising

  2. Mark Shaw

    Mark Shaw Guest

    Mark Shaw <> wrote:
    > How does one turn OFF the syntax highlighting in the perl
    > debugger?


    > I'm running 5.8.0 under linux.


    I find it hard to believe that nobody knows the answer to
    this one....

    --
    Mark Shaw
    ========================================================================
    "Labor to keep alive in your breast that little spark of mnshaw@
    celestial fire called conscience." - George Washington gmail.com
     
    Mark Shaw, Aug 10, 2005
    #2
    1. Advertising

  3. Mark Shaw <> writes:

    > Mark Shaw <> wrote:
    >> How does one turn OFF the syntax highlighting in the perl
    >> debugger?

    >
    >> I'm running 5.8.0 under linux.

    >
    > I find it hard to believe that nobody knows the answer to
    > this one....


    I don't. There are many debuggers one can use with Perl. Some of them use a
    graphical interface, some of them run in a console, some support color syntax
    highlighting, some don't.

    If you're using a GUI app, have a look around its preferences panel. If it has
    a web site, have a look around there for a manual and/or FAQ.

    sherm--

    --
    Cocoa programming in Perl: http://camelbones.sourceforge.net
    Hire me! My resume: http://www.dot-app.org
     
    Sherm Pendley, Aug 10, 2005
    #3
  4. Mark Shaw

    Mark Shaw Guest

    Sherm Pendley <> wrote:
    > Mark Shaw <> writes:


    > >> How does one turn OFF the syntax highlighting in the perl
    > >> debugger?

    > >
    > >> I'm running 5.8.0 under linux.


    [...]

    > If you're using a GUI app, have a look around its preferences panel. If it has
    > a web site, have a look around there for a manual and/or FAQ.


    It's the debugger that comes with the standard library, running
    in an xterm.

    --
    Mark Shaw moc TOD liamg TA wahsnm
    ========================================================================
    "All of my mistakes are giving me ideas." - Natalie Lileks
     
    Mark Shaw, Aug 10, 2005
    #4
  5. Mark Shaw <> writes:

    >> >> How does one turn OFF the syntax highlighting in the perl
    >> >> debugger?

    >
    > It's the debugger that comes with the standard library, running
    > in an xterm.


    Well, the immediate question then is how did you turn *ON* syntax high-
    lighting? Nothing in "perldoc perldebug" mentions that the built-in
    debugger can do that, much less how to enable it. None of the variables
    displayed with "o" look relevant to that.

    Are you using the standard vanilla xterm, or the GNOME, KDE, or some other
    terminal app? Are you certain it's not your terminal app that's doing the
    highlighting?

    sherm--

    --
    Cocoa programming in Perl: http://camelbones.sourceforge.net
    Hire me! My resume: http://www.dot-app.org
     
    Sherm Pendley, Aug 10, 2005
    #5
  6. Mark Shaw

    Paul Lalli Guest

    Sherm Pendley wrote:
    > Mark Shaw <> writes:
    >
    > >> >> How does one turn OFF the syntax highlighting in the perl
    > >> >> debugger?

    > >
    > > It's the debugger that comes with the standard library, running
    > > in an xterm.

    >
    > Well, the immediate question then is how did you turn *ON* syntax high-
    > lighting? Nothing in "perldoc perldebug" mentions that the built-in
    > debugger can do that, much less how to enable it. None of the variables
    > displayed with "o" look relevant to that.
    >
    > Are you using the standard vanilla xterm, or the GNOME, KDE, or some other
    > terminal app? Are you certain it's not your terminal app that's doing the
    > highlighting?


    >From perldoc perldebug:

    If you have the FSF's version of emacs installed on your system, it
    can
    interact with the Perl debugger to provide an integrated software
    development environment reminiscent of its interactions with C
    debuggers.

    Perl comes with a start file for making emacs act like a
    syntax-directed
    editor that understands (some of) Perl's syntax. Look in the emacs
    directory of the Perl source distribution.

    Is it possible that the OP is actually seeing emacs' perl-mode when
    he's using the debugger? I don't have this sort of thing in my
    environment, so it's difficult for me to test, and even more difficult
    for me to find a solution.

    Basically, this is my shot in the dark.

    Paul Lalli
     
    Paul Lalli, Aug 10, 2005
    #6
  7. Mark Shaw

    Mark Shaw Guest

    Sherm Pendley <> wrote:
    > Mark Shaw <> writes:


    > >> >> How does one turn OFF the syntax highlighting in the perl
    > >> >> debugger?

    > >
    > > It's the debugger that comes with the standard library, running
    > > in an xterm.


    > Well, the immediate question then is how did you turn *ON* syntax high-
    > lighting?


    I didn't. It seems to have come that way, at least in the Red
    Hat distro.

    > Nothing in "perldoc perldebug" mentions that the built-in
    > debugger can do that, much less how to enable it. None of the variables
    > displayed with "o" look relevant to that.


    Yes, I'm reasonably certain it's not native in the debugger
    itself. I thought that someone here might have run into this
    and would know where the syntax highlighting was coming from.

    The 'man' command also has syntax highlighting, which I'd also
    dearly love to turn off. As do 'vi' (actually vim) and 'ls',
    but I've already figured those out.

    I can see this having some utility in a text editor for certain
    types of coding, but otherwise I think it's an abomination -
    and I'm fairly ticked off that it's not obvious how to defeat
    it.

    > Are you using the standard vanilla xterm, or the GNOME, KDE, or some other
    > terminal app? Are you certain it's not your terminal app that's doing the
    > highlighting?


    It's xterm. The only thing I do differently is set a background
    and text color (black and yellow, respectively) that I find easy
    to work with.

    Here's my command line:

    xterm -bg black -fg yellow -title !* &

    --
    Mark Shaw
    ========================================================================
    "The most exciting phrase to hear in science, the one that heralds new
    discoveries, is not 'Eureka!' but 'That's funny....'" - Isaac Asimov
     
    Mark Shaw, Aug 10, 2005
    #7
  8. Mark Shaw

    Mark Shaw Guest

    Paul Lalli <> wrote:
    > Is it possible that the OP is actually seeing emacs' perl-mode when
    > he's using the debugger? I don't have this sort of thing in my
    > environment, so it's difficult for me to test, and even more difficult
    > for me to find a solution.


    All I can tell you is that when I'm in the debugger, it's
    absolutely nothing like emacs. It's, well, the perl debugger.
    It acts on this machine exactly like it's acted on every other
    machine I've ever used it on.

    > Basically, this is my shot in the dark.


    Thanks, though.

    --
    Mark Shaw
    ========================================================================
    "The most exciting phrase to hear in science, the one that heralds new
    discoveries, is not 'Eureka!' but 'That's funny....'" - Isaac Asimov
     
    Mark Shaw, Aug 10, 2005
    #8
  9. Mark Shaw <> writes:

    > Yes, I'm reasonably certain it's not native in the debugger
    > itself. I thought that someone here might have run into this
    > and would know where the syntax highlighting was coming from.
    >
    > The 'man' command also has syntax highlighting, which I'd also
    > dearly love to turn off. As do 'vi' (actually vim) and 'ls',
    > but I've already figured those out.


    Beats me then. :-(

    I'd try using a different terminal emulator - especially as it seems you
    aren't too happy with xterm for a number of different apps. There's no
    shortage of alternatives, certainly.

    sherm--

    --
    Cocoa programming in Perl: http://camelbones.sourceforge.net
    Hire me! My resume: http://www.dot-app.org
     
    Sherm Pendley, Aug 10, 2005
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?QkxpVFpXaU5H?=

    Syntax Highlighting / Code Completion for non-compiled apps

    =?Utf-8?B?QkxpVFpXaU5H?=, Apr 15, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    405
    =?Utf-8?B?QkxpVFpXaU5H?=
    Apr 16, 2004
  2. Berlin  Brown

    Adding Syntax Highlighting for JPanel

    Berlin Brown, Feb 23, 2005, in forum: Java
    Replies:
    4
    Views:
    1,118
    Berlin Brown
    Mar 4, 2005
  3. rom1
    Replies:
    1
    Views:
    455
  4. Matthias Pospiech

    automatic syntax highlighting in web pages ?

    Matthias Pospiech, Jan 15, 2005, in forum: HTML
    Replies:
    6
    Views:
    562
    Toby Inkster
    Jan 16, 2005
  5. Moosebumps

    Syntax highlighting in .NET IDE

    Moosebumps, Jan 7, 2004, in forum: Python
    Replies:
    4
    Views:
    388
    Phipps Xue
    Jan 9, 2004
Loading...

Share This Page