System.Data.SqlClient.SqlException: Login failed for user 'NT AUTHORITY\ANONYMOUSLOGON'

Discussion in 'ASP .Net' started by Nick nkw, Feb 23, 2007.

  1. Nick nkw

    Nick nkw Guest

    Nick nkw, Feb 23, 2007
    #1
    1. Advertising

  2. RE: System.Data.SqlClient.SqlException: Login failed for user 'NT AUTH

    What this is telling you is that the Anonymous Logon identity doesn't have
    permissions to the specified database. Obviously, as you stated, you can
    either change the identity to one that does, or give this account permssions.
    Or, you can use SQL Server authentication, which is often a lot easier.
    Peter

    --
    Site: http://www.eggheadcafe.com
    UnBlog: http://petesbloggerama.blogspot.com
    Short urls & more: http://ittyurl.net




    "Nick nkw" wrote:

    > I already following the steps in:
    > http://msdn.microsoft.com/library/d...ngsqlserverusingwindowsintegratedsecurity.asp
    >
    > But I still get the error. I found it works when using VS.Net internal
    > web server. It use Domain\MachineName$ to connect SQL Server after
    > publish to IIS. (It works on IIS after I remove <identity
    > impersonate="true"/>)
    >
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=, Feb 23, 2007
    #2
    1. Advertising

  3. Nick nkw

    bruce barker Guest

    Re: System.Data.SqlClient.SqlException: Login failed for user 'NTAUTHORITY\ANONYMOUS LOGON'

    you will notice, that if you connect to your dev box from another
    machine it won't work with <identity impersonate="true"/> and if you hit
    the site locally on the web server it will work (just like using your
    dev box).

    to use impersonation you need to switch to kerberos (and enable forwarding).

    -- bruce (sqlwork.com)


    Nick nkw wrote:
    > I already following the steps in:
    > http://msdn.microsoft.com/library/d...ngsqlserverusingwindowsintegratedsecurity.asp
    >
    >
    > But I still get the error. I found it works when using VS.Net internal
    > web server. It use Domain\MachineName$ to connect SQL Server after
    > publish to IIS. (It works on IIS after I remove <identity
    > impersonate="true"/>)
    bruce barker, Feb 23, 2007
    #3
  4. Nick nkw

    msdn Guest

    Re: System.Data.SqlClient.SqlException: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    my develop box is also connect to the SQL server remotely. And sp_who shows
    my Windows domain users. Sounds internal web server and IIS handle SQL
    Server logon differently.

    "bruce barker" <> wrote in message
    news:...
    > you will notice, that if you connect to your dev box from another machine
    > it won't work with <identity impersonate="true"/> and if you hit the site
    > locally on the web server it will work (just like using your dev box).
    >
    > to use impersonation you need to switch to kerberos (and enable
    > forwarding).
    >
    > -- bruce (sqlwork.com)
    >
    >
    > Nick nkw wrote:
    >> I already following the steps in:
    >> http://msdn.microsoft.com/library/d...ngsqlserverusingwindowsintegratedsecurity.asp
    >> But I still get the error. I found it works when using VS.Net internal
    >> web server. It use Domain\MachineName$ to connect SQL Server after
    >> publish to IIS. (It works on IIS after I remove <identity
    >> impersonate="true"/>)
    msdn, Feb 24, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?S2FseWFu?=
    Replies:
    2
    Views:
    1,408
    =?Utf-8?B?S2FseWFu?=
    Jun 18, 2004
  2. Kal
    Replies:
    1
    Views:
    9,520
    Kevin Spencer
    Jun 21, 2004
  3. =?Utf-8?B?UGF0cmljay5PLklnZQ==?=

    System.Data.SqlClient.SqlException: problem!

    =?Utf-8?B?UGF0cmljay5PLklnZQ==?=, Sep 30, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    2,442
    =?Utf-8?B?UGF0cmljay5PLklnZQ==?=
    Sep 30, 2004
  4. johntigner
    Replies:
    0
    Views:
    1,079
    johntigner
    May 22, 2008
  5. egsdar
    Replies:
    0
    Views:
    1,558
    egsdar
    Dec 13, 2008
Loading...

Share This Page