the development environment is overzealously formatting my html when switching from design to code v

Discussion in 'ASP .Net' started by Jacob Crossley, Jun 9, 2004.

  1. Please tell me there is a way to prevent this annoyance ; - )

    I'm into writing perfectly indented html, but the .net dev environment is
    being overzealous and messing up my html formatting.

    for example, I originally write:

    <table>
    <tr>
    <td>
    <asp:label id="lblSuccess" runat="server">
    </asp:/label>
    </td>
    </tr>
    </table>

    then the dev environment switches it to something like:

    <table>
    <tr>
    <td><asp:label id="lblSuccess" runat="server"></asp:/label>
    </td></tr></table>


    I'm running the latest version of .net --version 7.1.3088
    I've run through the tools/options and placed the envirionment to do the
    least amount of microsoftesque-preemptive formatting.

    Please HELP!!! If there is no solution I think I'm gonna code .net stuff in
    notepad until I can get a linux, bsd or UNIX job...lol jk. I've been an MS
    developer for years!
     
    Jacob Crossley, Jun 9, 2004
    #1
    1. Advertising

  2. Jacob Crossley

    Curt_C [MVP] Guest

    it's a setting in the options of VS.....

    --
    Curt Christianson
    Owner/Lead Developer, DF-Software
    Site: http://www.Darkfalz.com
    Blog: http://blog.Darkfalz.com


    "Jacob Crossley" <> wrote in message
    news:dTHxc.405$...
    > Please tell me there is a way to prevent this annoyance ; - )
    >
    > I'm into writing perfectly indented html, but the .net dev environment is
    > being overzealous and messing up my html formatting.
    >
    > for example, I originally write:
    >
    > <table>
    > <tr>
    > <td>
    > <asp:label id="lblSuccess" runat="server">
    > </asp:/label>
    > </td>
    > </tr>
    > </table>
    >
    > then the dev environment switches it to something like:
    >
    > <table>
    > <tr>
    > <td><asp:label id="lblSuccess" runat="server"></asp:/label>
    > </td></tr></table>
    >
    >
    > I'm running the latest version of .net --version 7.1.3088
    > I've run through the tools/options and placed the envirionment to do the
    > least amount of microsoftesque-preemptive formatting.
    >
    > Please HELP!!! If there is no solution I think I'm gonna code .net stuff

    in
    > notepad until I can get a linux, bsd or UNIX job...lol jk. I've been an

    MS
    > developer for years!
    >
    >
    >
     
    Curt_C [MVP], Jun 9, 2004
    #2
    1. Advertising

  3. which setting? I've tried them all!


    "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    news:...
    > it's a setting in the options of VS.....
    >
    > --
    > Curt Christianson
    > Owner/Lead Developer, DF-Software
    > Site: http://www.Darkfalz.com
    > Blog: http://blog.Darkfalz.com
    >
    >
    > "Jacob Crossley" <> wrote in message
    > news:dTHxc.405$...
    > > Please tell me there is a way to prevent this annoyance ; - )
    > >
    > > I'm into writing perfectly indented html, but the .net dev environment

    is
    > > being overzealous and messing up my html formatting.
    > >
    > > for example, I originally write:
    > >
    > > <table>
    > > <tr>
    > > <td>
    > > <asp:label id="lblSuccess" runat="server">
    > > </asp:/label>
    > > </td>
    > > </tr>
    > > </table>
    > >
    > > then the dev environment switches it to something like:
    > >
    > > <table>
    > > <tr>
    > > <td><asp:label id="lblSuccess" runat="server"></asp:/label>
    > > </td></tr></table>
    > >
    > >
    > > I'm running the latest version of .net --version 7.1.3088
    > > I've run through the tools/options and placed the envirionment to do the
    > > least amount of microsoftesque-preemptive formatting.
    > >
    > > Please HELP!!! If there is no solution I think I'm gonna code .net

    stuff
    > in
    > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've been an

    > MS
    > > developer for years!
    > >
    > >
    > >

    >
    >
     
    Jacob Crossley, Jun 9, 2004
    #3
  4. Jacob Crossley

    Curt_C [MVP] Guest

    Tools
    Options
    Text Editor
    HTML/XML
    Format

    Try the settings there.

    --
    Curt Christianson
    Owner/Lead Developer, DF-Software
    Site: http://www.Darkfalz.com
    Blog: http://blog.Darkfalz.com


    "Jacob Crossley" <> wrote in message
    news:_7Jxc.408$...
    > which setting? I've tried them all!
    >
    >
    > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    > news:...
    > > it's a setting in the options of VS.....
    > >
    > > --
    > > Curt Christianson
    > > Owner/Lead Developer, DF-Software
    > > Site: http://www.Darkfalz.com
    > > Blog: http://blog.Darkfalz.com
    > >
    > >
    > > "Jacob Crossley" <> wrote in message
    > > news:dTHxc.405$...
    > > > Please tell me there is a way to prevent this annoyance ; - )
    > > >
    > > > I'm into writing perfectly indented html, but the .net dev environment

    > is
    > > > being overzealous and messing up my html formatting.
    > > >
    > > > for example, I originally write:
    > > >
    > > > <table>
    > > > <tr>
    > > > <td>
    > > > <asp:label id="lblSuccess" runat="server">
    > > > </asp:/label>
    > > > </td>
    > > > </tr>
    > > > </table>
    > > >
    > > > then the dev environment switches it to something like:
    > > >
    > > > <table>
    > > > <tr>
    > > > <td><asp:label id="lblSuccess" runat="server"></asp:/label>
    > > > </td></tr></table>
    > > >
    > > >
    > > > I'm running the latest version of .net --version 7.1.3088
    > > > I've run through the tools/options and placed the envirionment to do

    the
    > > > least amount of microsoftesque-preemptive formatting.
    > > >
    > > > Please HELP!!! If there is no solution I think I'm gonna code .net

    > stuff
    > > in
    > > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've been

    an
    > > MS
    > > > developer for years!
    > > >
    > > >
    > > >

    > >
    > >

    >
    >
    >
     
    Curt_C [MVP], Jun 9, 2004
    #4
  5. You are wrong. You are just guessing. Its best not to answer questions
    unless you have a specific and tested answer. Please excuse my bluntness.
    "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    news:%...
    > Tools
    > Options
    > Text Editor
    > HTML/XML
    > Format
    >
    > Try the settings there.
    >
    > --
    > Curt Christianson
    > Owner/Lead Developer, DF-Software
    > Site: http://www.Darkfalz.com
    > Blog: http://blog.Darkfalz.com
    >
    >
    > "Jacob Crossley" <> wrote in message
    > news:_7Jxc.408$...
    > > which setting? I've tried them all!
    > >
    > >
    > > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    > > news:...
    > > > it's a setting in the options of VS.....
    > > >
    > > > --
    > > > Curt Christianson
    > > > Owner/Lead Developer, DF-Software
    > > > Site: http://www.Darkfalz.com
    > > > Blog: http://blog.Darkfalz.com
    > > >
    > > >
    > > > "Jacob Crossley" <> wrote in message
    > > > news:dTHxc.405$...
    > > > > Please tell me there is a way to prevent this annoyance ; - )
    > > > >
    > > > > I'm into writing perfectly indented html, but the .net dev

    environment
    > > is
    > > > > being overzealous and messing up my html formatting.
    > > > >
    > > > > for example, I originally write:
    > > > >
    > > > > <table>
    > > > > <tr>
    > > > > <td>
    > > > > <asp:label id="lblSuccess" runat="server">
    > > > > </asp:/label>
    > > > > </td>
    > > > > </tr>
    > > > > </table>
    > > > >
    > > > > then the dev environment switches it to something like:
    > > > >
    > > > > <table>
    > > > > <tr>
    > > > > <td><asp:label id="lblSuccess" runat="server"></asp:/label>
    > > > > </td></tr></table>
    > > > >
    > > > >
    > > > > I'm running the latest version of .net --version 7.1.3088
    > > > > I've run through the tools/options and placed the envirionment to do

    > the
    > > > > least amount of microsoftesque-preemptive formatting.
    > > > >
    > > > > Please HELP!!! If there is no solution I think I'm gonna code .net

    > > stuff
    > > > in
    > > > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've

    been
    > an
    > > > MS
    > > > > developer for years!
    > > > >
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >
    > >

    >
    >
     
    Jacob Crossley, Jun 9, 2004
    #5
  6. Jacob Crossley

    Curt_C [MVP] Guest

    Yeah, whatever you say.

    PLONK - Killfile

    --
    Curt Christianson
    Owner/Lead Developer, DF-Software
    Site: http://www.Darkfalz.com
    Blog: http://blog.Darkfalz.com


    "Jacob Crossley" <> wrote in message
    news:6IJxc.410$...
    > You are wrong. You are just guessing. Its best not to answer questions
    > unless you have a specific and tested answer. Please excuse my bluntness.
    > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    > news:%...
    > > Tools
    > > Options
    > > Text Editor
    > > HTML/XML
    > > Format
    > >
    > > Try the settings there.
    > >
    > > --
    > > Curt Christianson
    > > Owner/Lead Developer, DF-Software
    > > Site: http://www.Darkfalz.com
    > > Blog: http://blog.Darkfalz.com
    > >
    > >
    > > "Jacob Crossley" <> wrote in message
    > > news:_7Jxc.408$...
    > > > which setting? I've tried them all!
    > > >
    > > >
    > > > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    > > > news:...
    > > > > it's a setting in the options of VS.....
    > > > >
    > > > > --
    > > > > Curt Christianson
    > > > > Owner/Lead Developer, DF-Software
    > > > > Site: http://www.Darkfalz.com
    > > > > Blog: http://blog.Darkfalz.com
    > > > >
    > > > >
    > > > > "Jacob Crossley" <> wrote in message
    > > > > news:dTHxc.405$...
    > > > > > Please tell me there is a way to prevent this annoyance ; - )
    > > > > >
    > > > > > I'm into writing perfectly indented html, but the .net dev

    > environment
    > > > is
    > > > > > being overzealous and messing up my html formatting.
    > > > > >
    > > > > > for example, I originally write:
    > > > > >
    > > > > > <table>
    > > > > > <tr>
    > > > > > <td>
    > > > > > <asp:label id="lblSuccess" runat="server">
    > > > > > </asp:/label>
    > > > > > </td>
    > > > > > </tr>
    > > > > > </table>
    > > > > >
    > > > > > then the dev environment switches it to something like:
    > > > > >
    > > > > > <table>
    > > > > > <tr>
    > > > > > <td><asp:label id="lblSuccess"

    runat="server"></asp:/label>
    > > > > > </td></tr></table>
    > > > > >
    > > > > >
    > > > > > I'm running the latest version of .net --version 7.1.3088
    > > > > > I've run through the tools/options and placed the envirionment to

    do
    > > the
    > > > > > least amount of microsoftesque-preemptive formatting.
    > > > > >
    > > > > > Please HELP!!! If there is no solution I think I'm gonna code

    ..net
    > > > stuff
    > > > > in
    > > > > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've

    > been
    > > an
    > > > > MS
    > > > > > developer for years!
    > > > > >
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > >
    > > >
    > > >

    > >
    > >

    >
    >
    >
     
    Curt_C [MVP], Jun 9, 2004
    #6
  7. See the problem is that you acted like you know the answer, so now a
    microsoft employee monitoring this board will assume that my question was
    answered. At the bottom of my initial post I mentioned I had already run
    through the tools /options. of VS and put them all on settings that do the
    least amount of work.

    Nothing against you personally, but please don't give unspecific answers
    that don't work. That diminishes the quality of the board for the rest of
    us. Also be sure to read the full thread before answering. If you'd have
    done that in this case, you'd have known that even your third attempt to
    answer was inadequate. Were you such a pain in the a## to your teachers when
    you were in school---always wanting cheap credit for rushing to give the
    obvious answer that all the other students knew, but not exactly what the
    teacher asked for?


    "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    news:...
    > Yeah, whatever you say.
    >
    > PLONK - Killfile
    >
    > --
    > Curt Christianson
    > Owner/Lead Developer, DF-Software
    > Site: http://www.Darkfalz.com
    > Blog: http://blog.Darkfalz.com
    >
    >
    > "Jacob Crossley" <> wrote in message
    > news:6IJxc.410$...
    > > You are wrong. You are just guessing. Its best not to answer questions
    > > unless you have a specific and tested answer. Please excuse my

    bluntness.
    > > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    > > news:%...
    > > > Tools
    > > > Options
    > > > Text Editor
    > > > HTML/XML
    > > > Format
    > > >
    > > > Try the settings there.
    > > >
    > > > --
    > > > Curt Christianson
    > > > Owner/Lead Developer, DF-Software
    > > > Site: http://www.Darkfalz.com
    > > > Blog: http://blog.Darkfalz.com
    > > >
    > > >
    > > > "Jacob Crossley" <> wrote in message
    > > > news:_7Jxc.408$...
    > > > > which setting? I've tried them all!
    > > > >
    > > > >
    > > > > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    > > > > news:...
    > > > > > it's a setting in the options of VS.....
    > > > > >
    > > > > > --
    > > > > > Curt Christianson
    > > > > > Owner/Lead Developer, DF-Software
    > > > > > Site: http://www.Darkfalz.com
    > > > > > Blog: http://blog.Darkfalz.com
    > > > > >
    > > > > >
    > > > > > "Jacob Crossley" <> wrote in message
    > > > > > news:dTHxc.405$...
    > > > > > > Please tell me there is a way to prevent this annoyance ; - )
    > > > > > >
    > > > > > > I'm into writing perfectly indented html, but the .net dev

    > > environment
    > > > > is
    > > > > > > being overzealous and messing up my html formatting.
    > > > > > >
    > > > > > > for example, I originally write:
    > > > > > >
    > > > > > > <table>
    > > > > > > <tr>
    > > > > > > <td>
    > > > > > > <asp:label id="lblSuccess" runat="server">
    > > > > > > </asp:/label>
    > > > > > > </td>
    > > > > > > </tr>
    > > > > > > </table>
    > > > > > >
    > > > > > > then the dev environment switches it to something like:
    > > > > > >
    > > > > > > <table>
    > > > > > > <tr>
    > > > > > > <td><asp:label id="lblSuccess"

    > runat="server"></asp:/label>
    > > > > > > </td></tr></table>
    > > > > > >
    > > > > > >
    > > > > > > I'm running the latest version of .net --version 7.1.3088
    > > > > > > I've run through the tools/options and placed the envirionment

    to
    > do
    > > > the
    > > > > > > least amount of microsoftesque-preemptive formatting.
    > > > > > >
    > > > > > > Please HELP!!! If there is no solution I think I'm gonna code

    > .net
    > > > > stuff
    > > > > > in
    > > > > > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've

    > > been
    > > > an
    > > > > > MS
    > > > > > > developer for years!
    > > > > > >
    > > > > > >
    > > > > > >
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >
    > >

    >
    >
     
    Jacob Crossley, Jun 9, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Akhlaq Khan
    Replies:
    4
    Views:
    839
    =?Utf-8?B?Q293Ym95IChHcmVnb3J5IEEuIEJlYW1lcikgLSBN
    Sep 27, 2004
  2. Replies:
    2
    Views:
    670
    Juan T. Llibre
    Mar 9, 2007
  3. Replies:
    1
    Views:
    147
  4. Ziyad Makki
    Replies:
    1
    Views:
    380
    Harry F. Harrison
    Aug 23, 2004
  5. Akhlaq Khan
    Replies:
    1
    Views:
    209
    Tom Kaminski [MVP]
    Apr 29, 2004
Loading...

Share This Page