The request failed with HTTP status 401: Access Denied

Discussion in 'ASP .Net Web Services' started by jdhavo@yahoo.com, Mar 17, 2006.

  1. Guest

    I have a webservice that allows all users to access it but am receiving
    an access denied message.
    IIS virtual directory for application is set to allow annonymous access
    with windows authentication.
    The annonymous user id is an active directory account
    USPHC\COR089SAPDM.
    I've entered the password in the password field and unchecked the allow
    windows to control password checkbox.

    When I change the user in the virtual directory to IUSR_XXXXXXXX, the
    webservice works fine.
    Here is the web.config for the webservice section.
    <location path="WebService/User/pdmUsersV1R0.asmx">
    <system.web>
    <authorization>
    <allow users="*"/>
    </authorization>
    </system.web>
    </location>
    The everyone group is authorized for nt security to read/execute on the
    folder.

    Any help would be appreciated.
    Thank you,
    Clem
     
    , Mar 17, 2006
    #1
    1. Advertising

  2. Anonymous users are usually used with the built-in IUSR anonymous account.
    The account may have several other priveleges that you might have to find out
    and manually set if you are using an AD account.

    It is better to leave it with anonymous. If you are changing it for setting
    the context for accessing some resource in your ASP code, you should consider
    using .NET impersonation and not change the IIS account.

    Regards,
    Pandurang

    --
    blog: www.thinkingMS.com/pandurang


    "" wrote:

    > I have a webservice that allows all users to access it but am receiving
    > an access denied message.
    > IIS virtual directory for application is set to allow annonymous access
    > with windows authentication.
    > The annonymous user id is an active directory account
    > USPHC\COR089SAPDM.
    > I've entered the password in the password field and unchecked the allow
    > windows to control password checkbox.
    >
    > When I change the user in the virtual directory to IUSR_XXXXXXXX, the
    > webservice works fine.
    > Here is the web.config for the webservice section.
    > <location path="WebService/User/pdmUsersV1R0.asmx">
    > <system.web>
    > <authorization>
    > <allow users="*"/>
    > </authorization>
    > </system.web>
    > </location>
    > The everyone group is authorized for nt security to read/execute on the
    > folder.
    >
    > Any help would be appreciated.
    > Thank you,
    > Clem
    >
    >
     
    Pandurang Nayak, Mar 22, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sachin
    Replies:
    2
    Views:
    17,930
    Sachin
    Nov 4, 2005
  2. ad
    Replies:
    2
    Views:
    13,555
  3. ad
    Replies:
    0
    Views:
    1,634
  4. James
    Replies:
    1
    Views:
    245
    James
    Dec 9, 2003
  5. Kevin Burton

    The request failed with HTTP status 401: Unauthorized.

    Kevin Burton, Dec 17, 2004, in forum: ASP .Net Web Services
    Replies:
    2
    Views:
    159
    Mohamed El Ashmawy
    Dec 19, 2004
Loading...

Share This Page