Tomcat on Linux Platform

Discussion in 'Java' started by mania, Feb 11, 2006.

  1. mania

    mania Guest

    Hello,

    I have installed tomcat 5.5.15 on Fedora Core 3 , it is
    running on the host but when i want to access it from remote machine
    using IP address of server ( host on which tomcat is running ) it is
    showing the error. The error is Gateway could not retrive the page. Can
    anybody suggest me that how to do that?? I used the defult port 8080.
    http://ip:8080/ is this the right way to do ? It is working
    on windows platform.



    regards.
     
    mania, Feb 11, 2006
    #1
    1. Advertising

  2. mania wrote:
    > Hello,
    >
    > I have installed tomcat 5.5.15 on Fedora Core 3 , it is
    > running on the host but when i want to access it from remote machine
    > using IP address of server ( host on which tomcat is running ) it is
    > showing the error. The error is Gateway could not retrive the page. Can
    > anybody suggest me that how to do that?? I used the defult port 8080.


    Generally that is the way to do it.

    Does it work from the local machine or across a network? do you have a
    local firewall or a router w/firewall in between? You can also check the
    catalina log file so see whether tomcat receives a request at all.

    /tom
     
    tom fredriksen, Feb 11, 2006
    #2
    1. Advertising

  3. mania

    none Guest

    tom fredriksen wrote:
    > mania wrote:
    >
    >> Hello,
    >>
    >> I have installed tomcat 5.5.15 on Fedora Core 3 , it is
    >> running on the host but when i want to access it from remote machine
    >> using IP address of server ( host on which tomcat is running ) it is
    >> showing the error. The error is Gateway could not retrive the page. Can
    >> anybody suggest me that how to do that?? I used the defult port 8080.

    >
    >
    > Generally that is the way to do it.
    >
    > Does it work from the local machine or across a network? do you have a
    > local firewall or a router w/firewall in between? You can also check the
    > catalina log file so see whether tomcat receives a request at all.
    >
    > /tom

    double check tomcat's server.xml for the configuration of the host
    element, as it may be listening on localhost or 127.0.0.1 and won't be
    accessible from a remote machine. If so, change this to the domain name/
    public ip of the box.

    Tim
     
    none, Feb 11, 2006
    #3
  4. mania

    Guest

    Most likely, yoru Linux box is doing what any self-respecting OS should
    do, protect its self from intruders. The reason you can't access it
    from a remote machine is that your firewall is preventing remote users
    from accessing your machine.

    To fix this, just open TCP port 8080. The firewall gui till is
    available from the menu, but i'm not on FC3 anymore, but you can launch
    the gui program from the command line by running the...
    redhat-config-securitylevel ...command.
     
    , Feb 12, 2006
    #4
  5. mania

    mania Guest

    Thanks.
    I disabled the firewall settings from system settings-> security
    level of FC3 and now its working.
     
    mania, Feb 13, 2006
    #5
  6. mania

    mania Guest

    Thanks.
    I disabled the firewall settings from system settings-> security
    level of FC3 and now its working.
     
    mania, Feb 13, 2006
    #6
  7. mania

    Nigel Wade Guest

    mania wrote:

    > Thanks.
    > I disabled the firewall settings from system settings-> security
    > level of FC3 and now its working.


    That's a big mistake unless your system is on a private network. The firewall is
    there to protect it from the big, bad, world.

    You really ought to learn how to open ports in the firewall.

    --
    Nigel Wade, System Administrator, Space Plasma Physics Group,
    University of Leicester, Leicester, LE1 7RH, UK
    E-mail :
    Phone : +44 (0)116 2523548, Fax : +44 (0)116 2523555
     
    Nigel Wade, Feb 13, 2006
    #7
  8. mania

    mania Guest

    Thanks Nigel for your suggestion. I opened the default port for tomcat
    which is 8080.
     
    mania, Feb 16, 2006
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ParkSungJae
    Replies:
    0
    Views:
    897
    ParkSungJae
    Sep 22, 2003
  2. Jonah Olsson
    Replies:
    4
    Views:
    429
    Jonah Olsson
    Jun 13, 2004
  3. jcc
    Replies:
    15
    Views:
    4,747
    Nigel Wade
    May 12, 2006
  4. Coca
    Replies:
    15
    Views:
    668
    Alan Balmer
    Jan 14, 2004
  5. Kaspar Schiess

    platform.rb (was: PLATFORM tests)

    Kaspar Schiess, Nov 25, 2005, in forum: Ruby
    Replies:
    0
    Views:
    137
    Kaspar Schiess
    Nov 25, 2005
Loading...

Share This Page